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Introduction 

Combined Manual 
AquiferWin32, WinFlow and WinTran are now basically the same product.  With the 
exception of the program name, the default icon, and the types of document files you 
can create everything is the same.  An AquiferWin32 Flow Model document file is 
identical to a WinFlow document file and the user-interfaces are identical as well.  
We no longer sell multiple products and only sell the Modelling Version of 
AquiferWin32 . 

What is AquiferWin32? 
AquiferWin32 is the most sophisticated and most Windows™ compliant application 
for the analysis and presentation of aquifer tests including pump tests, slug tests, step 
tests and analytic element flow and contaminant transport models.  The analysis of 
these data incorporates a wide variety of solution types with comprehensive plotting 
features. 

AquiferWin32 comes in four different versions, Modeling, Professional, Standard, and 
Slug Test.  AquiferWin32 is an OLE Full Server allowing the results to be linked to or 
embedded in OLE client applications.  The Slug Test version is limited to the 
analysis of slug test data using any one of the 6 slug test solutions; these solutions 
range from the simple Hvorslev to the complex Kansas Geological Survey (KGS) 
Model supporting confined or unconfined conditions, partial penetration, well skin 
effects and the response of a monitoring well.  The Standard version adds over a 
dozen pump test analyses including solutions for confined, leaky confined, 
unconfined and fracture rock aquifers with support for variable pumping rates, 
partial penetration, delayed yield and well bore storage.  The Professional version 
adds derivative analysis, Step tests and a Pump Test Simulator.  The Modeling 
version extends many of the pump test solutions into a modeling environment 
supporting any number of pumping wells with variable pumping rates.  Output 
includes contour maps of hydraulic head or drawdown, color floods, particle traces 
and graphs of drawdown versus time at any number of monitoring wells.  Auto-
calibration to any number of transient targets is also supported. 

The following are some of the most important features of AquiferWin32: 

About data entry… 
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¾ As simple as entering or importing data into a spreadsheet, characterize pumping 
and monitoring well, select solution type and match data  

¾ Alternatively, designed as a repository for raw aquifer test data with 
programmatic data conversions 

¾ Define a site plan including a site map, well locations and well construction 
information 

¾ Define an aquifer test including pumping schedule, wells monitored and 
raw drawdown versus time data 

¾ Define an analysis by grouping wells, transforming and clipping well 
response data, optionally adjust for radial distance on a well by well basis 

 

About data analysis… 

¾ Primary support for traditional manual curve matching techniques 

¾ User selectable and unlimited type curves on curve match graph 

¾ Multiple parameters available as type curves for many analyses 

¾ Graphically visualize the impact of specific parameters with custom type curve 
suites 

¾ Extensive curve match optimization capability 

¾ Control which parameters are optimized 

¾ Set minimum and maximum bounds on parameters 

¾ Optimize any parameters across multiple data sets 

¾ Manual and optimized curve match of the first-order derivative of the data to 
first-order derivative type curves 

¾ Support for variable pumping rates 

¾ Pump test simulations with contour maps and time/drawdown graphs 

¾ Steamline and particle trace analysis 

¾ Analytic element modeling with recharge, ponds, linesinks etc. 

¾ Auto-calibration of flow modeling parameters 

 

About units… 

¾ Full control of parameter and data units on a parameter by parameter and well 
by well basis 

¾ On-the-fly unit conversions 

¾ Peer review process assisted by instantaneous global unit conversions without 
affecting match results 

¾ Parameter-based unit conversion calculator 

 

About graphics… 

¾ Full control of graphs including size, titles, axes, colors, fonts, dash patterns and 
line thickness 
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¾ Type curve graph, predicted drawdown curve through data points, observed 
drawdown data 

¾ Contours of predicted drawdown at a given time and predicted drawdown versus 
time data at any number of monitoring wells 

¾ Annotate maps and graphs with text, parameters, symbols, lines, frames and 
legends 

¾ Frames support display of bitmaps and metafiles 

¾ Exports to DXF, Windows Metafile and ArcView™ Shapefile formats 

¾ Site map and well location plan displayed in map view 

¾ Color flood maps in addition to or as an alternative to contour maps 

¾ Three dimensional perspective display using the Visualization Toolkit (vtk), 
written and copyrighted by Ken Martin, Will Schroeder and Bill Lorensen. 

 

About printing… 

¾ WYSIWYG printing with Print Preview of all views 

¾ Customizable margins and scaling 

¾ Customizable headers and/or footers supporting bitmaps and metafiles 

¾ Supports any Windows™ printer driver 

 

About Windows™ features… 

¾ Multiple Document Interface 

¾ OLE Full-server supporting linked and embedded items 

¾ Copy views to clipboard as metafiles and OLE objects 

¾ Tab views including spreadsheet, type curves, predicted curves, map and 
simulator 

¾ Data spreadsheet in split window 

¾ Context-sensitive help 

¾ Context menus 

¾ Property Sheets (Tab Dialogs) to maximize ease of use 

¾ Tip of the Day 

¾ Dockable toolbars with tool tips 

 

Slug Test Analyses  

Hvorslev, 1951 Time Lag and Soil Permeability in Ground-Water 
Observations 

Bouwer & Rice, 1976 Slug test for determining hydraulic conductivity of 
unconfined aquifers with completely or partially 
penetrating wells 

Black, 1978 The use of the slug test in groundwater investigations 
(Modified Bouwer & Rice unconfined aquifer slug 
test analysis using an exponential type curve) 
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Cooper, Bredehoeft & Papadopulos, 1967 Response of a Finite-Diameter 
Well to an Instantaneous Charge of 
Water 

Hyder, Butler, McElwee & Liu, 1994 Slug tests in partially penetrating wells 
(KGS Model including well skin and 
monitoring well response) 

Kipp, 1985 Type Curve Analysis of Inertial Effects 
in the Response of a Well to a Slug Test 

Pumping Test Analyses  

Cooper and Jacob, 1946 A generalized graphical method for evaluating 
formation constants and summarizing well field 
history.  (Cooper Jacob Straight Line Method) 

Theis, 1935 Constant discharge from a fully penetrating well in a 
nonleaky aquifer* 

Theis, 1935 (Unconfined) Constant discharge from a fully penetrating well in a 
nonleaky aquifer* 

Theis, 1946 (Recovery) Recovery test after constant discharge from a fully 
penetrating well in a nonleaky aquifer 

Hantush, 1961 Constant discharge from a partially penetrating well 
in a nonleaky aquifer* 

Papadopulos and Cooper, 1967 Constant discharge from a fully penetrating well 
of finite diameter in a nonleaky aquifer* 

Hantush, 1960 Constant discharge from a well in a leaky aquifer 
with storage of water in the confining beds* 

Hantush and Jacob, 1955 Constant discharge from a fully penetrating well in a 
leaky aquifer* 

Hantush, 1964 Constant discharge from a partially penetrating well 
in a leaky aquifer* 

Neuman, 1972 Theory of flow in unconfined aquifers considering 
delayed response of the water table* 

Neuman, 1974 Effects of partial penetration on flow in unconfined 
aquifers considering delayed aquifer response* 

Moench, 1984 Double-Porosity Models for a Fissured Groundwater 
Reservoir with Fracture Skin* 

Moench, 1985 Transient Flow to a Large-Diameter Well in an 
Aquifer With Storative Semiconfining Layers* 

Moench, 1997 Flow to a well of finite diameter in a homogeneous, 
anisotropic water table aquifer 

* Analysis available for use in pump test simulator 

 

Step/Variable Rate Test Analyses 

Eden and Hazel, 1973 Step-drawdown test analysis for fully penetrating 
well in a confined aquifer. Determines well 
losses and aquifer transmissivity. 
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Birsoy and Summers, 1980 Variable or intermittent discharge rate analysis 
for well in a confined aquifer. Determination of 
aquifer transmissivity and storage. 

Model Solutions 

Theis, 1935 Constant discharge from a fully penetrating well 
in a nonleaky aquifer  

Hantush, 1960 Constant discharge from a well in a leaky aquifer 
with storage of water in the confining beds 

Hantush and Jacob, 1955 Constant discharge from a fully penetrating well 
in a leaky aquifer 

Neuman, 1972 Theory of flow in unconfined aquifers 
considering delayed response of the water table 

WinFlow Analytic element flow model developed by ESI 

WinTran Analytic element flow and Finite element 
contaminant transport model developed by ESI 

What is WinFlow? 
WinFlow is a powerful yet easy-to-use groundwater flow model.  The user-interface 
represents the most sophisticated and WindowsTM compliant available today.   
WinFlow provides an extensible common user-interface for analytical analyses and 
models capable of hosting other calculation engines in the future. 

WinFlow is an interactive, analytical modeling tool that simulates two-dimensional 
steady-state and transient ground-water flow.  The steady-state module simulates 
ground-water flow in a horizontal plane using analytical functions developed by 
Strack (1989).  The transient module uses equations developed by Theis (1935) for 
confined aquifers, Hantush and Jacob (1955) and Hantush (1960) for leaky aquifers, 
and Neuman (1972) for unconfined aquifers.  Each module uses the principle of 
superposition to evaluate the effects from multiple analytical functions (wells, etc.) 
in a uniform regional flow field. 

The steady-state module simulates the effects of the following analytic elements in 
two-dimensional flow: wells, uniform recharge, circular recharge/discharge areas, 
and line sources or sinks.  Any number of these elements may be added to the model, 
including a uniform regional hydraulic gradient.  The model depicts the flow field 
using streamlines, particle traces, and contours of hydraulic head.  The streamlines 
are computed semi-analytically to illustrate ground-water flow directions.  Particle-
tracking techniques are implemented numerically to compute travel times and flow 
directions.  Both confined and unconfined aquifers are simulated with the steady-
state module. 

The transient module simulates the effects of wells, circular ponds, linear 
sources/sinks, and a uniform regional gradient for confined and leaky aquifers.  
Numerical particle-tracking is also available in the transient module.  The transient 
module computes hydraulic heads using the Theis (1935) equation for confined 
aquifers and the Hantush and Jacob (1955) or Hantush (1960) equation for leaky 
aquifers.  Neuman’s method (1972) can also be used for unconfined aquifers with 
delayed yield from storage. 

In addition to the WinFlow calculation engine described above, WinFlow extends 
other analytical solutions from the popular AquiferWin32 pumping test analysis 
application into its modeling environment.  These additional solutions support any 



 

6  •  Introduction Guide to Using AquiferWin32 

number of pumping wells with variable pumping rates.  Auto-calibration to any 
number of transient targets is also supported for these additional solutions. 

WinFlow is simple to use and highly interactive, allowing you to create an analytical 
model in minutes.  The software features standard Windows pulldown menus and tab 
dialogs to facilitate the model design.  The model is recomputed and recontoured 
either by selecting a menu item or by pressing a toolbar button.  Streamlines and 
particle-traces are added interactively and recomputed each time new wells or other 
elements are added. 

WinFlow can import a Drawing Interchange Format (DXF) file (from AutoCAD for 
example) to use as a digitized base map.  QuickFlow and ModelCad-format map 
files may also be imported into WinFlow.  The digitized map gives the modeler a 
frame of reference for designing the analytical model. 

WinFlow produces report-quality graphics using any Windows device driver.  
Output may also be exported to a wide variety of file types, including SURFER, 
Geosoft, Spyglass, Windows Metafiles, and AutoCAD-compatible DXF files. 

What is WinTran? 
 

WinTran is designed to be an easy-to-use model for simulating the fate and transport 
of dissolved contaminants in fully saturated groundwater systems.  The WinTran 
model couples the steady-state groundwater flow model from WinFlow, with a 
contaminant transport model.  The transport model feels like an analytic model but is 
actually an embedded finite-element simulator.  The software automatically 
constructs the finite-element transport model so that you may quickly get answers to 
your groundwater problems.   

The steady-state flow model in WinTran uses analytic functions developed by Strack 
(1989) to simulate the effects of wells, uniform recharge, circular recharge/discharge 
areas (called ponds), and line sources or sinks.  Any number of these elements may 
be added to the model.  The model depicts the flow field using streamlines, particle-
traces, contours of hydraulic head (water levels) and color floods of hydraulic heads.  
Both confined and unconfined aquifers may be simulated with the WinTran flow 
model. 

The contaminant transport model uses a finite-element formulation whereby the 
finite-element mesh is identical to the head contour matrix.  The contour matrix is a 
rectangular array of points where head is computed by the flow model.  WinTran 
computes groundwater velocity at each "node" in the contour matrix for use in the 
finite-element transport model.  Diagnostic information is displayed on the status bar 
at the bottom of the window as the transport model runs.  These data alert you to 
potential problems in the numerical transport model.  These diagnostic data include 
the mass balance error, Peclet number, and Courant number.  If these error criteria 
indicate problems, you may stop the simulation, choose new simulation options, and 
start the simulation again.   

Contaminant mass may be injected or extracted using any of the analytic elements 
from the groundwater flow model, including wells, ponds, and linesinks.  In addition, 
constant concentration elements may be placed in the model to keep the source 
contaminant concentration at a specified value.  WinTran displays both head and 
concentration contours.  Concentration versus time data may be calculated and 
graphically displayed for selected monitoring locations.  The transport model 
includes the effects of dispersion, linear sorption (retardation), and first-order decay.  
The latter may be used to simulate the biologic decay of organic compounds, such as 
benzene or the radioactive decay of elements such as uranium. 
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WinTran can import a Drawing Interchange Format (DXF) file (from AutoCAD, for 
example) to use as a digitized base map.  The digitized map gives you a frame of 
reference for designing the flow and transport models. 

WinTran produces report-quality graphics using any Windows device driver.  Output 
may also be exported to a wide variety of file types, including SURFER, Geosoft, 
Spyglass, Windows Metafiles, and AutoCAD-compatible DXF files. 

Installation 
AquiferWin32 and WinFlow are distributed on CD-ROM and use a sophisticated 
installation wizard that is similar to other Windows™ products.  You simply run 
“Setup” from the CD-ROM and follow the directions as the installation proceeds.  
Start by placing the CD-ROM in the drive.  Now, select Run from the Start menu 
and enter the following: 

 d:\setup.exe 

You must first agree to the "ENVIRONMENTAL SIMULATIONS SOFTWARE 
LICENSE AGREEMENT" in order to continue installing the software.  The next  
page prompts for the directory where the files will be stored.  The default is 
"c:\aquifer3" or “c:\winflow3”.  If you would like to place the files in a different 
directory, click the Browse button and locate a new directory.  Click the Next button 
when you are done.  Select Cancel at any time to terminate the installation process.  
The next step is to decide which optional components to install.  By default, example 
files are installed and documentation files, in .pdf format, are not.  Click the Next 
button after checking the optional components you want to install. 

The next page of the wizard allows you to specify the name of the submenu to add to 
the Start->Programs menu; the default name is AquiferWin32 Version 3 or 
WinFLow Version 3.  To change this, you may select from an existing submenu 
listed or type a new name.  Select Next to accept your choice.  Finally, select the 
Next button again to begin the installation.  After all the files have been installed, 
another wizard will be started to install the security block device driver; you must 
have administrator rights to install this driver.  After the device driver installation is 
complete, click the Finish button on this wizard and on the main installation wizard. 

Optionally Obtaining a Security Code 
AquiferWin32 and WinFlow are protected by a security block (dongle) or an optional 
security code that is tied to the computer you install it on.  By default, AquiferWin32 
and WinFlow both ship with a security block.  If you opt for a security code instead, 
you are licensed to run AquiferWin32 or WinFlow on only one computer and you must 
obtain a security code in order to complete the installation.  If you obtain a security 
block, you are licensed to install AquiferWin32 or WinFlow on any number of 
computers; however, AquiferWin32 and WinFlow will require the security block to be 
installed on a given computer before its full functionality is activated. 

If you have a security block, plug the block into the parallel port on the computer and 
start the program.  If you do not have a security block, registration is a three-step 
process.  The first step is to select the Help->About menu to display the About 
AquiferWin32 or About WinFlow dialog as below. 
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Click the Register button to display the AquiferWin32 Registration or WinFlow 
Registration dialog as below. 

 
The dialog will display a System Code which can be copied to the clipboard (you do 
this by highlighting the system code and pressing Ctrl-C) and pasted into an email to 
be sent to aquifer@groundwatermodels.com or aquifer@esinternational.com.  We 
will reply with a security code that you paste or enter into the Security Code field in 
the above dialog.  Alternatively, you can get a security code by calling either ESI in 
the United States at (610) 670-3400 or ESL in the United Kingdom at +44 1743 
248600; however, it is strongly recommended that the transaction be done via email 
since the codes are rather long. 

If the security code is invalid or expired, the program will run as a demo which is 
fully functional without exports, printing and OLE. 
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Uninstalling the Software 

Uninstalling AquiferWin32 
AquiferWin32 and WinFlow are uninstalled like most other software packages.  Click 
the Start->Settings->Control Panel menu, double click on the Add/Remove 
Programs icon, locate "AquiferWin32 Version 3" or “WinFlow Version 3” in the list 
box and click the Add/Remove button.  At this point, you have 3 choices:  (1) select 
Automatic to quickly remove all of the AquiferWin32 or WinFlow files, (2) select 
Custom to determine which files will be deleted, or (3) select Cancel to end the 
uninstall program. 

The uninstall program will not harm any program files in your Windows directory or 
any other directory.  Only files placed on your computer related to AquiferWin32 or 
WinFlow will be removed. 

How to Use This Manual 
You should start learning about AquiferWin32 and/or WinFlow by working through the 
appropriate tutorials in the next chapter.  The tutorials are quite extensive and cover 
most of the major concepts in AquiferWin32 and WinFlow. You should also read the 
chapter entitled Concepts to learn about the primary assumptions that AquiferWin32 
and WinFlow use in analyzing aquifer test data, simulating aquifer tests, and flow 
and transport modeling.  After you have read through these two chapters, you are 
ready to start. 

Technical Support 
At times, you will have questions about a particular menu or property sheet.  The 
chapter entitled Menus and Property Sheets  is a reference section that describes each 
menu and property sheet.  If you cannot find the answer to your question, try looking 
at the index or search through the help file.  Still puzzled?  Call or e-mail the 
numbers listed below, our technical support is always free! 

United States:  

(610) 670-3400 

email:  support@groundwatermodels.com 

 

United Kingdom: 

 +44 1743 248600   

email:  aquifer@esinternational.com 

 

We always keep the latest version of AquiferWin32 on the Internet.  The updates are 
available on our web site at http://www.groundwatermodels.com. You may 
download the update file from our ftp site at any time.  The update is a self-installing 
program that should be run from Program Manager (or Start->Run) to install the 
update.
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What’s New In Version 3.0 

General 
AquiferWin32/WinFlow have been updated to include many of the things users have 
requested.  Every attempt has been made to make the application more user-friendly 
and full featured.  If we have missed something you feel is important, let us know.  
We will continually be enhancing AquiferWin32/WinFlow and all interim releases will 
be free and downloadable from the internet until Version 4.0 is available. 

The major changes are summarized below: 

• New analyses 

• Kipp, 1985 – Type Curve Analysis of Inertial Effects in the Response 
of a Well to a Slug Test 

• Moench, 1985 - Transient Flow to a Large-Diameter Well in an 
Aquifer With Storative Semiconfining Layers 

• Moench, 1997 - Flow to a well of finite diameter in a homogeneous, 
anisotropic water table aquifer 

• WinTran - WinTran is designed to be an easy-to-use model for 
simulating the fate and transport of dissolved contaminants in fully 
saturated groundwater systems. 

• New functionality 

• On screen editing of items within legends 

• Legend Wizard – Enables easy setup of legends and optionally 
automatically resizes legend, adds default parameters and maintains 
position in the lower right corner of the graph or map 

• 3D Perspective in Flow Model 

• Line Calculations and Distance/Drawdown graphs 

• Shapefile export of contours, particle traces, streamlines and wells 

• Shapefile maps now supported 
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New Analyses 

Kipp, 1985 
The Kipp, 1985 analysis is used for slug tests that exhibit a sinusoidal response due 
to inertial effects. 

 

Moench, 1985 
The Moench, 1985 analysis is very versatile and supports all three Hantush aquitard 
boundary types (Constant head, No Flow and Constant Head/No Flow) ) and allows 
leakage from above, below or both.  It also supports a line source well or a finite 
diameter well including well bore storage and well bore skin. 
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Moench, 1997 
The Moench, 1997 analysis allows analysis of pump tests in unconfined aquifers in 
which well bore storage and/or well bore skin are a significant factor. 

 

WinTran 
WinTran is designed to be an easy-to-use model for simulating the fate and transport 
of dissolved contaminants in fully saturated groundwater systems.  The WinTran 
model couples the steady-state groundwater flow model from WinFlow with a 
contaminant transport model.  The transport model feels like an analytic model but is 
actually an embedded finite-element simulator.  The software automatically 
constructs the finite-element transport so that you may quickly get answers to your 
groundwater problems. 
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New Functionality 

Legend Wizard 
One of the most common support issues has been setting up legends and we have 
attempted to make this process much easier.  In Version 3, adding a legend is as 
simple as clicking the mouse in the view, clicking the Add->Legend menu and 
dragging a rectangle.  The following wizard is activated to help in setting up the 
wizard.  If you simply click the finish button, a legend will be created containing the 
pertinent parameters and will be located in the lower right corner of the graph or 
map. 

To make a legend as in previous versions, select the Create empty legend radio 
button and click the Finish button; double click on the newly created legend box and 
set it up as you see fit. 

The legend generated by the wizard was patterned after the example legends created 
in the example files shipped with previous versions of the program.  The specific 
legend created using the following example wizard screens is below. 

 
The legend has three sections, the Title sublegend, the Parameter sublegend and the 
Symbol sublegend.  The Title and Symbol sublegends are optional as is the bitmap in 
the Title sublegend. 

To customize the legend created with the wizard, click the Create custom legend 
radio button and the Finish button becomes a Next button to continue the 
customization.  Two other options are available via check boxes.  The Don’t use this 
wizard for future editing option overrides the default behavior that, when you 
double click the legend to edit it, the wizard will not be used.  The Automatically 
Adjust and Locate Legend check box controls whether the system will 
automatically maintain the location of the legend. 
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If you chose to create a custom legend, the next step in the wizard enables you to 
choose the items you want added to the legend. The Parameters  step presents a list 
of parameter items which is dynamic and defined by the active document type, 
analysis type and view type.  As with Parameters in previous versions, you drill 
down into the options and click on the item you want, in this case Transmissivity.  
Using the Append, Insert and Remove buttons, you select what you want.  You can 
also change the default title for an item by selecting it in the right list box and 
entering the new title in the  Title edit field. 
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The Text step of the process controls colors and fonts of the legend title, parameter 
titles and parameter values.  It also controls the overall format and precision for 
parameter values. 
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The Styles step defines the layout of the legend including sublegends, border colors 
and thicknesses, background colors and title bitmap. 

 
The Symbols step is only displayed when the Symbol Sublegend checkbox has been 
checked in the previous step.  You can control the contents of the symbol sublegend. 
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On Screen Editing of Legends 
If you have created a legend using the legend wizard and have selected the 
Automatically adjust and locate legend option any changes made on screen will be 
automatically undone when the screen refreshes.  The on screen editing features are 
for older legends, those created as empty legends using the wizard or those that have 
selected the Don’t use this wizard for future editing option. 

On screen manipulation now drills into legends no matter how deeply they are nested 
to allow the typical on screen manipulations to be performed.  In addition, a context 
menu has been created for legends that allows for Cut/Copy/Paste/Select 
All/Delete/Add/Add to Legend operations within the legend. 

Of particular note is the Add to Legend menu.  When items have been selected in 
the main view, they can be added to the legend using this menu.  In most cases, you 
will want to drag the object into the legend and position it before using this option.  
You can, however, attach items to the legend that are not located inside the legend.  
When the legend is moved, they maintain their relative position to the legend.  

Line Calculations and Distance/Drawdown graphs 
A line calculation is simply a line dragged onto the map view in a Simulation or 
Flow Model document along which head/drawdown calculations will be made and a 
graph generated.  If one of the end points of the line corresponds with a pumping 
well, a drawdown versus distance graph can be generated. 

Line calculation elements appear on the map with similar characteristics to a line 
and, when the View->Well Data menu is checked, a view tab is added for the graph 
of drawdown versus distance. 



 

20  •  What’s New In Version 3.0 Guide to Using AquiferWin32 

 

 

The specific options available for Line Calculations are as follows: 
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Line Calculation Designator: Each line calculation must have a unique name so 

that it can be identified on view tabs. 

Spatial Parameters 

Start X: The x-coordinate of the starting point for the line 
calculation in map coordinates.  Distances are 
calculated relative to this point. 

Start Y: The y-coordinate of the starting point for the line 
calculation in map coordinates.  Distances are 
calculated relative to this point. 

End X: The x-coordinate of the ending point for the line 
calculation in map coordinates. 

End Y: The y-coordinate of the ending point for the line 
calculation in map coordinates. 

Data Spacing Parameters 

Equal Divisions Data points will be calculated at equal intervals 
between the start and end points of the line 
calculation. 

Number: The number of equal intervals to calculate between 
the start and end points of the line calculations. 

Linear  Data points will be calculated at specified intervals 
starting at the start point of the line calculation. 

Spacing: The spacing, in map units, between adjacent points in 
the line calculation. 
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Log  Data points will be calculated at logarithmic intervals 
starting at the start point of the line calculation. 

Samples Per Decade: The number of logarithmic intervals between 
adjacent powers of 10 in the line calculation. 

Custom Distances, in map units, entered into the spreadsheet 
on the Data tab will be used for the calculations. 

 
Line Style 

Color: Sets the color of the line connecting the data points 

Thickness: Sets the thickness in points of the line connecting the 
data points 

Dash: Sets the dash pattern to use for the line connecting 
the data points 

Length: Sets the length in inches of the dash pattern for the 
line connecting the data points 

Label Parameters 

Color The color to use when displaying the line calculation 
label 

Angle The angle to rotate the text when displaying the line 
calculation label 

Alignment The alignment of the label relative to the label 
location 

Display Label If checked, the line calculation designator is used to 
label the well 
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Font Defines the font, font style, size and effects for the 
label  

Label Offsets 

dX: The distance, in map units, to offset the label in x 
from the x-coordinate of the line calculation center 
point. 

dY: The distance, in map units, to offset the label in y 
from the y-coordinate of line calculation center point. 

 
Calculation Time: The time at which to calculate head/drawdown versus 

distance data. 

Spreadsheet The data in the spreadsheet reflect the calculated data 
points.  If Custom has been selected on the Line tab, 
you can edit the number lines and the values of  the 
distances at which to calculate; if Custom was not 
selected, any changes made will be ignored. 

3D Perspective 
The 3D vertical tab contains the 3D perspective view of the hydraulic head or 
drawdown  values.  Contour lines can be optionally displayed as well.  All the 
normal annotations can be added; however, the annotations are fixed in position in 
the view and are not moved/rotated when the 3D perspective is manipulated. 
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. 

View Manipulation 
Selecting the 3D Manipulation menu from the edit field context menu allows the 
manipulation of the 3D view using the mouse and keyboard.  Clicking and/or 
holding the left mouse button in the view causes the display to rotate in the direction 
toward the cursor location.  Holding the Shift button while clicking and/or holding 
the left mouse button causes the display to move in the direction toward the cursor 
location.   

Clicking and/or holding the right mouse button causes the display to zoom in and 
zoom out.  If the cursor is in the upper half of the view, it will zoom out.  If the 
cursor is in the lower half of the view, it will zoom in.  The amount of the zoom is 
controlled by how far the cursor is from the vertical center of the view. 

The Reset 3D menu is used recenter the 3D perspective view.  This is sometimes 
required when changes have been made via the Contour Options property sheet or on 
screen editing. 

Contour Options 
Four tabs on the Contour Options property sheet apply to the 3D view and are 
described below.  The color flood parameters apply to both the contour view and the 
3D view. 
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3D Mesh 

Vertical Scale Factor: A multiplier applied to head/drawdown to increase 
the vertical scale relative to the horizontal scale 

Color Bar: Controls the presence and location of the default 
scale bar 

Display X: The x-coordinate of the lower left corner (vertical) or 
upper right corner (horizontal) of the scale bar 

Display Y: The y-coordinate of the lower left corner (vertical) or 
upper right corner (horizontal) of the scale bar 

Contour Plane 

View Contours: When checked, a contour map is displayed in the 3D 
perspective view 

Color: Controls the color of the contours which can be either 
Black or Flood Colors 

Automatic Elevation: Controls the elevation on the vertical axis which 
corresponds to the contour plane; when checked the 
contour map will automatically be relocated as the 
contour data changes 

Specified Elevation: Controls the elevation on the vertical axis which 
corresponds to the contour plane; when checked, the 
value entered in the adjacent edit field will be used to 
locate the contour plane 

Reset 3D View At times, the perspective drawing can leave the field 
of view.  Checking this option will relocate it into 
view 
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Focal Point 

Focal X: The x-coordinate of the focal point used to display 
the 3D perspective drawing 

Focal Y: The y-coordinate of the focal point used to display 
the 3D perspective drawing 

Focal Z: The z-coordinate of the focal point used to display 
the 3D perspective drawing 

Position 

Position X: The x-coordinate of the camera position used to 
display the 3D perspective drawing 

Position Y: The y-coordinate of the camera position used to 
display the 3D perspective drawing 

Position Z: The z-coordinate of the camera position used to 
display the 3D perspective drawing 

View Up 

View X: The x-coordinate defining the view up direction for 
the camera used to display the 3D perspective 
drawing 

View Y: The y-coordinate defining the view up direction for 
the camera used to display the 3D perspective 
drawing 

View Z: The z-coordinate defining the view up direction for 
the camera used to display the 3D perspective 
drawing 
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Automatic When checked, the distribution of colors is 

automatically determined by the application 

Interval: The interval to use when generating flood colors for 
values of head/drawdown to be used when the 
Generate button is clicked. 

Generate When clicked, a new color distribution will be 
generated using the same algorithm as the Automatic 
setting; however, these can be edited by the user 
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Label Information 

First Sets the head/drawdown value for the first labeled 
value in color flood legends 

Number: The number of equally spaced labels to use when 
labeling the color flood legends 

Interval: The interval between adjacent labels; used when the 
Specify Interval option is activated 

Specify Interval When checked, the value for Interval is used when 
labeling color flood legends 

Format: The numeric format to use when displaying the labels 
on color flood legends 

Precision: The number of digits to the right of the decimal point 
to use when displaying the label on color flood 
legends 

Color The color to use when displaying labels on color 
flood legends 

Font Defines the font, font style and size for the label 

Border Line Information 

Color: The color to use when displaying the border around 
the color flood legend 

Thickness: The thickness, in points, of the line used when 
displaying the border around the color flood lege 
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Getting Started Using the 
WinFlow Solver 

Starting WinFlow 

Start WinFlow by simply double-clicking on the WinFlow icon  or activating 
the Start->Programs->WinFlow Version 3 menu.  If you are unfamiliar with 
Windows, please consult your Windows manual for common procedures, key 
strokes, and mouse procedures. 

Since WinFlow is well integrated with the Windows shell, you can also double click 

on a WinFlow data file icon  on either the Desktop or from Explorer.  You can 
also right click the mouse on the desktop and select the New->WinFlow Document 
to open WinFlow and create a new document. 

WinFlow Interface 
WinFlow uses a Microsoft Windows-compatible graphical user interface (GUI).  A 
menu, part of the GUI, is displayed at the top of the WinFlow window.  All modeling 
operations are controlled from this menu.  The majority of the window below the 
menu is the design area.  The models you create are displayed below the menu.  You 
may have multiple model windows open in the design window.  The maximum 
number of models that may be open at one time depends upon the complexity of the 
models and the amount of memory in your computer. 

You have two options to select a menu item - mouse or keyboard.  To use the 
keyboard, select a main menu item by pressing the ALT key and the underlined 
letter of the menu item.  Pulldown menu items are then selected by pressing the 
underlined letter of the pulldown menu item.  For example, to open an existing 
WinFlow model, press ALT-F (File) and then press O (Open).  To use the mouse, 
simply click the left mouse button when the cursor is over the desired menu item. 

Toolbars are displayed below the main menu and contain icons that represent key 
WinFlow operations or commands.  Using a toolbar button is a shortcut to the menu 
system.  To execute one of these shortcuts, use the mouse to move the cursor over 
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the toolbar icon and click on the Toolbar button.  For example, clicking on  adds 
a well to the model. 

The available toolbars are shown below: 

 

  
The Standard Toolbar icons represent (from left to right): 

Create a new model (in MDI terminology, a document)  

Open an existing WinFlow data file  

Save the current model to a file  

Cut the currently selected item to the clipboard  

Copy the currently selected item to the clipboard  

Paste from the clipboard  

Print the current model  

Recontour the current model  

Recalculate the current model  

Refresh the current model screen  

Display program information (About)  

Help  

 

 
The Annotation Toolbar icons represent (from left to right): 

Add a title  

Add a parameter  

Add a symbol  

Add a line  

Add a frame  
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Add a legend  

Add a scale bar  

 

 
The Analytic Toolbar icons represent (from left to right): 

Add a well  

Add a head linesink  

Add a flux linesink  

Add a pond  

Add a streamline  

Add a particle trace  

Add a target  

Add a line calculation  

 

Use the mouse to move the cursor over these toolbar icons and a description of the 
icon is displayed in the status bar in the lower-left corner of the screen.  The status 
bar also displays the X- and Y-coordinates in the lower-right corner of the screen.  
The model head (water level) is displayed in the lower-right corner if the model has 
been calculated. 

You may choose to remove the toolbars and/or the status bar from the WinFlow 
window using the View menu.  Pull down the View menu and click on Standard 
Toolbar to remove the Standard toolbar.  Repeat the procedure to have it 
redisplayed.  The specific toolbar is displayed when a check mark appears next to the 
appropriate View menu item.  The status bar works the same way. 

In addition to using the mouse, you may also use the arrow keys on the keyboard to 
move the cursor around the model design window.  Pressing an arrow key moves the 
cursor a certain distance (set by selecting Options->Map).  Other key combinations 
are used to simulate using the mouse, as described below: 

 

Keyboard Action What Happens? 

arrow keys cursor moves in direction of arrow 

shift-arrow keys cursor moves one pixel at a time for fine adjustment  

space bar equivalent to mouse double-click 

enter key equivalent to mouse click (left button) 
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shift-Enter add another element to those selected; also used to 
start resizing of a line or circle if such an element has 
been selected and the cursor has changed to a two-
prong or four-prong arrow. 

ctrl-arrow equivalent to View->Page 

alt-arrow equivalent to View->Scroll 

shift-mouse click add an element to those selected 

Applying WinFlow 
WinFlow is a powerful tool for analyzing two-dimensional groundwater flow 
problems.  A flexible user interface using pull-down menus and tab dialogs (property 
sheets) provides you with an easy method of setting up the model and rapidly getting 
to a solution.  The analytical model is developed in several steps, as follows: 

 Digitize a base map in a CAD package such as AutoCAD. 

 Export the drawing to a DXF format file. 

 Double-click on the WinFlow icon to run WinFlow. 

 Load the digitized map into WinFlow. 

 Specify aquifer parameters. 

 Choose a solution type (steady-state or transient). 

 Add analytic elements to the model (wells, ponds, etc.). 

 Calculate the model and contour the results. 

 Add streamlines or particle-traces to define flow paths. 

 Create a graphical or summary output of the results. 

These steps can be performed in a matter of minutes after the base map has been 
digitized.  The base map is optional; however, it provides you with a frame of 
reference in designing the analytical model. 

Data Requirements 
WinFlow requires you to specify a few simple pieces of information or data to define 
the analytical model.  Data can be classified in four different ways: (1) fundamental 
data required by all problems; (2) data required for only transient applications; (3) 
data required for particle-tracking analysis; and (4) optional data. 

Fundamental Data are required for all analytical models created by WinFlow.  These 
data include: 

 

 regional gradient and direction of flow, 

 hydraulic conductivity, 

 aquifer top elevation and bottom elevation, and 

 reference head. 
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Regional gradient and direction of flow are used to superimpose a uniform 
groundwater flow field on the analytical model.  You must define the regional 
gradient which has units of [L/L] (dimensionless) and the direction of flow.  The 
direction of flow is entered in degrees, with 0.0 degrees representing east, 90.0 
degrees representing north, etc.  You may enter a gradient of 0.0.  You may want to 
do this if you are computing drawdowns.  Note that in unconfined aquifers, the 
gradient is defined at the reference point and may change throughout the model as 
the saturated thickness (and hence the transmissivity) changes. 

Hydraulic conductivity is assumed to be homogeneous throughout the infinite 
aquifer and has units of [L/T], e.g. ft/d.  The aquifer top and bottom elevations have 
units of length [L], e.g. ft, and are used to compute transmissivity.  In addition, the 
steady-state module allows for conversion to unconfined flow.  Therefore, if the head 
falls below the top of the aquifer the model becomes unconfined.   

The reference head defines a point where the head is known.  In the steady-state 
model, the reference head is always constant and never changes during simulations.  
The reference head may or may not be constant in the transient model, depending 
upon a user-selectable option.  All computations are based upon the reference head, 
which should be located as far from wells, ponds, etc. as possible.  The reference 
head is analogous to a constant head in a numerical model. 

WinFlow allows you to use any set of units you would like; however, using 
consistent units throughout the model may minimize confusion.  For example, if you 
are using length [L] units of feet and time [T] units of days, hydraulic conductivity 
could be expressed in units of ft/d and pumping rates could be in units of ft3/d. 

Transient flow problems require three additional data types, including 

 storage coefficient [dimensionless], 

 Hantush leakage factor (denoted by L or B) [L], and 

 time steps used to compute solution [T]. 

The Hantush Leakage factor, denoted by the letter L or B, has units of length 
(Hantush, 1956).  The leakage factor is only required for leaky aquifers.  It should be 
set to zero for confined flow. 

Particle-tracking analyses require that porosity be defined.  The porosity 
(dimensionless) is used to compute the average linear groundwater flow velocity at 
discrete points within the system. 

Optional data types define the analytic elements of the model.  These elements 
include the following information: 

 well locations and pumping rates, 

 recharge rate, 

 pond locations and recharge/discharge rates,  

 linesink locations and recharge/discharge rates, and 

 calibration targets. 

All of the elements above are available for the steady-state model and all but 
recharge are simulated by the transient model. 

Wells are defined by the coordinates of the center of the well, a pumping rate, and a 
well radius.  The pumping rate has units of [L3/T], such as ft3/d.  A positive pumping 
rate indicates production and a negative rate indicates injection. 

Recharge is defined only for steady-state models and has units of [L/T], such as ft/d.  
The recharge is distributed over the entire infinite plane of the model.  An ellipse 
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defines the shape and position of the water-table mound created if there is no 
regional gradient.  You must define the center coordinates of the ellipse, the length 
of the a- and b-axis of the ellipse, and the angle between the a-axis (long axis) of the 
ellipse and the x-axis of the model.  The recharge rate should be a positive value. 

Ponds are circular recharge or discharge areas.  Ponds are defined in a manner 
similar to wells.  The coordinates of the center of the pond are given, along with the 
radius of the pond.  The pond infiltration rate has units of [L/T] and is computed by 
dividing the total discharge rate into or out of the pond by the area of the pond.  
Thus, the pond infiltration/discharge rate has the same units as recharge.  A positive 
rate indicates infiltration and negative indicates discharge from the aquifer. 

Linesinks are linear recharge or discharge features.  The linesink is defined by 
providing the coordinates of each end point and either an infiltration/discharge rate 
or a head.  If the linesink is defined in terms of head, the model will compute a 
discharge rate based on the given head value (assumed to be at the center of the 
linesink).  Linesink discharge/infiltration rates have units of [L2/T], which is 
computed by dividing the total discharge rate by the length of the line.  Thus, the 
linesink rate (or strength) is a rate per unit length.  The sign convention for linesinks 
is the same as wells: positive indicates pumping or production and negative signifies 
injection or infiltration. 

After defining all aquifer properties and analytic elements, you run the model by 
selecting Calc from the main menu and Recalculate from the pull-down menu.  
WinFlow will now compute hydraulic head on a regular grid of points and contour 
the results using ten contour intervals.  You may change the contour settings by 
selecting Options from the main menu and Contour from the pull-down menu and 
Paramers from the submenu. 

Starting a New Model 
The first step in using WinFlow to solve a two-dimensional ground-water flow 
problem is to digitize a site map.  While this step is not required, it does help you by 
providing a convenient frame of reference.  WinFlow map files are similar in format 
to QuickFlow map or ModelCadTM map files and may be created by first using any 
CAD package (such as AutoCAD) to digitize the map.  Next, export the CAD 
drawing as a DXF (Drawing Interchange Format) file.  

Double-click on the WinFlow icon to start the model.  You translate the DXF map 
file into a WinFlow map file within WinFlow by first opening a new model 
document.  Select File from the main menu and New from the pulldown menu.  You 
may also click on the New Document button on the Toolbar.  Now that you have a 
model to work with, select File from the main menu, Map from the pulldown menu.  
Set the Files of Type: selection on the resulting dialog to “DXF Files (*.dxf)”.  Select 
your DXF file using the standard Windows file dialog.  You must now select a new 
file name for the map file that will be created (again using a standard Windows file 
dialog). 

Finally, you will be asked for one additional item, a multiplication factor.  The 
multiplication factor is used to scale the drawing to model units.  Normally, the 
multiplication factor will be 1.0; however, if your CAD system exports the DXF file 
in units of inches, this factor would be 1.0/12.0 or 0.08333333.  You may need to use 
a multiplier other than 1.0 in AutoCAD if you are using engineering units instead of 
decimal units.  If the map units look wrong in WinFlow, it is probably in units of 
inches.  You must then re-import the DXF file with a new multiplication factor.   

It is easy to check the units on the imported map by moving the mouse around the 
map and looking at the X and Y coordinates displayed in the lower right corner of 
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the status bar.  Choose two points that are a known distance apart and check the 
distance with the status bar.  If the distance is incorrect, compute a multiplication 
factor to use in the map import and start again. 

The DXF file import feature first translates the DXF file into a WinFlow map file 
and displays the map on your screen.  The map file will be displayed the next time 
you open this WinFlow model (assuming that you save it later). 

When starting with a map that is already in the proper WinFlow map file format, 
simply select File from the main menu, Map from the pulldown menu, and set the 
Files of Type: selection on the resulting dialog to “Map Files (*.map)”.  Select the 
proper file name, and the map is displayed on your screen. 

Now that the map has been loaded, you must define the aquifer parameters.  Default 
parameters have been defined by WinFlow, however, these may not be the proper 
ones for your problem.  To change these parameters, select Edit from the main menu 
and Model from the pulldown menu.  The resulting property sheet contains tabs or 
pages on which you can define the following prarmeters: 

 hydraulic conductivity, 

 aquifer bottom elevation, 

 aquifer top elevation, 

 reference head value, 

 regional hydraulic gradient, 

 recharge rate, 

 porosity, 

 storage coefficient (transient models), 

 leakage factor (transient models), and 

If you select the Reference Head tab or Reference Head from the Edit menu, a 
dialog appears that prompts for the reference head value, gradient, and angle of the 
gradient.  A gradient angle of 0.0 degrees represents east, 90 degrees is north, etc.  
You may change the location of the reference head by dragging the reference head to 
a new location.  You do this by moving the cursor over the reference head symbol 
until the move cursor appears.  Now, hold down the left mouse button and move the 
cursor to the desired location.  Release the mouse button to place the reference head 
at the new location. 

You must always define a reference head!  You do not necessarily need to define a 
gradient, however.  If no gradient is defined, WinFlow will be simulating an 
"impact" model using a flat water-table.  If the reference head is zero and the 
gradient is zero, WinFlow will compute drawdown.  In this case, be sure that the 
bottom of the aquifer is set below zero also. 

For a transient model, click the Options from the main menu and Transient from 
the pull-down menu.  Click on the Time Steps tab and set up the time steps you want 
calculated.  Each time step will appear as a tab along the bottom of the map view. 

After confirming that all aquifer parameters have been properly set, select a solution 
type - steady-state or transient.  If the solution currently selected does not support 
both, one will be disabled.  The default solution type is steady-state.  To change the 
solution type, select Model from the main menu.  Now select either Steady-state or 
Transient from the pull-down menu.  A check-mark is displayed next to the selected 
model type. 
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If you want to display contours representing the uniform regional gradient, you may 
now select Calc from the main menu and Recalculate from the pull-down menu.  
WinFlow will display the status of the computations in a status dialog.  After 
calculating the head at a regular grid of points, a contour map will be displayed using 
a default contour interval.  If you want to change the appearance of the contours, 
select Options from the main menu and Contour from the pull-down menu.  A third 
menu will appear with two options for controlling the contouring, Window and 
Parameters.  Use Window to change the size or location of the area that is 
contoured and Parameters to change the contour interval and font. 

Adding Model Features 
Wells, linesinks, ponds, streamlines, and/or particle-traces may be added to the 
model.  To add one of these features to the analytical model, select Add from the 
main menu and select the desired feature from the pull-down menu.  You must then 
move the cursor around the design screen to locate the item.  This is accomplished 
using the cursor keys or the mouse.  To alter the distance that the cursor moves after 
pressing an arrow key, select Options from the main menu and Map from the pull-
down menu and Parameters from the second pull-down.  The cursor step size is 
defined in model units of length, e.g., feet. 

Wells are defined by moving the cursor to the desired coordinates or location and 
pressing the Enter key or left mouse button.  You will then be prompted for a name, 
the well construction information and a pumping rate [L3/T].  The name entered must 
be unique across all wells in the model.  You will also be permitted to edit the well 
coordinates.  If you change the coordinates, the well will be redrawn at the correct 
location.  Remember that a positive pumping rate indicates production, while a 
negative rate indicates injection.  There is no set limit to the number of wells or any 
other element that may be added to the WinFlow model.  The actual limit depends 
upon the amount of memory in your computer. 

Linesinks are defined by pressing the left mouse button at the beginning of the 
linesink.  While holding down the left mouse button, move the cursor to the end of 
the linesink and release the button.  You will then be prompted for a name, and the 
head or flux of the linesink.  If you have selected a Head Linesink, WinFlow 
computes the flux required to maintain that head at the center of the linesink.  If you 
have selected Flux Linesink, the flux is entered in units of [L2/T].  This is normally 
computed by dividing the total flux rate [L3/T] by the length of the linesink [L].  A 
negative flux indicates injection and positive indicates production.  As with the 
wells, you also have the opportunity to edit the coordinates and name of the linesink. 

Ponds are defined by selecting the center of the pond and dragging a circle to the 
desired radius while holding down the left mouse button.  A property sheet will 
appear that allows you to edit the center coordinates, the radius, infiltration/discharge 
rate, and name.  The pond rate is in units of [L/T] in the same manner as recharge.  A 
positive pond flux indicates recharge, while negative signifies discharge.  Note that 
the sign convention for ponds is opposite of wells and linesinks. 

Streamlines are only computed for the steady-state model.  You have the option of 
adding a single streamline, several streamlines started along a line, or several 
streamlines along a circle.  If you choose the line or circle option, you will then enter 
the number of streamlines to add.  These will be added at even increments along the 
line or circle.  When you add a streamline, the point you select is the beginning of 
the streamline, which is drawn downgradient of that point.  When you change the 
model in any way, all streamlines are recomputed during the recalculation of the 
model.  Arrow heads may be added to the streamline by selecting Options from the 
main menu and Trace from the pulldown menu.  You define the distance between 
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arrowheads and the size of the arrow (in model units of length) on the Streamline 
tab. 

Particle-traces may be computed for either steady-state or transient models and are 
defined in the same manner as streamlines.  Particle-traces take longer to calculate 
than streamlines, however.  The particle-trace differs from the streamline in several 
ways: (1) the particle-trace is computed numerically instead of semi-analytically; (2) 
a time value may be posted on the resulting trace; and (3) particle-traces may be 
tracked upgradient (reverse particle-tracking).  Options controlling the appearance 
and computation of particle-traces are modified by selecting Options from the main 
menu and Trace from the pull-down menu. 

All of these analytical features may be added from the Analytic Toolbar, as 
described in the previous section.  Simply click on the proper toolbar button.  As the 
cursor is moved over the toolbar, a text is displayed in the status bar to help you 
remember which icons go with which elements. 

Editing Analytic Elements 
You may edit any analytic element on the map (well, linesink, pond, title, scale bar, 
etc) by moving the cursor over the item and double clicking.  Make sure that the 
cursor changes to four arrows pointing up, down, left and right before double 
clicking.  A property sheet will appear that allows you to edit the parameters 
associated with that element (e.g. pumping rate).  To move the element, hold down 
the left mouse button and drag the item to a new location. 

The size of linesinks and ponds may be changed by moving the cursor to the edge of 
the pond or end of the linesink.  When in the proper location, the cursor will change 
to one with two arrows pointing left and right.  Hold down the left mouse button and 
drag to a new size. 

Computing the Model 
If you have added a feature, edited a feature, or changed any aquifer property, 
WinFlow will display "ReCalculate" in the status bar.  This means that the contour 
map on the screen may no longer reflect the changes that you have made.  To 
recompute, select Calc from the main menu and Recalculate from the pull-down 
menu.  If you have only changed contouring options, you may select Recontour 
from the pull-down menu.  You may also use toolbar buttons to recalculate and 
recontour the model. 

When WinFlow recalculates the problem, it displays the percent completion in a 
status dialog.  The time required to recalculate depends on the speed of your 
computer and the number of features that you have added to the model.  
Recalculation normally only takes a matter of seconds or a few minutes.  After 
recomputing the model, WinFlow will recalculate the locations of any streamlines 
and/or particle-traces that you have added to the model.  Finally, WinFlow will 
recontour the results.  Slide bars are displayed during each operation so that you can 
judge how long it will take to finish. 

Displaying the Results 
WinFlow displays the results from model calculations using contours, streamlines, 
and particle-traces.  By default, the design window defines the area that will contain 
the contours.  You may change the default by selecting Options from the main menu 
and Contour from the pull-down menu.  A third menu will display two options.  The 
Window selection allows you to drag a rectangular box to define the new contour 
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region.  The Parameters selection on this third menu provides ways to change the 
labeling of the contours and the contour interval.  If you make any changes to these 
options, a dialog will prompt you to recontour the results.  If you have redefined the 
contour window, you must select Recalculate from the Calc menu. 

You may change the current view of the model by selecting View from the main 
menu.  A pull-down menu allows you to zoom on a point (Zoom), zoom on a 
window (Window), display the full map and contours (Full), scroll the screen a 
given distance in a certain direction (Scroll and Left, Right, Up, Down), or to 
simply redraw or refresh the current screen (Refresh). 

Other options that control the appearance of the model results are found under the 
Options main menu selection.  The Map->Parameters selection lets you change 
most of the colors and object sizes related to the design screen.  Contour-
>Parameters allows you to change the way contours are produced, as described 
above. 

Creating Output 
WinFlow creates graphical and summary output in several different ways, including 
the following: 

 Print to any selected Windows device; 

 Create files that are compatible with SURFERTM, Geosoft, or Spyglass; 

 Create standard Windows Metafiles (wmf); 

 Create ASCII text files containing X- and Y-coordinates and head (XYZ); 

 Create DXF file for importing into CAD systems; and 

 Create an ASCII summary output file. 

Any of these options can be selected from the File option on the main menu.  Select 
Print to send the plot to the current Windows printer.  Select Export to create the 
other files listed above.   

A common problem when printing to the current Windows printer is that the text for 
contour labels is not properly rotated.  To correct this problem, select File from the 
main menu and Printer Setup from the pulldown menu.  Most printer drivers have 
an option to "Print Truetype Fonts as Graphics" or something similar.  Make sure 
that this option is switched ON.  If this does not correct the problem, you may need 
an update for your printer driver.  Contact your printer manufacturer or Microsoft for 
a new one.  Many driver updates are also available on the internet. 

Another problem can occur in getting the plot to fit on a single page.  Select Page 
Setup from the File menu and click on the Scale tab and select "Scale to Page" in the 
Map Scale section.  This will force the next printout to fit on a page.  There are two 
other check boxes on the dialog, labelled "Display Window" and "Map Window".  
Placing a check in "Display Window" causes only what is currently displayed on the 
screen to be printed.  Placing a check in "Map Window" causes the currently defined 
map window to be printed.  The current Map Window is the area defined when you 
select View->Full->Screen.  You may change the size of the map window by using 
Options->Map->Window. 

DXF files created by WinFlow are compatible with AutoCAD and most other CAD 
software, such as Design-CAD.  All entities, such as wells, contours, base map, 
streamlines, etc. are stored as separate layers in the DXF file.  This allows for easy 
editing of the CAD drawing. 
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WinFlow creates up to three different SURFER files.  The regular grid of head 
values computed by the analytical model is stored in a SURFER grid file that can be 
displayed by the TOPO and SURF programs.  The grid file can also be used in the 
GRID program to make modifications.  If you are using a base map or if you have 
added streamlines or particle-traces, a SURFER XYLINE file may be created.  This 
file can be read by the TOPO program to display a digitized map on the contours.  If 
you have generated time postings on the particle traces, a posting file may be created 
for use in TOPO. 

In order to maintain a QA/QC record of your model run, a summary file may be 
created.  The summary file contains a listing of all data making up the analytical 
model, the names of all files used, the current date, and a summary of all 
computations. 

Saving a WinFlow Model 
Eventually, you will want to save your WinFlow model in a data file for later use.  If 
you have previously saved the file, select the File->Save menu; if not, select the 
File->Save As menu and give the file a name.  The file created is totally self-
contained and, unlike previous versions of WinFlow, contains the base map 
information as well. 

Applying WinTran 
WinTran is a powerful tool for analyzing two-dimensional groundwater flow and 
contaminant fate and transport problems.  A flexible user interface using pull-down 
menus and simple dialogs provides you with an easy method of setting up the model and 
rapidly getting to a solution.  The analytical model is developed in several steps, as 
follows: 

 Digitize a base map in a CAD package such as AutoCAD. 

 Export the drawing to a DXF format file. 

 Double-click on the WinTran icon to run WinTran. 

 Load the digitized map into WinTran. 

 Specify aquifer parameters. 

 Specify transport and time-stepping parameters. 

 Add analytic elements to the flow model (wells, ponds, etc.). 

 Add sources of contamination and/or initial contaminant distribution. 

 Calculate the model and contour the results. 

 Add streamlines or particle-traces to define flow paths. 

 Create a graphical or summary output of the results. 

These steps can be performed in a matter of minutes after the base map has been 
digitized.  The base map is optional; however, it provides you with a frame of 
reference in designing the analytical model. 

Data Requirements 
WinTran requires you to specify a few simple pieces of information or data to define the 
analytical model.  Data can be classified in four different ways: (1) fundamental data 
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required by all problems; (2) data required for only transient applications; (3) data 
required for particle-tracking analysis; and (4) optional data. 

Fundamental Data includes information for both the flow and transport model as noted 
below: 

 flow model 

  regional gradient and direction of flow, 

  hydraulic conductivity, 

  aquifer top elevation and bottom elevation, and 

  reference head. 

 transport model 

  longitudinal and transverse dispersivity, 

  porosity, 

  diffusion coefficient, 

  contaminant half-life, and 

  retardation coefficient. 

Flow Model Data 
Regional gradient and direction of flow are used to superimpose a uniform 
groundwater flow field on the flow model.  You must define the regional gradient which 
has units of [L/L] (dimensionless) and the direction of flow.  The direction of flow is 
entered in degrees, with 0.0 degrees representing east, 90.0 degrees representing north, 
etc.  You may enter a gradient of 0.0.  You may want to do this if you are computing 
drawdowns.  Note that in unconfined aquifers, the gradient is defined at the reference 
point and may change throughout the model as the saturated thickness (and hence the 
transmissivity) changes. 

Hydraulic conductivity is a coefficient of the aquifer that defines the ease at which 
water moves through the medium.  Hydraulic conductivity is assumed to be 
homogeneous throughout the infinite aquifer and has units of [L/T], e.g. ft/d.   

The aquifer top and bottom elevations have units of length [L], e.g. ft, and are used to 
compute transmissivity.  In addition, the flow model allows for conversion to 
unconfined flow.  Therefore, if the head falls below the top of the aquifer the model 
becomes unconfined.   

The reference head defines a point where the head is known.  In the steady-state model, 
the reference head is always constant and never changes during simulations.   All 
computations are based upon the reference head, which should be located as far from 
wells, ponds, etc. as possible.  The reference head is analogous to a constant head in a 
numerical model. 

Transport Model Data 
Dispersivity is a scale-dependent parameter which is generally larger as the scale of 
the contaminant plume increases.  A typical rule of thumb is that the dispersivity is 
10 percent of the length of the contaminant plume (National Research Council, 
1990).  However, values of dispersivity reported in the literature range generally 
range from 1 to 100 percent of the problem scale (Gelhar, 1986).  There are two 
values of dispersivity used in the WinTran transport model, longitudinal and 
transverse.  Longitudinal dispersivity represents the spreading of the contaminant 
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plume in the direction of groundwater flow.  The transverse component represents 
spreading perpendicular to the flow direction.  Usually, the longitudinal dispersivity 
is 5 to 10 times higher than transverse. 

Porosity is used to compute the average linear groundwater velocity in WinTran.  
The porosity value entered in WinTran is actually the effective porosity and defines 
the ratio of connected void space to the volume of aquifer material.  The porosity is 
used in computing velocity according to the following equation: 

 
V K

n
dh
dl

=
 

where V is the average linear groundwater velocity (L/T), K is the hydraulic 
conductivity (L/T), n is the effective porosity, and dh/dl is the groundwater gradient. 

Molecular diffusion is the spreading of a contaminant in water due to concentration 
gradients.  That is, dissolved contaminants will spread in water from areas of high 
concentration to areas of lower concentration.  This process is caused by random 
movement of molecules in a fluid.  The coefficient of molecular diffusion (or simply 
the diffusion coefficient) is expressed in units of L2/T (e.g., cm2/s) and is often 
assumed to equal zero in advective-dominated transport.  Only in very slow-moving 
groundwater is diffusion important.  Bear and Verruijt (1987) estimate the diffusion 
coefficient to be approximately 1 x 10-5 cm2/s in dilute systems. 

Parameters are also assigned in the transport model based upon the type of 
constituents (chemicals) being simulated.  These compound-specific parameters 
include the half-life for decaying species and chemical reaction types.  Most 
transport models, including WinTran, lump chemical reactions into sorption 
processes in which a distribution coefficient (kd) controls the relative velocity of the 
compound compared to the ground-water velocity.  In this case, a retardation 
coefficient is computed which retards the velocity of the contaminant relative to the 
groundwater velocity.   

Most contaminant transport models require you to enter a decay coefficient, which is 
different from the contaminant half-life.  The decay coefficient is defined in the 
following equation: 

 λ = ln 2 / t1/2 

where λ is the decay coefficient, ln 2 is the natural log of 2, and t1/2 is the half-life of 
the contaminant.  The half-life is the time required for half of the original mass of 
contaminant to decay.  WinTran requires you to enter the half-life of the contaminant 
and computes the decay coefficient internally.   

While the half-life is most often used for radioactive elements, such as uranium, it 
can also be used to express the decay of organic compounds through biodecay.  The 
Handbook of Environmental Degradation Rates (Howard et al., 1991) is a good 
reference for contaminant half-life data. 

WinTran requires you to enter the retardation coefficient directly rather than the 
distribution coefficient (kd).  Calculation of the retardation coefficient is given by the 
following equation: 

R = 1 + kd (ρb/n) 

where R [dimensionless] is the retardation coefficient, kd  [L3/M] the distribution 
coefficient, ρb [M/L3] is the bulk density of the aquifer, and n [dimensionless] is the 
porosity.  Other more complex reactions have been used in numerical models, 
however, these have not been commonly applied and are not supported in WinTran.   
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Optional Data 
Optional Data types define the analytic elements and initial conditions of the model.  
These elements include the following information: 

 well locations and pumping rates, 

 recharge rate, 

 pond locations and recharge/discharge rates,  

 linesink locations and recharge/discharge rates, 

 calibration targets, and 

 initial contaminant conditions. 

Wells are defined by the coordinates of the center of the well, a pumping rate, and well 
construction parameters.  The pumping rate has units of [L3/T], such as ft3/d.  A positive 
pumping rate indicates production and a negative rate indicates injection.  Injection 
wells may also serve as sources of contamination.  In addition to the injection rate, you 
may also enter a concentration of contaminant in the injected water. 

Recharge is defined only for steady-state models and has units of [L/T], such as ft/d.  
The recharge is distributed over the entire infinite plane of the model.  An ellipse defines 
the shape and position of the water-table mound created if there is no regional gradient.  
You must define the center coordinates of the ellipse, the length of the a- and b-axis of 
the ellipse, and the angle between the a-axis (long axis) of the ellipse and the x-axis of 
the model.  The recharge rate should be a positive value. 

Ponds are circular recharge or discharge areas.  Ponds are defined in a manner similar to 
wells.  The coordinates of the center of the pond are given, along with the radius of the 
pond.  The pond infiltration rate has units of [L/T], such as ft/d, and is computed by 
dividing the total discharge rate into or out of the pond by the area of the pond.  Thus, 
the pond infiltration/discharge rate has the same units as recharge.  A positive rate 
indicates infiltration and negative indicates discharge from the aquifer.  Infiltrating 
ponds may be a source of contamination by entering a concentration value.  The 
concentration represents the contaminant concentration in the infiltrating water. 

Linesinks are linear recharge or discharge features.  The linesink is defined by 
providing the coordinates of each end point and either an infiltration/discharge rate or a 
head.  If the linesink is defined in terms of head, the model will compute a discharge 
rate based on the given head value (assumed to be at the center of the linesink).  
Linesink discharge/infiltration rates have units of [L2/T], such as ft2/d, which is 
computed by dividing the total discharge rate by the length of the line.  Thus, the 
linesink rate (or strength) is a rate per unit length.  The sign convention for linesinks is 
the same as wells: positive indicates pumping or production and negative signifies 
injection or infiltration.  Like injection wells and infiltrating ponds, linesinks may be 
sources of contamination when water is injected into the aquifer. 

Calibration targets are values of hydraulic head that have been measured in the field.  
WinTran will compute the difference between the computed head at a target location 
and the measured head.  This difference is called the residual and is displayed by 
selecting Calc->Target Statistics from the main menu. 

Initial conditions are the contaminant concentrations in the aquifer at the start of the 
transport simulation.  The default initial concentration is zero at all points.  Initial 
conditions may be changed from the default of zero in two ways, (1) save the ending 
contaminant concentrations from a previous simulation as the initial conditions for a 
subsequent simulation, and (2) import contoured concentration data from a SURFER 
grid file.  The tutorial in the next chapter discusses the saving of initial concentration 
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data from one run to another.  The initial concentrations are graphically displayed on 
Step 1 of the tab view representing a time of 0. 

After defining all aquifer properties, analytic elements, and transport parameters, you 
run the model by selecting Calc from the main menu and Recalculate from the pull-
down menu.  WinTran will now compute hydraulic head on a regular grid of points and 
contour the results using ten contour intervals.  You may change the contour settings by 
selecting Options->Contour->Parameters menu. 

To compute the transport model, you must select Transport from the Model menu and 
then select Recalculate from the Calc menu.  If Steady-State is selected in the Model 
menu, only the flow model will be computed. 

Starting a New Problem 
The first step in using WinTran to solve a two-dimensional ground-water flow and 
transport problem is to digitize a site map.  While this step is not required, it does help 
you by providing a convenient frame of reference.  WinTran map files are similar in 
format to QuickFlow map or ModelCadTM map files and may be created by first using 
any CAD package (such as AutoCAD) to digitize the map.  Next, export the CAD 
drawing as a DXF (Drawing Interchange Format) file.  

Double-click on the WinFlow icon to start the model.  You translate the DXF map file 
into a WinTran map file within WinTran by first opening a new model document.  
Select File from the main menu and New from the pulldown menu.  You may also click 

on the New Document button on the Toolbar .  Now that you have a model to 
work with, select File from the main menu, Map from the pulldown menu, and set 
Files of Type to “DXF Files (*.dxf)”.  Select your DXF file using the standard 
Windows file dialog.  You must now select a new file name for the map file that will 
be created (again using a standard Windows file dialog). 

Finally, you will be asked for one additional item, a multiplication factor.  The 
multiplication factor is used to scale the drawing to model units.  Normally, the 
multiplication factor will be 1.0; however, if your CAD system exports the DXF file in 
units of inches, this factor would be 1.0/12.0 or 0.08333333.  You may need to use a 
multiplier other than 1.0 in AutoCAD if you are using engineering units instead of 
decimal units.  If the map units look wrong in WinTran, it is probably in units of inches.  
You must then re-import the DXF file with a new multiplication factor.   

It is easy to check the units on the imported map by moving the mouse around the map 
and looking at the X and Y coordinates displayed in the lower right corner of the status 
bar.  Choose two points that are a known distance apart and check the distance with the 
status bar.  If the distance is incorrect, compute a multiplication factor to use in the map 
import and start again. 

The DXF file import feature first translates the DXF file into a WinTran map file and 
displays the map on your screen.  The map file will be used the next time you open 
this WinTran model (assuming that you save it later). 

When starting with a map that is already in the proper WinTran map file format, simply 
select File from the main menu, Map from the pulldown menu, and set Files of Type to 
“Map Files (*.map)”.  You may have to enter a rotation angle for the map after the map 
has been loaded.  This option has been included because it is recommended that the 
simulated contaminant plume flow parallel to either the X- or Y-direction.  This 
minimizes what is sometimes called “grid effect”, which causes numerical problems in 
the transport solution.  To set the rotation angle, click the Options->Map->Parameters 
menu, click the File tab, change the value for Angle and click OK. 
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Now that the map has been loaded, you must define the aquifer parameters.  Default 
parameters have been defined by WinTran, however, these may not be the proper ones 
for your problem.  To change these parameters, select Edit from the main menu and 
Parameters from the pulldown menu.  The following parameters are entered on this 
dialog: 

hydraulic conductivity, 

aquifer bottom elevation, 

aquifer top elevation, 

reference head value, 

regional hydraulic gradient, 

recharge rate, and 

porosity. 

If you select Reference Head from the edit menu, a dialog appears that prompts for the 
reference head value, gradient, and angle of the gradient.  A gradient angle of 0.0 
degrees represents east, 90 degrees is north, etc.  You may change the location of the 
reference head by dragging the reference head icon (Î) to a new location.  You do this 

by moving the cursor over the reference head icon (Î) until the  cursor appears.  
Now, hold down the left mouse button and move the cursor to the desired location.  
Release the mouse button to place the reference head at the new location. 

You must always define a reference head!  You do not necessarily need to define a 
gradient, however.  If no gradient is defined, WinTran will be simulating an "impact" 
model using a flat water-table.  If the reference head is zero and the gradient is zero, 
WinTran will compute drawdown In this case, be sure that the bottom of the aquifer is 
set below zero also. 

After confirming that all aquifer parameters have been properly set, you must then 
define the transport parameters, which include the following: 

 longitudinal and transverse dispersivity, 

 coefficient of molecular diffusion, 

 retardation coefficient, and 

 contaminant half-life. 

 Finally, you must select parameters that pertain to the time-stepping of the 
transient transport model.  These parameters include the number of time steps, the 
length of the first time step, the maximum time step size, and the time step multiplier.  
WinTran starts the simulation using the initial time step size.  Subsequent time steps are 
multiplied by the time-step multiplier to obtain the new time step size.  This 
multiplication continues until the maximum time step size is reached or the end of the 
simulation occurs.  Normally, you need to start with small time steps and gradually 
move to larger ones in order to have a good mass balance.  The mass balance error is 
displayed in the status dialog as the model runs.  If the mass balance error rises above 10 
percent, you should stop the simulation and adjust the time stepping parameters, 
dispersivity, or porosity until a better mass balance is achieved.  The last chapter in the 
documentation provides some guidance on selection of these parameters. 

If you want to display contours representing the uniform regional gradient, you may 
now select Calc from the main menu and Recalculate from the pull-down menu.  
WinTran will display the status of the computations in a status dialog.  After calculating 
the head at a regular grid of points, a head contour map will be displayed using a default 
contour interval.  If you want to change the appearance of the contours, select Options 
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from the main menu and Contour from the pull-down menu.  A third menu will appear 
with two options for controlling the contouring, Window and Parameters.  Use 
Window to change the size or location of the area that is contoured.  Parameters is 
used to change the size of the contour matrix and contour parameters related to the head 
and concentration contours. 

Adding Model Features 
Wells, linesinks, ponds, streamlines, and/or particle-traces may be added to the model.  
To add one of these features to the analytical model, select Add from the main menu 
and select the desired feature from the pull-down menu.  You must then move the cursor 
around the design screen to locate the item.  This is accomplished using the cursor keys 
or the mouse.  To alter the distance that the cursor moves after pressing an arrow key, 
select Options from the main menu and Map from the pull-down menu.  The cursor 
step size is defined in model units of length, e.g., feet. 

Wells are defined by moving the cursor to the desired coordinates or location and 
pressing the Enter key or left mouse button.  You will then be prompted for the well 
construction parameters and pumping rate [L3/T].  You must enter a unique well 
designator.  You will also be permitted to edit the well coordinates.  If you change the 
coordinates, the well will be redrawn at the correct location.  Remember that a positive 
pumping rate indicates production, while a negative rate indicates injection.  Injection 
wells may be contaminant sources by providing a concentration value in the Transport 
tab of the property sheet.  The concentration represents the contaminant concentration in 
the injected water.  Note that this is not necessarily the concentration that will be 
computed in the model because dilution in the flowing groundwater will normally 
reduce the injection concentration to a much lower value. 

There are two other options available for wells: (1) observation wells, and (2) constant 
concentration wells.  In observation wells, concentration is recorded by WinTran at each 
time step.  These data, presented in the Transport tab, can also be graphically presented 
in a view tab (click the View->Well Data menu) or may then be exported to a text file 
that can be imported into another graphics program, such as Microsoft Excel, to plot 
concentration versus time.  In a constant concentration well, the contaminant 
concentration is held constant in the aquifer at the well location.  When using constant 
concentration wells, you should specify a pumping rate of zero. 

Another option that effects wells in WinTran is the Options->Snap Wells to Contour 
Grid menu.  Placing a check mark next to this options causes WinTran to move newly 
added wells to a contour matrix node.  Remember that the finite-element mesh used for 
transport is identical to the contour matrix used to contour heads.  If you enter a well at a 
location other than a node (intersection of contour grid lines), the velocities computed 
by WinTran around the well will not be accurate.  The inaccurate velocities may 
produce undesirable mass balance errors.  This option only effects wells added after the 
option is selected.  It is recommended that you use this option to ensure proper mass 
balance in the transport model. 

There is no set limit to the number of wells or any other element that may be added to 
the WinTran model.  The actual limit depends upon the amount of memory in your 
computer. 

Linesinks are defined by pressing the left mouse button at the beginning of the linesink.  
While holding down the left mouse button, move the cursor to the end of the linesink 
and release the button.  You will then be prompted for the head or flux of the linesink.  
If you have selected a Head Linesink, WinTran computes the flux required to maintain 
that head at the center of the linesink.  If you have selected Flux Linesink, the flux is 
entered in units of [L2/T].  This is normally computed by dividing the total flux rate 
[L3/T] by the length of the linesink [L].  To aid you in determining the proper flux rate, 
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WinTran displays the length of the linesink in the dialog.  A negative flux indicates 
injection and positive indicates production.  As with the wells, you also have the 
opportunity to edit the coordinates and name of the linesink.  You may also specify a 
concentration value for the linesink.  The concentration is only used if the linesink 
injects water into the aquifer.  As with wells, the concentration represents contaminant 
concentration in the injected water. 

Ponds are defined by selecting the center of the pond and dragging a circle to the desired 
radius while holding down the left mouse button.  A dialog will appear that allows you 
to edit the center coordinates, the radius, infiltration/discharge rate, and name.  The pond 
rate is in units of [L/T] in the same manner as recharge.  A positive pond flux indicates 
recharge, while negative signifies discharge.  Note that the sign convention for ponds is 
opposite of wells and linesinks.  As in wells and linesinks, you may specify a 
concentration to apply to any injected water. 

Streamlines are only computed for the steady-state model.  You have the option of 
adding a single streamline, several streamlines started along a line, or several 
streamlines along a circle.  If you choose the line or circle option, you will then enter the 
number of streamlines to add.  These will be added at even increments along the line or 
circle.  When you add a streamline, the point you select is the beginning of the 
streamline, which is drawn downgradient of that point.  When you change the model in 
any way, all streamlines are recomputed during the recalculation of the model.  Arrow 
heads may be added to the streamline by selecting Options from the main menu and 
Trace from the pulldown menu and clicking the Display Arrows checkbox.  You 
define the distance between arrowheads and the size of the arrow (in model units of 
length) on the Streamline tab. 

Particle-traces are defined in the same manner as streamlines.  Particle-traces take 
longer to calculate, however.  The particle-trace differs from the streamline in several 
ways: (1) the particle-trace is computed numerically instead of semi-analytically; (2) a 
time value may be posted on the resulting trace; and (3) particle-traces may be tracked 
upgradient (reverse particle-tracking).  Options controlling the appearance and 
computation of particle-traces are modified by selecting Options from the main menu 
and Particle from the pull-down menu.  If you want to display arrow heads and/or post 
travel times, click the appropriate checkbox.  You define the distance between arrow 
heads and the size of the arrow heads (in model units of length) on the Particle Trace 
tab and travel time label parameters on the Label tab 

All of these analytical features may be added from the Toolbar, as described in the 
previous section.  Simply click on the proper Toolbar icon.  As the cursor is moved over 
the Toolbar, a text is displayed in the status bar to help you remember which icons go 
with which elements. 

Editing Analytic Elements 
You may edit any analytic element on the map (well, linesink, pond, title, or scale 
bar) by moving the cursor over the item and double clicking.  Make sure that the 

cursor changes to  before double clicking.  A dialog will appear that allows you 
to edit the parameters associated with that element (e.g. pumping rate).  To move the 
element, hold down the left mouse button and drag the item to a new location. 

The size of linesinks and ponds may be changed by moving the cursor to the edge of 
the pond or end of the linesink.  When in the proper location, the cursor will change 
to a .  Hold down the left mouse button and drag to a new size. 
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Computing the Model 
If you have added a feature, edited a feature, or changed any aquifer property, WinTran 
will display "ReCalculate" on the status bar.  This means that the contour map on the 
screen may no longer reflect the changes that you have made.  To recompute, select 
Calc from the main menu and Recalculate from the pull-down menu.  If you have only 
changed contouring options, you may select Recontour from the pull-down menu.  You 
may also use Toolbar icons to recalculate and recontour the model. 

When WinTran recalculates the problem, it displays the percentage completion in a 
status dialog.  The time required to recalculate depends on the speed of your computer 
and the number of features that you have added to the model.  Recalculation normally 
only takes a matter of seconds or a few minutes.  After recomputing the model, 
WinTran will recalculate the locations of any streamlines and/or particle-traces that you 
have added to the model.  Finally, WinTran will recontour the results.  Progress bars are 
displayed during each operation so that you can judge how long it will take to finish. 

WinTran provides you with the option to compute just the flow model or both flow and 
transport.  The Model menu contains three options: (1) Steady-State, (2) Transient, 
and (3) Transport.  A check mark will appear next to either Steady-State or Transport 
and Transient will be inactive. 

WinTran provides two options for computing groundwater velocities in the transport 
model.  The default method is to compute velocities analytically using the analytic 
element flow model.  This is the "hybrid model approach" described in the chapter 
entitled Mathematical Models.  It is possible that this modeling approach may produce 
poor mass balance errors, especially when you are using linesinks and ponds.  If you get 
large mass balance errors (above 1 to 10 percent), try selecting the Edit->Model menu, 
click the Solver tab and set Flow Model Type to “Finite-Element”.  The finite-element 
flow model option adds an intermediate step in the simulation process.  WinTran first 
computes the analytic flow model.  Next, WinTran sets up a finite-element flow model 
using boundary conditions from the analytic model.  After running the finite-element 
flow model, WinTran computes velocities for transport. 

Evaluating Model Error 
Numerical transport models require the user to carefully evaluate each simulation for 
potential errors.  WinTran assists you in evaluating model error by displaying the mass 
balance error on the status bar when the transport model is running.  The mass balance 
error is expressed as a percentage and should be less than 10 percent for a valid 
simulation.  Usually, the mass balance error is less than 1 percent. 

Even if the mass balance error is below 10 percent, there can be oscillations in the 
transport solution.  Oscillations are indicated by negative concentrations computed by 
WinTran.  In extreme cases, alternating nodes will have positive and negative 
concentrations producing diamond-shaped contours.  When the transport solution 
oscillates, check the following: 

(1) The Peclet number is displayed on the status dialog as “Pe =“ and is computed by 
dividing the nodal spacing (the distance between nodes in the contour matrix) by the 
longitudinal dispersivity.  The Peclet number should generally be less than 2 for a stable 
solution.  If you are experiencing mass balance problems or oscillations, increase 
dispersivity until the Peclet number is less than 2. 

(2) The Courant number is another criterion used to judge the stability of a transport 
simulation.  The Courant number is computed as the velocity times time-step size 
divided by nodal spacing.  This criterion is displayed as “Cr=“ on the status bar and 
should generally be less than 1.  Again, if you are experiencing mass balance or 
oscillation problems, try decreasing the initial and maximum time-step sizes. 
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There are also times when the Courant number is too low.  In cases where the Courant 
number is less than 0.1, there can be round-off errors in the matrix solver.  In this case, 
you should increase the initial and maximum time-step sizes until the Courant number is 
close to 1. 

There are two other WinTran options that can aid in model stability.  These include the 
time discretization method (backward and centered in time) and upstream weighting.  
The time discretization methods are selected using the Edit->Model menu and clicking 
the Solver tab.  Backward in time is unconditionally stable but is only first-order 
accurate, while centered in time is second-order accurate but may be subject to 
instability (Javandel et al., 1984).  It is usually best to start with backward in time. 

Upstream weighting factors in the X- and Y-directions are edited from the Edit->Menu 
Parameters menu and Solver tab.  Upstream weighting factors of 1.0 indicate full 
upstream weighting, while a weighting factor of 0.0 turns off upstream weighting.  
Upstream weighting adds stability to the solution (helps eliminate oscillations) at the 
expense of added numerical dispersion.  Numerical dispersion is artificial dispersion that 
produces similar results to an increase in the dispersivity coefficient. 

For more information on model stability, see the Problems with Model Stability section 
of the WinTran Application Guide chapter. 

Displaying the Results 
WinTran displays the results from model calculations using contours, streamlines, and 
particle-traces.  By default, the design window defines the area that will contain the 
contours.  You may change the default by selecting Options from the main menu and 
Contour from the pull-down menu.  A third menu will display several contouring 
options.  The Window selection allows you to drag a rectangular box to define the new 
contour region.  The Parameters selection on this third menu provide ways to change 
the labeling of the head and concentration contours and the contour interval.  If you 
make any changes to these options, a dialog will prompt you to recontour the results.  If 
you have redefined the contour window, you must select Recalculate from the Calc 
menu. 

You may change the current view of the model by selecting View from the main menu.  
A pull-down menu allows you to zoom on a point (Zoom), zoom on a window 
(Window), display the full map and contours (Full), scroll the screen a given distance in 
a certain direction (Scroll and Left, Right, Up, Down), or to simply redraw  or refresh 
the current screen (Refresh). 

Creating Output 
WinTran creates graphical and summary output in several different ways, including the 
following: 

Print to any selected Windows device; 

Create files that are compatible with SURFERTM, Geosoft, or Spyglass; 

Create standard Windows Metafiles (wmf); 

Create ASCII flat files containing X- and Y-coordinates and head (XYZ); 

Create DXF file for importing into CAD systems; and 

Create an ASCII summary output file. 

Any of these options can be selected from the File option on the main menu.  Select 
Print to send the plot to the current Windows printer.  Select Export to create the other 
files listed above.   
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Contour labels are often not 
properly rotated when 
printing!  Make sure you 
select Printer Setup and 
select the option to Print 
Truetype Fonts as Graphics. 

A common problem when printing to the current Windows printer is that the text for 
contour labels is not properly rotated.  To correct this problem, select File from the main 
menu and Printer Setup from the pulldown menu.  Most printer drivers have an option 
to “Print Truetype Fonts as Graphics” or something similar.  Make sure that this option 
is switched ON.  If this does not correct the problem, you may need an update for your 
printer driver.  Contact your printer manufacturer or Microsoft for a new one.  Many 
driver updates are also available on Compuserve. 

Another problem can occur in getting the plot to fit on a single page.  Select Page Setup 
from the File menu, click the Scale tab and click on the Scale to Page radio button in 
the Map Scale section.  This will force the next printout to fit on a page.  Additionally, 
placing a check in Display Window causes only what is currently displayed on the 
screen to be printed.  Placing a check in Map Window causes the currently defined map 
window to be printed.  The current Map Window is the area defined when you select 
View->Full->Screen.  You may change the size of the map window by using Options-
>Map->Window or directly changing it by clicking the Options->Map->Parameters 
menu on the Window tab. 

DXF files created by WinTran are compatible with AutoCAD and most other CAD 
software, such as Design-CAD.  All entities, such as wells, contours, base map, 
streamlines, etc. are stored as separate layers in the DXF file.  This allows for easy 
editing of the CAD drawing. 

WinTran creates up to three different SURFER files.  The regular grid of head values 
computed by the analytical model is stored in a SURFER grid file that can be displayed 
by the TOPO and SURF programs.  The grid file can also be used in the GRID program 
to make modifications.  If you are using a base map or if you have added streamlines or 
particle-traces, a SURFER XYLINE file may be created.  This file can be read by the 
TOPO program to display a digitized map on the contours.  If you have generated time 
postings on the particle traces, a posting file may be created for use in TOPO. 

In order to maintain a QA/QC record of your model run, a summary file may be created.  
The summary file contains a listing of all data making up the analytical model, the 
names of all files used, the current date, and a summary of all computations. 

Saving a WinTran Model 
Eventually, you will want to save your WinTran model in a data file for later use.  If 
you have previously saved the file, select the File->Save menu; if not, select the 
File->Save As menu and give the file a name.  The file created is totally self-
contained and, unlike previous versions of WinTran, contains the base map 
information as well. 
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Tutorial 

Starting with a Simple Test 
What you will learn: 

• entering data into the program 

• analyzing a test with one observation well using the Theis method 

• manual type curve matching 

• using weighted least-squares matching 

• specifying units 

• modifying the graph & displaying bitmaps 

• printing your results 

• pasting your graph into Microsoft Word 

 

AquiferWin32 is designed to be both easy to use and very flexible in analyzing aquifer 
test data and displaying the results.  The first part of the tutorial shows you how to 
analyze a simple aquifer test, one in which there is only one observation well.  This 
first analysis will use the Theis solution (1935) for confined aquifers.  The data are 
from a real aquifer test reported by Kruseman and de Ridder (1990; page 59). 

Kruseman and de Ridder call this aquifer test Oude Korendijk for the area where the 
test was conducted.  The pumping well was screened over the entire aquifer 
thickness of  7 meters.  Piezometers were placed at distances of 0.8, 30, 90, and 215 
meters.  The well was pumped at a constant discharge rate of 0.547 m3/min for 14 
hours.  This tutorial will use time and drawdown data for the 30 meter piezometer. 

Entering Data 
The easiest way to get time and drawdown data into AquiferWin32 is to copy the data 
to the clipboard from a spreadsheet and then paste the data into the AquiferWin32 
spreadsheet.  Any Windows spreadsheet, like Excel, can be used to manipulate the 
data before using it in the aquifer test analysis. 

You start the AquiferWin32 program using the Start menu.  To start a new aquifer test, 

simply click the  button on the Standard toolbar or select File->New.  Selecting 
New from the File menu displays five types of documents or analysis types, 
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including (1) “AquiferWin32 Flow Model”, (2) “AquiferWin32 Analysis”, (3) 
“AquiferWin32 Simulation”, (4) “AquiferWin32 Slug Test”, and (5) “AquiferWin32 
Step Test”.  A Flow Model document is used for analytical groundwater flow 
modeling or the analysis of very complex pump tests.  An Analysis document is for 
normal analysis of aquifer test data and is the document created when clicking the 

 button on the Standard toolbar.  A Simulation document is for simple modeling 
of an aquifer test and presenting contours of drawdown.  A Slug Test document is a 
special type of analysis document for evaluating the results of slug tests using several 
different methods. A Step Test document is for analyzing variable discharge aquifer 
test data from the pumping well. 

In this first tutorial exercise, simply click the  button of the Standard toolbar to 
start.  Two windows are created within the AquiferWin32 frame, including a 
spreadsheet on the left and a graph on the right.  The default graph type is for the 
Theis confined analysis and we will not change that for this example.  The 
spreadsheet contains one default data from which to begin data entry.  If the default 
data line is absent, it has been disabled using the Spreadsheet Information property 
sheet accessed using the Edit->Options menu.  If the default data line is absent, 
depress the Ins key. 

The first thing you should do when starting a new analysis is to set the units for the 
pumping test data.  Select Edit->Units to tell AquiferWin32 what units you are using.  
In this case, select minutes (min) for Time Units, meters (m) for Length Units, meters 
cubed per minute (cu m/min) for Pumping Rate Units, and  square meters per minute 
(sq m/min) for Transmissivity Units.  Click the Apply Globally check-box at the 
bottom of the property sheet to set these units for the entire analysis including all 
data types.  Take note of the Convert Data check-box at the bottom of the 
property sheet.  The convert option would transform all data from the units initially 
shown on the property sheet to those you want to use.  This can be convenient when 
you want to convert units later on; however, we do not want AquiferWin32 to perform 
any calculations at this point.  When both the Apply Globally and Convert Data 
check-boxes are checked, the entire document will be updated to a new set of units 
without affecting the analysis results.  This feature is of primary use when peer 
reviewing analyses that were done in a different set of units than the one you are 
comfortable with.  You can simply change the units and review the analysis.  In this 
example, we just want to define what our units are. Accept the property sheet by 
clicking the OK button. 

AquiferWin32 has a very sophisticated unit conversion scheme that allows you to 
convert just about any data item in the program from one set of units to another at 
any time.  We will explore unit conversion in more detail later.  Right now, we just 
want to set up the units that our data were entered in.  The time and drawdown data 
points for this test are provided in a file called kdr_ok.xls which is in Microsoft 
Excel Version 7.0 format.  You can enter the data for this test in three ways, (1) open 
this file in your spreadsheet, copy the data to the clipboard, and paste into the 
spreadsheet in AquiferWin32 , (2) manually type the data into the AquiferWin32 
spreadsheet, or (3) input the data from an ASCII text file (kdr_ok.dat). 

To paste the data into the AquiferWin32, simply go into your spreadsheet (Excel or 
Lotus, etc.), open the kdr_ok.xls file, drag a selection block around the first two 
columns of data from spreadsheet row 6 through row 39, and copy the data to the 
clipboard.  Next, click on the left side of line 1 in the AquiferWin32 spreadsheet.  Type 

Ctrl-V or click the   button on the Standard toolbar to paste the data into 
AquiferWin32.  The default first point is still in the spreadsheet, however, so go to line 
35 in the spreadsheet, click on the line to highlight the data, and hit the Del key. 
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Many users have indicated that they do not want the default first line in the 
spreadsheet when a new document is created.  It’s primary purpose is to facilitate 
manual data entry; however, most often the data is imported or pasted into the 
spreadsheet.  To eliminate the default data row from appearing in future documents, 
click on the Edit->Options menu and click on the Add initial row to the 
spreadsheet check-box to remove the check as below. 

 
To import the data from a text file, click on the first line in the spreadsheet to 
highlight that row.  Select File->Import and find the file called kdr_ok.dat.  
AquiferWin32 will notify you that 34 lines were imported.  As with pasting from the 
clipboard, there will be one extra line to be deleted.  In this case, however, you will 
delete the first line. 

You may also enter the data by hand.  Simply click on the first cell in the spreadsheet 
and start typing the data.  The first column is for time and the second column is 
drawdown.  These data are shown below for the 30 meter piezometer. 

 

Time (min) Drawdown (m) 
0.100 0.040 

0.250 0.080 

0.500 0.130 

0.700 0.180 

1.000 0.230 

1.400 0.280 

1.900 0.330 

2.330 0.360 
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2.800 0.390 

3.360 0.420 

4.000 0.450 

5.350 0.500 

6.800 0.540 

8.300 0.570 

8.700 0.580 

10.000 0.600 

13.100 0.640 

18.000 0.680 

27.000 0.742 

33.000 0.753 

41.000 0.779 

48.000 0.793 

59.000 0.819 

80.000 0.855 

95.000 0.873 

139.000 0.915 

181.000 0.935 

245.000 0.966 

300.000 0.990 

360.000 1.007 

480.000 1.050 

600.000 1.053 

728.000 1.072 

830.000 1.088 

You will see the data being displayed in the graph window as they are entered.  After 
entering the data shown above, your screen should look similar to the one shown 
below (if the data point locations are different from those shown below, select Calc-
>Reset Data Offset ): 
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Now that we have the time and drawdown data, we will enter the remaining test data.  
Select Edit->Aquifer Test to enter the pumping rate and distance to observation 
well.  Click on the Pumping tab on this property sheet and enter the following 
information: 

Pumping Well Name P1 

Pumping rate 0.547 m3/min. 

Pumping well screen length 7 m 

Monitoring Well Name H30 

Radial Distance 30 m 

Screen length 7 m 

 

The property sheet should resemble the one below.  Click OK when you are done.   
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At this point, the data for our analysis have been entered.  This involved essentially 
two steps, (1) enter the time and drawdown into the spreadsheet and (2) define the 
pumping rate and radial distance to the observation well.  Now, click anywhere on 
the graph window.  You will notice that the toolbar buttons that were gray are now 
ready for use.  The toolbar and menu respond to the currently active window.  The 
spreadsheet and graph are two different windows and they have two different menus. 

Analyzing the Test 
AquiferWin32 provides two ways to estimate aquifer properties from time-drawdown 
data: (1) manual curve matching, and (2) a nonlinear least-squares statistical match.  
We will show you the statistical matching first. 

Click on the graph to activate most of the toolbar.  Click the  button on the 
Match toolbar to automatically choose the best value of transmissivity and storage 
coefficient for this test.  AquiferWin32 uses the Marquardt (modified Gauss-Newton) 
nonlinear least-squares technique to find the best statistical match between the field 
data and the type curve you have chosen, in this case the Theis curve.  You will see 
T (transmissivity) and S (storage coefficient) displayed on the status bar at the 
bottom of the AquiferWin32 frame window.  The values should be 0.334 m2/min for T 
and 0.000112 for S after the optimization is complete.  

You may view detailed results of the nonlinear least-squares match by selecting the 
Edit->Solution menu.  The Solution tab on the Solution Information property sheet 
displays the type of analysis you have performed (in this case, the Theis analysis).  
Other tabs include: 

• Parameters (the initial guesses for parameter values) 

• Results (optimized parameters computed by either manual or nonlinear 
least-squares) 
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• Exceptions (unlink or unfix parameters; set enforced minimum and 
maximum values for parameters) 

• Statistics (match point data and statistical measures) 

• Data (time and drawdown data used to construct the type curve) 

We will discuss this property sheet in more detail later in this tutorial.  For now, just 
click the tabs to see what types of information are displayed.  One unique feature of 
AquiferWin32 is the ability to display the units for any field by moving the mouse 
cursor over that field.  The units are displayed as tooltips (a box drops down from the 
field) and on the status bar.  You may also right click on the field to display a context 
menu containing more options.  One of the options on the context menu is a unit 
conversion feature. 

The values reported by Kruseman and de Ridder are 0.272 m2/min for T and 0.00016 
for S.  They obtained different results because they ignored late time data.  You can 
come close to these results by pressing the down arrow key on the keyboard once 
followed by the left arrow key three times (NOTE: the number of times you press 
the arrow keys is system-dependent and may vary).  This moves the data over the 
curve and yields T and S values that are closer to the Kruseman and de Ridder 
results. 

In addition to using the arrow keys on the keyboard, AquiferWin32 provides two sets 
of four arrows (up, down, left, right) on the toolbar.  There are four large arrows and 
four small arrows.  The large arrows move the data farther than the small arrows.  
The keyboard arrow keys are equivalent to the large arrows on the toolbar.  Holding 
down the shift key and pressing the keyboard arrow keys is equivalent to clicking the 
small arrows on the toolbar which move the data a small distance for fine tuning the 
match.   

Weighted Data 
Notice that the last 12 points on the curve do not match very well with the type 
curve.  You can remove them from the analysis by changing their weights in 
AquiferWin32.  AquiferWin32 performs the nonlinear least-squares analysis on weighted 
residuals (errors).  A higher weight means that the error has less significance to the 
results.  By default all data points have a weight of 1.0.  We will now change the 
weights of the last 12 data points to a value of 1000.0.  Select Edit->Aquifer Test as 
before and click on the Well Data tab.  You will see a spreadsheet showing time, 
drawdown, symbol type, and weight.  Scroll to the last part of the spreadsheet and 
enter the value 1000.0 for the last 12 points.  Alternatively, select the last 12 rows by 
clicking the mouse in the left most column of the spreadsheet containing row 
numbers on row 23 and dragging a selection around the remaining rows.  Right click 
the mouse on the spreadsheet to activate the context menu and select the Selection 
menu.  The Selection Edit Options property sheet is displayed.  Tabs exist for each 
column of the spreadsheet.  Since we are interested in the value of weight, click on 
the Weight tab, click on the Set Value radio button and enter “1000” into the 
adjacent edit field as below. 
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You might also change the symbol type to show that these points are being treated 
differently.  To change the symbol type directly on the spreadsheet, double click on 
the spreadsheet cell containing the symbol you wish to change.  You may change the 
color, size, and shape of the symbol.  In this case, click on the Symbol tab, click the 
Set Value radio button, and set the Symbol combo box to a triangle as below.  
Accept the property sheets by clicking the OK buttons.  
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After modifying the weights click the  button on the Match toolbar again and 
you should end up with a transmissivity value of 0.28 m2/min and a storage value of 
0.000167.  These are close to the Kruseman and de Ridder results. 

Changing Analysis Types 
The example presented so far used the Theis method for confined aquifers.  You may 
change the analysis type at any time by selecting Edit->Solution.  We will cover the 
more advanced tests in later sections. 

Modifying the Graph 
You may modify just about any feature of the graph presented in AquiferWin32.  
Changing axes and labels is accomplished by selecting the Edit->Graph menu 
(NOTE: you must first click on the graph side of the window to enable editing of 
the graph).  The Graph Information property sheet is displayed with the following 
tabs: 

Graph Title of the graph and size of the graph in inches 

X-axis Style and annotation of the X-axis 

Y-axis Style and annotation of the Y-axis 

Line Types Thickness and color of the graph border, axes, grid lines 

Line Styles Color, thickness, labeling, style of data and type curve 
line(s) 

You should explore these options to see how you can modify the style of the graph.  
The default settings are usually adequate, however, for most applications. 

Another useful feature to annotate the plot is the use of legends, titles, and frames to 
enhance the graph.  These are selected on the Add menu when the graph window is 
highlighted.  One common use of these features is to add a logo for your firm.  To do 
this, select Add->Frame.  Now drag a rectangle on the graph.  The Frame 
Information property sheet will be displayed for this frame.  Click on the Contents 
tab and change the Type field to “Bitmap”.  Click the Browse button to find the 
bitmap file you want to display (an example ESILOGO.BMP is provided for the 
tutorial).  Most of the time, you will check the check-box Scale to Rectangle which 
forces the bitmap to fit within the rectangular frame.  You may move the frame 
around on the screen and resize it.  You may add as many frames as you like to the 
graph. 

You will often want to add legends to the graph to display the value of T and S for 
example.  The easiest way is to add a default legend by clicking the Add->Legend 
menu, drag a rectangle on the screen and click the Finish button on the Legend 
Wizard.  Custom legends can be somewhat complex and are covered in another 
chapter.  Another aproach to legends is to create one that you like and then 
copy/paste it from one AquiferWin32 document to another.  That way, you only have 
to create it once. 

Below is an example of what a final analysis would look like by modifying the title, 
adding the legend, and performing the analysis with the weighted time-drawdown 
data as discussed above.  This legend also includes information identifying which 
data points were used and which were ignored. 
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Printing Results 
AquiferWin32 prints the graph on your screen using any available Windows™ driver.  
Simply select File->Page Setup to decide margins etc.  Now select File->Print or 
File->Print Preview to print the graph. 

Displaying a Graph in Another Application 
AquiferWin32 is an OLE server application.  This means that you can copy a graph 
from AquiferWin32 into another Windows application (Word or Excel, for example).  
You have the choice of linking the graph to the AquiferWin32 file so that it can be 
modified if you change your analysis in the future. 

To copy a graph to Word, for example, you would run AquiferWin32 and perform the 
analysis.  Click on the graph window and select Edit->Copy.  Now, run Word (or 
any other Windows application) and select Edit->Paste Special.  A property sheet is 
displayed that allows you to paste the graph as a “Picture” or as an “AquiferWin32 
Analysis Document Object”.  If you choose the latter, you may then double click on 
the graph in Word to modify it.  You may also choose an option called Paste Link 
which would link the graph to your AquiferWin32 file so that the Word document 
would be modified when you change the analysis.  This is a powerful feature that 
allows you to create customized reports for your aquifer test analysis. 

Multiple Type Curve Example 
What you will learn: 

• Analyzing an aquifer test in a leaky aquifer with one well 

• Displaying and manipulating multiple type curves 

Many of the aquifer test analysis methods use a family of type curves.  In this case, 
your goal is to not only fit the data to a curve but to also choose the best curve.  
AquiferWin32 is designed to help in this type of analysis by displaying a family of type 
curves for these methods.  You may choose how many curves are displayed and may 
use this feature to prepare sets of master type curves for use in analyzing data in the 
field (i.e., the old-fashioned way!). 
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In this second example, we will analyze an aquifer test reported by Lohman (1979; 
page 33) using the Hantush (1960) method for leaky aquifers with storage in the 
aquitard.  This method uses a family of curves with each curve having a constant 
value for β, which accounts for the thickness, hydraulic conductivity, and storage 
properties of the aquitard. 

Follow these steps to prepare for the analysis of the Lohman data: 

1.  Click the  button on the Standard toolbar and enter the time and drawdown 
data for the test.  These data are given in an ASCII text file loh33.dat and in the 
following table.  Remember, to import the ASCII file click on the first row in the 
spreadsheet and select File->Import.  You can also right click on the spreadsheet 
and select Import from the context menu. 

 

Time (min) Drawdown(ft) 
6.37 0.01 

8.58 0.02 

10.23 0.03 

11.9 0.04 

12.95 0.05 

14.42 0.06 

15.1 0.07 

16.88 0.08 

17.92 0.1 

21.35 0.12 

21.7 0.13 

22.7 0.14 

23.58 0.15 

24.65 0.17 

29 0.21 

30 0.22 

32 0.24 

34 0.26 

36 0.28 

38 0.3 

41 0.33 

44 0.36 

47 0.38 

50 0.42 

54 0.46 

60 0.52 

65 0.56 

70 0.6 

80 0.65 

90 0.75 
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100 0.82 

137 1.04 

150 1.12 

160 1.17 

173 1.24 

184 1.27 

200 1.35 

210 1.4 

278 1.68 

300 1.76 

315 1.83 

335 1.87 

365 1.99 

390 2.1 

410 2.13 

430 2.2 

450 2.23 

470 2.29 

490 2.32 

510 2.39 

560 2.48 

740 2.92 

810 3.05 

890 3.19 

1255 3.66 

1400 3.81 

1440 3.86 

1485 3.9 

2.  Select Edit->Units and set Time Units to “min”, Length Units to “ft”, Pumping 
Rate Units to “gal/min”, and Transmissivity Units to “sq ft/d”.  Click the Apply 
Globally check-box then click OK to accept the property sheet. 

3.  Select Edit->Aquifer Test and click on the Pumping tab.  Enter the pumping rate 
of 750 gallons per minute (gpm) and the distance of the observation well from the 
pumped well of 1,400 ft.  Click OK to accept the property sheet. 

4.  Click on the graph window and then select Edit->Solution.  The Solution tab is 
shown first by default.  Change the combobox from “Theis, 1935 (Confined)” to 
“Hantush, 1960 (Leaky Aquifer with Storage)”.  Click the Curves tab to see which 
values of β will be plotted as separate type curves.  You may add additional curves 
by clicking the Add button.  

5.  Click the Parameters tab and ensure the all three Hydraulic Parameters are free 
to vary.  The small check-boxes that are intended to resemble push pins located to 
the right of Transmisivity, Storage coefficient and Beta should all be unchecked.  If 
they were checked, as with Radial distance and Pumping rate, the values would be 
held constant during optimizations. 
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6.  Click OK to accept the property sheet. 

You are now ready to analyze the data.  It is strongly recommended that a manual 
match be performed first.  Using the arrow keys on the keyboard, attempt to 
manually match the data to the third type curve from the left.  Essentially, you try to 
determine which type curve best matches your data.  Then, set the combo box on the 
Match toolbar to that value, in this case use “2.00”.  You could also toggle through 
the type curves by using Ctrl-T on the keyboard.  Once you have changed the 
selected type curve, make final adjustments to the manual match.  A manual match 
will update the initial guesses for parameter values based on the match point and the 
selected type curve so you must move the data after a new type curve has been 
selected to update its initial guess. 

The default behavior of the application is to calculate an initial guess for T and S 
using a straight line method.  Although this works well for some analyses, it doesn’t 
work for this one; therefore, deactivate this default behavior by clicking the Edit-
>Solution menu, click the Advanced button on the Solution Information property 
sheet and click the Calculate Initial Estimates check-box to remove the check.  If 
you do not deactivate the calculation of initial estimates, you will get an error 
message during an optimization stating that the numerical solution has become 
unstable.  This means that the Marquardt procedure could not come up with an 
improved estimate for T and S.  One problem with the Marquardt method is that your 
initial guess for T and S must be fairly close to the “right” answer before it will work 
properly.  You will get another message after the error dialog that asks if you would 
like to turn off the option to automatically estimate initial guesses for parameters.  
Selecting Yes on this dialog does the same thing as removing the check from the 
Calculate Initial Estimates check-box. 

Click the  button on the Match toolbar to analyze the test results using the 
nonlinear least-squares technique.  The solution should converge to a T value of 
about 2,190 to 2,200 ft2/d, an S value of about 4.6e-05, and a beta value of 1.76.   

In order to have the correct type curve on the graph (for a beta value of 1.76), select 
Edit->Solution, click on the Curves tab, select “2.00” in the Curve Information list 
box, click the Edit button, and change the value to “1.76”.  Click the OK button on 
the dialog and the OK button on the property sheet.  The type curves will then 
recalculate.  Select the 1.76 type curve and click the calculator button.  The values 
obtained by Lohman were 2,170 ft2/d and 3.0e-05 for T and S, respectively. 

In order to add a legend to the graph, click the Add->Legend menu and drag a 
rectangle anywhere on the screen, click the Finish button on the Legend Wizard that 
appears.  This will add the default legend to the graph.  Your screen should look 
similar to the one shown below. 



 

64  •  Tutorial Guide to Using AquiferWin32 

 

If you are familiar with other aquifer test software, you will see that AquiferWin32 has 
a slightly different philosophy or focus.  Whereas most other aquifer test analysis 
packages rely heavily on the automatic matching procedures, AquiferWin32 is 
designed to be more like the visual or manual matching techniques advocated by 
most hydrogeology text books (See Fetter, 1994 for example) and by ASTM.  An 
alternative view of the match results is presented in the Predicted view tab.  Click on 
this tab and also click on the View->Clip Data menu to clip the predicted curve to 
the graph window.  Repeat the above procedure to add the default legend.  The 
resultant graph displays the observed drawdown versus time data and predicted 
drawdown versus time curve.  This graph can be annotated and modified as required 
and an example is shown below. 
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Using Multiple Observation Wells 
 

What you will learn: 

• analyzing an aquifer test with multiple observation wells 

• advanced discussion of unit conversions 

• more about adding legends 

• optimizing the solution for all wells and for individual wells 

• more about using AquiferWin32 as an OLE server 

The remaining tutorial examples cover advanced topics in AquiferWin32.  These 
examples are designed to show you how to perform unit conversions, annotate plots, 
and work with complex data sets.   

This section outlines how to analyze a multiple well pump test.  The particular data 
are taken from Lohman, (1979; page 19).  The first step is to create a new 

AquiferWin32 Analysis document by clicking on the  button on the Standard 
toolbar.  Once the document is created, the first step is to set the units to be used in 
the analysis.  The Edit->Units menu displays the Unit Information property sheet 
with two tabs.  The first tab, Summary, contains the four basic parameters and their 
respective units.  The values represent either the program defaults or the values 
previously saved as default.  Under normal circumstances, you would set the 
summary units to most closely approximate the units of the data collected.  In this 
instance, we will intentionally deviate from the norm in order to demonstrate unit 
changes activated from other parts of the program.  Set Time Units, Length Units, 
Pumping Rate Units and Transmissivity Units to “sec”, “ft”, “gal/min” and “sq ft/d”.  
Click the Save As Default check-box and the Apply Globally check-box.  There is 
no need to click the Convert Data check-box because no data exist yet.  (NOTE: 
Whenever a new parameter or well is created in AquiferWin32, the default values 
saved in this way are used to set the initial units.) 

Before exiting the property sheet, click on the Units tab.  This tab allows specific 
parameters to be assigned units.  AquiferWin32 allows the ultimate flexibility when it 
comes to setting units; however, it is imperative that one understands the paradigm.  
Every parameter contained in AquiferWin32 has units that can be expressed in terms of 
three generic "units"; these are length (L), time (T) and volume (V) with the possible 
values organized into three sets of radio buttons.  When a parameter is selected in the 
Parameter combobox, the appropriate radio button sets are activated.  Simply select 
the desired unit from each radio button set.  One of the most complicated parameters, 
Transmissivity, can be expressed in dimensionless units as V/T/L.  If you select 
gallons, days and feet for V, T and L the resulting units would be gallons per day per 
foot (gal/d/ft).  If you select cubic feet, days and feet, the resulting units would be 
square feet per day (sq ft/d).  (NOTE: If changes are made to both tabs of this 
property sheet, the values on the Summary tab take priority.)  Accept the 
property sheet by clicking the OK button. 

Since we are setting up a multiple well scenario, click on the Site Map view tab to 
activate it.  Now we should set up the map via the Options->Map->Parameters 
menu.  Click on the Window tab and set both Height and Width to “1000”.  If we had 
a basemap of the site, we would click on the File tab and enter a map file name 
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which would automatically set the map window dimensions based on the map being 
imported.  (NOTE: Unlike other ESI software, the map is stored with the 
document so that it is self-contained.)  Accept the property sheet and add the wells 

by using the Add->Well menu or clicking the  button on the Analytic toolbar.  
In either case, the cursor will change to perform a drag insert.  Move the cursor to the 
desired location on the map and click the left mouse button.  For our purposes, put 
the cursor anywhere and edit the Well Information property sheet as below. 

 
Although it is a good idea to fully define the pertinent construction parameters, it is 
not required for this example. The reason is that the Theis analysis (which we intend 
to use) does not use any of the well construction parameters. Click on the Display tab 
and click on the Display check-box so that the well name, PW, is displayed and click 
on the OK button.  In similar fashion, add three more wells using the default well 
construction information: 

 

Name X Y 
N-1 100 300 

N-2 500 100 

N-3 900 100 

 

Now that the "Site" has been defined, the next step is to define the "Aquifer Test".  
Click on the Edit->Aquifer Test menu.  The first tab of the Aquifer Test Information 
property sheet contains user-fields.  These user-fields can be used to annotate any 
Graph or Map View and are also included in the hard copy report.  Click on the 
Pumping tab and select “PW” in the Pumping Well combobox. Now we must define 
the pumping schedule.  Click the left mouse button in the Pumping Rates spreadsheet 
or Tab into it from the Pumping Well combobox.  Hit the Ins key or right click the 



 

Guide to Using AquiferWin32 Tutorial  •  67 

mouse within the spreadsheet and select Insert from the context menu.  We now 
want to set the pumping rate to 96,000 ft3/d but the units on the column are gallons 
per minute (gpm).  Right click the mouse within the spreadsheet and select Column 
Conversion to display the Unit Information property sheet as below.   

 
Select “Pumping Rate” in the Column combobox and set the Time units to “days” 
and the Volume units to “cubic feet”.  Click on the Apply Units and Apply Globally 
check-boxes and click on the OK button.  The column title will change to reflect the 
new units. 

To enter the data, click the mouse in spreadsheet row 1 and column 2 and enter 
“96000”.  At this point, if you were to hit the Tab key or the Enter key a new data 
row would be added and you could continue entering the pumping schedule.  Hit the 
Esc key once to clear the field.  Now lets assume you really want your pumping rates 
displayed in gpm.  Right click the mouse to bring up the context menu and activate 
the Column Conversion menu.  With “Pumping Rates” selected in the Column 
combobox, set the Volume units to “gallons” and the Time units to “minutes”.  
Activate Apply Units, Apply Globally and Convert Data then click on the OK 
button.  The pumping rate is now displayed as 498.667 gal/min. 

The next step is to define the wells monitored during the test.  Click the Wells tab 
and move wells N-1, N-2 and N-3 from the Available Wells list to the Monitored 
Wells list by clicking the Add button three times.  (NOTE: This and other 
Add/Remove list box pairs are Drag and Drop enabled so you can drag items 
from one list box to the other.) 

To enter the drawdown data for the monitoring wells, click on the Well Data tab.  
This spreadsheet has tabs along the bottom for the Match Data and each of the 
monitored wells.  Click on the N-1 tab to begin entering the data.  By now you 
probably have experience entering data into the spreadsheet using the keyboard so 
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we will import the data from an ASCII file.  Click the right mouse button within the 
spreadsheet to activate the context menu and select Import.  Import the file n-1.dat 
which should be contained in the AquiferWin32 directory.  Repeat the procedure for 
the other three monitored wells using n-2.dat for well N-2 and n-3.dat for well N-3.  
Since this tutorial attempts to represent real world, we must now correct a mistake.  
The time data contained in the ASCII files are represented in minutes and the units 
on the Time columns in the respective spreadsheets is seconds.  Activate the context 
menu (right click the mouse) and select Column Conversion.  Set the Column 
combobox to “Time” and click on the “minutes” radio button.  Click on the Apply 
Units and Apply Globally check-boxes and then click the OK button to perform the 
unit change.  The Apply Globally check-box made the unit change to all time data 
throughout the data file saving us some time.  Obviously, global unit changes 
without data conversion must be done with care. 

After we accept the Aquifer Test Information property sheet by clicking the OK 
button, we are ready for the next step.  You will note that the Match Data 
spreadsheet to the left of the map has only changed in that the units on the Time 
column are now minutes due to our global time unit change.  We must now define 
the "Analysis" by using the Edit->Analysis menu.  The Analysis tab contains 
additional user fields and determines how the pumping rate is calculated from the 
pumping schedule.  In this case, the default, Calculate Time Average Pumping, is 
acceptable.  Click on the Match Data tab as shown below. 
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There are various ways to analyze this problem so we will begin with the most 
traditional which is to combine all the wells together adjusted by radial distance.  To 
accomplish this, click on the Include Well In Match Data radio button and the Adjust 
Data for Radial Distance check-box.  Change the selection in the Well Designator 
combobox to “N-2” and repeat the previous settings.  Also, change the Symbol  Style 
to something other than the default.  Repeat the procedure for well N-3 and click the 
OK button.  Since we have made changes to the symbol styles, the following dialog 
will be displayed to confirm that we want to reset all symbols.  Click the Yes button. 

The spreadsheet has now been populated with the resulting data to be analyzed.  At 
this point the columns of the spreadsheet may need to be expanded to better see the 
column titles and data.  The easiest way is to click within the spreadsheet and select 
the View->Optimize menu which will make the columns just wide enough to 
display their contents.  Click on the Match Data tab to display the Type Curve 
Graph.  Since we have made some unit changes without converting the data, it is 
good practice to click the Calc->Reset Data Offset menu to reinitialize the data 
offsets.  Notice that the data is nowhere to be seen.  This is because the Adjusted 
Time coordinates are much lower than the minimum for the graph.  You can either 
repeatedly hit the right arrow key until they come into view or optimize the solution 
via the Calc->Optimize menu.  In this example, optimizing the solution gives a 
Transmissivity value of 13376.4 ft2/d and a Storage coefficient value of .000201527. 

Another way to analyze the same data is to include each well individually and 
optimize them as a group.  Choose the Edit->Analysis menu and click on the Match 
Data tab.  For each monitoring well click on the Include Well Individually radio 
button and click on the Adjust Data for Radial Distance to stop dividing the time 
data by radial distance squared.  Click on the OK button and the window would look 
like the one below. 
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Now that there are multiple data sets being analyzed individually, things are more 
complicated; however, this flexibility allows more detailed analysis of the data.  The 
group optimization procedure allows total control over which parameters are 
optimized across data sets.  Before we delve into the intricacies of this procedure it is 
important to understand how to work with multiple data sets.  The first thing to 
understand is that each well has its own set of analysis parameters that can be 
manipulated individually.  To demonstrate, manually match the currently selected 
data set, N-1, to the type curve using the arrow keys.  Fine tune the match by holding 
down the shift key while using the arrow keys.  To see how close your visual match 
is to the "optimized" match, activate the Calc->Optimize menu.  Toggle between 
data sets using the Edit->Toggle Data Set menu or the accelerator key Ctrl-D.  
Notice that the view tab changes to "Match Data - N-2" to indicate the active well.  
Also, note that the data values in the spreadsheet change to reflect the active well.  
Repeat the manual match and optimize match for this data set and for the N-3 data 
set.  As you toggle between data sets the status bar reflects the differing values 
calculated for Transmissivity and Storage Coefficient.  The same results could be 
achieved by simply using the Calc->Optimize Group menu which will optimize all 
data sets individually because we have not set any parameters to be optimized as a 
group. 

Using this procedure, you can determine the variability of the calculated parameters 
(Transmissivity and Storage Coefficient) to data from each well.  To simulate the 
previous results when all data were adjusted by radial distance and treated as one 
data set, use the Edit->Group Optimize Parameters menu.  The Group Optimize 
Parameters property sheet is an Add/Remove list box pair in which the Available 
Parameters list box contains all analysis parameters that are free to vary in each data 
set.  Click the Add button twice to move both “Transmissivity” and “Storage 
Coefficient” to the Optimized Parameters list box and click the OK button.  Now, 
clicking the Calc->Optimize Group menu will optimize all three data sets such that 
the best value of Transmissivity and Storage Coefficient are determined.  Click the 
Calc->Optimize Group menu and toggle through the data sets.  Notice that the 
value of Transmissivity and Storage Coefficient displayed in the status bar are all the 
same and, not coincidentally, equal the values calculated using the more traditional 
analysis we performed first. 

The final step in any analysis is to prepare a graph for the report.  The first thing to 
do is add a legend to the graph indicating which symbols represent the well data.  
Click on the Add->Legend menu and drag a rectangle along the bottom of the 
window.  After dragging a rectangle, the Legend Wizard will be displayed.  As 
before, just clicking finish is sufficient to add the default legend.  In this case, we 
want to click Create Empty Legend to create a different type of legend. 

After the legend box is displayed, double click on it to display the Legend 
Information property sheet.  Set the Spatial Parameters such that X1 equals “1”, Y1 
equals “.25”, X2 equals “9” and Y2 equals “0”.  Click on the Contents tab and click 
the Display Border check-box to deactivate it.  Next click the Items tab and click on 
the Automatic Maintenance of Graph Data Sets check-box to activate it.  Finally, 
click the OK button to accept the changes.  A legend will be displayed containing 
the symbol and well name for each data set.  In order to edit the label and/or font 
used, use the Edit->Graph menu to display the Graph Information property sheet.  
Click on the Line Styles tab, set the Data Set combobox to “N-1” and enter "Well N-
1" in the Label field.  This will override the default label which is the name of the 
well.  Click on the Font button and change the Font to “Times New Roman”, the 
Font Style to “Bold”.  Click the OK button and then set Color to “Red”.  Repeat the 
procedure for N-2 and N-3 and click the OK button to accept the changes. 

Add a more meaningful title to the graph by right clicking on the graph and selecting 
Graph from the context menu.  On the Graph tab, change the Title field to be 
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"Lohman Theoretical Confined Aquifer Test" and click on the OK button.  Now 
annotate the graph to display the calculated Transmissivity for all three wells. 

Click the Add->Legend menu and drag a rectangle starting from the lower right 
corner of the graph into the graph body.  The size does not matter only the starting 
point since the legend size will be automatically adjusted.  On the first page of the 
Legend Wizard click the Automatically Adjust and Locate Legend checkbox to 
uncheck it, click the Create custom legend checkbox to check it and then click the 
Next button.  Remove Transmissivity and Storage Coefficient from the right list box 
since these represent the current well values which change as you toggle between 
wells.  Now, drill down into the tree control into Specific Wells/N-1/Analysis 
Parameters and select Transmissivity.  Click the Append button to add it to the right 
list box.  Now, edit the Title field to be “Well N-1 Transmissivity”.  Repeat the 
procedure for the other two wells.  Click the Next button twice, click the Symbol 
Sublegend check box to remove it from the legend and click the Finish button. 

 
In order to demonstrate the manual procedure, you could accomplish a somewhat 
less complex legend as follows.  Use the Add->Legend menu and drag a rectangle 
in the lower right area of the graph.  On the Legend Wizard click the Create empty 
legend radio button and click the Finish button.  Double click the mouse inside the 
legend you just crateed to display the Legend Information property sheet.  Set X1 
equal to “5”, Y1 equal to “1.5”, X2 equal to “8.5” and Y2 equal to “3.25”.  Click on 
the Contents tab and set the Type combobox to “Solid”.  Click on the Items tab and 
set the Item Type combobox to “Title Object” and click on the Add button.  Set the 
Title field to "Well N-1" and X, Y to “.25”, “1.25”. Click on the OK button.  Repeat 
the add procedure for wells N-2 and N-3 using X, Y of “.25”, “.75” and X, Y of “.25”, 
“.25” respectively.  Now change the Item Type combobox to “Parameter Object” and 
click the Add button.  The following property sheet should be displayed. 
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In the Tree Control List Box, click on the + sign for “Specific Wells” to reveal the 
detail.  Continue to drill down into “Specific Wells/N-1/Analysis 
Parameters/Transmissivity” and select “Transmissivity”.  Set the X and Y values to 
“1.1” and “1.25”.  Add two more parameters for N-2 and N-3 using X, Y values of 
“1.1”, “.75” and “1.1”, “.25”.  Accept the legend by clicking on the OK button.  The 
resulting graph is displayed below. 
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Now that the analysis has been performed and the beautification procedure is done, 
activate the Edit->Group Optimize Parameters menu and remove 
“Transmissivity” and “Storage Coefficient” from the Optimized Parameters list box 
by clicking the Remove button twice.  Accept the property sheet by clicking the OK 
button.  Activate the Calc->Optimize Group menu and notice that the legend is 
updated at the end of each iteration.  When the process has completed, you now have 
a graph in which the data from all three monitoring wells have been optimized 
independently and the resulting transmissivity values are displayed. 

Now save the analysis document via File->Save As and name the file multwell.aqw 
and exit the program. 

Suppose that you are generating your final report using an OLE Container program 
such as Microsoft Word.  Since AquiferWin32 is an OLE Server, you can link the 
newly created analysis document directly into the report such that subsequent 
changes to the analysis will be automatically updated in your report.  To perform this 
operation, start up your OLE Container (e.g. Microsoft Word) and create a new 
document.  Click on Insert->Object menu and you should get a property sheet 
something like this: 

 
Notice that there are entries in the Object Type list box for the four AquiferWin32 
document types.  If you were to select one of them and click the OK button, you 
would find yourself in AquiferWin32 editing a new document of the selected type.  
Such a document would then remain an editable part of the document totally self-
contained.  Since we want to create an OLE Link click on the Create from File tab 
which will display the following property sheet. 
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Click on the Browse button and locate the file multwell.aqw, click the Link to File 
check-box and close the property sheet using the OK button.  When all the window 
flashing and disk access stops, the graph from your analysis document will be part of 
the Word document. 
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Double click the mouse on the graph and you will find yourself in AquiferWin32 

editing multwell.aqw.  Click the mouse within the graph in AquiferWin32 and hit the 
down arrow key.  Use the menu File->Save to save the change and change windows 
to the OLE client software in normal windows fashion.  Notice that the graphic 
within the Word document has changed to reflect the change made to the 
AquiferWin32 analysis. 
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Analyzing Recovery Tests 
 

What you will learn: 

• analyzing the recovery of an aquifer test 

• alternative solution using variable pumping 

The first tutorial demonstrated how to analyze a simple aquifer test, one in which 
there is only one observation well.  This tutorial shows how to analyze the recovery 
data from that same test taken from a real aquifer test reported by Kruseman and de 
Ridder (1990; page 59). 

As previously stated, Kruseman and de Ridder call this aquifer test Oude Korendijk 
for the area where the test was conducted.  The pumping well was screened over the 
entire aquifer thickness of 7 meters.  Piezometers were placed at distances of 0.8, 30, 
90, and 215 meters.  The well was pumped at a constant discharge rate of 0.547 
m3/min for 14 hours.  This tutorial will use time and drawdown data including 
recovery for the 30 meter piezometer. 

Entering Data 

Start a new aquifer test by clicking the  button on the Standard toolbar or select 
File->New.  The default graph type is for the Theis confined analysis which we will 
change after the data has been entered.  The first thing you should do when starting a 
new analysis is to set the units for the pumping test data.  Select Edit->Units to tell 
AquiferWin32 what units you are using.  In this case, select minutes (min) for Time 
Units, meters (m) for Length Units, meters cubed per minute (cu m/min) for 
Pumping Rate Units, and  square meters per minute (sq m/min) for Transmissivity 
Units.  Click the Apply Globally and Save As Defaults check-boxs at the bottom of 
the property sheet to set these units for the entire analysis including all data types and 
accept the property sheet by clicking the OK button. 

Import the drawdown versus time data including recovery from the file fulltest.dat.  
To import the data from a text file, click on the first line in the spreadsheet to 
highlight that row.  Select File->Import and find the file.  AquiferWin32 will notify 
you that 51 lines were imported.  If necessary, delete the default 1,1 data point. 

It is important to note that the data for a recovery test is the same as for a pumping 
test.  Time is relative to the start of pumping and drawdown is relative to the original 
static water level before pumping began.  You do not have to delete the data from the 
pumping test because the recovery analysis will automatically ignore it. 

Now that we have the time and drawdown data, we will enter the remaining test data.  
Select Edit->Aquifer Test to enter the pumping rate and distance to observation 
well.  Click on the Pumping tab on this property sheet and enter the following 
information: 

Pumping Well Name P1 

Pumping rate 0.547 m3/min. 

Pumping well screen length 7 m 

Monitoring Well Name H30 
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Radial Distance 30 m 

Screen length 7 m 

 

The property sheet should resemble the one below.  Click OK when you are done.   

 

Traditional Analysis 
At this point, click the Edit->Solution menu to activate the Solution Information 
property sheet.  Select “Theis, 1946 (Recovery)” in the solution combobox.  Click 
the Parameters tab and enter “830” into the Time Recovery Starts edit field.  Make 
sure the units are in minutes by right clicking in the edit field and selecting Units 
from the context menu; make sure the Time Units are minutes.  (NOTE: Forgetting 
to enter the Time Recovery Starts correctly is the most common mistake made 
using this analysis; it is used to properly convert the data for the analysis.)  
Accept the property sheet by clicking the OK button.  The resulting graph is shown 
below.  The data points prior to recovery are not displayed and a linear regression 
has been performed to calculate a transmissivity of .31 m2/min. 
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In a recovery test, as with other tests, the late data is usually assumed to be more 
representative.  In this case, the late data is on the left of the graph because it has 
been scaled during the analysis.  Click the Edit->Aquifer Test menu and click on 
the Well Data tab.  Change the weight on lines 35 through 39 to 100 which will 
remove them from consideration for the purposes of linear regression.  Also, change 
the symbol to a triangle for the same data points to visually indicate which points are 
being ignored.  Accept the property sheet by clicking the OK button.  Now click the 
Calc->Optimize menu to recalculate an answer. 
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Variable Pumping Analysis 
The linear regression Theis recovery analysis is the traditional method for analyzing 
recovery data; however, AquiferWin32 offers another alternative.  Since AquiferWin32 
supports variable pumping rates, we can analyze the pumping and recovery data 
simultaneously.  To set up for this analysis we can define and use wells on the site 
map or continue using a simple solutions without wells defined. 

Without Using Wells 
Click the Match Data view tab followed by the Edit->Solution menu.  Set the 
analysis to “Theis, 1935 (Confined)”.  Click the Advanced button to activate the 
Advanced Solution Information dialog box and click the Calculate Initial Estimates 
check-box to unset it.  Accept the property sheet by clicking the OK button.  Next, 
click the Edit->Aquifer Test menu to activate the Aquifer Test Information property 
sheet.  Click the Pumping tab and set the Variable Pumping Rate checkbox.  Click 
the Rates tab that was added to the property sheet and right click the mouse on the 
spreadsheet and click the Insert menu.  Click the mouse in the first row of the 
Pumping Rate column and enter the value .547.  Hit the Return key to add another 
line to the spreadsheet and enter 830.  Hitting the Return or Tab keys would 
advance to the Pumping Rate column but 0 is the value we want so click the OK 
button. 

Since data points had been modified with respect to weight and symbol, we need to 
set them back.  Click the Edit->Aquifer Test menu and click on the Well Data tab.  
Change the weight on lines 35 through 39 back to 1 and change the symbol back to 
an X.  Accept the property sheet by clicking the OK button.  Finally, click the Calc-
>Optimize menu to optimize the solution.  Click the Predicted view tab to review 
the results presented below.  If the curve extends beyond the limits of the graph, 
click the View->Clip Data menu. 

 



 

80  •  Tutorial Guide to Using AquiferWin32 

Using Wells 
To set up for this analysis we must add wells to the site map to set up for a multiple 
well analysis.  Click the Site Map tab on the view to activate the map.  Click the 
Add->Well menu and left click the mouse somewhere on the map.  The Well 
Information property sheet will be displayed.  Enter the values as below. 

 
Repeat the procedure to add the monitoring well and enter the values as below. 
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Click the Match Data view tab followed by the Edit->Solution menu.  Set the 
analysis to “Theis, 1935 (Confined)”.  Click the Advanced button to activate the 
Advanced Solution Information dialog box and click the Calculate Initial Estimates 
check-box to unset it.  Click the Parameters tab and unfix Transmissivity if it has 
been fixed by clicking on the push-pin check-box adjacent to the field.  It may have 
been set to fixed by the previous linear regression analysis.  Accept the property 
sheet by clicking the OK button.  Next, click the Edit->Aquifer Test menu to 
activate the Aquifer Test Information property sheet.  Click the Pumping tab and set 
the Pumping Well combobox to “PW”.  Click on the Pumping Rates spreadsheet and 
enter the pumping schedule.  To add a line to the spreadsheet, hit the Ins key and 
change the Pumping Rate to “.547” and hit the Tab key to advance to the next line 
adding another data point.  Enter a Time of “830” and a Pumping Rate of “0”.  Click 
the Wells tab and click the Add button to move “MW” from the Available Wells to 
the Monitored Wells list box.  Click the Well Data tab to enter the time/drawdown 
data.  Since the time/drawdown data is already in the Match Data tab of the 
spreadsheet from the previous analysis, right click the mouse on the spreadsheet and 
select the Select All menu item from the context menu.  Copy the information using 
Ctrl-C from the keyboard or Copy from the context menu.  Click the MW tab of the 
spreadsheet and paste using  Ctrl-V or Paste from the context menu.  Accept the 
property sheet by clicking the OK button. 

Next, click the Edit->Analysis menu to activate the Analysis Information property 
sheet.  Click the Variable Pumping radio button to use the pumping schedule we 
entered previously.  Click the Match Data tab, select “MW” in the Well Designator 
combobox, click the Include Well in Match Data check-box and accept the 
property sheet using the OK button. 

Now that the data has been entered, perform a manual match against the type curve 
ignoring the recovery data points to get a good initial estimate for the parameters.  
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Finally, click the Calc->Optimize menu to optimize the solution.  Click the 
Predicted view tab to review the results presented below. 
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Analyzing Slug Tests 
 

What you will learn: 

• analyzing a slug test 

• using different slug test analysis techniques 

• more about unit conversions 

Slug tests seem to be routine in many field investigations because they are simple 
and cost-effective to perform.  If you are looking for a procedure to perform all slug 
tests, this tutorial may be the answer.  The first step is to use the File->New menu to 

create a new document since the  button on the Standard toolbar defaults to an 
“AquiferWin32 Analysis” document.  Select “AquiferWin32 Slug Test” from the list 
box and click the OK button.  The default analysis for a slug test is the traditional 
linear regression version of Bouwer and Rice.   

The next step is to enter the time and displacement data.  The particular data set we 
will use is taken from Lohman (1979; page 29).  The data represent recovery in a 
well under confined conditions. 

To continue our theme of making life a little easier, the data is stored in the file 
dawson.dat.  Before importing the data, however, activate the spreadsheet view by 
clicking the mouse in the column title part of the spreadsheet.  Use the Edit->Units 
menu and set the values as below. 
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Accept the property sheet by clicking the OK button.  Next, import the data by right 
clicking the mouse on the spreadsheet and selecting Import from the context menu.  
Locate the file dawson.dat and load in the data.  Notice that the import has left the 
initial data value 1,1.  Click the left mouse button on the line number column 
(leftmost column) and hit the Del key to delete the row.  Now, click the mouse in the 
graph view and, resisting the temptation to use the Calc->Optimize menu, click on 
the Edit->Aquifer Test menu. At this point, skip the user fields and click on the 
Well tab.  It is important to complete the well construction information on this tab 
because the analysis requires it.  The field book says that: "the well is cased to 24 m 
below the top of the aquifer with 6 inch casing and drilled as a 15.2 cm open hole to 
a depth of 122 m and the theoretical initial displacement should be .56 m".   Put a 
meaningful value in the Well Name field like "Well".  Now enter the Casing Inner 
Diameter which is initially set to “.5” meters.  If you are unsure of the units, move 
the mouse cursor over the Casing Inner Diameter field and wait.  The units "m" will 
be displayed as a tool tip and the status bar will display "Casing Inner Diameter (m)". 

Lets take a moment to learn about units and unit conversions.  In this case, we have a 
field that wants meters and we have a value in inches.  Let us assume that our 
calculator battery died.  You now have several options.  The obvious first option is to 
do the conversion manually and enter the value.  A second option is to right click on 
the Casing Inner Diameter field, select the Units menu, change the units to inches, 
click the OK button and enter 6 into the field.  The system doesn't care what units 
you use because it internally converts all data before performing calculations.  You 
can go wild and use whatever units you want on a parameter by parameter basis.  
(This is not recommended if you are using Windows 3.x since the tool tip reminder 
as to unit values doesn't work!)  For our purposes here, click the Cancel button to 
cancel the changes. 

Click on the Edit->Aquifer Test menu again and feel free to fill in any user fields 
on the Test tab before clicking to the Well tab.  After entering something meaningful 
in the Well Name field, enter “6” in the Casing Inner Diameter field.  Right click on 
the Casing Inner Diameter field and  select Data Conversion from the context 
menu.  Click on inches in the Length radio buttons of the From tab of the embedded 
property sheet to indicate the units of the previously entered value.  Click on the To 
tab and notice that the units to convert to are not editable and reflect the prevailing 
units of the parameter being edited.  Now click the Convert button followed by the 
OK button.  The value of 6 inches has been converted to meters and the field has 
been updated with the converted value. 

To complete the data entry, type “.1524”, “98” and “24” in the Diameter of Drilled 
Hole, Screen Length and Screen Top Depth fields.  Finally, enter “.56” into the 
Initial Displacement field and accept the property sheet by clicking the OK button. 

The next step is to click on the Edit->Solution menu and update any additional 
parameters that are required for the analysis.  Since this is a linear regression 
solution, the Convergence Information on the Solution tab is disabled.  Click on the 
Well Parameters tab and note the previously entered well construction parameters 
are being used and there is one additional parameter.  The Gravel Pack Porosity 
defaults to “.3” which is fine.  In fact, unless the water is recovering within the 
screen or open hole interval, this value is not used by the analysis.  It is important to 
note at this point the custom check-boxes to the right of the fields.  The lower check-
box indicates whether the parameter is "linked" to a value entered at another section 
of the program.  In this case, the first four parameters are linked to the values 
previously enter in the Aquifer Test Information property sheet.  Should we choose to 
do so, we can unlink any or all of the values and enter an override value.  This action 
will not change the linked value and the linked value can be restored by relinking the 
parameter.  The upper check-box is not used in a linear regression analysis; however, 
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it determines if the parameter is free to vary in a curve match scenario.  A linked 
value is always fixed so it has to be unlinked to be estimated by the program. 

Click on the Hydraulic Parameters tab and change the Aquifer Thickness to “124”.  
If we wanted to simulate recovery within the well screen, the Correction Type should 
be set to “Recovery within Screen”.  Now click on the Additional Results tab and 
notice additional parameters are present.  The Effective Casing Inner Diameter and 
Effective Screen Inner Diameter  are calculated values used by the analysis that 
differ from the Casing Inner Diameter and Screen Inner Diameter  only if recovery 
is occurring within the screened interval.  There are also three additional calculated 
parameters which are specific to this analysis.  An attempt has been made to provide 
you with all the values you would need should you want to do the calculations on 
paper.  Accept the property sheet by clicking on the OK button. 

Now the time has come to calculate the optimized solution.  For this analysis, the 
optimized solution is achieved via linear regression.  Click in the graph view and 

click the  button on the Match toolbar or use the Calc->Optimize menu.  Notice 
that a linear regression has been performed on the data and the Bouwer and Rice 
solution has been calculated.  What a minute, this is supposed to be a confined 
analysis and the value for initial displacement should be .56 not the .453982 
calculated by linear regression.  Lets ignore for the moment that we know the 
solution is confined. 

There are two primary ways to determine the initial displacement, H0, and the slope 
of the line.  The first way is to manually set it.  Move the mouse cursor over the 
linear regression line near the center of  the graph.  The cursor will change to the 
NSEW cursor (the one with arrows pointing up, down, left and right).  Double click 
the left mouse button and the Regression Line Information property sheet is 
displayed. 

 
Actually, this property sheet is the best way to set H0 so change Intercept to the 
value we know to be cast in stone, “.56” meters.  Now if you are a veteran slug tester 
or if you read Bouwer and Rice, you know that the slope of the line and the well 
construction parameters are the only parameters that are involved in the calculation.  
How then do we proceed?  Accept the property sheet by clicking the OK button.  
You now have a "best fit line" that doesn't hit any of the data points.  (There are 
actually three lines on your screen; the outermost lines are actually part of the 
rectangle that surrounds the line and indicates that the line has been selected.  If you 



 

86  •  Tutorial Guide to Using AquiferWin32 

click the left mouse button outside of this rectangle the selection will disappear.)  
Now, move the mouse cursor over the rightmost section of the line.  The cursor will 
change to an EW (arrow left and arrow right) cursor indicating that you can move it.  
Click the left mouse button, hold it down and drag the end of the line around until 
you are satisfied that you have generated an acceptable match to the data.  Notice 
that as you drag the line around, the calculated value of hydraulic conductivity, K, 
changes too.  If you were to move the entire line, the calculated value of K would not 
change because only the slope matters.  Incidentally, the same procedure works for 
the left portion of the regression line so you never have to use the Regression Line 
Information property sheet as you did above; simply move the left portion of the line 
to reset the H0 (intercept) value.  However you slice it, you have full control on the 
solution just as you would if you were doing it on paper. 

The second approach is for those people who are drawn to the optimize button.  How 
can we change the "optimized" solution?  Right click the mouse on the spreadsheet 
and select the Columns menu from the context menu.  An Add/Remove list box pair 
is displayed showing that there are two additional columns available to you.  Move 
both the weight and symbol columns from the Available Columns to the Displayed 
Columns by clicking the Append button twice and click the OK button.  Where are 
they?  Use the View->Optimize menu to optimize the spreadsheet so that all 
columns are visible and only as wide as they need to be.  (NOTE: You can also 
access these data from the Well Data tab on the Aquifer Test Information 
property sheet).  Change the weight on data rows 5 through 21 to a number of 100 
or greater.  For all linear regression analyses, a weight of 100 or greater removes the 
point from consideration during the linear regression calculation. You can also 
change the symbol displayed for these data by double clicking the mouse on the 
current symbol and changing it.  This would give a visual indication of which data 
were ignored.  In this case, H0 is calculated to be .516 and not the theoretical value 
of .56; however, it is not always possible to know the theoretical H0 and the data 
may be the only indicator as to its value.  The important point is that you have lots of 
ways to perform the analysis. 

Since manually changing the weights and symbols can be time consuming, you could 
drag select lines 5 through 21 and click the Edit->Selection menu.  On the Selection 
Edit Options property sheet, click on the Weight tab.  Click the Set Value radio 
button and enter 100 into the adjacent edit field.  Now click on the Symbol tab, click 
the Set Value radio button, change the Symbol combobox to a triangle and accept the 
property sheet.  This option is easier for bulk changes to the spreadsheet. 

Now lets assume you are convinced that the Bouwer and Rice solution is 
appropriate.  How would you know?  AquiferWin32 takes a step toward answering that 
question with a second Bouwer and Rice solution base on a curve match.  Change 
the weights all back to 1 and all the symbols back to the same style if you changed 
them.  You may also want to slide the splitter bar over to hide the Weight and Symbol 
columns.  You could also remove the columns in an analogous manner to the one 
used to add them earlier. 

Click on the Edit->Solution menu and select “Black, 1978 (Unconfined Aquifer)” in 
the Analysis combobox.  If you look through the property sheet, you will notice that 
nothing has changed from Bouwer and Rice.  Click the Hydraulic Parameters tab 
and click on the push pin check-box next to the Hydraulic Conductivity field if it is 
currently checked.  The previous linear regression analysis may have initialized the 
value to fixed.  Accept the property sheet by clicking OK and attempt to match the 
data to the curve using the arrow keys.  Use the Edit->Aquifer Test menu to 
activate the Aquifer Test Information property sheet and click on the Well tab.  
Change the Initial Displacement to “.56” and try again.  Notice that the data is 
automatically rescaled to the new value and doesn't match any better.  Obviously, 
this data doesn't represent an unconfined aquifer response as shown below. 
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Another step to try is to click the Edit->Solution menu and go to the Hydraulic 
Parameters tab.  Unlink and unfix the Initial Displacement value by clicking both of 

the check-boxes to the right of the field so it looks like this .  Accept the 
property sheet by clicking the OK button.  Now click Calc->Optimize button and 
look at the results.  This process will optimize both T and H0 but doesn’t result in a 
good match.  The validity of this step is determined by how confident you are with 
the value of H0. 

Since the unconfined solution did not give an acceptable match and because we 
know the response is confined, we will move on to the confined solution.  Click on 
the Edit->Solution menu and select “Cooper, Bredehoeft & Papadopulos, 1967 
(Confined Aquifer)” for a confined slug test analysis.  Click on the Hydraulic 
Parameters tab and relink the Initial Displacement by clicking on the lower of the 
two check-boxes to the right of the field.  Now click on the OK button.  The system 
will calculate the 10 standard type curves for this analysis.  Use the arrow keys to 
match the data to the third curve from the left.  Hit the Ctrl-T key twice to select that 
curve (the currently selected type curve changes color), fine tune your match and 
look to the status bar for the answer.   

To get an optimized solution, go ahead and select the Calc->Optimize menu.  Notice 
that now the optimized solution has matched to a curve that is not displayed.  Click 
on the Edit->Solution menu and click on the Hydraulic Parameters tab and click on 
the little push pin check-box to the right of the Alpha field.  This will "fix" the 
parameter and remove it from optimization.  Set the value to .001 and click on the 
Apply button to optimize the match.  This would essentially optimize the manual 
match we did earlier.  Click on the little right arrow at the upper right of the property 
sheet to advance the tabs and click on the Statistics tab to quantify the "accuracy" of 
the curve match.  The residual standard deviation is .004379.  Now click on the 
Exceptions tab, select “Initial Displacement” in the Parameter combobox and click 
on the Linked Value check-box followed by the Fixed Value check-box; this tab 
provides an alternative way to link/unlink and fix/unfix parameters and also shows 
you where range information can be set for each parameter.  It is sometimes 
necessary to enforce minimum and maximum parameter values to achieve an 
optimized match.  In this case, they are not necessary so click on the Apply button.  
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Notice that the calculated value for Initial Displacement has changed to .547477 and 
a look at the Statistics tab reveals a residual standard deviation of .003467. 

How do I optimize the solution for Alpha and get the curve on the graph?  Go back 
to the Hydraulic Parameters tab and click on the push pin check-box next to Alpha 
and click on the Apply button.  Now click on the Hydraulic Results tab to see the 
calculated values or look in the status bar.  Go to the Curves tab and decide what 
curves you want on the graph.  Remove all but one of the values from the Curve 
Information list box by selecting them and clicking the Delete button.  Select the one 
remaining value and click on the Edit button.  Change the value to “.000136”, 
change the Label Format to “EXPONENTIAL” and change the Precision to “6” and 
click the OK button on the property sheet.  Click the OK button on property sheet 
and there is your optimized answer.  If you are not concerned with having the exact 
type curve represented on the graph you can skip this last step and use the Predicted 
view tab which displays the observed displacement data with the predicted 
displacement curve through the data. 

The final step in any analysis is to prepare a graph for the report.  The first thing to 
do is add a legend to the graph indicating what the symbols represent.  Click on the 
Add->Legend menu and drag a rectangle starting at the lower left hand corner of the 
graph.  The size does not matter but the starting point is the anchor point for the 
legend.  After dragging a rectangle, the Legend Wizard will be displayed.  Click the 
Create custom legend radio button and uncheck the Automatically Adjust and 
Locate Legend checkbox.  Click the Next button three times to go to the Styles page; 
uncheck the Symbol Sublegend checkbox and click the Finish button. 

Add a more meaningful title to the graph by right clicking on the graph and selecting 
Graph from the context menu.  On the Graph tab, change the Title field to be 
"Dawsonville Slug Test" and click on the OK button.  The resulting graph is 
displayed below. 
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Simulating Aquifer Tests 
 

What you will learn: 

• simulating an aquifer test 

• plotting simulated drawdown contours 

• plotting simulated hydrographs at observation wells 

The Professional version of AquiferWin32 can also be used to simulate pump tests.  If 
you have an idea of the type of response and hydraulic properties of an aquifer, you 
can estimate the aquifer response to a given pumping rate.  The response can be 
depicted as contour maps at given times and drawdown versus time graphs at any 
number of monitoring wells. 

First, use the File->New menu and create an “AquiferWin32 Simulation” document.  
The only visible object on the Test Simulator view is an arrow.  This arrow is the 
reference head arrow used to define the uniform flow field from which to subtract 
the drawdown predicted by the analysis.  To edit the parameters click the Edit-
>Reference Head menu.  We are not going to change any of the values because we 
are interested in a contour map of drawdown.  Given this fact, click the View-
>Reference Head menu to hide the reference head arrow. 

As with other tutorials, use the Edit->Units menu to set up the units to be used for 
the simulation.  Edit the values as below. 

 
Instead of using the Add->Well menu to add wells to the map, click on the Edit-
>Map Items menu to display the Map Item Information property sheet.  Set the Item 
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Type to “Well Object” and click the Add button.  The Well Information property 
sheet is displayed to set the pertinent parameters for the well.  Edit the Well 
Information property sheet as below. 

 
Accept the property sheet by clicking the OK button and add two additional wells. 

 

Well Screen Length Screen Top Depth X Y 
MW1 3 45 5500 4000 

MW2 3 97 4500 4000 

Assume that the aquifer thickness is 100 feet, we have screened the pumping well in 
the center and one monitoring well at the top and one at the bottom.  Accept the Map 
Item Information property sheet and the wells will appear on the map.  Next, click on 
the Edit->Model menu and select “Hantush, 1961 (Confined Partial Penetration)” in 
the Analysis combobox.  Select “PW” in the Pumping Well combobox and enter 
“2880” in the Contour Time field.  Click on the Well Parameters tab and set the 
Screen Length and Screen Top Depth to be “10” and “45” for both the Pumping Well 
and Monitoring Well.  Set the Pumping Rate to “25”.  Click on the Hydraulic 
Parameters tab and set the values as below. 
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Click on the OK button to accept the values and click the Calc->Recalculate menu 
to calculate the simulation.  The resulting contour map represents a projection of the 
drawdown expected in monitoring wells screened between 45 and 55 feet in response 
to a pumping well similarly screened pumping at 15 gpm for 2 days. 

Next we will adjust the contour parameters.  Click on the Options->Contour-
>Parameters, click the Levels tab change the Minimum Level to “-8.5” and the 
Interval to “.25”.  Click on the Labels tab and change Distance between to “2000”.  
Click on the Font button and change the point size to “14” and change the Font Style 
to “Bold”.  Click on the OK button and click on the Yes button in response to the 
subsequent message box.  Click the View->Full->Screen menu to adjust the map 
scale.  The resulting window is shown below. 
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To generate drawdown versus time data for the two monitoring wells previously 
added to the map, click on the Edit->Simulation menu, click on the Wells tab and 
click on the Add button twice to move “MW1” and “MW2” from the Available 
Wells list box to the Monitored Wells list box.  Click on the Well Data tab and notice 
that the spreadsheet has three tabs along the bottom.  One tab for each monitored 
well and the Simulation Times tab.  The values contained in the Simulation Times 
tab are used for all monitored wells.  Click on the OK button to accept the property 
sheet and click the Calc->Recalculate menu to calculate the solution.  To view the 
graphic results, click the View->Well Data menu to add two additional tabs to the 
view.  Click on both of the new tabs to view the results.  Click on the View->Clip 
Data menu to clip all data points not contained within the limits of the graph.  The 
difference between the two graphs is caused by the effects of partial penetration. 

Now we want to adjust the graph to display the same axis scales.  Although we could 
change them individually, an easier way is to click the Edit->Default Well Graph 
menu.  Click the X-Axis tab and enter “.01” for the Minimum X edit field and click 
on the Automatic Minimum check-box to unset it.  Click the Y-Axis tab and click 
on the Automatic Minimum check-box to unset it.  Click the OK button to accept 
the property sheet.  In order to activate the defaults, click the Edit->Simulation 
menu and go to the Wells tab.  Click the Remove button twice to remove the wells.  
Now add them back to the Monitored Wells list using the Add button. When we 
removed them the graph parameters were removed.  Adding them, initializes graph 
parameters using the Default Well Graph parameters.  Click the OK button to accept 
the changes.  Click the Calc->Recalculate menu and the graphs are as presented 
below. 
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Water Table Aquifers 
What you will learn: 

• Using Neuman’s Water Table Analysis Method 

 

This section outlines how to analyze an unconfined aquifer pump test.  The particular 
data are taken from Lohman (1979; page 38, Table 14).  The first step is to create a 

new analysis document by clicking on the  button on the Standard toolbar.  This 
toolbar button creates a new “AquiferWin32 Analysis” document whereas the File-
>New menu presents the five potential document types. 

Once the document is created, the first step is to set the units to be used in the 
simulation.  The Edit->Units menu displays a property sheet with two tabs.  The 
first tab, Summary, contains the four basic parameters and their respective units.  
The values represent either the program defaults or the values previously saved as 
default.  Under normal circumstances, you would set the summary units to most 
closely approximate the units of the data collected.  Set Time Units, Length Units, 
Pumping Rate Units and Transmissivity Units to “min”, “ft”, “gal/min” and “sq 
ft/min”.  Click the Save As Default check-box and the Apply Globally check-box.  
There is no need to click the Convert Data check-box because no data exist yet.  
Accept the property sheet by clicking the OK button. 

Click on the Edit->Aquifer Test menu.  The first tab of the Aquifer Test Information 
property sheet contains user-fields.  These user-fields can be used to annotate any 
graph or map view and are also included in the hard copy report.  Click on the 
Pumping tab and enter  “PW” as the Well Name in the Pumping Well section and 
enter “1080” into the Pumping rate field.  Enter “MW” as the Well Name in the 
Monitoring Well section and enter “73” in the Radial distance field.  The remainder 
of the well construction information is not required since this analysis will not 
consider partial penetration. 

To enter the well response data for the monitoring well, click on the Well Data tab.  
This spreadsheet has one tab along the bottom for the match data.  Click on the row 
number column of the first data row to select it and hit the Del key to delete the data 
row.  By now you probably have experience entering data into the spreadsheet using 
the keyboard so we will import the data from an ASCII file.  Click the right mouse 
button within the spreadsheet to activate the context menu and select Import to 
import the data from the file unconf.dat. 

After we accept the Aquifer Test Information property sheet by clicking the OK 
button, we are ready to select the analysis to use.  Click the left mouse button in the 
graph view to activate its menu.  Select the Calc->Reset Data Offset menu which is 
good practice when changing units without converting the data.  Click the Edit-
>Solution menu, click on the Analysis combobox and select “Neuman, 1972 
(Unconfined Aquifer)”.  Click on the Parameters tab and notice the Radial distance 
and Pumping rate have been updated based on our previous entries in the Aquifer 
Test Information property sheet.  Set the Specific Yield to be two orders of magnitude 
higher than the value of  Storage coefficient.  Right click the mouse on the Specific 
Yield data field and select the Sync->Calculated menu  Strictly speaking, this step is 
not necessary but will generate a better set of type curves.   (NOTE:  The ratio of 
Storage coefficient and Specific Yield dictate the offset between the “Early” and 
“Late” portions of the type curves).  Click on the Curves tab and set the contents 
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of the Curve Information list box to “0.001”, “0.01”, “0.05”,  “0.10” and “1.00”.  
Click on the OK button and the screen should appear as below. 

 

Click on the Calc menu and make sure there is a check mark next to the Match 
Early Data menu.  If it is not, click on the Calc->Match Early Data menu.  Move 
the data around using the arrow keys to perform a manual match of the early (left 
most) data points to the left side of the type curves.  Use Edit->Toggle Type Curve 
or Ctrl-T to select the appropriate type curve.  Look at the status bar and note the 
values for T and S which are representative of matching the early data (the initial 
confined response).  Although matches are subjective, match to a T of approximately 
20.3 and an S of approximately .0025 using the .05 type curve.  Next, click the Calc-
>Match Late Data menu to match the late data.  Notice that the data moves and the 
status bar T and S change.  This is because both the Early and Late Matches are kept 
independently as if they were two separate monitoring wells.  Repeat the procedure 
for the late (right most) data to determine T and S for the late data (the unconfined 
response).  This time, match to a T of approximately 23.6 and an S of approximately 
0.111 using the .05 type curve.  As you toggle between the early and late solutions, 
you can see the difference in the value of T. 

Now that you have made your two matches as prescribed by the analysis you have 
finished the traditional solution.  To improve the presentation of the results, you can 
click Calc->Recalculate Type Curves to calculate a set of type curves consistent 
with the new Storage Coefficient and Specific Yield ratio.  By recalculating the type 
curves, you will have to reset the selected type curve.  This step gives you better type 
curves than the traditional ones in the literature because they have been calculated 
specifically to your solutions.  Use Ctrl-T to toggle the type curve selection back to 
the .05 type curve. 

If you want to get an optimized solution and eliminate the need for two separate 
matches, click Edit->Solution,  click the Solution tab and click the Advanced 
button and click off the Calculate Initial Estimates check-box.  The initial estimates 
calculation is not necessary because we performed a manual match.  In some cases, 
this being one, the initial estimates calculation can cause the solution to become 
unstable.  Click the OK button to close the property sheet and click the Calc-
>Optimize menu.  To see the results of the optimization, click on the Edit-
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>Solution menu and go to the Results tab.  If  you would like the exact type value of 
.0468 instead of .05, click on the Curve tab and change Value from .05 to .0468 and 
set Precision to “3”.   Since a curve value was changed, the type curves will 
automatically be recalculated.  Add a legend by clicking the Add->Legend menu, 
dragging a rectangle on the screen and clicking the Finish button on the Legend 
Wizard.  The optimized view is as below. 
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Step Test Analysis 
 

 What you will learn: 

• Using the Eden and Hazel method to determine well performance 

• Automatic and manual matching procedures 

For this particular test, users are guided through the input and analysis of a data set 
taken from Kruseman and De Ridder (1994), page 204.  These data are also used in 
an example file (clarke4.aqp) which can be used to check the analysis results.  The 
data was taken from Clarke L. (1977), The analysis and planning of step-drawdown 
tests.  Q. Jl. Eng. Geol, volume 10. 

The first step is to set up a new file in which to input the step test data.  Selecting the 
File->New menu displays the five types of documents or analysis types, including 
“AquiferWin32 Flow Model”, “AquiferWin32 Analysis”, “AquiferWin32 
Simulation”, “AquiferWin32 SlugTest” and “AquiferWin32” StepTest.  Select 
“AquiferWin32 StepTest” and click the OK button. This action will bring up the 
default Eden and Hazel (Part 1) screen. 

The next step is the specification of the units to be used in the input and analysis.  It 
is recommended that these be specified at this stage, although as you know, the units 
can be modified after input.  For this example, set Time Units, Length Units, 
Pumping Rate Units and Transmissivity Units to “min”, “m”, “cu m/d” and “sq m/d”.  
Click the Save As Default check-box and the Apply Globally check-box.  There is 
no need to click the Convert Data check-box because no data exist yet.  Accept the 
property sheet by clicking the OK button. 

Once the step test has been selected and the units of input chosen, the data input 
process can begin.  You should be familiar by this stage with the options for 
inputting data and be well versed in all of the methods.  Since this is a large data file, 
it is recommended that the file clarkedd.dat be imported as an ASCII file using the 
File->Import menu option.  This file contains only the drawdown/time data and 
when imported the file should contain 174 lines.  It is again important to remove the 
initial default value from the first row of the time/drawdown column.  Next enter the 
pumping rate and time data.  This is entered by selecting the Edit->Aquifer Test 
menu, clicking the Pumping tab, right click the mouse on the spreadsheet and select 
the Insert menu to create a row of data; now, enter the data on the table as shown 
below. 
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Accept the property sheet by clicking the OK button.  Normally, the graph axes will 
automatically rescale to match the data; however, if you now look at the graph, the 
data may appear to be missing.  This is not due to its abduction but to the fact that 
the axes will have to be rescaled to allow the display of this data.  In this particular 
case the maximum on these linear scaled axes should be set such that the maximum 
value for x is 24000 and the maximum value for y is 30.  Click in the graph view and 
activate the Edit->Graph menu.  Click the X-Axis tab and enter “24000” in the 
Maximum X field and click the Automatic Maximum check-box to unset it. Click 
the Y-Axis tab and enter “30” in the Maximum Y  field and click the Automatic 
Maximum check-box to unset it.  When new data sets are to be analyzed the 
drawdown or y-axis can be scaled according to the maximum value of drawdown 
encountered.  In the case of the x-axis it is suggested that the initial scale be set to a 
high value to display the whole data set and that it is scaled down to increase 
resolution of the data at an appropriate lower value of H as desired. 

At this point it is worth mentioning data weighting.  Some of the early data in the 
data sets will not be very useful in the analysis.  If it is desired that some of this data 
be excluded from the analysis, go to the Edit->Aquifer Test menu, Well Data tab 
which can be used to change the weighting of some data points.  If the weight on a 
point is set to 100 or greater, it is then after excluded from the analysis.  A change in 
the symbol type can be used in conjunction with this function to allow the user to 
distinguish excluded data on the graph.  The resulting graph is shown below. 
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Now that these initial data have been entered the test is ready to run.  However it is 
worth noting that there are a number of extra inputs which are specified in the 
property sheet.  The Edit->Site, Edit->Aquifer Test and Edit->Analysis menus 
activate property sheets that can be used for the input of details which can be later 
displayed in the form of title boxes, headers, footers, parameter boxes etc.  The 
details can be entered into the defined boxes or one of the “User Fields” in the User 
tab of each property sheet.  User fields are customizable parameter fields which 
allow input of a wide range of preferred data or text items.  Click on the Edit->Site 
menu to bring up the Site Information property sheet.  If you click on the User tab, 
you will see that each field has a default name.  This default name can be changed 
easily by following the following instructions. Right click the mouse on the title for 
User Field 1 to activate the context menu and select the Edit menu.  Enter “Date” 
into the User Field Title field and click OK to accept the dialog.  Repeat the 
procedure to set User Field 2 to “Start Time”.  If you activate the context menu for 
User Field 3 the property sheet would resemble the one below.  
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Enter “12/31/98” into the newly identified Date field.  If you also activate the Save 
as Default menu for any of the fields, the system registry will be updated and future 
AquiferWin32 sessions will use the value.   

In addition to customizing the property sheets, this information can then be accessed 
in the parameter objects to enhance graphical output.  Accept the property sheet by 
clicking the OK button.  Click the Add->Parameter menu and click the left mouse 
button within the graph.  Drilling down into the tree list you will see the newly 
created fields as below. 
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There are several ways to analyze the data and obtain a solution.  These are briefly 
described in turn below.  The Step toolbar below shows the buttons to be used for the 
step analyses.  The buttons from left to right are: a combobox for choosing the active 
step which is used in conjunction with both the manual match and the single 
regression analysis; the button for performing single linear regression based on the 
active step; the multiple regression button; and the optimization button.  There are 
analogous menus on the Calc menu. 

      

The Calc->Linear Regression–>Single Step menu or  toolbar button calculates 
a linear regression line based on the active step.  In this case, the data for the first 
step or pumping period is used.  Since this analysis requires that the slope of all 
regression lines for all steps be equal, the remaining steps are calculated by 
specifying the slope and then finding the intercept of the best fit line.  The step is 
chosen either by using the toolbar combobox shown above, or using the Edit-
>Toggle Step menu or Ctrl+D accelerator key.  Analysis Step 2 is required to 
complete the analysis. 

The Calc->Linear Regression->Multiple Step menu or  toolbar button 
performs a linear regression on all steps combined to find the best slope across all 
steps and the individual intercepts for each step.  Analysis Step 2 is required to 
complete the analysis. 

The Calc->Optimize menu or  toolbar button performs the Marquardt (modified 
Gauss-Newton) nonlinear least-squares technique to calculate an optimized solution.  
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Analysis Step 2 is not required to complete the analysis.  Furthermore, parameters 
can be fixed and/or constrained during the optimization process.  This is described in 
more detail in previous sections.   

In this instance, change the active step to Step 6 and will use the Calc->Linear 
Regression->Single Step menu to calculate a resulting in a Transmissivity of 217 sq 
m/d.  The resulting graph is shown below. 

 

To complete the analysis, click on the Step 2 tab of the graph view.  Once again, the 
data points, which were calculated based on the results of Step 1, may not be visible 
if autoscalling has been deactivated.  Regardless, click the Edit->Graph menu, click 
the X-Axis tab and change the Maximum X to “6000” and click the Automatic 
Maximum check-box to unset it. Click the Y-Axis tab and change the Maximum Y to 
“.001” and click the Automatic Maximum check-box to unset it.  Also, change the 
Precision to “4”.  Finally, click the Graph tab and change the X-Origin to “1.1” so 
the axis label is not clipped. 

To complete Step 2, click the Calc->Linear Regression->Single Step menu or 
toolbar button.  The result of this step is to calculate the Coefficient of  Turbulent 
Head Loss as 1.31607e-007 sq d/m5.  The units of Coefficient of Turbulent Head 
Loss may be different and can by clicking the Edit->Solution menu, clicking the 
Parameters tab, right click the mouse on the edit field, select the Units menu, set the 
values appropriately, click the Convert Data check box and click the OK button.  
Whether you use the Calc->Linear Regression->Single Step or the Calc->Linear 
Regression->Multiple Step in Step 1, Step 2 remains the same.  If you had used the 
Calc->Optimize menu, Step 2 would be done automatically.  The resulting graph is 
shown below. 
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Changes to the solution can be made using manual methods; the lines can be moved 
in two ways.  First the lines can be adjusted as with other linear regression analyses 
discussed previously.  For analysis Step 1, set the active step using the Step toolbar 
combobox to activate the appropriate regression line.  To change the intercept of a 
line, move the mouse over the line until you get a NSEW (arrows pointing up, down, 
left and right) cursor, click with the left mouse button and drag the line to a new 
position.  To change the slope of the line, move the mouse cursor over either end of 
the line until you get the EW (arrows pointing left and right) cursor, click the left 
mouse button and drag the endpoint to a new position.  In analysis Step 1, all 
regression lines will be updated based on the new slope. 

Now, click the Calc->Optimize menu to calculate the optimized solution.  The 
values for T and C are 219 sq m/d and 1.34311e-007 sq d/m5 respectively.  Click the 
Edit->Solution menu and the Results tab to display the property sheet below. 
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An alternative view of the “goodness of fit” is contained in the Predicted view tab.  
The graph, shown below, was adjusted from the default by changing the axes to 
linear, changing the labels, etc.  It is a useful interpretive aid and allows you to 
establish the accuracy of the fit of the results by comparing observed and predicted 
drawdown versus time.   

 

Another graph presented in the Yield/Drawdown tab predicts the drawdown created 
by pumping at a given rate and over a specified time.  The time is currently taken to 
be the average of the time of each step, equal to 180 minutes in this example.  The 
drawdown line (shown in black on the graph) of the yield/drawdown curve shows the 
total drawdown/yield relationship for the given time, while the second line shows the 
effect of aquifer loss (shown in red on the graph) giving the hypothetical relationship 
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for a 100% efficient borehole.  The curve is useful in evaluating the extent of 
turbulent losses.  The enhanced graph is shown below. 
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Analytical Flow Model 
 

 What you will learn: 

• performing an analytical flow model 

• plotting simulated drawdown contours 

• plotting simulated hydrographs at wells 

• setting up a transient simulation with variable pumping rates 

• automatically calibrating the model to observed target heads 

• adding a legend to the contour map with a color flood bar 

The Modeling version of AquiferWin32 can also be used to perform analytical flow 
models or analyze multiple pumping well aquifer tests.  The analytical elements 
supported by a specific model are specified in the model specific documentation and 
help file.  In general, all models support wells and targets which is what we will use 
in this tutorial.  Additionally, some models support steady-state calculations, some 
support transient calculations and some support both. 

First, use the File->New menu and create an “AquiferWin32 Flow Model” 
document.  The only visible object on the view is an arrow.  This arrow is the 
reference head arrow used to define the uniform flow field from which to subtract 
the drawdown predicted by the analysis.  The first thing to do is set up the units by 
clicking the mouse within the map and then using the Edit->Units menu.  Select 
“min” for Time Units, “ft” for Length Units, “gal/min” for Pumping Rate Units and 
“sq ft/d” for Transmissivity Units.  Click the Save As Defaults and Apply Globally 
check-boxes and accept the property sheet by clicking the OK button.  It is important 
to save your selections as the defaults because these values are used whenever new 
items are created within the document. 

Next, we need to define the map window within which you are going to work.  In 
this case, click the mouse within the map window and use the File->Map menu to 
import the file example.map.  This file represents a large site; however we are going 
to focus our attention on a subset of this map.  Click the Options->Map->Window 
menu and drag a rectangle on the map.  On the Map Window dialog that is displayed, 
enter “40000” for Origin X, “4200” for Origin Y, “2000” for Height and “3000” for 
Width.  Accept the dialog by clicking the OK button.  When asked to adjust the 
contour window to the new map windows, select the YES button. 

Now, we need to define the initial heads for the model.  To edit the parameters click 
the Edit->Reference Head menu.  Set the value of Head to be “200”, Gradient to be 
“.001”, Angle to be “135”, X to be “37351” and Y to be “8280”.  This reference head 
location is not located on the map window we are using but it serves to calculate the 
correct initial head distribution for this simulation. 

Instead of using the Add->Well menu to add wells to the map, click on the Edit-
>Analytic Elements menu to display the AnalyticElement Information property 
sheet.  Set the Item Type to “Well Object” and click the Add button.  The Well 
Information property sheet is displayed to set the pertinent parameters for the well.  
On the Well Information property sheet set Well to “PW1”, X to “41250”, Y to 
“5100” and click the Transient Pumping Rate radio button.  Click the Display tab 
and click the Display Label check-box.  Now click the Transient tab and import the 
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file pw1gpm.dat to set the pumping schedule for this well.  Accept the property sheet 
by clicking the OK button.  Repeat the procedure to enter PW2 with an x-coordinate 
of 40750, a y-coordinate of 5100 and import the pumping schedule in file 
pw2gpm.dat.  Accept the Analytic Element Information property sheet by clicking 
the OK button. 

Now that we have set up two wells with variable pumping rates, click the Edit-
>Flow Model menu and set the solution to “Theis, 1935 (Confined)”.  Click the 
Parameters tab and set Transmissivity to “600”, the Storage Coefficient to “.005”, 
the Aquifer Thickness to “100” and the Porosity to “.3”.  The aquifer thickness and 
porosity parameters are used during particle tracking but not during calculation of 
hydraulic head.  Accept the property sheet by clicking the OK button and the view 
should appear as below. 

 

Notice that the view tabs have changed to Step 1, Step 2…  This reflects that fact 
that this solution does not support direct calculation of steady state conditions and 
the calculation was automatically changed to transient.  Click the Options-
>Transient menu to set up the time steps for the simulation.  Click the Time Steps 
tab and fill it out as below. 
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Accept the property sheet and you will be asked if you would like to recalculate the 
model.  Click Yes to proceed with the recalculation.  Click the Options->Contour-
>Parameters menu and set X Nodes to “100”, Y Nodes to “100”.  Go to the Levels 
tab and set Minimum Level to “203” and Interval to “.5”.  Now go to the Labels tab 
and click on the Font button.  Set the Size to “10” and the Font Style to “Bold”.  Also 
set the value of Distance between to “500” and the Precision to “1”.  Accept the 
property sheet by clicking OK.  Click the Yes button to recalculate and click the Yes 
button to propagate the changes to all time steps. 

The model is now calculated generating 5 view tabs representing the 5 time steps 
previously defined.  The rightmost status bar cell displays the time represented by 
the contour map in minutes.  The contour map for Step 5 is displayed below. 
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The next step is to calibrate the model to observed heads.  Click the Add->Target 
menu and add a target between the two wells.  Set the Target Designator to “MW1”, 
X to “41000”, Y to “5300” and click the Transient Target Head radio button.  Next, 
click the Transient tab and import the file mw1.dat.  Click the Add->Target menu 
and add another target between the two wells.  Set the Target Designator to “MW2”, 
X to “41000”, Y to “5100” and click the Transient Target Head radio button.  Next, 
click the Transient tab and import the file mw2.dat.   

Now that we have set head targets to calibrate the model we can check how well our 
initial estimates of parameters match.  Click the Edit->Simulation menu, click the 
Well Data, using the context menu activated by the right mouse click on the 
spreadsheet, use the Select All menu followed by the Delete menu.  Now import the 
file simtimes.dat to import the times at which we want to calculate predicted heads.  
The default values do not really work in this example because we want increased 
time resolution in the time periods during which pumping rate changes are occurring.  
Go to the Wells tab, click the Add button twice to move MW1 and MW2 from the 
Available Wells list to the Monitored Wells list.  Accept the property sheet by 
clicking the OK button.  No click the Calc->Recalculate menu to recalculate the 
model.  To view the graphs for the monitored wells, click the View->Well Data 
menu.  Click the left-pointing arrow in the lower left corner of the map view to slide 
the tabs and reveal the MW1 and MW2 tabs. 

Go the MW1 tab and click the Edit->Graph menu, click the Y-Axis tab and change 
the Axis Type radio button to Arithmetic Scale and the Axis Numbers Format to 
“FIXED”.  Also, change the Y-Axis label to “Hydraulic Head” because our model is 
set to calculate hydraulic head instead of drawdown.  Repeat the procedure for the 
MW2 tab. 

Notice that the observed and predicted heads do not match very well based on the 
initial estimates of the parameters.  To quantify the match, click on a time step tab 
and use the Calc->Target Statistics menu to activate the Target Statistics 
Information property sheet.  The residual standard deviation is .5.  Now we will 
perform an optimization to estimate parameter values that best match the target 
values.  Click the Calc->Recalculate menu followed by the Calc->Optimize Model 
menu.  Now take a look at the MW1 and MW2 view tabs to see the visual difference 
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and click the Calc->Target Statistics menu to quantify the match.  In this case, the 
standard deviation is .0004 and represents a significantly better calibration. 

 

After autocalibration, the next logical step is to enhance the graphical output.  Click 
on the Step 5 view tab to display the hydraulic head contour map for time step 5.  
Click the Add->Legend menu and drag a rectangle in the lower right corner of the 
map.  We are creating a custom legend so click the Create Empty Legend radio 
button followed by the Finish button.  Double click on the legend just created and 
set X1 to “41700”, Y1 to “4275”, X2 to “42900” and Y2 to “5175”.  Click the 
Contents tab and set Type to “Solid” then change to the Items tab.  Set Item Type to 
“Legend Object” and click the Add button.  Set X1 to “900”, Y1 to “50”, X2 to “950” 
and Y2 to “550”.  Click the Items tab and set the Automatic Maintenance of Color 
Flood Legend check-box.  Basically, we are reserving space within the legend to 
display a labeled color bar for a color flood.  Accept the property sheet by clicking 
the OK button.  Set the Item Type to “Title Object” and click the Add button.  Set X 
to “900”, Y to “600” and Title to “Head (ft)”.  Click the Font button and set the Size 
to “8”.  Accept the dialog and property sheet by clicking the respective OK buttons.  
Add another title with an X of “500”, Y of “750”, Title of  “LEGEND”, and set the 
font to 12 point bold.  Change the Item Type to “Parameter” and click the Add 
button.  Set X to “50”, Y to “400” and set the list control to “Transmissivity” under 
“Model Parameters”.  Click the Font button and set the Size to “8” and the Font style 
to “Bold”.  Accept the Parameter Information property sheet by clicking the OK 
button. 

Add another parameter and set X to “50”, Y to “300” and set the list control to 
“Storage Coefficient” under “Model Parameters”.  Click the Units check-box to 
unset it.  Set the Format to “EXPONENT”.  Click the Font button and set the Size to 
“8” and the Font style to “Bold”.  Accept the Parameter Information property sheet 
by clicking the OK button.  Add a final parameter and set X to “50”, Y to “200” and 
set the list control to “Time” under “Contour Parameters”.  Click the Font button and 
set the Size to “8” and the Font style to “Bold”.  Accept the Parameter Information  
property sheet by clicking the OK button.  Now accept the Legend Information 
property sheet by clicking the OK button. 
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Now that a legend is displayed, click the View->Display Color Flood menu and the 
resulting contour map is displayed below. 

 

WinFlow Solver 

Getting Started 
The WinFlow tutorial introduces you to most of the important features of this 
software in a step-by-step example.  You will be given very specific instructions to 
show how to use WinFlow to solve real-world problems.  In a graphical user 
environment such as Windows, it is difficult to tell you exactly what to do during 
each step, however, because many of the steps involve using the mouse.  This 
tutorial provides several snap-shots of the WinFlow screen to show you what your 
screen should look like.  In addition, the final tutorial data files are provided so that 
you may skip most of the following steps but still get a feel for how WinFlow works. 

The tutorial tells you to select menu items and a short-hand method is used to 
indicate what menu items are to be selected.  Thus, the menu items are listed in order 
of selection and are separated by  a "->" symbol.  For example, instead of writing the 
following text: 

Select File from the main menu and then select Open from the pull-down menu.  
The following shortened version is adopted in this manual: 

 Select File->Open 

Some instructions for using the mouse should also be explained here, although most 
Windows users understand these concepts.  The word "click" refers to pressing the 
left mouse button once and "double-click" means to press the mouse button twice in 
rapid succesion.  The word "drag" means to press the left mouse button and move the 
mouse to another location on the screen while keeping the button pressed down.  
Release the mouse button when the cursor is on the desired location. 
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Setting Up the Model 

Start the WinFlow program by double-clicking on its icon, .  You should see a 
simple menu displayed above a blank window.  A new model is started by selecting 

File->New or by pressing the  button on the Standard toolbar below the menu.  
Now you can start to design the model.  Note that the model view represents two 
windows separated by a vertical bar.  This is refered to as a split window.  The 
menus in WinFlow are context sensitive in that each view has different menu items.  
Click anywhere within the right view, the map view, to activate its menus. 

The first step is to identify the units you wish to use.  Click the Edit->Units menu to 
activate the Unit Information property sheet and set the values as below: 

 
We are using a consistent set of units as you would have done in WinFlow 1.0; 
however, you can use whatever units you wish.  We have selected the Save As 
Defaults checkbox so that these units are used by default.  If these are the units you 
always wish to use, you will not have to edit them again because future models will 
automatically use them.  We have also selected the Apply Globally checkbox so that 
all values throughout the entire model are changed.  Finally, we have not selected the 
Convert Data checkbox because no real data has been entered yet.  In the event you 
wanted to change the units on an existing model, selecting this checkbox would 
automatically convert all the parameters to the new set of units. 

The next step in most models is to import a base map that will serve as your 
reference point for the model.  Two maps have been supplied for use in the tutorial.  
You will import the map called PLUME1.MAP.  Select File->Map and choose 
PLUME1.MAP in the standard Windows file dialog.  Your screen should now look 
like the screen shown below. 
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Notice the green arrow in the center of the screen, which denotes the location of the 
"reference head".  The reference head is actually located at the center of the base of 
the arrow.  The reference head is a point in the aquifer where the head is fixed during 
the simulation and cannot change except in transient simulations.  This is analogous 
to a "constant head" in a numerical model, such as MODFLOW.  You must be 
careful to locate the reference head as far from the area of interest in your model 
(e.g., pumping wells) as you can.   

In this example, we want to move the reference head to the upper left portion of the 
screen.  You should now move the green arrow to coordinates X=167600 and 

Y=163180.  Place the cursor over the green arrow until you see the  cursor.  
Now, hold down the left mouse button and drag the green arrow to the desired 
coordinates.  The coordinates are displayed in the lower right corner of the status bar 
at the bottom of the screen.  The coordinates do not have to be exact, since you will 
be able to edit them when you release the mouse button. 

When you release the mouse button you can double click and will see a property 
sheet that lists data corresponding to the reference head.  Check the coordinates 
listed in the dialog and make sure the coordinates are close to the ones given above.  
Next, change the hydraulic head to 200, the hydraulic gradient to 1.0e-03 and the 
angle to 135 degrees.  Click on the OK button when you are done. 

The next step is to make sure that the aquifer properties are set correctly.  Select 
Edit->Model to activate the Model Information property sheet.  The default solution 
uses the WinFlow solver and the convergence information parameters are all 
disabled; this is because the WinFlow solver does not support auto-calibration.  Click 
on the Parameters tab and change the values as below: 
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In the steady-state model, WinFlow automatically determines whether an aquifer is 
confined or unconfined.  The aquifer is unconfined when the head is below the top of 
the aquifer and it is confined if the head is above the top of the aquifer.  In this 
example, the aquifer is unconfined, so you will make the top of the aquifer very high 
(e.g., a large distance above the reference head value of 200 ft.).  Once you have 
made the changes, click the OK button. 

You have now set up the most important parts of the WinFlow model!  To see the 

results, simply select Calc->Recalculate or click the  button.  You should see a 
series of contours that are straight lines, representing the uniform regional hydraulic 
gradient.  You will also note that the contour interval is not a round number.  When a 
new model is started, WinFlow simply computes the maximum head difference in 
the model and divides this number by ten to get the starting contour interval.  You 
should change the contouring parameters by selecting Options->Contour-
>Parameters.  Click on the Levels tab, change the minimum contour level to 199, 
the contour interval to 1.0 ft, and set the color to Black.  Click on the Labels tab and 
set the color to Black.  Click OK when you are done.  WinFlow will now ask 
whether you would like to recontour the current model.  Choose YES and your 
screen should look like the one below. 
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This is a good time to save your work.  Select File->SaveAs and enter the name EX1 
in the dialog.  Click OK when you are down.  WinFlow automatically attaches the 
file extension ".wfl" to the file name. 

Adding Features 
Most models are more complex that the one you just created.  Usually, you would 
like to analyze the effects of pumping wells or other features.  In the next section, 
you will add a pumping well to the model and evaluate the capture zone of the well 
by adding streamlines.  You will also learn how to change the pumping rate of the 
well. 

You should see a blue oval shape in the center of the base map.  This area is labeled 
"plume" and represents an area to be captured in a pump-and-treat system.  Add a 
well at the downgradient edge of the plume by selecting Add->Well or by clicking 

the  button.  Move the cursor to coordinates X=171500 and Y=160500 and click 
the left mouse button.  The well will be added where the point of the arrow cursor 
indicates.  Next, a property sheet for the well will be displayed; enter a name of PW1 
and a pumping rate of 20,000 ft3/d and click the OK button.  Note that the word 
"ReCalculate" appears in the status bar.  This reminds you that the contours on the 
screen may not be representative of your current model.  Click the calculate button 

 to recompute the model. 

The contours should show a slight cone of depression around the well you added.  To 
see if the well captures the plume, you will need to add several streamlines.  
Streamlines are used to illustrate groundwater flow directions.  Select Add-
>Streamline->Line.  You will now drag a line along the 208 ft contour line in the 
lower right portion of the screen.  After dragging the line, the Line Cluster 
Information property sheet is displayed.  Change the number of streamlines to 20 and 
click the OK button.  The streamlines will then be drawn on the contour map.  It is 
often useful to add arrow-heads to the streamlines to more clearly show the direction 
of flow.  Select Options->Trace and click on the Display Arrows checkbox.  Next, 
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click on the Streamline tab and change the distance between arrows to 500 ft and the 
arrow size to 100. 

Your screen should look like the one shown below. 

 

Note that the capture zone of the pumping well does not quite cover the entire plume 
area.  You can increase the amount of pumping from the well by moving the cursor 

over the well until you see the  cursor.  Now, double-click on the well and the 
Well Information property sheet appears.  Change the pumping rate to 50,000 ft3/d 
and recalculate the model.  The capture zone should now cover the entire plume. 

This is a good time to save the current model.  Select File->SaveAs and enter the 
name EX2.  Click the OK button to save the file. 

Now let's examine other aspects of the map.  The curved single line on the map (red 
in color) represents a river.  Thus far, we have ignored the river in our model.  
WinFlow can simulate the influence of rivers or drains using linesinks.  Linesinks 
can be defined using either a head value or a flux value.  In a head linesink, WinFlow 
computes the flux needed to maintain the head at the specified value at the center of 
the linesink.  In a flux linesink, you supply WinFlow with the flow rate into or out of 
the linesink per unit length (take the total flow and divide by the length of the 
linesink).  In this example, you will add 9 linesinks to the model along the river to 
evaluate the impact on the recovery system. 

First, in order to give you a better frame of reference for the linesinks, you will 
import a new map file.  WinFlow allows only one digitized map to be used at any 
one time.  When you import a map file into a model that already has a map, 
WinFlow deletes the first map and displays the second one.  Select File->Map and 
choose PLUME2.MAP.  Since you have imported a new map, the model coordinates 
have been reinitialized so recalculate the model and reset the minimum contour value 
and contour interval as before.  This new map has a series of "x"s along the river and 
numbers between the "x"s.  You must add a head linesink between each pair of "x"s 
and set the head to the value displayed on the map. 
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For example, you will add a head linesink in the upper left corner at a head value of 

200 ft.  Select Add->Head Linesink or click the  button.  Drag a line between 
the last two "x"s on the left side of the river.  A property sheet will be displayed; 
enter a head value of 200 ft and click the OK button.  Now add the remaining 8 
linesinks in intervals of 1 ft between the "x"s.  Finally, recompute the model and 
your screen should look like the one below. 

 

You can see that the linesinks have a subtle effect on the flow field.  You can also 
determine how much groundwater the river is gaining or losing.  To find out the flow 

rate of a linesink, place the cursor on a linesink (you will see the  cursor) and 
double-click.  The Linesink Information property sheet shows the flow rate on the 
Calculated tab.  All of the linesinks are removing water from the aquifer except the 
one labeled 204.  A linesink removes water from the aquifer if the sign on the flow 
rate is positive and losing water to the aquifer if the flow rate is negative.  Check the 
linesink flows with your model. 

You should now save the linesink model as EX3.WFL.  Select File->SaveAs just as 
you did before.  You may want to compare the two models (with and without 
linesinks) more closely to determine the impact of the river on the aquifer.  You 
could print the contour maps using File->Print or you could have both models 
displayed simultaneously on your screen.  You can do this by selecting File->Open 
and choosing the file EX2.WFL.  By default, WinFlow overlays the two models so 
that you can only see one at a time.  Select Window->Tile Horizontally and both 
models will be displayed at the same time.  You can resize the windows and move 
the model windows around. 

Where to Go from Here 
The WinFlow tutorial has introduced you to the basics of creating a model.  There 
are many other features, however, that have not been covered.  You should see both 
the Getting Started Using the WinFlow Solver and Concepts chapters for an 
overview of some of the remaining features.  WinFlow Assumptions covers some 
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hints on how to use WinFlow to solve real-world problems and answers common 
questions. 

WinTran Solver 
The WinTran Solver tutorial, described below, introduces you to the most important 
features of this software in a step-by-step example.  You will be given very specific 
instructions illustrating how to use the WinTran Sovler to solve real-world problems.  
In a graphical user environment such as Windows, it is difficult to tell you exactly 
what to do during each step; however, because many of the steps involve using the 
mouse.  This demonstration provides several snap-shots of the WinTran screens to 
show you what your screen should look like for the steps described. 

The exercise below tells you to select menu items and a short-hand method is used to 
indicate what menu items are to be selected.  The menu items are listed in order of 
selection and are separated by  a “->“ symbol.  For example, instead of writing the 
following text: 

Select File from the main menu and then select Open from the pulldown menu 

the following shortened version is adopted in this manual: 

 Select File->Open 

Some instructions for using the mouse should also be explained here, although most 
Windows users understand these concepts.  The word “click” refers to pressing the 
left mouse button once and “double-click” means to press the left mouse button 
twice in rapid succesion.  The word “drag” means to press the left mouse button and 
move the mouse to another location on the screen while keeping the button pressed 
down.  Release the mouse button when the cursor is on the desired location. 

Setting Up a New WinTran Model 

In WinFlow, start a new flow model document clicking the  button on the 
Standard toolbar or select File->New.  In AquiferWin32, click the File->New menu 
and select “AquiferWin32 Flow Model”. 

The first step is to identify the units you wish to use.  Click inside the map view to 
activate its menus.  Click the Edit->Units menu to activate the Unit Information 
property sheet and set the values as below: 
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We are using a consistent set of units as you would have done in WinTran 1.0; 
however, you can use whatever units you wish.  We have selected the Save As 
Defaults checkbox so that these units are used by default.  If these are the units you 
always wish to use, you will not have to edit them again because future models will 
automatically use them.  We have also selected the Apply Globally checkbox so that 
all values throughout the entire model are changed.  Finally, we have not selected the 
Convert Data checkbox because no real data has been entered yet.  In the event you 
wanted to change the units on an existing model, selecting this checkbox would 
automatically convert all the parameters to the new set of units. 

The first step in most models is to import a base map that will serve as your 
reference point for the model.  An example of a base map has been supplied.  You 
will import the map called SITE1.MAP.  Select File->Map and choose site1.map in 
the standard Windows file dialog.  Your screen should now look like the screen 
shown below.  Notice the green arrow in the center of the screen, which denotes the 
location of the “reference head”.  The reference head is actually located at the center 
of the base of the arrow.  The reference head is a point in the aquifer where the head 
is fixed during the simulation and cannot change.  This is analogous to a “constant 
head” in a numerical model, such as MODFLOW.  You must be careful to locate the 
reference head as far from the area of interest in your model (e.g., pumping wells) as 
you can.   
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In this example, we want to move the reference head to the lower left portion of the 
screen (near the word “Reference”).  You should now move the green arrow to 
coordinates X=75 and Y=65.  The X and Y coordinates are displayed on the status 
line at the bottom of the main window as you move the cursor.  Place the cursor over 

the green arrow until you see the  cursor.  Now, hold down the left mouse 
button and drag the green arrow to the desired coordinates.  The coordinates do not 
have to be exact, since you will be able to edit them later. 

Next, place the cursor over the reference head (green arrow) and double-click the left 
mouse button.  You will see a dialog that lists data corresponding to the reference 
head.  Check the coordinates listed in the dialog and make sure the coordinates are 
close to the ones given above.  Then, change the hydraulic gradient to 1.0e-02 and 
the head value to 25.  Click on the OK button when you are done. 

The next step is to make sure that the aquifer properties are set correctly.  Select 
Edit->Model menu, change the solution to “WinTran 1.0 Compatible”, click the 
Flow tab and set the aquifer properties to the values identified below: 
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WinTran automatically determines whether an aquifer is confined or unconfined by 
comparing the computed water level to the aquifer top elevation.  The aquifer is 
unconfined when the head is below the top of the aquifer and it is confined if the 
head is above the top of the aquifer.  In this example, the aquifer is unconfined, so 
you will make the top of the aquifer very high by setting the top elevation to 100 ft 
(e.g., a large distance above the reference head value of 25 ft.). 

The next step is to edit the transport parameters by selecting Transport tab.  Change 
the longitudinal dispersivity to 30 ft and the transverse dispersivity to 6 ft as below.  
Click the OK button when you are done. 
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The default is a steady state flow model so we need to change to a transport model 
by clicking the Model->Transport menu.  This will give access to the transport 
related parameters when adding well.  Finally, we will change the time-stepping 
parameters for the transport simulation.  Select Options->Transient from the menu.  
Change the number of time steps to 30, Contour Every to 10, Initial Time Value to 0, 
Initial Time Step Size to 1, Time Step Multiplier to 1.2 and the maximum time step 
size to 100 days.  Click the OK button when you are done. 

In order to run the transport model, you need either initial concentrations other than 
zero or a source of contamination in the model.  Sources of contaminant can be 
injection wells, ponds that recharge the aquifer, or linesinks that are injecting water 
into the aquifer.  In this example, you will add a well at the point on the map labeled 
“Source”.  Add a well at this location by selecting Add->Well or by clicking the 

 button.  Move the cursor to coordinates X=145 and Y=225 and click the left 
mouse button.  The well will be added where the point of the arrow cursor indicates.  
Next, a dialog box for the well will be displayed; enter a Well Designator of Well, 
enter a pumping rate of -1 ft3/d (the negative sign denotes an injection rate).  Next, 
click the Transport tab and enter a concentration of 100.  Now, click the OK button.  
Note that the word “ReCalculate” appears in the status bar.  It is there to remind you 
that the contours on the screen may not be representative of your current model.   

You have now set up the initial WinTran model!  Click the Model->Steady State 
menu to only simulate flow at this point.  To see the results, simply select Calc-

>Recalculate or click the  button.  You should see a series of contours that are 
straight lines, representing the uniform regional hydraulic gradient, but there are no 
concentration contours.  This is because we have not told WinTran to run the 
transport model yet; only the flow model was simulated.   

Click the Model->Transport model again to run the transport model.  Before 
running the transport model, change the contouring options for both the flow model 
and for the transport model.  Select Options->Contour->Parameters the menu, 
click the Levels tab, change the Minimum Level to 18.0 ft and the Interval to 0.5 ft.  
Click the Labels tab, change the Precision value to 1  Next, click the Transport tab, 
set the Min Log Cycle to -2 to use a starting log cycle concentration of 0.01.  Set the 
value of Per Cycle to 5 to use 5 contours per log cycle.  Unlike flow, where head is 
computed on a regular contour interval, concentration is contoured using log 
intervals.  Click the Font button and set the font size to 10.  Finally, set the Distance 
between to 200, set the Color to Red and click the OK button when you are done.  
Click the Yes button on subsequent dialogs to propogate the changes to all time steps 
and recontour. 

Now select Calc->Recalculate and both the flow and the transport model will run.  
You will first see the flow model computed, followed by a progress dialog showing 
the percentage complete for the transport simulation.  In one of the property sheets 
above, we told WinTran to contour the results every 10 time steps.  You also 
specified a total of 30 time steps for the simulation.  You should four view tabs 
labeled Step 1 through Step 4.  Step 1 represents time of 0 and initial concentration 
conditions.  In this case, the initial concentrations are 0 so only the flow contours are 
displayed.  Click the Step 4 tab which represents time step 30 as below. 
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During the calculation process, you should also see information displayed on the 
status dialog including the mass balance error.  This value should be small (0.01 
percent in this case).  Additionally, the Peclet and Courant Criteria for the transport 
simulation are displayed.  Generally, the Peclet number should be less than 2 and the 
Courant number less than 1.  In this case, the Courant number is larger than 1, but 
the mass balance is good (less than 10 percent) so we will accept the results.  This 
information is also available by clicking the Calc->Simulation Summary menu as 
below. 
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Simulating Remediation 
The next step in the tutorial is to add a recovery well to the model.  Select Add-

>Well from the menu or click the  button on the toolbar.  Move the cursor to 
coordinates X=620, Y=225 (near the word “Recovery Well”) and click the left 
mouse button.  Enter RW as the Well Designator , change the Constant Pumping 
Rate to 10,000 ft3/d and click the OK button.   

You will now save the concentrations computed at the end of the last simulation as 
initial concentrations for the remediation scenario.  By default, WinTran assumes 
that initial concentrations are zero everywhere in the aquifer.  You may override this 
default by selecting Calc->Restart from the menu.  This action saves the current 
concentrations as initial conditions for the next run.  Try this now. 

To see the results, simply select Calc->Recalculate or click the  button.  This 
time, you will see the cone of depression around the recovery well and the 
concentration contours stop at the recovery well.  Note that the source is still in 
place, so a steady-state concentration distribution develops between the source and 
recovery well, as shown in the figure below. 
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As a final exercise, we will remove the source to observe the clean-up of the plume.  

First, place the cursor over the source well until you see the   cursor.  Click the 
left mouse button to select the well.  Now, press the Del key or select Edit->Delete 
from the menu to remove the well.  Select Calc->Restart to save the previous 
concentrations as intial conditions and select Calc->Recalculate to see the results.  
Notice that the plume disappears quickly.  To get a better picture of the cleanup, 
select Calc->Transient, change the Number of Time Steps to 10, Contour Every to 
2 and Maximum Time Step Size to 10.  Select Calc->Recalculate and your screen 
should look like the one shown below. 
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We hope that this brief demonstration has shown you what a powerful tool WinTran 
can be in simulating the fate and transport of dissolved contaminants in groundwater.  
You should now be familiar enough with WinTran to use the model on many of your 
projects 
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Concepts 

Introduction 
This chapter covers basic operating features and concepts for AquiferWin32.  It is a 
good idea to read this chapter after completing the tutorial to clarify or reinforce the 
concepts learned during the tutorial exercises.  Many of the sections covered below 
are very important to a thorough understanding of how AquiferWin32 works.  We 
encourage you to read on! 

Document Types 
AquiferWin32 creates five types of documents or files.  These include Analysis, 
Simulation, Slug Test, Step Test and Flow Model.  The Analysis document is used 
when analyzing pumping test data.  A Simulation document is used to simulate an 
aquifer test and display contours of head or drawdown over an optional base map.  
The Slug Test document is used to analyze slug test data and the Step Test 
document is used to analyze variable pumping tests or step tests.  The Flow Model 
document is used to perform analytical flow models.  The Modeling version of 
AquiferWin32 can create and edit all five document types.  The Professional version 
excludes Flow Model documents.  The Standard version works with Analysis and 
Slug Test documents and the Slug Test version can only work with Slug Test 
documents. 

To start a new aquifer test, simply click the  button on the Standard toolbar or 
select the File->New menu.  Selecting New from the File menu displays five types 
of documents or analysis types, including (1) “AquiferWin32 Flow Model, (2) 
“AquiferWin32 Analysis”, (3) “AquiferWin32 Simulation”, (4) “AquiferWin32 Slug 
Test” and (5) “AquiferWin32 Step Test” as shown below. 
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Clicking the  button on the Standard toolbar creates an Analysis document in the 
Standard and Professional versions and a Slug Test document if you are only 
licensed for the Slug Test version of AquiferWin32.   To create a Flow Model, 
Simulation, Slug Test or Step Test document, you must select the File->New 
menu. 

Entering Time/Drawdown Data 
You can enter the time and drawdown data for an analysis into AquiferWin32 in three 
ways:  

(1) cut and paste data from a spreadsheet application such as Microsoft Excel,  

(2) import data from a comma delimited ASCII file, or 

(3) manually type the data into the AquiferWin32 spreadsheet. 

To paste the data into the AquiferWin32 spreadsheet, simply go into your spreadsheet 
(Excel or Lotus, etc.), open the spreadsheet file, drag a selection box around the two 
columns of data (time and drawdown), and copy the data to the clipboard.  Next, 
click on the left side of line 1 in the AquiferWin32 spreadsheet.  Type Ctrl-V or click 

the  button on the Standard toolbar to paste the data into AquiferWin32.  The 
default first point is still in the spreadsheet, however, so go to the last line in the 
AquiferWin32 spreadsheet, click on the line to highlight the data, and hit the Del key. 

During paste operations, the data is assumed to be in Windows™ text clipboard 
format with Tab characters separating data values and a newline character at the end 
of each data row.  During cut and copy operations this same format is produced.  
Additionally, the order of the values in the clipboard corresponds to the order of the 
columns displayed on the spreadsheet.  Since the number of and order of columns on 
the spreadsheet can be adjusted make sure the data matches the spreadsheet into 
which it will be pasted. 

To import the data from a text file, click on the first line in the spreadsheet to 
highlight that row.  Select File->Import and find the file using the File Open dialog.  
AquiferWin32 will tell you how many lines were imported.  As with pasting from the 
clipboard, there will be one extra line to be deleted.  In this case, however, you will 
delete the first line in the AquiferWin32 spreadsheet.  Furthermore, the data values in 
the file must be separated by a comma character and each row of data must be 
terminated with a newline character.  The issue of column order versus data order is 
the same as with cut, copy and paste. 

You may also enter the data manually.  Simply click on the first cell in the 
spreadsheet and start typing the data.  The first column is for time and the second 
column is drawdown.  Using the Tab key or the Enter key advances to the next 
column.  When editing the last column, these keys advance to the first column of the 
next row, creating new data values in the next row if you are currently editing the 
last row of data. 

Analysis Parameters 
An analysis parameter is a data value that is either required for or calculated by the 
currently selected analysis.  Parameters can be numeric values such as 
Transmissivity, Radial distance and Pumping rate.  They can also be enumerated 
(specific values from a predefined list) such as Block Type.  Since analysis 
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parameters are the central theme to any aquifer analysis application, it is essential to 
understand how to set and manipulate them. 

A list containing all parameters for those analyses currently supported by 
AquiferWin32 would exceed 60 items.  Obviously, the user desiring to perform a 
simple Theis analysis should be sheltered from the 50+ extraneous parameters in 
order to avoid confusion.  Further, this application will routinely undergo 
enhancement to include additional analyses; in a typical application, this would 
exacerbate the problem by adding additional parameters over time.  Our solution to 
the problem is to encapsulate each analysis into a separate Dynamic Link Library 
and use the Solution Information property sheet to dynamically alter the user-
interface based on the selected analysis.  In this manner, the user need only deal with 
those parameters dictated by any given analysis and the addition of a new analysis 
need not change the main application. 

The Solution Information property sheet is where most of the parameters are edited.  
As previously stated, this property sheet is dynamic in that it presents a list of 
available analyses for the particular document type and adjusts the tabs of 
information in the property sheet based on the selected analysis type as shown 
below. 

 
In addition to other tabs, the Solution Information property sheet presents two groups 
of tabs relating to the specific parameters for the analysis.  The first group contains 
the initial guess for each parameter while the second group contains the calculated 
result for each.  There can be any number of tabs for each group depending on how 
many parameters are involved in the selected analysis.  In the case of a “Theis, 1935 
(Confined)” analysis, there is one Parameters tab and one Results tab.  In this simple 
case, the Parameters tab and Results tab are visually identical; however, they have 
different functionality. 

The parameter fields in the Results tab are all “read-only” such that the values can be 
selected and copied to the clipboard but not modified.  In some cases, parameters 
calculated by the analysis only appear on the Results tab.  Such calculated 
parameters are provided in case the user would like to verify calculations based on 
the appropriate equations.  
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Fields on the Parameters tab are, in most cases, editable.  The parameter values 
represent the initial value to be used during the optimization calculation; these values 
are updated automatically when a manual match is performed.  A special control, 

, appears to the right of most parameters.  This control contains two separate 
check-boxes each of which can constrain adjacent parameter value.  Although not 
applicable to all parameters, the lower check-box controls whether a parameter is 
“linked”.  A linked parameter gets its value and units from a value either specified or 
calculated in some other property sheet.  An example is Radial distance which can 
derive its value from one of two different places.  In the case of a simple analysis, 
one that does not have well objects defined in the Site Map view, the value for 
Radial distance is linked to the value entered into the Pumping tab of the Aquifer 
Test Information property sheet.  In the case of a multiple well analysis the value for 
Radial distance is calculated based on the distance between the selected pumping 
well and the monitoring well.  In either case, you can click on the check-box to 
unlink the parameter.  After is has been unlinked, the value and/or units can be 
changed.  If it is subsequently linked, the value and units will revert back to those of 
the value to which it is linked.  This concept allows you to manipulate the parameters 
during an analysis more easily. 

The upper check-box controls whether a parameter is “fixed” during optimizations.  
Any parameter that is fixed will not be allowed to change during the optimization 
calculations.  This flexibility is unique to AquiferWin32 and allows optimization on 
parameters that are typically held constant.  An example would be Aquifer Thickness 
in a partially penetrating well analysis.  The physical thickness may not always be 
representative of its hydraulic impact or may no even be known.  You could allow it 
to vary within a specified range with AquiferWin32 to get a better match. 

Should you desire to constrain a given parameter with respect to its minimum and/or 
maximum acceptable values during an optimization, the Exceptions tab is where to 
do it.  In reality, this step may be required to get the solution to converge.  The 
Exceptions tab contains a combobox listing all parameters involved in the solution.  
Once a specific parameter is selected, you can dictate how the optimization 
calculations treat it.  As shown below, you can enforce a minimum value and/or a 
maximum value.  You can also fix, link and specify the initial value as an alternative 
to the Parameters tab. 
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Another noteworthy tab within the Solution Information property sheet is the Curves 
tab as shown below for the “Hantush, 1964 (Leaky Confined Partial Penetration)” 
analysis.  This tab only appears when the selected analysis allows for multiple type 
curves.  The Parameter combobox in this case has numerous parameters including; 
r/B, Screen Length, Depth to Screen Top, Aquifer Thickness, Kz/Kr, Monitor Depth 
to Screen Top, Monitor Screen Length.  Using this flexibility, you can generate sets 
of type curves to quantify the impact of varying any one of these parameters with the 
rest held constant. 

 

Well Construction Information 
It is very important to 
understand that all depths 
referenced in well 
construction information are 
relative to the top of the 
aquifer. 

AquiferWin32 allows entry of many parameters that apply to one or more analyses. In 
order to adopt a paradigm that applies to all available analyses, some conventions 
were adopted out of necessity.  One of the most important conventions deals with 
well construction information.   

Generally, an attempt has been made to limit the parameters that are presented to the 
user to those pertinent to the currently selected analysis.  Well construction 
information is the most notable exception.  

In AquiferWin32, whether you are performing a simple analysis or you have defined 
wells, you must provide the well construction information whether it is pertinent to 
the currently selected analysis or not.  Well construction parameters such as 
Screen Top Depth and Maximum Water Depth are relative to the top of the 
aquifer and not the ground surface.  In the case of an unconfined aquifer, the 
top of the aquifer is the water table. 

If you are unsure whether a particular analysis uses any of the well construction 
parameters, refer to the Solution Information property sheet or the respective journal 
article detailing the analysis.  If the parameter appears in the Solution Information 
property sheet, it is used and will likely be “linked” to the information entered into 
the Well Information property sheet or the Aquifer Test Information property sheet. 
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Units 
The easy way to deal with units is to 
select Edit->Units right after creating 
a new document.  Choose the units 
you will use, click on the Save as 
Default check-box, and click OK to 
save these units as your defaults. 

AquiferWin32 allows the ultimate flexibility when it comes to setting units; however, it 
is imperative that one understands the paradigm.  Every parameter contained in 
AquiferWin32 has units that can be expressed in terms of three generic "units"; these 
are length (L), time (T) and volume (V).  It is a good idea to use a consistent set of 
units for your analysis, but AquiferWin32 does not require this.  You may have 
drawdown in meters, time in seconds, transmissivity in gallons per day per square 
foot, pumping rates in gallons per minute, etc.  You may also set up your default 
units that will be used whenever you run the AquiferWin32 program.   

Selecting the Edit->Units menu displays the Unit Information property sheet with 
two tabs, as shown below.  The first tab is labeled Summary and contains the four 
basic parameters and their respective units.  The values represent either the program 
defaults or the values previously saved as default.  Under normal circumstances, you 
would set the summary units once and save them as your defaults.  If you always use 
the same types of units in your analyses, then you never need to change these again.  
Click the Save As Default check-box to do this and then click OK.   

 
The Convert Data check-box is checked when you want AquiferWin32 to convert the 
existing data from the current set of units to a new set.   The Apply Globally check-
box is used to convert data for all wells in the current document.  If this box is not 
checked, the data would only be converted or have units set for the currently selected 
well.   

The Units tab allows specific parameters to be assigned units.  As mentioned above, 
every parameter contained in AquiferWin32 has units that can be expressed in terms of 
three generic "units"; these are length (L), time (T) and volume (V) with the possible 
values organized into three sets of radio buttons.  When a parameter is selected in the 
Parameter combobox, the appropriate radio button sets are activated.  Simply select 
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the desired unit from each radio button set.  One of the most complicated parameters, 
Transmissivity, can be expressed in dimensionless units as V/T/L.  If you select 
gallons, days and feet for V, T and L the resulting units would be gallons per day per 
foot (gal/d/ft).  If you select cubic feet, days and feet, the resulting units would be 
square feet per day (sq ft/d).  (NOTE: If changes are made to both tabs of this 
property sheet, the values on the Summary tab take priority).  Accept the 
property sheet by clicking the OK button. 

 
Display of units in tooltips 
does not work in Windows 
3.1.  Call Bill Gates to ask 
why. 

AquiferWin32 makes it easy to track what units are assigned to each data item in the 
program.  When viewing a data field on a property sheet, simply place the mouse 
cursor over the field and wait a second.  A tooltip will be displayed that lists the 
current units assigned to that field.  The following is an example where the cursor 
was over the Transmissivity field of the Solution Information property sheet.  The 
tooltip reads “sq m/min” which is square meters per minute. 
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You can also reset the units applied to any data type using a similar approach.  With 
the mouse cursor hovering over a data field, click the right mouse button and choose 
Units from the context menu.  You will see the following property sheet that is 
similar to the one shown above. 

 
Set the units that you want for this data item and check the Convert Data option to 
automatically convert from the current units to the new ones.  Choose the Apply 
Globally option if you have more than one observation well in this data set and you 
want to affect them all. 
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AquiferWin32 also has a couple of ways of accessing a unit conversion calculator.  
This calculator does not change the units used in your analysis but can be used to 
take data in another set of units and transform it to your set of units.  For example, 
suppose you want to set an initial guess for transmissivity in the Solution Information 
property sheet.  This is the same property sheet as shown above with units of sq. 
m/min.  You have a rough estimate for transmissivity in ft2/day but need to enter it 
here in m2/min.  You can right-click on the Transmissivity field and select Data 
Conversion from the context menu.  Another property sheet is displayed as shown 
below.  You simply enter your T value in ft2/day and choose “feet” for Length, 
“days” for Time, and “cubic feet” for Volume and click the Convert button.  You 
now have a value in m2/min.  Click OK to enter this value on the property sheet.  
This example is shown below. 

 
Note that you cannot change the To field here because you are converting a value to 
your set of units.  You can access a more generic data converter by selecting Calc-
>Data Conversion from the main menu.  In this case, you can enter both the To and 
From units.  Using this calculator does not change anything in AquiferWin32; it is 
simply provided to help with unit conversions. 

A final type of data conversion is related to columns of the spreadsheet view.  You 
may right click on any column of the spreadsheet and select Column Conversion 
from the context menu.  Enter the new units for the column of data and check the 
Apply Units and Convert Data check-boxes to recalculate the data in the new set of 
units.  For multiple wells, use the Apply Globally option as well.  An example of the 
column conversion property sheet is shown below. 
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Manual Curve Matching 
AquiferWin32 is designed with the philosophy that manual matching of the data to type 
curves is preferable to automated matching.  When you learn about aquifer test 
analysis in seminars and college courses or through studying popular texts on the 
subject (see Fetter, 1994, page 220 for example), this is the technique that is taught.  
AquiferWin32 is different from most other aquifer test analysis software because it 
provides a means of displaying multiple type curves and you choose the values of the 
type curves.  AquiferWin32 also provides you with the value of the match point you 
have selected. 

When performing a manual type curve match, you use the arrow keys on the 
keyboard (up, down, left, right) to move the data over the type curve(s).  As the data 
move, the estimates of Transmissivity and Storage are updated on the status bar.  If 
you have defined a legend on your plot, the parameter values are also updated on the 
legend.  You may also move the data by clicking the left mouse button over the 
arrows on the toolbar.  The toolbar large arrows move the data a greater distance 
than the small arrows.  The arrow keys on the keyboard are equivalent to the large 
arrows on the toolbar.  You may hold down the shift key when pressing the arrow 
keys to simulate the smaller arrows on the toolbar; in this manner, you can make fine 
adjustments to the match. 

Type Curve Methods 
The basic idea is to move the data so that they match as closely as possible to the 
type curve that has been selected.  In the case of single type curve methods (e.g., 
Theis), obviously there is only one curve.  For many others, though, there are an 
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infinite number of curves that could be chosen.  AquiferWin32 has a default set of type 
curves that closely correspond to those in the original paper that presents the 
technique.  You may add or subtract from this number or define your own values.  

As you move the data over multiple curves, the parameter estimates change based 
upon the currently selected curve.  The selected curve is drawn in a different color 
than the other curves (default is blue).  To change the selected curve, you may either 
select the curve value from the combobox on the toolbar (immediately to the left of 
the calculator button), select Edit->Toggle Type Curve, or press Ctrl-T on the 
keyboard.  If you move the data over the newly selected curve and press the 
calculator button to optimize the solution, AquiferWin32 will use the selected type 
curve data for initial guesses for the new solution. 

You change the type curves that are displayed by selecting Edit->Solution and 
pressing the Curves tab.  An example is shown below for one of the Hantush leaky 
solutions: 

 
In some cases, there is more than one value in the Parameter combobox.  In the case 
of “Neuman, 1974 (Unconfined Partial Penetration)”, valid values in the Parameter 
combobox are “Beta (β)”, “Screen Length”, “Depth to Screen Top”, “Aquifer 
Thickness”, “Kz/Kr”, “Monitor Screen Length”, and “Monitor Depth to Screen 
Top”.  When constructing type curves, the initial guess parameters are used except 
for the parameter selected in the Parameter combobox; the specific values for this 
value are listed in the Curve Information list box.  As you can see, you have great 
flexibility when constructing type curves. 

Straight-Line Methods 
Straight-line methods are different from type curve methods in that the data are not 
moved with the cursor keys or the arrows on the toolbar.  In this case, you must 
move the line or change the slope of the line using the mouse.  To move the line up 
or down without changing the slope, move the mouse over the center of the line until 
the cursor changes to a four-arrow cursor.  Now hold the left mouse button down and 
drag the line up or down.  To change the slope, move the cursor to either end and 
wait until the cursor changes to an east-west cursor.  Hold the left mouse button 
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down and drag the end of the line to change the slope.  You can also double-click on 
the regression line to enter the slope and intercept directly. 

Automated Curve Matching 
AquiferWin32 uses the Marquardt (modified Gauss-Newton) nonlinear least-squares 
technique to find the best statistical match between the field data and the type curve 

you have chosen.  Click the  button on the Match toolbar or choose Calc-
>Optimize from the menu to implement the automatic match.  You will see T 
(transmissivity) and S (storage coefficient) displayed on the status bar at the bottom 
of the AquiferWin32 window as each iteration of the match is finished  

You may view detailed results of the nonlinear least-squares match by selecting 
Edit->Solution from the menu.  The first tab, Solution, on the property sheet 
displays the type of analysis you have performed.  Other tabs include: 

Parameters The initial guesses for parameter values 

Results Optimized parameters computed by nonlinear least-
squares 

Exceptions Unlink or unfix parameters and set enforced minimum 
and maximum parameter values 

Statistics Match point data and statistical measures 

Data Values calculated for each type curve 

The Marquardt nonlinear least-squares procedure will estimate any parameter you 
choose.  You may fix (or hold constant) any of the parameters, however, by selecting 

Edit->Solution, choosing the Parameters tab, and using the  icon.  If the little 
pushpin is not checked, then the parameter is free to vary during the optimization.  If 

you click the pushpin so that it looks like this , then that parameter is fixed and 
will not vary.  The most common parameter to fix in the Hantush method, for 
example, is the value of r/B, which defines what type curve you are matching.  For 
example, suppose that you have a type curve on your screen with a r/B value of 0.05 
and you want to have AquiferWin32 compute the best values of T and S for this given 
r/B value.  You would enter a value of “0.05” for the r/B field on the Solution 

Information property sheet and make sure the button looks like . 

The automatic procedure will not always converge to a valid solution the first 
attempt.  You may get an error message stating that the numerical solution has 
become unstable.  This means that the Marquardt procedure could not come up with 
an improved estimate for the pertinent parameters.  One problem with the Marquardt 
method is that your initial guesses for parameters must be fairly close to the “right” 
answer before it will work properly.  You may also get a message after the error 
dialog that asks if you would like to turn off the option to automatically estimate 
initial guesses for parameters.  Select Yes if you see this dialog.  The default 
behavior is to calculate an initial guess for T and S using a straight-line method.  
Although this works well for some analyses, it doesn’t work for all of them.  This 
dialog controls the Calculate Initial Estimates check-box from the Advanced 
Solution Information dialog show below.  This dialog is accessed from the 
Advanced button on the Solution tab of the Solution Information property sheet. 
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If you have convergence problems, this dialog is the first place to go.  Turn off 
Calculate Initial Estimates by clicking on the check-box to remove the check mark.  
Now, go back and try a manual match making sure to select the type curve you are 
matching to.  Also, make sure you have fine-tuned the match after you have selected 
the curve.  Merely selecting a type curve does not update the initial guess of the type 
parameter; this is only done when you perform a manual match.   

If optimization fails again, you should increase the value of Lambda by several 
orders of magnitude.  With higher values of Lambda the solution is more likely to 
converge but the precision of convergence is diminished.  If you set Lambda to a 
value of 1 or 10 and you are still can’t achieve convergence, go to the Solution 
Information property sheet and look at the Results tabs.  One or more of the 
parameters are likely diverging and have become invalid.  A likely candidate might 
be the parameter represented by the type curves.  Go to the Exceptions and start 
enforcing minimum and maximum values.  The more you constrain the solution, the 
more likely it will converge. 

Whether you are having convergence problems or not, it is a good idea to perform a 
manual match.  Take a look at the data points that don’t fit the curve; you have made 
a conscious decision that these points are of less importance than the ones that more 
closely match the curve.  This being the case, set a higher value of weight on these 
points so that the optimization procedure can ignore them as well. 

Manipulating the information on the Advanced Solution Information dialog, fixing 
and/or constraining parameters, changing data weights and initial guesses are the 
four areas where you can influence the convergence.  Sometimes it takes a good bit 
of trial and error to achieve convergence, especially if the data deviates substantially 
from theoretical.  Also remember that a manual match is just as good or maybe better 
because you are using you professional judgement when analyzing the data.  The 
numerical algorithm can only minimize residuals. 

During the course of optimization, you may wish to update the initial estimates of 
parameters to correspond to the values recently calculated.  This would allow future 
optimizations to converge faster.  Although you could manually copy/paste the 
values between the results and parameters pages, a context menu is available to 
perform this task.  Find the field in the parameters or results set of pages, right click 
the mouse on the data field and select the Sync->Estimated menu to copy the 
calculated value into the estimated value to used in subsequent optimizations. 
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Manual Parameter Estimation 
Some of the aquifer test analysis methods use a family of type curves that can be 
dependent on a number of parameters.  In these cases, it can be somewhat difficult to 
come up with initial estimates that will allow the solution to converge.  Also, it is 
sometimes desirable to change parameters and see what affect they have on the 
predicted well responses to try and determine better initial estimates or assess 
sensitivities of specific parameters.  In order to enable this functionality, the Apply 
button on the Solution Information property sheet acts differently depending on the 
view from which it was activated.  If the Curve Match view is active, the Apply 
button will perform an optimization.  If the Predicted view is active, it will simply 
recalculate the predicted curve.  Additionally, if a parameter is changed with the 
Predicted view active that would affect the match point, the new match point is 
calculated and the Match view will be updated; this is useful if it is desired to see the 
match point for given values of T and/or S without randomly moving the data around 
until you get close to the desired values. 

The procedure is to activate the Predicted view, click the Edit->Solution menu to 
display the Solution Information property sheet, locate the parameter you want to 
change in the parameters set of tabs, change the value, use the Sync->Calculated 
context menu and click the Apply button.  The predicted curve will be recalculated 
and displayed visually demonstrating the impact this parameter change has had on 
the match.  Additionally, the Statistics tab can be used to quantitatively determine 
how well the predicted curve matches the observed data. 

Multiple Type Curves 
Many of the aquifer test analysis methods use a family of type curves.  In this case, 
your goal is to not only fit the data to a curve but to also choose the best curve.  
AquiferWin32 is designed to help in this type of analysis by displaying a family of type 
curves for these methods.  You may choose how many curves are displayed and may 
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use this feature to prepare sets of master type curves for use in analyzing data in the 
field. 

If you are familiar with other aquifer test software, you will see that AquiferWin32 has 
a slightly different philosophy or focus.  Whereas most other aquifer test analysis 
packages rely heavily on the automatic matching procedures, AquiferWin32 is 
designed to be more like the visual or manual matching techniques advocated by 
most hydrogeology text books (See Fetter, 1994 for example) and by ASTM. 

You change the type curves that are displayed by selecting Edit->Solution and 
pressing the Curves tab.  An example is shown below for one of the Hantush leaky 
solutions. 

 
In some cases, there is more than one value in the Parameter combobox.  In the case 
of “Neuman, 1974 (Unconfined Partial Penetration)”, valid values in the Parameter 
combobox are “Beta (β)”, “Screen Length”, “Depth to Screen Top”, “Aquifer 
Thickness”, “Kz/Kr”, “Monitor Screen Length”, and “Monitor Depth to Screen 
Top”.  When constructing type curves, the results parameters are used except for the 
parameter selected in the Parameter combobox; the specific values for this value are 
listed in the Curve Information list box.  As you can see, you have great flexibility 
when constructing type curves. 

In cases where a number of parameters affect the type curves, optimization of 
parameters can invalidate the type curves by changing the value of a parameter that 
was used in calculating the type curves.  You can identify this condition by looking 
at the last pane in the status bar when the type curves are displayed.  It will contain a 
value of "Valid" or "InValid" indicating if the type curves displayed are valid for the 
current set of parameters.  If they are not, use the Calc->Recalculate Type Curves 
menu to recalculate them. 

To directly control the parameter values used in the type curves, you will have to 
update the parameter values on the results set of pages in the Solution Information 
property sheet.  These values are not directly editable but can be changed by using 
the Sync->Calculated menu on the edit control context menu.  Find the field in the 
parameters set of pages as you would to adjust the initial guess for a parameter; enter 
the value, right click the mouse on the data field and select the Sync->Calculated 
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menu to copy this estimated value to the calculated value which will be used in 
subsequent calculations of type curves. 

 

Data Setup for Multiple Well Analyses 
AquiferWin32 has advanced features that require additional effort to implement and 
understand but provide enhanced capabilities for those who choose to spend the time.  
Three high level concepts are contained in AquiferWin32  which relate to analysis of 
multiple wells.  In reality, they can be looked at as the three preliminary steps to 
analyzing the data from an aquifer test.  The three concepts are Site, Aquifer Test 
and Analysis; each will be discussed in this section. 

Site 
The site is nothing more than the collection of wells present at a given field location.  
The Site Map view is the graphical view of the site and the Site Information property 
sheet, accessed via the Edit->Site menu, is used to view the detail.  Wells are added 

to the Site Map view using the Add->Well menu or the  button on the Analytic 
toolbar.  The Well Information property sheet is then presented and should be filled 
in.  The Physical tab contains the well construction information and the Display tab 
contains parameters controlling how the well will be displayed on the Site Map 
view. 
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The Site Information property sheet, accessed via the Edit->Site menu, has three 
tabs of information.  The Site tab contains predefined user fields that can be used and 
the User tab contains nine additional user fields that can be customized to meet your 
needs.  These user fields are available to Parameter elements which can be used in 
headers/footers or to annotate views.  The third tab, Wells, is used to edit individual 
well objects.  The Well Designator combobox contains all wells defined for the site. 
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Although the Site Map view can be fully implemented by loading a basemap and 
entering all wells, the minimum requirement is to enter the pumping well and all 
monitoring wells you wish to analyze.  An approach that seems appropriate would be 
to load a basemap and add all the wells displaying their designations.  This file can 
then be saved to serve as a template for future pump tests at the site.  When a specific 
pump test is performed, reset the size and/or color of the pumping well and wells 
monitored during the pump test.  The resultant map would likely be incorporated into 
your report. 

Aquifer Test 
Having defined a site, the next step is to define the aquifer test.  The idea behind the 
aquifer test is to characterize the pump test in terms of the pumping well, pumping 
schedule and raw monitoring well responses.  These data are compiled in the Aquifer 
Test Information property sheet which is accessed via the Edit->Aquifer Test menu.  
Like the Site Information property sheet, the Aquifer Test Information property sheet 
has two tabs for user fields.  In addition, it has three additional tabs to define the 
pump test that was performed.  Again, this data is designed to be the raw field data 
with AquiferWin32 serving as the repository for the data. 

The first thing to do is define the pumping well and the pumping schedule.  As 
shown below, the Pumping tab is used for this purpose.  The Pumping Well 
combobox contains a list of all wells defined in the site.  Set the selection to the well 
that was pumped during the test.  Also, enter the pumping schedule in the Pumping 
Rates spreadsheet starting from a Time value of 0.  With the exception of Step Tests, 
AquiferWin32 does not support variable pumping rates during the analysis phase; 
however, you can enter the entire pumping schedule here and decide what rate to use 
in the Analysis phase. 
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The Wells tab is used to select which wells were monitored during the pump test.  
Move the wells that were monitored from the Available Wells list to the Monitored 
Wells list using either the Add button or using drag and drop.  Once a well has been 
moved to the Monitored Wells list, it is enhanced to include data storage for the 
time/drawdown data and other parameters required for analysis.  A new tab is added 
to the spreadsheet in the Well Data tab to store the time/drawdown data.  It is 
important to note that the process of removing a well from the Monitored Wells list 
will delete all the additional data which cannot be recovered. 
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The Well Data tab is where the time/drawdown data is entered.  Ignoring the Match 
Data tab for the moment, enter the time/drawdown data for each well by clicking on 
the appropriate spreadsheet tab.  This is intended to be the raw data from the field 
which will be clipped and/or transformed in the Analysis phase.  Again, by storing 
the raw data, you can use the AquiferWin32 document as a repository for information. 
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Analysis 
Having defined a site and the aquifer test, the next step is to define and perform the 
analysis.  The idea behind the analysis is to decide how you want to reduce the pump 
test data.  The particular data to be analyzed is defined in the Analysis Information 
property sheet which is accessed via the Edit->Analysis menu.  Like the Site 
Information property sheet and the Aquifer Test Information property sheet, the 
Analysis Information property sheet has user fields.  In addition to the predefined 
user fields, the Analysis tab defines what pumping rate to use.  You can use a time 
average pumping rate, the first pumping rate or a specific pumping rate.  Using this 
mechanism, the entire pumping schedule has been recorded, as well as, the rate you 
choose to use for this particular analysis.  Such information is of particular 
importance during the peer review process. 

 
The Match Data tab is now used to set up the time/drawdown data for analysis.  As 
shown below, you have many options on how to assemble the data for analysis.  The 
Well Designator combobox contains all wells that were specified as monitored in the 
Aquifer Test phase.  By default, the Exclude Well radio button is set which means 
that the well and its data are not to be analyzed.  Set either the Include Well In Match 
Data radio button or the Include Well Individually radio button if you intend to 
analyze the data for well. 



 

148  •  Concepts Guide to Using AquiferWin32 

 
All wells that have the Include Well In Match Data radio button set are combined 
together into one data set, the Match Data.  Additionally, you have the option to 
check the Adjust Data for Radial Distance check-box.  If any one of the wells 
included in the match data set have been adjusted for radial distance, all will be.  The 
adjustment is to divide data points by the square of the radial distance (the distance 
between the particular monitoring well and the pumping well).  As demonstrated in 
the “Using Multiple Observation Wells” tutorial, a traditional approach is to include 
all monitored wells into one match data set and adjust for radial distance.  You then 
match the resultant data against a Theis curve to get a “uniform” Transmissivity and 
Storage coefficient for the ensemble of wells.  This traditional procedure was limited 
the Theis analysis.  The tutorial goes on to demonstrate an alternative approach is to 
include all wells individually, don’t adjust for radial distance and optimize them as a 
group.  This yields the same result but is not limited to the Theis analysis.  This is a 
powerful feature of AquiferWin32. 

Again, setting the Include Well Individually radio button allows that data for the 
particular monitoring well to be analyzed independently or as part of a group 
optimize procedure.  Furthermore, you can generate a match data set from any of the 
monitoring wells and/or include the rest individually.  The user interface 
mechanisms to deal with them will be discussed later. 

Regardless of how a well is included, the raw data that was entered as part of the 
Aquifer Test phase, can now be adjusted.  The Data Clipping parameters allow you 
to filter out bad data and the Data Transformation parameters allow you to correct 
for errors in the raw data.  It is important to note that the data clipping operation 
occurs after data has been transformed. 
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Additionally, you can and should set the Symbol Style parameters to differentiate 
data from different monitoring wells on the graphs. 

User Interface Issues for Multiple Well Analyses 
During the analysis of multiple wells, the user-interface has enhanced functionality.  
The enhancements occur in both the spreadsheet and the graph view.  Each will be 
discussed separately along with some additional concepts. 

Spreadsheet View 
In the simple analysis of data, the spreadsheet view has one tab and data can be 
entered directly into that tab.  There are four columns of data available including 
Time, Drawdown, Weight and Symbol; however, only two are visible by default.  
Entering data into these columns is equivalent to entering data into the Match Data 
tab of the spreadsheet on the Well Data tab of the Aquifer Test Information property 
sheet. 

In a multiple well analysis, the spreadsheet functionality is somewhat changed.  Now 
the data in Match Data tab is calculated and the Time and Drawdown columns of 
data should not be edited; however, the Weight and Symbol columns can be edited.  
If editing the raw data for the individual wells is desired, click the View->Well Data 
menu.  In so doing, tabs are added to the spreadsheet for each well.  These tabs can 
be used to edit the raw data.  Once changes have been made to the raw data, click the 
Calc->Match Data menu to recalculate the data in the Match Data tab.  If you edit 
the data using the Well Data tab of the Aquifer Test Information property sheet, this 
calculation is done automatically when you accept the property sheet. 

In a multiple well analysis in which wells are included individually changes the 
Match Data tab of the spreadsheet.  As discussed in previous sections, each well has 
data associated with it including raw time/drawdown data, 
transformed/clipped/weighted data, graph characteristics and analysis parameters.  In 
order to manipulate the data for a specific well, you must make it active.  The active 
well is set by toggling among the available wells using either Ctrl-D or the Edit-
>Toggle Data Set menu.  If the active well is truly the Match Data well, generated 
when at least one well has been set to be included in the match data set using the 
Match Data tab of the Analysis Information property sheet, the spreadsheet and 
graph view tab is Match Data.  On the other hand, if the active well is a well 
included individually, the tab is Match Data – “Well Name”.  This gives the user a 
visual indication as to which well is active. 

Another important concept in a multiple well analysis is the data weights and 
symbols.  We have already discussed that the Time and Drawdown columns of data 
are calculated from the raw data.  Initially, the weight is initialized to 1 and the 
symbol is set based on that defined in the Match Data tab of the Analysis 
Information property sheet for the specific well.  During the course of analyzing the 
data, weights are typically changed for individual data points that are anomalous.  
Similarly, symbols are typically changed for individual data points to indicate those 
that have been weighted or ignored.  If you later want to change the raw data, the 
data weights and symbols will be maintained unless you add or delete data points.  
Any change in the number of raw data points will result in a re-initialization of both 
weights and symbols.  The weights will be reset to 1 and the symbols will be reset to 
the symbol indicated in the Match Data tab of the Analysis Information property 
sheet.  If you change the symbol for any well in the Match Data tab of the Analysis 
Information property, you will be asked if you want to reset all symbols.  This action 
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will reset the symbols for all wells in the analysis; however, the data weights will not 
be affected. 

Graph View 
The graph view functionality is changed when multiple wells are analyzed.  As in the 
spreadsheet view, the Match Data tab’s name is defined by the currently active well. 
The active well is set by toggling among the available wells using either Ctrl-D or 
the Edit->Toggle Data Set menu.  When performing a manual match, the data 
points associated with the currently active well are the ones that can be moved and 
selecting a type curve affects only the active well.  The analysis parameters 
associated with the currently active well are the only ones affected by such a manual 
match.  Finally, the Calc->Optimize and Calc->Reset Data Offset only affect the 
active well. 

Previously, we mentioned that each well has a unique set of analysis parameters 
which can be accessed using the Edit->Solution menu.  Ignoring Group 
Optimization for the moment, each well is analyzed independently of the rest; 
however, they are all presented on the same graph.  If you manipulate parameters for 
one well, it doesn’t affect the others. 

It was previously discussed that the spreadsheet can display a separate tab for the 
raw data of each well.  When selecting the raw data in the spreadsheet view, the 
graph view is transformed to display a graph of drawdown versus time.  Like other 
graphs, you have full control of the display characteristics of this graph and changes 
to this graph do not affect other graphs.  The initial characteristics of this graph were 
copied from the default well graph which can be set up using the Edit->Default 
Well Graph menu.  The copy occurs when the well was moved from the Available 
Wells list to the Monitored Wells list in the Wells tab of the Aquifer Test Information 
property sheet; therefore, subsequent changes to the default well graph do not affect 
current wells. 

Group Optimization 
Group optimization represents the real power of multiple well analysis.  Having gone 
to the trouble of setting up the data for multiple wells, you can now determine the 
best parameter values for the test as a whole.  We have discussed that each well has a 
unique set of parameters that can be manipulated individually.  Group optimization 
can be performed on all analysis parameters that are free to vary, not fixed, for all 
wells involved in the analysis.  What group optimization does is to perform the 
Marquardt (modified Gauss-Newton) nonlinear least-squares method using all data 
from all wells to find the best parameters.  If no parameters have been set to be 
optimized as a group, which is the default, the Calc->Optimize Group menu would 
be equivalent to toggling among each well and optimizing them individually. 

Using the Edit->Group Optimize Parameters menu, as shown below, you can 
select which parameters are to be optimized across all wells.  Simply move the 
parameters from the Available Parameters list to the Optimized Parameters list.  In 
the specific case below for a Hantush and Jacob, 1955 (Leaky Aquifer) analysis, the 
parameter r/B is expected to vary among wells so it is not optimized as a group.  
After performing the group optimization process, you will get the best uniform value 
of Transmissivity and Storage Coefficient for the test.  Using traditional methods, 
you would have to get individual values for each well and average them in some way 
to get an answer; the exception is a Theis response for which you could divide by the 
radial distance squared and match to the Theis curve to get the answer. 
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Annotations 
AquiferWin32 has numerous ways to enhance graph and map views with additional 
elements.  These elements can be copied and pasted from one graph to another or 
from one map to another.  Although each type of annotation will be discussed in 
subsequent sections, the characteristics common to all of them will be discussed 
here.  Furthermore, refer to the corresponding Add menu description in the Menus 
and Dialogs chapter for details about the specific fields on the property sheets. 

Spatial Parameters are common to all annotations.  In graph views, the Spatial 
Parameters represent inches from the lower left corner of the view while in map 
views, the Spatial Parameters represent map units.  It is important to remember that 
graphs are scaled to fit the views they are contained in so one inch will not 
necessarily represent one inch on the screen.  If you print graphs with Use Specified 
Dimensions set on the Graphs tab of the Page Setup Options property sheet, one 
inch will represent one inch on the printed page. 

Titles 
Using Title elements, you can annotate any graph or map with text items. As shown 
below, you can control the Color, Angle, Alignment and Font of the text. 
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Parameters 
Parameter elements are similar to Title elements except that the text is referenced 
rather than specified.  Available references include all User Fields and Analysis 
Parameters.  The tree control is used to select the reference by drilling down into the 
available items and selecting one.  You can select any item in the tree that has 
exactly one child item.  The child item is the text currently associated with the 
selected reference.  The associated text is not static and references are continuously 
resolved.  You can control whether to display the Title, Value and/or Units.  For 
numbers, you can specify the Format and Precision. 
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If the reference becomes invalid the parameter object is not displayed.  This can 
happen if you reference an Analysis Parameter like r/B for Hantush and Jacob, 1955 
and subsequently change to Theis, 1935.  Invalid parameters are retained and will 
reappear when they become valid. 

Lines 
Using Line elements, you can annotate any graph or map with lines. As shown 
below, you can control the Color, Thickness, Dash and Length of the line.  There are 
nine dash patterns to choose from.  The Length parameter controls the frequency 
with which the dash pattern is repeated. 
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Symbols 
Using Symbol elements, you can annotate any graph or map with symbols. As shown 
below, you can control the Color, Thickness, Symbol and Size of the symbol.  There 
are ten symbols to choose from.  The Thickness parameter controls the thickness of 
the lined use when drawing the line segments that make up the symbol. 

 

Frames 
Using Frame elements, you can annotate any graph or map with rectangular frames 
that can be simple rectangles, contain solid colors, contain hatch patterns, contain 
bitmaps or contain metafiles. As shown below, you can control the Color, Thickness, 
Dash and Length of the line used to draw the optional border of the frame; refer to 
the Lines subsection for more details. 
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Additionally, you can control the contents of the frame element.  The Display 
Border check-box controls whether the border is displayed.  The Type combobox 
defines whether the frame is empty or is filled.  Depending on the Type, you can 
specify the Background Color, Hatch Color and Hatch Pattern.  In the case of 
Bitmaps and Metafiles, you must specify the file that contains the bitmap or metafile.  
Once loaded, the contents of the file is stored within the AquiferWin32 document and 
the File Name field is purely for reference.  For Bitmaps, the Scale to Rectangle 
check-box controls whether the bitmap is expanded or contracted to fit the rectangle; 
if you want the screen image and the printed image to be the same, this check-box 
must be checked. 
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Legends 

General 
Legend elements are essentially enhanced Frame elements.  In addition to the 
characteristics outlined in the previous subsection on Frames, Legends can contain 
additional annotations such as Titles, Parameters, Lines, Symbols, Frames and other 
Legends.  You can nest legends as deeply as you like keeping in mind that the origin 
for each embedded legend, the lower left hand corner, is reset to 0,0.  The scale 
within a legend is inherited from the parent view.  Since the position of all embedded 
items within a legend is relative to the lower left corner of the legend, the legend can 
be moved and all items contained within it are moved as well. 

Items within legends cannot be moved and edited using the standard editing features 
of the view.  The Items tab on the Legend Information property sheet is the 
mechanism by which they are edited.  As shown below, a tree control lists all the 
items contained within the legend.  The items are categorized based on their type and 
listed by X and Y Offset.  To add an item, set the Item Type to the appropriate value 
and click the Add button.  Selecting an item activates the Edit and Delete buttons.  
In the case of both Add and Edit, the property sheet for the item is displayed.  
Although legend layout can be tedious due to the lack of a graphical interface, 
legends provide very powerful annotation capabilities. 

 
The Automatic Maintenance of Graph Data Sets check-box only appears if the 
parent view of the legend is a graph.  If this check-box is checked, symbols and 
labels for each data set in the graph will be automatically displayed within the 
legend.  If the legend is higher than it is wide, the symbol/label items will be spaced 
evenly vertically and centered horizontally within the legend.  If the legend is wider 
than it is high, the symbol/label items will be spaced evenly horizontally and 
centered vertically within the legend.  Typically, a legend set up using Automatic 
Maintenance of Graph Data Sets does not contain any other elements although it is 
likely embedded in another legend element. 
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Default Legends 
A context menu (accessed via clicking the right mouse button or using the Shift-F10 
keys) exists on the Legend Information property sheet to Cut/Copy/Paste individual 
legend items; in addition, there is a Save As Default menu item.  If you desire to 
define a legend to be used as the default when a particular analysis is created, use 
this feature save a legend as the default.  Control of whether the default legend is 
displayed is achieved using the View->Default Legend menu.  Default legends are 
stored on the computer containing the software.  If the document is moved to a 
different computer different default legends will be displayed.  If you want to save 
the default legend with the document on any system, click on the legend to select it, 
click the Edit->Copy menu, click the View->Default Legend menu to turn off the 
default legend and click the Edit->Paste menu and save the document.  Now the 
legend is part of the document. 

 
Default legends are associated with each supported solution/view combination and 
enable the user to set the legend that is displayed when new documents are created.  
The default legends are saved as files in the Defaults directory with the file name 
being inherited from the file name of the active analysis dynamic link library and the 
following extensions: 

.prl Predicted View 

.stl Step Test Step 2 View 

.spl Step Test Special View 

.wel Well View 

.mal Curve Match View 

.mdl Flow Model Main View 

.sml Simulation Main View 

.stl Analysis Site View 

.cnl Concentration Graph View 
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.lcl Line Calculation Graph View 

As an example, the default legend for the Curve Match View for Theis, 1935 would 
be saved as Anal0005.mal. 

Wizard 
One of the most common support issues has been setting up legends and we have 
attempted to make this process much easier.  In Version 3, adding a legend is as 
simple as clicking the mouse in the view, clicking the Add->Legend menu and 
dragging a rectangle.  The following wizard is activated to help in setting up the 
wizard.  If you simply click the finish button, a legend will be created containing the 
pertinent parameters and will be located in the lower right corner of the graph or 
map. 

To make a legend as in previous versions, select the Create empty legend radio 
button and click the Finish button; double click on the newly created legend box and 
set it up as you see fit. 

The legend generated by the wizard was patterned after the example legends created 
in the example files shipped with previous versions of the program.  The specific 
legend created using the following example wizard screens is below. 

 
The legend has three sections, the Title sublegend, the Parameter sublegend and the 
Symbol sublegend.  The Title and Symbol sublegends are optional as is the bitmap in 
the Title sublegend. 

To customize the legend created with the wizard, click the Create custom legend 
radio button and the Finish button becomes a Next button to continue the 
customization.  Two other options are available via check boxes.  The Don’t use this 
wizard for future editing option overrides the default behavior that, when you 
double click the legend to edit it, the wizard will not be used.  The Automatically 
Adjust and Locate Legend check box controls whether the system will 
automatically maintain the location of the legend. 
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If you chose to create a custom legend, the next step in the wizard enables you to 
choose the items you want added to the legend. The Parameters  step presents a list 
of parameter items which is dynamic and defined by the active document type, 
analysis type and view type.  As with Parameters in previous versions, you drill 
down into the options and click on the item you want, in this case Transmissivity.  
Using the Append, Insert and Remove buttons, you select what you want.  You can 
also change the default title for an item by selecting it in the right list box and 
entering the new title in the  Title edit field. 
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The Text step of the process controls colors and fonts of the legend title, parameter 
titles and parameter values.  It also controls the overall format and precision for 
parameter values. 
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The Styles step defines the layout of the legend including sublegends, border colors 
and thicknesses, background colors and title bitmap. 

 
The Symbols step is only displayed when the Symbol Sublegend checkbox has been 
checked in the previous step.  You can control the contents of the symbol sublegend. 
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On Screen Editing of Legends 
If you have created a legend using the legend wizard and have selected the 
Automatically adjust and locate legend option any changes made on screen will be 
automatically undone when the screen refreshes.  The on screen editing features are 
for older legends, those created as empty legends using the wizard or those that have 
selected the Don’t use this wizard for future editing option. 

On screen manipulation now drills into legends no matter how deeply they are nested 
to allow the typical on screen manipulations to be performed.  In addition, a context 
menu has been created for legends that allows for Cut/Copy/Paste/Select 
All/Delete/Add/Add to Legend operations within the legend. 

Of particular note is the Add to Legend menu.  When items have been selected in 
the main view, they can be added to the legend using this menu.  In most cases, you 
will want to drag the object into the legend and position it before using this option.  
You can, however, attach items to the legend that are not located inside the legend.  
When the legend is moved, they maintain their relative position to the legend.  

Headers/Footers 
Headers and Footers are special cases of Legends that only appear on printed output.  
As shown below in the Page Setup Options property sheet, the printed output can 
have margins and space can be reserved within the margins for a Header and/or a 
Footer.  The user specifies the height of the Header and/or Footer in inches and 
selects one of the available Header/Footer elements in the adjacent combobox. 
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The Header/Footer tab of the Page Setup Options property sheet is very similar to 
the Items tab of the Legend Information property sheet and the user should refer to 
the Legends subsection of the Annotations section for details on how to layout the 
contents of the Header/Footer.  The New and Rename buttons are used to create and 
rename the available Header/Footer objects.  Additionally, a context menu is 
available to Cut/Copy/Paste header/footer objects to move them from one document 
to another. 

 
Although header/footer layout can be tedious due to the lack of a graphical interface, 
header/footer objects provide very powerful annotation capabilities for the printed 
output.  You can produce very diverse results and three examples are shown below 
that present the results of the same analysis using the File->Print Preview menu. 
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Derivative Analysis 
Analysis of pump test data can be greatly improved using a plot know as a derivative 
plot.  Although rather simple in concept, such a plot can be very instrumental in 
accurately reducing the data from a pump test.  It is beyond the scope of this manual 
to go into the theory of analyzing a derivative plot and the user is referred to texts 
like Horne, 1995 and journal articles like Spane & Wurstner, 1993 for the details.  
Suffice it to say that the characteristics of curves representing the first-order pressure 
derivative versus time can be more distinctive than the traditional type curves.  The 
difference is the result of the sensitivity of the derivative to small variations in the 
pressure change that occurs during a pump test.  This sensitivity can be used to 
identify wellbore storage effects, boundary effects and the establishment of radial 
flow conditions.  The following two graphs demonstrate the marked difference of the 
derivative plot from the traditional leaky-confined type curves that flatten out with 
time. 
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The implementation of the derivative analysis within AquiferWin32 was adapted from 
two sources.  The first-order pressure derivative of the data is performed as per 
Spane & Wurstner, 1993 and the algorithm from their DERIV program was adapted.  
As indicated in their paper, the differential algorithm is based on the preferred 
algorithm listed by Bourdet et al., 1989; the algorithm calculates the first derivative 
of the pressure change with respect to the natural logarithm of the change of time.  
Two options are available for calculating the data slopes before and after a given 
point, LEAST SQUARES and FIXED ENDPOINT.  The fixed endpoint uses the 
points predeeding and following the point of interest by the specified distance along 
the x axis.  The least squares regression option uses all the points preceeding and 
following the point of interest within the specified distance in the calculation. 

Spane & Wurstner, 1993 recommend the fixed end point options for data from 
published type curves or data devoid of significant noise.  For noisy test data the 
least squares option is preferred.  In AquiferWin32 the least squares option is the 
default. 
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The distance along the x-axis to use in the aforementioned calculations is referred to 
as the L-Spacing.  The L-Spacing ranges from 0 to .5 in which 0 uses the points 
immediately adjacent to the point of interest.  Values greater than .2 smooth out 
noisy data but can also cause a loss of resolution. 

Since AquiferWin32 directly calculates the values for type curves, the presure 
derivatives are directly calculated using the equation presented by Horne, 1995. 
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In the above equation, the differentiation interval or L-Spacing is used to be 
consistent with the derivatives of the data.  In the special case where the L-Spacing 
has been set to 0 to cause the adjacent data points to be used, the type curves will be 
generated using an L-Spacing of .1. 

The Calculation Options property sheet used to control the differentiation method 
and l-spacing is accessed using the Calc->Options menu and is displayed below. 

 
Manual Match Options 

Coarse Adjustment The distance in inches to move the data relative to the 
type curves when performing a coarse adjustment 

Fine Adjustment The distance in inches to move the data relative to the 
type curves when performing a fine adjustment 

Pressure Derivative Options 

Differentiation Method Specifies the calculation method to use when 
calculating derivatives 

LEAST SQUARES See discussion above 

FIXED ENDPOINT See discussion above 

L-Spacing Specifies the interval over which data and type curve 
derivatives are calculated 



 

168  •  Concepts Guide to Using AquiferWin32 

Variable Pumping 

Variable Pumping 
AquiferWin32 has always provided a mechanism to store the full pumping schedule for 
a given pump test when wells have been defined.  Now variable pumping schedules 
can be directly used in the analysis of the pump test.  Although this represents a 
major advancement to the functionality of the program, the only user interface 
change is the addition of the Variable Pumping Rate radio button on the Analysis tab 
of the Analysis Information property sheet shown below. 

 
For simple solutions not involving wells defined in the site map, a very simple 
change has been made to support variable pumping rates.  By clicking the "Variable 
Pumping Rate" checkbox, an additional tab, Rates, is added to the Aquifer Test 
Information property sheet.  The pumping rates can be added to spreadsheet in the 
Rates tab. 
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Once activated by either method, variable pumping rates will be taken into account 
in both the Marquardt nonlinear least-squares solution and in the calculation of 
predicted drawdown.  Since traditional curve matching techniques and the type 
curves they employ do not take into account variable pumping rates, the type curve 
will not reflect changes in pumping rates; however, it is still valid to match the data 
from the first stage of pumping to the type curves.  The resultant parameters are valid 
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and serve as the best method to generating the initial estimates for parameters to be 
used during optimization.  In the case of a variable pumping rate analysis, the 
“goodness of fit” is best viewed in Predicted view tab as shown below. 

 

3D Perspective View 

Contents 
The 3D vertical tab contains the 3D perspective view of the hydraulic head or 
drawdown  values.  Contour lines can be optionally displayed as well.  All the 
normal annotations can be added; however, the annotations are fixed in position in 
the view and are not moved/rotated when the 3D perspective is manipulated. 
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View Manipulation 
Selecting the 3D Manipulation menu from the edit field context menu allows the 
manipulation of the 3D view using the mouse and keyboard.  Clicking and/or 
holding the left mouse button in the view causes the display to rotate in the direction 
toward the cursor location.  Holding the Shift button while clicking and/or holding 
the left mouse button causes the display to move in the direction toward the cursor 
location.   

Clicking and/or holding the right mouse button causes the display to zoom in and 
zoom out.  If the cursor is in the upper half of the view, it will zoom out.  If the 
cursor is in the lower half of the view, it will zoom in.  The amount of the zoom is 
controlled by how far the cursor is from the vertical center of the view. 

The Reset 3D menu is used recenter the 3D perspective view.  This is sometimes 
required when changes have been made via the Contour Options property sheet or on 
screen editing. 

Contour Options 
Four tabs on the Contour Options property sheet apply to the 3D view and are 
described below.  The color flood parameters apply to both the contour view and the 
3D view. 
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3D Mesh 

Vertical Scale Factor: A multiplier applied to head/drawdown to increase 
the vertical scale relative to the horizontal scale 

Color Bar: Controls the presence and location of the default 
scale bar 

Display X: The x-coordinate of the lower left corner (vertical) or 
upper right corner (horizontal) of the scale bar 

Display Y: The y-coordinate of the lower left corner (vertical) or 
upper right corner (horizontal) of the scale bar 

Contour Plane 

View Contours: When checked, a contour map is displayed in the 3D 
perspective view 

Color: Controls the color of the contours which can be either 
Black or Flood Colors 

Automatic Elevation: Controls the elevation on the vertical axis which 
corresponds to the contour plane; when checked the 
contour map will automatically be relocated as the 
contour data changes 

Specified Elevation: Controls the elevation on the vertical axis which 
corresponds to the contour plane; when checked, the 
value entered in the adjacent edit field will be used to 
locate the contour plane 

Reset 3D View At times, the perspective drawing can leave the field 
of view.  Checking this option will relocate it into 
view 
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Focal Point 

Focal X: The x-coordinate of the focal point used to display 
the 3D perspective drawing 

Focal Y: The y-coordinate of the focal point used to display 
the 3D perspective drawing 

Focal Z: The z-coordinate of the focal point used to display 
the 3D perspective drawing 

Position 

Position X: The x-coordinate of the camera position used to 
display the 3D perspective drawing 

Position Y: The y-coordinate of the camera position used to 
display the 3D perspective drawing 

Position Z: The z-coordinate of the camera position used to 
display the 3D perspective drawing 

View Up 

View X: The x-coordinate defining the view up direction for 
the camera used to display the 3D perspective 
drawing 

View Y: The y-coordinate defining the view up direction for 
the camera used to display the 3D perspective 
drawing 

View Z: The z-coordinate defining the view up direction for 
the camera used to display the 3D perspective 
drawing 
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Automatic When checked, the distribution of colors is 

automatically determined by the application 

Interval: The interval to use when generating flood colors for 
values of head/drawdown to be used when the 
Generate button is clicked. 

Generate When clicked, a new color distribution will be 
generated using the same algorithm as the Automatic 
setting; however, these can be edited by the user 
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Label Information 

First Sets the head/drawdown value for the first labeled 
value in color flood legends 

Number: The number of equally spaced labels to use when 
labeling the color flood legends 

Interval: The interval between adjacent labels; used when the 
Specify Interval option is activated 

Specify Interval When checked, the value for Interval is used when 
labeling color flood legends 

Format: The numeric format to use when displaying the labels 
on color flood legends 

Precision: The number of digits to the right of the decimal point 
to use when displaying the label on color flood 
legends 

Color The color to use when displaying labels on color 
flood legends 

Font Defines the font, font style and size for the label 

Border Line Information 

Color: The color to use when displaying the border around 
the color flood legend 

Thickness: The thickness, in points, of the line used when 
displaying the border around the color flood legend 
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Model Parameters 
A model parameter is a data value that is either required for or calculated by the 
currently selected model.  Parameters can be numeric values such as Transmissivity, 
Storage coefficient and Aquifer Thickness.  They can also be enumerated (specific 
values from a predefined list) such as Block Type.  Since model parameters are the 
central theme to any modeling application, it is essential to understand how to set 
and manipulate them. 

A list containing all parameters for those models supported by WinFlow could be 
large.  Obviously, the user desiring to perform a simple Theis-based model should be 
sheltered from the other extraneous parameters in order to avoid confusion.  Further, 
this application will routinely undergo enhancement to include additional models; in 
a typical application, this would exacerbate the problem by adding additional 
parameters over time.  Our solution to the problem is to encapsulate each model into 
a separate Dynamic Link Library and use the Model Information property sheet to 
dynamically alter the user-interface based on the selected model.  In this manner, the 
user need only deal with those parameters dictated by any given model and the 
addition of a new model need not change the main application. 

The Model Information property sheet is where most of the parameters are edited.  
As previously stated, this property sheet is dynamic in that it presents a list of 
available models and adjusts the tabs of information in the property sheet based on 
the selected model type as shown below. 

 
In addition to other tabs, the Model Information property sheet presents two groups 
of tabs relating to the specific parameters for the selected model solver.  The first 
group contains the initial estimate for each parameter while the second group 
contains the calculated result for each after an auto-calibration.  If the model does not 
support auto-calibration, the second group will be absent.  There can be any number 
of tabs for each group depending on how many parameters are involved in the 
selected model.  In the case of a “Theis, 1935 (Confined)” solution, there is one 
Parameters tab and one Results tab.  In this simple case, the Parameters tab and 
Results tab are visually identical; however, they have different functionality. 
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The parameter fields in the Results tab are all “read-only” such that the values can be 
selected and copied to the clipboard but not modified.  In some cases, parameters 
calculated by the model only appear on the Results tab.  Such calculated parameters 
are provided in case the user would like to verify calculations based on the 
appropriate equations.  

Fields on the Parameters tab are, in most cases, editable.  The parameter values 
represent the initial value to be used during model calculations and are used as the 

initial estimate during optimization calculations.  A special control, , appears to 
the right of most parameters in models that support auto-calibration.  This control 
contains two separate check-boxes each of which can constrain adjacent parameter 
value.  Although not applicable to all parameters, the lower check-box controls 
whether a parameter is “linked”.  A linked parameter gets its value and units from a 
value either specified or calculated in some other property sheet.  Currently, no 
linked parameters exist but could in the future.  You can click on the check-box to 
unlink a parameter.  After it has been unlinked, the value and/or units can be 
changed.  If it is subsequently linked, the value and units will revert back to those of 
the value to which it is linked.  This concept allows you to manipulate the parameters 
during a model more easily. 

The upper check-box controls whether a parameter is “fixed” during optimizations.  
Any parameter that is fixed will not be allowed to change during the optimization 
calculations. 

Should you desire to constrain a given parameter with respect to its minimum and/or 
maximum acceptable values during an optimization, the Exceptions tab is where to 
do it.  In reality, this step may be required to get the solution to converge.  The 
Exceptions tab contains a combobox listing all parameters involved in the solution.  
Once a specific parameter is selected, you can dictate how the optimization 
calculations treat it.  As shown below, you can enforce a minimum value and/or a 
maximum value.  You can also fix, link and specify the initial value as an alternative 
to the Parameters tab. 
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WinFlow/WinTran Parameters 

Flow Parameters 

 
The flow parameters are accessed using the Edit->Flow Model menu and are 
located on the Reference Head tab, the Recharge tab, on the Parameters tab 
(WinFlow) or Flow tab (WinTran).  These parameters define the physical 
characteristics of the aquifer system.  These characteristics include: 

Hydraulic conductivity, 

Aquifer Bottom Elevation, 

Aquifer Top Elevation, 

Reference Head Value, 

Regional hydraulic gradient, 

Recharge rate, and 

Porosity (used for particle-tracking and transport). 

Hydraulic conductivity is assumed to be homogeneous throughout the infinite aquifer 
and has units of [L/T], e.g. ft/d.  The aquifer top and bottom elevations have units of 
length [L], e.g. ft, and are used to compute transmissivity.  In addition, the flow model 
allows for conversion to unconfined flow.  Therefore, if the head falls below the top of 
the aquifer the model becomes unconfined.   

The reference head defines a point where the head is known.  In the steady-state model, 
the reference head is always constant and never changes during simulations.   All 
computations are based upon the reference head, which should be located as far from 
wells, ponds, etc. as possible.  The reference head is analogous to a constant head in a 
numerical model. 
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The regional gradient is used to superimpose the regional flow system on your model.  
You enter the gradient here or by double-clicking the green arrow on the screen 
representing the reference head.  The gradient is dimensionless (L/L) and is computed 
by dividing the change in water level over a specified distance by that same distance. 

Recharge rate is the infiltration rate over the entire model.  Recharge is primarily for 
regional simulations in which model boundaries are simulated with wells and 
linesinks.  In this case, the recharge then creates water table divides and mounds 
between these regional features.  Recharge should not be used for small-scale models 
such as those used to simulate remediation systems around gasoline stations and 
other similar sites. 

Porosity is used to compute the average linear groundwater velocity in WinTran.  
The porosity value entered in WinTran is actually the effective porosity and defines 
the ratio of connected void space to the volume of aquifer material.  The porosity is 
used in computing velocity according to the following equation: 

 
V K

n
dh
dl

=
 

where V is the average linear groundwater velocity (L/T), K is the hydraulic 
conductivity (L/T), n is the effective porosity, and dh/dl is the groundwater gradient. 

Transport Parameters 
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The transport parameters are accessed using the Edit->Flow Model menu and are 
located on the Transport tab and the Solver tab.  Transport parameters include 
dispersivity (longitudinal and transverse), coefficient of molecular diffusion, 
recharge concentration, retardation coefficient, and contaminant half-life.  In 
addition the upstream weighting factors for the X- and Y-direction are specified. 

Dispersivity is a scale-dependent parameter which is generally larger as the scale of 
the contaminant plume increases.  A typical rule of thumb is that the dispersivity is 
10 percent of the length of the contaminant plume (National Research Council, 
1990).  However, values of dispersivity reported in the literature range generally 
range from 1 to 100 percent of the problem scale (Gelhar, 1986).  There are two 
values of dispersivity used in the WinTran transport model, longitudinal and 
transverse.  Longitudinal dispersivity represents the spreading of the contaminant 
plume in the direction of groundwater flow.  The transverse component represents 
spreading perpendicular to the flow direction.  Usually, the longitudinal dispersivity 
is 5 to 10 times higher than transverse. 

Molecular diffusion occurs when a contaminant spreads in water due to 
concentration gradients.  That is, dissolved contaminants will spread in water from 
areas of high concentration to areas of lower concentration.  This process is caused 
by random movement of molecules in a fluid.  The coefficient of molecular diffusion 
(or simply the diffusion coefficient) is expressed in units of L2/T (e.g., cm2/s) and is 
often assumed to equal zero in advective-dominated transport.  Only in very slow-
moving groundwater is diffusion important.  Bear and Verruijt (1987) estimate the 
diffusion coefficient to be approximately 1 x 10-5 cm2/s in dilute systems. 

Parameters are also assigned in the transport model based upon the type of 
constituents (chemicals) being simulated.  These compound-specific parameters 
include the half-life for decaying species and chemical reaction types.  Most 
transport models, including WinTran, lump chemical reactions into sorption 
processes in which a distribution coefficient (kd) controls the relative velocity of the 
compound compared to the ground-water velocity.  In this case, a retardation 
coefficient is computed which retards the velocity of the contaminant relative to the 
groundwater velocity.   
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Most contaminant transport models require you to enter a decay coefficient, which is 
different from the contaminant half-life.  The decay coefficient is defined in the 
following equation: 

 λ = ln 2 / t1/2 

where λ is the decay coefficient, ln 2 is the natural log of 2, and t1/2 is the half-life of 
the contaminant.  The half-life is the time required for half of the original mass of 
contaminant to decay.  WinTran requires you to enter the half-life of the contaminant 
and computes the decay coefficient internally.   

While the half-life is most often used for radioactive elements, such as uranium, it 
can also be used to express the decay of organic compounds through biodecay.  The 
Handbook of Environmental Degradation Rates (Howard et al., 1991) is a good 
reference for contaminant half-life data. 

WinTran requires you to enter the retardation coefficient directly rather than the 
distribution coefficient (kd).  Calculating the retardation coefficient is done by using 
the following equation: 

R = 1 + kd (ρb/n) 

where R [dimensionless] is the retardation coefficient, kd  [L3/M] the distribution 
coefficient, ρb [M/L3] is the bulk density of the aquifer, and n [dimensionless] is the 
porosity.  Other more complex reactions have been used in numerical models, 
however, these have not been commonly applied and are not supported in WinTran.  

Recharge concentration is the contaminant concentration in the infiltrating recharge 
waters.  Note, however, that this creates a source of contamination over the entire 
model domain. 

The advective-dispersive transport equation is more difficult to solve numerically 
than the groundwater flow equation (Javandel et al. 1984).  The problems are 
particularly severe when advection dominates over dispersion.  In this situation, the 
finite-element solution, as employed in WinTran, can exhibit oscillations producing 
negative concentration values.  One method for overcoming these oscillations is to 
use an upstream-weighted formulation of the transport equations.  The upstream 
weighting factors on this dialog are used to implement this upstream weighting 
technique.  An upstream weighting factor of implements full upstream weighting, 
while an upstream weighting factor of zero eliminates upstream weighting. 

Time Stepping 
Time-stepping parameters control the transient transport simulation.  These parameters 
include the number of time steps, the initial time value, the length of the first time step, 
the maximum time step size, and the time step multiplier.  WinTran starts the simulation 
at the initial time value using the initial time step size.  Subsequent time steps are 
multiplied by the time-step multiplier to obtain the new time step size.  This 
multiplication continues until the maximum time step size is reached or the end of the 
simulation occurs.  Normally, you need to start with small time steps and gradually 
move to larger ones in order to have a good mass balance (i.e., mass balance error less 
than 10 percent).  The mass balance error, current time step number, and time value are 
displayed in the status bar as the model runs.  If the mass balance error rises above 10 
percent, you should stop the simulation and adjust the time stepping parameters, 
dispersivity, or porosity until a better mass balance is achieved.  The last chapter in the 
documentation provides some guidance on selection of these parameters. 

The final parameters on the Time Stepping dialog define the time approximation in the 
transport solution.  You may choose from Backward-in-time or Centered-in-time.  The 
Centered-in-time approximation is more accurate but may exhibit instability.  The 
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Backward-in-time introduces more numerical dispersion but is more stable.  It is usually 
recommended that you start with backward-in-time and move to centered-in-time after 
you have a stable model. 

Automatic Calibration 
In some solutions supported by WinFlow, the Marquardt (modified Gauss-Newton) 
nonlinear least-squares technique can be used to find the best statistical match 

between the observed response data and the model you have chosen.  Click the  
button on the Match toolbar or choose Calc->Optimize Model from the menu to 
implement the automatic match. 

You may view detailed results of the nonlinear least-squares match by selecting 
Edit->Model from the menu.  The first tab, Solution, on the property sheet displays 
the type of model you have performed.  Other tabs include: 

Parameters The initial parameter values 

Results Optimized parameters computed by nonlinear least-
squares 

Exceptions Unlink or unfix parameters and set enforced minimum 
and maximum parameter values 

Reference Head Values used to define the plane of initial heads 

Recharge Values used to define the recharge elipse for steady-state 
simulations 

The Marquardt nonlinear least-squares procedure will estimate any parameter you 
choose.  You may fix (or hold constant) any of the parameters, however, by selecting 

Edit->Solution, choosing the Parameters tab, and using the  icon.  If the little 
pushpin is not checked, then the parameter is free to vary during the optimization.  If 

you click the pushpin so that it looks like this , then that parameter is fixed and 
will not vary.  

The automatic procedure will not always converge to a valid solution the first 
attempt.  You may get an error message stating that the numerical solution has 
become unstable.  This means that the Marquardt procedure could not come up with 
an improved estimate for the pertinent parameters.  One problem with the Marquardt 
method is that your initial guesses for parameters must be fairly close to the “right” 
answer before it will work properly.  This dialog is accessed from the Advanced 
button on the Solution tab of the Model Information property sheet. 
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If you have convergence problems, this dialog is the first place to go.  You should 
increase the value of Lambda by several orders of magnitude.  With higher values of 
Lambda the solution is more likely to converge but the precision of convergence is 
diminished.  If you set Lambda to a value of 1 or 10 and you are still can’t achieve 
convergence, go to the Model Information property sheet and look at the Results 
tabs.  One or more of the parameters are likely diverging and have become invalid.  
Go to the Exceptions and start enforcing minimum and maximum values.  The more 
you constrain the solution, the more likely it will converge. 

Manipulating the information on the Advanced Solution Information dialog, fixing 
and/or constraining parameters and changing initial guesses are the three areas where 
you can influence the convergence.  Sometimes it takes a good bit of trial and error 
to achieve convergence, especially if the data deviates substantially from theoretical. 
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Menus and Dialogs 

Introduction 
This chapter discusses the detailed data entered on all dialogs and property sheets in 
AquiferWin32 and thus serves as a reference section of the manual.  The dialogs and 
property sheets are shown for each menu selection and are presented in order from 
left to right and top to bottom in each menu.  AquiferWin32 actually has many 
different menus depending upon the active document type and active view type.  
You may make a view active by simply clicking the left mouse button anywhere 
within the view and the menus will change accordingly.  Alternatively, the F6 key 
toggles between views in the split window. 

File Menu 
The File menu contains several choices in a dropdown menu.  Some of these items 
are standard to most Windows applications, including New, Open, Close, Save, 
SaveAs, Print, Print Preview, Print Setup, Send, and Exit.  Other items are unique 
to AquiferWin32, including Page Setup (to set margins on the output page), Import 
(to import DOS text files containing the time-drawdown data), and Export (to create 
a text file report or to create graphics files in either DXF or Windows Metafile, wmf, 
formats).  Each of these selections from the File menu is described below. 

New 

To start a new aquifer test, simply click the  button on the Standard toolbar or 
select the File->New menu.  Selecting New from the File menu displays five types 
of documents or analysis types, including (1) “AquiferWin32 Analysis”, (2) 
“AquiferWin32 Simulation”, (3) “AquiferWin32 Slug Test”, (4) “AquiferWin32 
Step Test” and (5) “AquiferWin32 Flow Model”, as shown below. 
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Clicking the  button on the Standard toolbar creates an Analysis document in the 
Standard and Professional versions and a Slug Test document if you are only 
licensed for the Slug Test version of AquiferWin32.   To create a Simulation, Slug 
Test, Step Test or Flow Model document, you must select File->New menu. 

Open 

Use the Open menu to read an existing AquiferWin32 file.  You may also use the  
button on the Main or press Ctrl-O. 

The Open dialog is a standard Windows dialog that allows you to choose any 
directory or drive on your computer.  By default, all supported file types are 
displayed; however, you can change the "Files of type:" combobox to any one of the 
five supported file types, a Flow Model document (*.aqf), an Analysis document 
(*.aqw), a Slug Test document (*.aql), a Simulation document (*.aqs) and a Step 
Test document (*.aqp). 
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Close 
Use the Close menu to close the active AquiferWin32 document.  You will be 
prompted to save the document if you have made any changes or it is a newly 
created document. 

Save 
The Save menu saves the current document to a disk file.  The name of the file is 
shown at the top of the AquiferWin32 window.  For a new document that has not been 
saved yet, you may want to use the Save As menu in order to provide a name of your 

choice.  The Save menu may also be executed from the  button on the Standard 
toolbar or by pressing Ctrl-S. 

Save As 
The Save As menu allows you to save the current document with a new name.  A 
standard Windows file dialog prompts for the file name and path.   

Print, Print Preview, Print Setup 
There are four menu selections related to printing the currently active view.  These 
include Print, Print Preview, Print Setup, and Page Setup.  The first three options 
are standard Windows menus and will work the same as your other Windows 
applications.  The current view can be printed to any printer, plotter, fax modem, or 
other device supported by Windows.  The only potential problem with printing is 
related to the rotated fonts used in type curve and contour labels.  Some Windows 
device drivers do not properly support rotated fonts.  It is very important to select 
Print Setup and choose the option to “Print TrueType as Graphics”.  Most Windows 
device drivers will support this option, which allows for proper font rotation.  If after 
selecting this option the type curve and contour labels are not properly rotated, you 
should call the manufacturer of your printer or other output device to get an updated 
Windows driver. 

Page Setup 
NOTE: This menu is not available in the spreadsheet view. 

Choose Page Setup to control the margins and scale on the printed output.  You can 
also use this menu to define headers and footers and select which ones will occur on the 
printed output via the Page Setup Options property sheet. 
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Orientation 

Portrait When selected, the printed output uses the short 
dimension of the paper as the x-axis and the long 
dimension of the paper as the y-axis 

Landscape When selected, the printed output uses the long 
dimension of the paper as the x-axis and the short 
dimension of the paper as the y-axis 

Margins 

Left Left margin in inches 

Right Right margin in inches 

Top Top margin in inches 

Bottom Bottom margin in inches 

Header/Footer 

Header Space, in inches, between the top margin and printing 
area reserved for printing the header 

Header combobox Specifies what to print in the header area if Header is 
greater than 0 inches 

None – No header will be printed 
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Default – Uses the information on the Default Header/Footer page 
to construct the header 

Custom - Stands for any number of user-designed header/footer 
elements 

Footer Space, in inches, between the bottom margin and 
printing area reserved for printing the footer 

Footer combobox Specifies what to print in the footer area if Footer is 
greater than 0 inches 

None – No footer will be printed 

Default – Uses the information on the Default Header/Footer page 
to construct the footer 

Custom - Stands for any number of user-designed header/footer 
elements 

Border Style 

Color The color to use when displaying the border lines 

Thickness The line thickness to use when displaying the border 
lines 

Display Border When checked, a border line is displayed around the 
printable area defined by the margins 

Header Line When checked, a border line is displayed separating 
the header area from the main printable area 

Footer Line When checked, a border line is displayed separating 
the footer area from the main printable area 

Save As Defaults When checked, the values contained in this property 
sheet are stored in the system registry when the 
property sheet is accepted and are used as the defaults 
when an new document is created 

Restore System Defaults When checked, the default system values are restored 
when the property sheet is accepted; this operation 
occurs before the Save As Defaults operation so 
having both checked resets both the document and 
the system registry 
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Graph Scale 

Scale to Page While maintaining the ratio of vertical to horizontal 
graph dimensions, the graph is scaled to fill the 
printed page. 

Use Specified Dimensions The graph dimensions specified in the Graph 
Information property sheet are used to print the 
graph. 

Map Scale 

Scale to Page The map scale is adjusted to fill the printed page. 

Specify Scale The map scale of the printed page is set to the value 
in the (map units per inch) field.  The output will be 
paginated accordingly. 

Window Scale The prevailing map scale in the display window is 
used in printing. .  The output will be paginated 
accordingly. 

Map Clip Window 

Display Window The printed map is clipped to that which is displayed 
in the display window and scaled as defined above. 

Map Window The printed map is clipped to the defined map 
window and scaled as defined above. 
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NOTE: If both check-boxes are checked, the intersection between the display 
window and map window is used as the clipping window. 

 
Title Block 

 Each of the four data fields and Font buttons define a 
line of text in the title block section 

Bitmap File 

File Name: The name of the file that was loaded for Bitmap and 
Metafile type frames 

NOTE: The contents of the file are loaded and stored within the document so 
the file is no longer required and the name is for historical reference 
only. 

Scale to Rectangle If checked, the bitmap is expanded/compressed to fill 
the frame 

NOTE: This check-box is usually checked, otherwise, the screen display and 
printed output will not be the same. 

Browse Click this button to display a standard File Open 
dialog used to locate the Bitmap or Metafile file 
stored on the computer. 

Bitmap Size 
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Height Specifies the height, in inches, of the frame used to 
contain the bitmap or metafile 

Width Specifies the width, in inches, of the frame used to 
contain the bitmap or metafile 

 

 
New: Creates a new header/footer and prompts for a name. 

Rename: Prompts the user for a new name for the selected 
header/footer. 

Add: Adds an item to the selected header/footer.  The item 
selected  in Item Type is added. 

Edit: Edits the currently selected item. 

Delete: Deletes the currently selected item. 

Item Type: Specifies the currently active item to be added when 
the Add button is clicked. 

NOTE: A context menu is provided to allow Cut/Copy/Paste of headers and 
footers to move them between documents. 
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Import 
In the spreadsheet view of an Analysis, Slug Test or Step Test document, the 
Import menu allows you to import data from a text file.  The spreadsheet view must 
be the active view before you can use the Import option.  Simply click within the 
spreadsheet to make it active. 

The data values in the file must be separated by a comma character and each row of 
data must be terminated with a newline character.  Additionally, the order of the 
values in the file corresponds to the order of the columns displayed on the 
spreadsheet.  Since the number of and order of columns on the spreadsheet can be 
adjusted make sure the data matches the spreadsheet into which it will be imported. 

Map 
The Map menu allows you to import a basemap in one of two different formats.  The 
map view must be the active view before you can use the Map menu.  Simply click 
within the map view to make it active. 

The File Open dialog activated by this menu has a File of Type combobox that 
supports ESI’s map file format, DXF file format and Bitmap file format.  Set the 
combobox to the appropriate type and accept the dialog.  If the file type is DXF, you 
will be prompted to enter a multiplier to scale the DXF coordinates.   

If you have selected Bitmap a property sheet will be displayed as below.  If the 
bitmap you are using was generated from a scanned quad map, it may have come 
with a .tfw (world) file.  You can rename this file to filename.bmw where the 
filename is the same as for the bitmap file and the Map Window parameters will be 
automatically calculated from the world file. 

 
Bitmap Dimensions 

Height: The number of vertical pixels in the bitmap being 
imported. 

Width: The number of horizontal pixels in the bitmap being 
imported. 

Map Window 
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Origin X: The x-coordinate in map units corresponding to the 
lower left corner of the bitmap being imported. 

Origin Y: The y-coordinate in map units corresponding to the 
lower left corner of the bitmap being imported. 

Height: The height of the bitmap in map units. 

Width: The width of the bitmap in map units. 

Import Wells 
In the Test Simulator view of a Simulation document or the Site Map view of an 
Analysis or Slug Test document, the Import Wells menu allows you to import data 
for wells.  The file must be a text file (ASCII file) containing three columns of data 
separated by commas.  The order of the columns is as follows: 

 

 (1) Well name, 

 (2) X coordinate of well, and 

 (3) Y coordinate of well 
 

The well import file name must use a .dat extension.  For example, the name of a 
valid file would be wells.dat. 

Selecting Import from the File menu displays a standard Windows file dialog.  
Choose the path and file name to import.  AquiferWin32 reads data from the file and 
adds the wells to the current model.  If you are replacing existing wells, you must 
first select and delete the existing wells.  Importing new wells at the same location as 
existing wells will give you 2 wells at each location. 

Import Wizard – Time/Drawdown 
In the spreadsheet view, the import wizard enables easier data importing from data 
logger files and other applications.  The Import Wizard->Time/Drawdown menu 
activates the import wizard which can be used to define filters for data formats of 
disk files and data copied to the Windows’ clipboard.  The wizard separates the 
information into header information, data, and footer information.  Any number of 
columns are supported in each of the three categories.  Several data delimiters are 
supported and the data is loaded into a tab spreadsheet for review before the data is 
actually imported into the program.  The time data can be either elapsed time or any 
of a number of supported data/time formats.  Well response can be head or 
drawdown; in the case of head data, the user specifies the static head from which to 
calculate drawdown.  Similarly, elapsed time is calculated from date/time data given 
a start date/time value.  Additionally, both time and drawdown data can be 
transformed and clipped. 

Once defined, the filter can be added to the program and will appear in the list of 
supported file types.  Such filters can also be used for data in the Windows’ 
clipboard.  A case in point is In-Situ’s Data Manager program; once loaded into the 
Data Manager program, the information can be copied to the Windows’ clipboard 
and imported directly into AquiferWin32 without creating an intermediate data file.  
Likewise, filters can be defined for custom spreadsheets defined in a spreadsheet 
program like Microsoft Excel and copied to the clipboard and imported directly into 
AquiferWin32. 

The following are descriptions of the pages involved in the wizard. 



 

Guide to Using AquiferWin32 Menus and Dialogs  •  195 

 
Data File Specifies that the data will be read from a data file 

Windows clipboard Specifies that the data will be read from the 
Windows’ clipboard 

Database Specifies that the data will be imported directly from 
a database (not currently supported) 
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File Name Identifies the data file to import 

Browse When clicked, presents a File Open dialog to locate 
the appropriate data file 

File Type 

Generic Data File - Loads system default values 

InSitu Data Logger - Loads values specific to the InSitu Data Logger 
format 

Isodaq Data Logger - Loads values specific to the Isodaq Data Logger 
format 

Custom - The list can be enhanced to include as many 
custom formats as needed 

Delimiter 

Comma - Specifies a data delimiter of the comma character 

Space - Specifies a data delimiter of the space character 

Tab - Specifies a data delimiter of the tab character 

Header/Footer Information 

Header Lines Specifies the number of lines of header information 
before the data columns begin 

Columns Specifies the number of columns of header 
information present on each line 

Load Header Data When checked, the header information will be loaded 
into the subsequent tab spreadsheet 

Footer Lines Specifies the number of lines of footer information 
after the data ends 

Columns Specifies the number of columns of footer 
information present on each line 

Load Footer Data When checked, the footer information will be loaded 
into the subsequent tab spreadsheet 

Data Column Information 

Date Col. Indicates which column contains the value for date 

Time Col. Indicates which column contains the value for time 

Date/Time Conv. When checked, the date/time data is converted to 
elapsed time 

Drawdown Col. Indicates which column contains the drawdown data 

Weight Col. Indicates which column contains the data weights 

Advanced When clicked, presents the following dialog with 
advanced settings 
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Data Column Titles from Line Indicates which line, 0 if none, to take data column 

titles from 

Date Delimiter Specifies the delimiter used to separate components 
of the date format 

Date Format 

Month/Day/Year - Month first, Day second, Year third 

Day/MonthYear - Day first, Month second, Year third 

Time Delimiter Specifies the delimiter used to separate components 
of the time 

Date before Time… When checked, the date value precedes the time 
value when both are combined into one column 

File Filter Information 

File Name Specifies the file name to store the filter information 
in; must be located in the program directory to be 
accessible to the application 

File Description Specifies the descriptive text displayed in the File 
Type combobox 

File Extension Specifies the default file extension for files of this 
type, eg. dat 

Save When clicked, updates the current filter 

Save As When clicked, presents a File Save dialog to specify 
the file into which to save the filter 
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This tab spreadsheet displays the columns of data loaded from the data source with 
optional tabs for the header and footer information.  The data is read-only and used 
to verify that the filter information has been set up properly. 

 
Test Start Date Specifies the date for the start of the pump test; used 

to calculate elapsed time from date/time data 
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Test Start Time Specifies the time for the start of the pump test; used 
to calculate elapsed time from date/time data 

Time Adjustment 

Transformation When checked, the time data are transformed by 
multiplying it by the Scale and adding the Offset 

Scale Specifies the value by which to multiply the time 
value if transformation is active 

Offset Specifies the value to be added to the scaled time 
value if transformation is active 

Clipping When checked, the time data are clipped based on the 
specified Minimum and Maximum values 

Minimum Specifies the minimum acceptable value for time 
data; data points with a time value less than this value 
are not imported 

Maximum Specifies the maximum acceptable value for time 
data; data points with a time value greater than this 
value are not imported 

Water level data… When checked, the water level data represents head 
and must be subtracted from the PreTest Head to 
calculate drawdown 

PreTest Head Specifies the head value at the start of the test 

Drawdown Adjustment 

Transformation When checked, the drawdown data are transformed 
by multiplying it by the Scale and adding the Offset 

Scale Specifies the value by which to multiply the 
drawdown value if transformation is active 

Offset Specifies the value to be added to the scaled 
drawdown value if transformation is active 

Clipping When checked, the drawdown data are clipped based 
on the specified Minimum and Maximum values 

Minimum Specifies the minimum acceptable value for 
drawdown data; data points with a drawdown value 
less than this value are not imported 

Maximum Specifies the maximum acceptable value for drawdown data; data 
points with a drawdown value greater than this value are not imported 

Import Wizard – Pumping Rate 
In the spreadsheet view, the import wizard enables easier data importing from data 
logger files and other applications.  The Import Wizard->Pumping Rate menu 
activates the import wizard which can be used to define filters for data formats of 
disk files and data copied to the Windows’ clipboard.  The wizard separates the 
information into header information, data, and footer information.  Any number of 
columns are supported in each of the three categories.  Several data delimiters are 
supported and the data is loaded into a tab spreadsheet for review before the data is 
actually imported into the program.  The time data can be either elapsed time or any 
of a number of supported data/time formats.  Elapsed time is calculated from 
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date/time data given a start date/time value.  Additionally, both time and pumping 
rate data can be transformed and clipped. 

Once defined, the filter can be added to the program and will appear in the list of 
supported file types.  Such filters can also be used for data in the Windows’ 
clipboard.  A case in point is In-Situ’s Data Manager program; once loaded into the 
Data Manager program, the information can be copied to the Windows’ clipboard 
and imported directly into AquiferWin32 without creating an intermediate data file.  
Likewise, filters can be defined for custom spreadsheets defined in a spreadsheet 
program like Microsoft Excel and copied to the clipboard and imported directly into 
AquiferWin32. 

The following are descriptions of the pages involved in the wizard. 

 
Data File Specifies that the data will be read from a data file 

Windows clipboard Specifies that the data will be read from the 
Windows’ clipboard 

Database Specifies that the data will be imported directly from 
a database (not currently supported) 
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File Name Identifies the data file to import 

Browse When clicked, presents a File Open dialog to locate 
the appropriate data file 

File Type 

Generic Data File - Loads system default values 

InSitu Data Logger - Loads values specific to the InSitu Data Logger 
format 

Isodaq Data Logger - Loads values specific to the Isodaq Data Logger 
format 

Custom - The list can be enhanced to include as many 
custom formats as needed 

Delimiter 

Comma - Specifies a data delimiter of the comma character 

Space - Specifies a data delimiter of the space character 

Tab - Specifies a data delimiter of the tab character 

Header/Footer Information 

Header Lines Specifies the number of lines of header information 
before the data columns begin 

Columns Specifies the number of columns of header 
information present on each line 

Load Header Data When checked, the header information will be loaded 
into the subsequent tab spreadsheet 

Footer Lines Specifies the number of lines of footer information 
after the data ends 
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Columns Specifies the number of columns of footer 
information present on each line 

Load Footer Data When checked, the footer information will be loaded 
into the subsequent tab spreadsheet 

Data Column Information 

Date Col. Indicates which column contains the value for date 

Time Col. Indicates which column contains the value for time 

Date/Time Conv. When checked, the date/time data is converted to 
elapsed time 

Rate Col. Indicates which column contains the pumping rate 
data 

Advanced When clicked, presents the following dialog with 
advanced settings 

 
Data Column Titles from Line Indicates which line, 0 if none, to take data column 

titles from 

Date Delimiter Specifies the delimiter used to separate components 
of the date format 

Date Format 

Month/Day/Year - Month first, Day second, Year third 

Day/MonthYear - Day first, Month second, Year third 

Time Delimiter Specifies the delimiter used to separate components 
of the time 

Date before Time… When checked, the date value precedes the time 
value when both are combined into one column 

File Filter Information 
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File Name Specifies the file name to store the filter information 
in; must be located in the program directory to be 
accessible to the application 

File Description Specifies the descriptive text displayed in the File 
Type combobox 

File Extension Specifies the default file extension for files of this 
type, eg. dat 

Save When clicked, updates the current filter 

Save As When clicked, presents a File Save dialog to specify 
the file into which to save the filter 

 

 
This tab spreadsheet displays the columns of data loaded from the data source with 
optional tabs for the header and footer information.  The data is read-only and used 
to verify that the filter information has been set up properly. 
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Test Start Date Specifies the date for the start of the pump test; used 

to calculate elapsed time from date/time data 

Test Start Time Specifies the time for the start of the pump test; used 
to calculate elapsed time from date/time data 

Time Adjustment 

Transformation When checked, the time data are transformed by 
multiplying it by the Scale and adding the Offset 

Scale Specifies the value by which to multiply the time 
value if transformation is active 

Offset Specifies the value to be added to the scaled time 
value if transformation is active 

Clipping When checked, the time data are clipped based on the 
specified Minimum and Maximum values 

Minimum Specifies the minimum acceptable value for time 
data; data points with a time value less than this value 
are not imported 

Maximum Specifies the maximum acceptable value for time 
data; data points with a time value greater than this 
value are not imported 

Rate Adjustment 

Transformation When checked, the pumping rate data are 
transformed by multiplying it by the Scale and 
adding the Offset 

Scale Specifies the value by which to multiply the pumping 
rate value if transformation is active 
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Offset Specifies the value to be added to the scaled pumping 
rate value if transformation is active 

Clipping When checked, the pumping rate data are clipped 
based on the specified Minimum and Maximum 
values 

Minimum Specifies the minimum acceptable value for pumping 
rate data; data points with a pumping rate value less 
than this value are not imported 

Maximum Specifies the maximum acceptable value for pumping 
rate data; data points with a pumping rate value 
greater than this value are not imported 

Export 
In a graph view, the Export menu is used to save four different file types which 
provide you with a means of transferring graphics and data to other software 
packages.  Supported file formats include the following:  

1. Summary (*.out) – ASCII file presenting analysis results 

2. AutoCAD DXF (*.dxf) - file for importing into CAD software 

3. Windows Metafile (*.wmf) – graphics import file for most Windows 
applications such as Microsoft Word or Excel.  You should use the Windows 
metafile if you want to preserve fonts and colors when importing the type curves 
into other applications.  DXF files do not preserve fonts or colors properly. 

4. Placeable Metafile (*.wmf) – alternative metafile format required by some 
Windows applications 

In a spreadsheet view, the Export menu exports an ASCII file with the time and 
drawdown data.  The file is a comma-delimited text file that can be imported into 
most applications, such as spreadsheets. Additionally, the order of the values in the 
file will correspond to the order of the columns displayed on the spreadsheet.  Since 
the number of and order of columns on the spreadsheet can be adjusted make sure 
the spreadsheet matches what you want to export. 

In a map view, the Export menu is used to save 10 different file types which provide 
you with a means of transferring graphics and data to other software packages.  
Supported file formats include the following: 

1. Surfer ASCII (*.grd) - ASCII file containing the matrix of head values 
computed by AquiferWin32 for recontouring in SURFER 

2. Surfer BINARY (*.grd) ) - BINARY file containing the matrix of head values 
computed by AquiferWin32 for recontouring in SURFER 

3. Surfer XYLINE (*.bln) - ASCII file containing selected graphic lines for use in 
SURFER 

4. Surfer POSTING (*.pst) ) - ASCII file containing selected graphic text for use in 
SURFER 

5. AutoCAD DXF (*.dxf) - file for importing into CAD software 

6. SpyGlass (*.spy) - Spyglass is a commercial graphics program that provides 
more sophisticated visualization capabilities than AquiferWin32 

7. ASCII XYZ (*.dat) ) - ASCII file containing the matrix of head values 
computed by AquiferWin32 in the format x, y, z 
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8. Geosoft (*.geo) - Geosoft is a commercial graphics program that provides more 
sophisticated visualization capabilities than AquiferWin32 

9. Windows Metafile (*.wmf) – graphics import file for most Windows 
applications such as Microsoft Word or Excel.  You should use the Windows 
metafile if you want to preserve fonts and colors when importing the type curves 
into other applications.  DXF files do not preserve fonts or colors properly. 

10. Placeable Metafile (*.wmf) – alternative metafile format required by some 
Windows applications 

11. ArcView Shapefile (*.shp) – Exports using ArcViewTM Shapefile format. 

Send 
If electronic mail has been installed on the computer, this menu will appear.  The 
Send menu is used to send the active document through electronic mail.  The 
currently supported electronic mail editor is displayed with a copy of the active 
document included as an attachment. 

Most Recently Used Files 
The four most recently opened document files are listed at the bottom of the File 
menu for easy access.  Simply click on the appropriate file name in the menu and 
that file will be automatically opened. 

Exit 
The Exit menu closes all open documents and exits the application.  You will be 
prompted to optionally save each of the currently opened documents that has 
unsaved changes. 

Edit Menu 
The Edit menu, like the File menu, contains both standard Windows menus and 
those customized for AquiferWin32.  The standard Edit menu including Cut, Copy, 
Paste, and Delete has been enhanced to include additional menus items specific to 
AquiferWin32.  As with other menus, the accessibility of particular menu items is 
determined by the active view and the active document type. 

Cut, Copy, Paste, Delete 
The Cut, Copy, Paste, and Delete menus are standard Windows functions.  Each 
menu operates on the currently selected elements or spreadsheet lines.  An element 
can be a well, title, line, frame, legend, symbol, parameter, or scale.     To select one 
of these elements in a map view, simply move the cursor over the element until you 

see the  arrow appear, then click the left mouse button.  The element will turn a 
solid color or a bounding rectangle will appear to identify that it has been selected.  
Multiple selection is achieved by repeating the procedure while holding down the 
Shift key.  Now, all of the edit operations will work on this element.  If no element 
has been selected, these menus will appear in gray and cannot be used.  One 
exception is the Copy menu which allows copying the entire view to the clipboard as 
an OLE object and a metafile. 
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To select lines in a spreadsheet view, click the left mouse button in the leftmost 
column of the spreadsheet and drag a selection.  Alternatively, hold down the shift 
key and use the arrow keys or page keys to expand the selection. 

Use Cut to remove the selected elements or spreadsheet lines from the view and put 

them on the Windows clipboard.  You may also use the  button on the Standard 
toolbar to cut.  Use the Delete menu to simply remove the elements or spreadsheet 
lines from the view without placing them on the clipboard.  Use Copy to keep the 
elements or spreadsheet lines in the view but make a copy on the Windows 

clipboard.  You may also use the  button on the Standard toolbar to copy.  You 
may put clipboard elements into the current view using the Paste menu selection or 

the  button on the Standard toolbar.  The items or lines are pasted back at the 
same coordinates as the original elements or before the currently selected line of the 
spreadsheet.  These edit features are most useful to transfer elements from one 
aquifer test analysis document to another.  You may have several analyses open at 
one time and cut, copy, and paste elements from one document to another. 

During spreadsheet paste operations, the data is assumed to be in Windows text 
clipboard format with Tab characters separating data values and a newline character 
at the end of each data row.  During spreadsheet cut and copy operations this same 
format is produced.  Additionally, the order of the values in the clipboard 
corresponds to the order of the columns displayed on the spreadsheet.  Since the 
number of and order of columns on the spreadsheet can be adjusted make sure the 
data matches the spreadsheet into which it will be pasted. 

Undo 
The Undo menu is only available on the spreadsheet to undo the changes made to the 
active cell.  Once the active cell is changed in the spreadsheet, the previous changes 
are committed. 

Select All 
In the spreadsheet view, the Select All menu selects all lines in the spreadsheet. 

In the map view, the Select All menu is used to highlight all elements in a particular 
category.  A third menu appears with the following categories: well (in map views), 
head linesink (in model views), flux linesink (in model views), pond (in model 
views), streamline (in model views), particle (in model views), target (in model 
views), title, line, frame, legend, parameter, or symbol.  You may want to select all 
instances of a particular element in order to cut/copy and then paste into another 
document. 

Select Data Bounds 
The Select Data Bounds menu is only available for the match view and is used to 
drag a rectangle around data points on the graph to select them in the spreadsheet.  In 
a multiple well analysis, the spreadsheet contains the data for the current well and 
selecting data bounds operates on the data for the current well.  The most common 
use for this operations is to visually select data points and change the weight and/or 
symbol; this requires that these columns have been added to the spreadsheet so they 
can be edited. 
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Graph Items/Map Items/Analytic Elements 
The Graph Items menu is displayed in graph views while the Map Items menu is 
displayed in map views.  In the case of a Flow Model document, the map view 
displays the Analytic Elements menu.  They are virtually identical except that the 
map view versions allows you to edit well data and/or analytic elements in addition 
to the other types of items. 

The Graph Items Information property sheet is shown below although the Map Item 
Information property sheet and Analytic Element Information property sheet are 
identical except for the title.  This menu selection is used to manually add, delete, or 
edit objects in the currently active view.  These objects include legends, lines, 
parameters, frames, symbols, and titles.  In the case of a map view, wells, head 
linesinks, flux linesinks, ponds, streamlines, particles, line clusters, circle clusters, 
and targets are available as well. 

The items are categorized by item type and individual items are identified based on 
their primary X and Y coordinates.  As discussed in the concepts section, the 
coordinate system is map units or scaled inches for map views and graph views 
respectively.  All editing is done using the property sheet specific to the item. 

 
Add Adds an item to the currently active graph.  The item 

selected in Item Type is added. 

Edit Edits the currently selected item. 

Delete Deletes the currently selected item. 

Item Type Specifies the currently active item to be added when 
the Add button is clicked. 

Reference Head 
The Reference Head menu is used to edit the characteristics of the reference head 
for simulation documents.  The reference head represents one location within the 
aquifer where the head is known.  Reference head characteristics that may be edited 
in the Reference Information property sheet include the X and Y coordinates of the 
reference location, the head value, and the magnitude and direction of the regional 
hydraulic gradient.  The angle of the regional gradient is entered in degrees with zero 
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degrees representing East, 90 degrees is North, etc.  The regional gradient is 
dimensionless (ft/ft). 

 
Head The value for hydraulic head at a point from which to 

calculate initial head matrix 

Gradient The value for representing the change in hydraulic 
head with distance used to calculate the initial head 
matrix 

Angle The angle of rotation used to calculate the initial head 
matrix. 

Display Parameters 

Color: The color used to display the reference head symbol 
on the map 

Size The size in map units of the reference head symbol 
on the map 

Spatial Parameters 

X: The x-coordinate of the point at which the value of 
hydraulic head is being set 

Y The y-coordinate of the point at which the value of 
hydraulic head is being set 

Recharge Ellipse 
The Recharge Ellipse menu displays the Recharge Information property sheet used 
to change the characteristics of the recharge rate and location of the recharge ellipse 
for selected flow models.  The property sheet allows you to specify the recharge rate 
(e.g., ft/d), the angle of the recharge ellipse axis (zero degrees is parallel to the X 
axis), the X and Y coordinates of the center of the ellipse, and the axes lengths (a and 
b) of the ellipse.  Note that the size of the ellipse does not effect the ultimate shape of 
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the water table mound that develops in response to recharge.  Only the aspect ratio 
(a/b) effects the shape of the recharge mound. 

Recharge is currently only used in the steady-state WinFlow model and the WinTran 
model.  It is primarily for regional simulations in which model boundaries are 
simulated with wells and linesinks.  In this case, the recharge then creates water table 
divides and mounds between these regional features.  Recharge should not be used 
for small-scale models such as those used to simulate remediation systems around 
gasoline stations and other similar sites. 

 
Hydraulic Parameters 

Rate Sets the recharge rate in units of length/time 

Angle Set the angle of the recharge ellipse axis (zero 
degrees is parallel to the X axis) 

Display Parameters 

Color: The color used to display the recharge ellipse on the 
map 

Spatial Parameters 

X: The x-coordinate of the center point of the ellipse 

Y: The y-coordinate of the center point of the ellipse 

a: The x-axis length of the ellipse 

b: The y-axis length of the ellipse 

NOTE: Only the aspect ratio (a/b) effects the shape of the recharge mound. 
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Graph/Default Well Graph 
The Graph, Default Well Graph,  Default Line Graph and Default 
Concentration Graph menus all control the characteristics of a graph.  The Graph 
Information property sheet is displayed with several tabs to allow you to modify the 
way graphs are drawn on the screen.  The Graph menu affects the active graph view 
while the Default Well Graph menu only affects the default parameters used when 
new wells are added to the aquifer test or model.  Similarly, the Default Line Graph 
affects the default parameters used when adding new line calculation elements.  
Finally, the Default Concentration Graph affects the default parameters used when 
creating concentration versus time graphs for monitored wells.  You may change the 
axis annotation, line types, line labels, graph paper, and fonts used on the graph.  The 
following describes each of the items you may edit. 

 
Spatial Coordinates 

X-Origin Horizontal offset of lower left corner of the graph 
(inches) 

X-Length Length of graph x-axis (inches) 

Y-Origin Vertical offset of lower left corner of the graph 
(inches) 

Y-Length Height of graph y-axis (inches)  
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Display Internal Grid Toggle the display of the internal grid on the graph 

Display Axis Ticks  Toggle the display of axis ticks adjacent to axis 
numbers 

Title Information 

Title The text to be displayed as the title above the graph 

Color The color used for the title 

Font Defines the font, font style, size, effects and color for 
the title 

Window Maximums 

Max. X Defines the maximum x value, in inches, to reserve 
for the graph window 

Max. Y Defines the maximum y value, in inches, to reserve 
for the graph window 

Save As Defaults When checked, the values contained in this property 
sheet are stored in the system registry when the 
property sheet is accepted and are used as the defaults 
when an new document is created 

Restore System Defaults When checked, the default system values are restored 
when the property sheet is accepted; this operation 
occurs before the Save As Defaults operation so 
having both checked resets both the document and 
the system registry 
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Axis Type 

Arithmetic Scale: Defines an arithmetic x-axis 

Logarithmic Scale: Defines a logarithmic x-axis 

Subdivisions 

Major: Sets the number of major subdivisions for the graph 

Minor: Sets the number of minor subdivisions for an 
arithmetic axis (always 10 for a logarithmic axis) 

Minimum X: Sets the minimum value represented by the x-axis 

Maximum X: Sets the maximum value represented by the x-axis 

NOTE: To reverse the axis numbers on an arithmetic scale, set the Minimum X 
greater than the Maximum X. 

Automatic Minimum When checked, the minimum axis value is 
automatically set based on the data being graphed 

Automatic Maximum When checked, the minimum axis value is 
automatically set based on the data being graphed 

Axis Numbers 
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Format: Defines the format to use for axis numbers 

EXPONENTIAL generates numbers as 1.0e-001 

FIXED  generates numbers as 0.1 

POWER  generates numbers as 10-1 

Precision:  Defines the number of decimal places to display for 
FIXED and EXPONENTIAL formats 

Color Defines the color to use when displaying the axis 
numbers 

Font: Defines the font, font style, size, effects and color for 
the  axis numbers 

Axis Label 

Text: The text to be displayed as the x-axis label 

Color Defines the color to use when displaying the axis 
numbers 

Append Units When checked, the units of the data will be appended 
to the axis label 

Font: Defines the font, font style, size, effects and color for 
the label 
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Axis Type 

Arithmetic Scale: Defines an arithmetic x-axis 

Logarithmic Scale: Defines a logarithmic x-axis 

Subdivisions 

Major: Sets the number of major subdivisions for the graph 

Minor: Sets the number of minor subdivisions for an 
arithmetic axis (always 10 for a logarithmic axis) 

Minimum X: Sets the minimum value represented by the x-axis 

Maximum X: Sets the maximum value represented by the x-axis 

NOTE: To reverse the axis numbers on an arithmetic scale, set the Minimum X 
greater than the Maximum X. 

Automatic Minimum When checked, the minimum axis value is 
automatically set based on the data being graphed 

Automatic Maximum When checked, the minimum axis value is 
automatically set based on the data being graphed 

Axis Numbers 
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Format: Defines the format to use for axis numbers 

EXPONENTIAL generates numbers as 1.0e-001 

FIXED  generates numbers as 0.1 

POWER  generates numbers as 10-1 

Precision:  Defines the number of decimal places to display for 
FIXED and EXPONENTIAL formats 

Color Defines the color to use when displaying the axis 
numbers 

Font: Defines the font, font style, size, effects and color for 
the  axis numbers 

Axis Label 

Text: The text to be displayed as the x-axis label 

Color Defines the color to use when displaying the axis 
numbers 

Append Units When checked, the units of the data will be appended 
to the axis label 

Font: Defines the font, font style, size, effects and color for 
the label 
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Graph Perimeter 

Color: Sets the color of the graph perimeter line 

Thickness: Sets the thickness of the graph perimeter line in 
points 

Major Subdivisions 

Color: Sets the color of the graph major subdivisions 

Thickness: Sets the thickness of the graph major subdivisions in 
points 

Minor Subdivisions 

Color: Sets the color of the graph minor subdivisions 

Thickness: Sets the thickness of the graph minor subdivisions 

Major Ticks 

Color: Sets the color of the graph major ticks 

Thickness: Sets the thickness of the graph major ticks in points 

Minor Subdivisions 

Color: Sets the color of the graph minor ticks 
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Thickness: Sets the thickness of the graph minor ticks 

 

 
Data Set: Specifies which graph data set is being edited 

Default Type Curves - Defines the values used when a new type curve 
is added to the graph 

Selected Type Curve - Defines the Line Style parameters used when 
displaying the selected type curve 

Display Line: Activates the display of lines connecting data points 

Display Symbol: Activates the display of symbols at data points 

Display Label: Activates the display of a label on the data set 

Line Style 

Color: Sets the color of the line connecting the data points 

Thickness: Sets the thickness in points of the line connecting the 
data points 

Dash: Sets the dash pattern to use for the line connecting 
the data points 
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Length: Sets the length in inches of the dash pattern for the 
line connecting the data points 

Symbol Style 

Color: Sets the color of the symbol displayed at each data 
point 

Thickness: Sets the thickness in points of the line used to draw 
the symbol 

Symbol: Sets the symbol to display at each data point 

Size: Sets the size in points of the symbol to display at 
each data point 

Label Information 

Label: The text to be displayed as the label on the data set 

Separation: The minimum distance in inches between labels 

Maximum Number: The maximum number of labels to display 

Tolerance: The maximum difference in inches between the total 
distance along the data curve where the label is to be 
displayed and the length of the label 

Color Sets the color of the label displayed on the data set 

NOTE: The value for tolerance determines how straight the section of the curve 
has to be for the label to be displayed.  If the tolerance is exceeded the 
label will be advanced forward until an acceptable section of the curve 
is found. 

Font: Defines the font, font style, size, effects and color for 
the label 

Solution 
The Solution menu activates the Solution Information property sheet which allows 
you to change the analysis type (i.e., confined versus leaky aquifers etc.), the way in 
which the automatic curve match is performed, initial guesses for parameter values, 
the way data are displayed, and the type curves to be displayed.  You can also use 
this property sheet to view the results of the current match.  The Solution Information 
property sheet is dynamic and changes depending on the specific analysis selected.  
You are referred to the Analysis Parameters section of the Concepts chapter for more 
details. A general discussion of each tab of the property sheet is provided below. 
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Solution Information 

Analysis: Defines the type of analytic solution to use when 
evaluating the current aquifer test 

Convergence Information 

Convergence Criteria: The change in the sum of squared residuals that 
determines when the automated curve match 
algorithm is finished 

Maximum Iterations: The maximum number of nonlinear least-squares 
iterations allowed for each automated curve match. 

Advanced: This button activates the Advanced Solution 
Information dialog that provides more control of the 
nonlinear least-squares solution 
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The  control adjacent to each edit field acts like two check-boxes.  The upper 
check-box controls whether the adjacent parameter is fixed, held constant, during 
optimization.  The lower check-box controls whether the particular parameter is 
linked to another parameter within the document.  Linked parameters are not editable 
and share both value and units with the parameter to which they are linked.  
Furthermore, linked parameters are forced to be fixed. 

Well Parameters 

Radial distance (r) Initial guess for distance from the pumping well to 
the observation well 

Pumping Rate (Q) Initial guess for pumping rate at the production well 

Hydraulic Parameters 

Transmissivity Initial guess for transmissivity 

Storage coefficient Initial guess for storage coefficient 

Beta (ß) Initial guess for Beta 

NOTE: These example parameters are specific to the Hantush, 1960 analysis.  
Additional parameters and/or parameter pages may appear in this area 
depending upon the type of aquifer test analysis specified. 
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Well Parameters 

Radial distance (r) Calculated value for distance from the pumping well 
to the observation well 

Pumping Rate (Q) Calculated value for pumping rate at the production 
well 

Hydraulic Parameters 

Transmissivity Calculated value for transmissivity 

Storage coefficient Calculated value for storage coefficient 

Beta (ß) Calculated value for Beta 

NOTE: These example results are specific to the Hantush, 1960 analysis.  
Additional parameters and/or results pages may appear in this area 
depending upon the type of aquifer test analysis specified. 
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Parameter Defines the parameter used when generating type 

curves 

Curve Information 

Add Add a new value for which to generate a type curve 

Edit Change the currently selected type curve value 

Delete Remove the currently selected type curve value 

Move Up Move the currently selected type curve value up in 
the list 

Move Down Move the currently selected type curve value down in 
the list 

NOTE: This page may be absent if the active solution does not support multiple 
type curves.  Also, the order in the list controls the order the curves are 
drawn.  In some cases, the selected type curve color is overwritten when 
type curves are drawn.  In this case, move the selected type curve to the 
bottom of the list. 
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Parameter Selects the parameter to edit 

Value Information 

Initial Initial guess to use for the selected parameter 

Fixed Value If checked, the value is fixed for the selected 
parameter during optimization 

Calculated Calculated value for the selected parameter 

Linked Value If checked, the value is linked to a parameter 
elsewhere in the document.  Linked values are linked 
in both value and units and force the Fixed Value 
check-box to be checked. 

Range Information 

Enforce Minimum If checked, the adjacent value is the minimum value 
allowed during optimization 

Enforce Maximum If checked, the adjacent value is the maximum value 
allowed during optimization 

NOTE: It is often necessary to enforce minimum and maximum values for 
parameters to achieve convergence on a solution. 
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The Statistics tab displays the results from the current match.  A residual is the 
difference between the field drawdown and the value computed according to the 
current match.  The automatic method tries to minimize the residual sum of squares.  
The Match Point data are useful if you are trying to compare your results with those 
obtained from more traditional graph paper methods. 

 
The Data tab contains a tab spreadsheet containing the data points used to represent 
each type curve.  The spreadsheet is read-only; however, a context menu is available 
to export the data points for individual type curves. 

 



 

226  •  Menus and Dialogs Guide to Using AquiferWin32 

Toggle Step 
The Toggle Step option is active only in Step Test documents.  Selecting this item 
changes the currently selected step and updates the combobox in the Step toolbar 
shown below. 

 
The currently active step controls which subset of data points and their respective 
linear regression line are active.  The currently active step is used when either the 

Calc->Linear Regression->Single Step menu or the  button on the Step toolbar 
is clicked.  

Toggle Type Curve 
Selecting the Toggle Type Curve menu changes the currently selected type curve 
when there are multiple type curves being displayed.  It also updates the combobox 
in the Match toolbar as shown below. 

 
For single type curve analyses (e.g., the Theis method for confined aquifers), this 
menu is not active.  Further, this menu is only available when the Match Data view is 
active. 

Toggle Data Set 
Selecting the Toggle Data Set menu changes the currently selected well in a 
multiple well analysis.  The data points for the currently selected well are displayed 
in the spreadsheet and are active in the Match Data view.  Both automatic and visual 
matching use the active well.  The name of the currently selected well is displayed 
on the Match Data view tab at the bottom left of the graph view.  This menu is only 
available in a multiple well analysis. 

Group Optimize Parameters 
Selecting the Group Optimize Parameters menu displays the Group Optimization 
Parameters property sheet.  This property sheet has a Parameters tab containing an 
Add/Remove listbox pair.  This menu is only available in multiple well analyses.  
Optimizing the wells as a group uses data from all wells in estimating the parameter 
values for the automatic match.  The Group Optimization Parameters property sheet 
is displayed below. 
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Available Parameters:  Contains the parameters that can optimized for all 

wells.  In order for a parameter to appear in either 
list, it cannot be fixed in any well in the group. 

Optimized Parameters: Contains the parameters that will be optimized across 
the group of wells. 

Add>>: Moves the currently selected parameter from the 
Available Parameters list to the Optimized 
Parameters list. 

Add All>>: Moves all parameters from the Available Parameters 
list to the Optimized Parameters list.                     

Remove>>: Moves the currently selected parameter from the 
Optimized Parameters list to the Available 
Parameters list. 

Remove All>>: Moves all parameters from the Optimized Parameters 
list to the Available Parameters list. 

Flow Model 
The Flow Model menu accesses the Model Information property sheet which allows 
you to change the solution type (i.e., confined versus leaky aquifers etc.), the way in 
which the model parameters are optimized, model parameter values, the reference 
head and the recharge ellipse.  The Model Information property sheet is dynamic and 
changes depending on the specific analysis selected.  If a solution does not support 
optimization, the Results and Exceptions pages will not be present.  Additionally, the 
Parameter and Results pages have help links to the specific solution help files 
accessed by pressing the F1 key.  A general discussion of each tab of the property 
sheet is provided below. 
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Solution Information 

Analysis: Defines the type of analytic solution to use when 
evaluating the current aquifer test 

Convergence Information 

Convergence Criteria: The change in the sum of squared residuals that 
determines when the automated curve match 
algorithm is finished 

Maximum Iterations: The maximum number of nonlinear least-squares 
iterations allowed for each automated curve match. 

Advanced: This button activates the Advanced Solution 
Information dialog that provides more control of the 
nonlinear least-squares solution 
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The Reference Head tab is used to edit the characteristics of the reference head for 
simulation and flow model documents.  The reference head represents one location 
within the aquifer where the head is known.  Reference head characteristics that may 
be edited in this property sheet include the X and Y coordinates of the reference 
location, the head value, and the magnitude and direction of the regional hydraulic 
gradient.  The angle of the regional gradient is entered in degrees with zero degrees 
representing East, 90 degrees is North, etc.  The regional gradient is dimensionless 
(ft/ft). 

Head: The value for hydraulic head at a point from which to 
calculate initial head matrix 

Gradient: The value for representing the change in hydraulic 
head with distance used to calculate the initial head 
matrix 

Angle: The angle of rotation used to calculate the initial head 
matrix. 

Display Parameters 

Color: The color used to display the reference head symbol 
on the map 

Size: The size in map units of the reference head symbol 
on the map 

Spatial Parameters 

X: The x-coordinate of the point at which the value of 
hydraulic head is being set 

Y: The y-coordinate of the point at which the value of 
hydraulic head is being set 
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The Recharge tab is used to change the characteristics of the recharge rate and 
location of the recharge ellipse for selected flow models.  The property sheet allows 
you to specify the recharge rate (e.g., ft/d), the angle of the recharge ellipse axis 
(zero degrees is parallel to the X axis), the X and Y coordinates of the center of the 
ellipse, and the axes lengths (a and b) of the ellipse.  Note that the size of the ellipse 
does not affect the ultimate shape of the water table mound that develops in response 
to recharge.  Only the aspect ratio (a/b) effects the shape of the recharge mound. 

Recharge is currently only used in the steady-state WinFlow model and the WinTran 
model.  It is primarily for regional simulations in which model boundaries are 
simulated with wells and linesinks.  In this case, the recharge then creates water table 
divides and mounds between these regional features.  Recharge should not be used 
for small-scale models such as those used to simulate remediation systems around 
gasoline stations and other similar sites. 

Hydraulic Parameters 

Rate Sets the recharge rate in units of length/time 

Angle Set the angle of the recharge ellipse axis (zero 
degrees is parallel to the X axis) 

Display Parameters 

Color: The color used to display the recharge ellipse on the 
map 

Spatial Parameters 

X: The x-coordinate of the center point of the ellipse 

Y: The y-coordinate of the center point of the ellipse 

a: The x-axis length of the ellipse 

b: The y-axis length of the ellipse 

NOTE: Only the aspect ratio (a/b) effects the shape of the recharge mound. 
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The  control adjacent to each edit field acts like two check-boxes.  The upper 
check-box controls whether the adjacent parameter is fixed, held constant, during 
optimization.  The lower check-box controls whether the particular parameter is 
linked to another parameter within the document.  Linked parameters are not editable 
and share both value and units with the parameter to which they are linked.  
Furthermore, linked parameters are forced to be fixed. 

Hydraulic Parameters 

Transmissivity Value to use for transmissivity 

Storage coefficient Value to use for storage coefficient 

Particle Tracking Parameters 

Aquifer Thickness Value to use when converting transmissivity to 
hydraulic conductivity for the purpose of calculating 
flow velocities for particle tracking 

Porosity Value to use for porosity for the purpose of 
calculating flow velocities for particle tracking 

NOTE: These example parameters are specific to the Theis, 1935 analysis.  
Additional parameters and/or parameter pages may appear in this area 
depending upon the type of aquifer test analysis specified. 
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Hydraulic Parameters 

Transmissivity Calculated value for transmissivity 

Storage coefficient Calculated value for storage coefficient 

Particle Tracking Parameters 

Aquifer Thickness Value used when converting transmissivity to 
hydraulic conductivity for the purpose of calculating 
flow velocities for particle tracking 

Porosity Value used for porosity for the purpose of calculating 
flow velocities for particle tracking 

NOTE: These example parameters are specific to the Theis, 1935 analysis.  
Additional parameters and/or parameter pages may appear in this area 
depending upon the type of aquifer test analysis specified. 
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Parameter Selects the parameter to edit 

Value Information 

Initial Initial guess to use for the selected parameter 

Fixed Value If checked, the value is fixed for the selected 
parameter during optimization 

Calculated Calculated value for the selected parameter 

Linked Value If checked, the value is linked to a parameter 
elsewhere in the document.  Linked values are linked 
in both value and units and force the Fixed Value 
check-box to be checked. 

Range Information 

Enforce Minimum If checked, the adjacent value is the minimum value 
allowed during optimization 

Enforce Maximum If checked, the adjacent value is the maximum value 
allowed during optimization 

NOTE: It is often necessary to enforce minimum and maximum values for 
parameters to achieve convergence on a solution. 

Model 
The Model menu accesses the Model Information property sheet which allows you 
to change the analysis type (i.e., confined versus leaky aquifers etc.), the pumping 
well, the reference head and the pertinent parameters for the simulation.  The Model 
Information property sheet is dynamic and changes depending on the specific 
analysis selected.  A general discussion of each tab of the property sheet is provided 
below. 
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Solution Information 

Analysis: Defines the type of analytic solution to use when 
simulating a pump test 

Pumping Information 

Pumping Well: Selects one of the available wells to serve as the 
pumping well for the simulation 

Contour Time: The time at which a head matrix and contour map 
will be calculated 
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The Reference Head tab is used to edit the characteristics of the reference head for 
simulation documents.  The reference head represents one location within the aquifer 
where the head is known.  Reference head characteristics that may be edited in this 
property sheet include the X and Y coordinates of the reference location, the head 
value, and the magnitude and direction of the regional hydraulic gradient.  The angle 
of the regional gradient is entered in degrees with zero degrees representing East, 90 
degrees is North, etc.  The regional gradient is dimensionless (ft/ft). 

Head: The value for hydraulic head at a point from which to 
calculate initial head matrix 

Gradient: The value for representing the change in hydraulic 
head with distance used to calculate the initial head 
matrix 

Angle: The angle of rotation used to calculate the initial head 
matrix. 

Display Parameters 

Color: The color used to display the reference head symbol 
on the map 

Size: The size in map units of the reference head symbol 
on the map 

Spatial Parameters 

X: The x-coordinate of the point at which the value of 
hydraulic head is being set 

Y: The y-coordinate of the point at which the value of 
hydraulic head is being set 

 
Well Parameters 

Radial distance (r) In a simulation, this parameter is not used and is 
inactive 
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Pumping Rate (Q) The constant pumping rate to use during the 
simulation 

Hydraulic Parameters 

Transmissivity Value to use for transmissivity 

Storage coefficient Value to use for storage coefficient 

NOTE: These example parameters are specific to the Theis, 1935 analysis.  
Additional parameters and/or parameter pages may appear in this area 
depending upon the type of aquifer test analysis specified. 

Site 
The Site menu allows you to specify information describing the aquifer test site, 
including job number, client, etc.  The menu item activates the Site Information 
property sheet.  You may also specify the parameters describing each well used in 
the test, as described below. 

 
Site Designator User field that appears in the summary report and can 

be used to annotate a graph or map view. 

Site Information 

Job Number User field that appears in the summary report and can 
be used to annotate a graph or map view. 

Client User field that appears in the summary report and can 
be used to annotate a graph or map view. 

Site Name User field that appears in the summary report and can 
be used to annotate a graph or map view. 
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Additional Info: User field that appears in the summary report and can 
be used to annotate a graph or map view. 

 
Well Designator: Specifies which well is being edited 

Construction Parameters 

Casing Inner Diameter The inner diameter of the well casing 

Diameter of Drilled Hole The diameter of the drilled hole 

Screen Length The length of the well screen 

Screen Top Depth The depth to top of the well screen relative to the top 
of the aquifer 

Spatial Parameters 

X: The x-coordinate of the well location in map units 

Y: The y-coordinate of the well location in map units 

NOTE: This tab is only shown when wells have been defined in the map view. 
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The User tab contains customizable parameter boxes which allow the input of a wide 
range of user specified data or text items. Each field initially has a default name 
which can be changed.  Place the cursor over the field name to be changed and right 
click the mouse. On the context menu displayed, select Edit and enter the new name 
required. Click on OK and the new name will be saved. The required information 
can then be entered into the input section of each box. 

Information entered in these fields can be accessed in footers/headers, figures and 
parameter boxes displayed on graphical output. 

Aquifer Test 
Selecting the Aquifer Test menu displays the Aquifer Test Information property 
sheet; this property sheet allows you to enter data defining the test you performed, 
including a description of the test, the pumping rate history for the test, wells that 
were monitored during the test, and the time-drawdown data for each well.  A subset 
of the nine potential tabs will be displayed depending on the document type and data.  
The Aquifer Test Information property sheet is described below. 
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Test Designator: User field that appears in the summary report and can 

be used to annotate a graph or map view. 

Test Information 

Job Number User field that appears in the summary report and can 
be used to annotate a graph or map view. 

Date User field that appears in the summary report and can 
be used to annotate a graph or map view. 

Area Name User field that appears in the summary report and can 
be used to annotate a graph or map view. 

Additional Info User field that appears in the summary report and can 
be used to annotate a graph or map view. 
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Pumping Well 

Well Name Name of the pumping well. 

Pumping Rate Well discharge rate. 

Variable Pumping Rate Set this check box to activate a variable pumping rate 
analysis.  An additional Rates tab will be added to 
the property sheet for entering the pumping rates. 

Casing Inner Diameter The inner diameter of the pumping well casing. 

Diameter of Drilled Hole The diameter of the pumping well drilled hole. 

Screen Length The length of the pumping well screen. 

Screen Top Depth The depth to top of the pumping well screen relative 
to the top of the aquifer. 

Monitoring Well 

Well Name Name of the monitoring well. 

Radial Distance Distance between the monitoring well and the 
pumping well. 

Casing Inner Diameter  The inner diameter of the monitoring well casing. 

Diameter of Drilled Hole The diameter of the monitoring well drilled hole. 

Screen Length The length of the monitoring well screen. 

Screen Top Depth The depth to top of the monitoring well screen 
relative to the top of the aquifer. 

NOTE: The Pumping tab is displayed as shown above when no wells have been 
defined in the site map. 
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Pumping Well Select the well pumped during the test 

Pumping Rates 

Time The time coordinate of the pumping 

Pumping Rate The discharge rate at the specified time 

NOTE: The Pumping tab is displayed as shown above when wells have been 
defined in the site map. 
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Pumping Well The name of the well pumped during the test 

Pumping Rates 

Time The starting time coordinate of the pumping step 

Pumping Rate The discharge rate during the pumping step 

NOTE: The Pumping tab is displayed as shown above when the active 
document is a Step Test document. 
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Pumping Rates 

Time The starting time of the pumping rate 

Pumping Rate The pumping rate at the specified time 

NOTE: The Rates tab is displayed as shown above when no wells have been 
defined in the site map and Variable Pumping Rate has been checked 
on the Pumping tab. 
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Available Wells Contains wells that are not being monitored 

Monitored Wells Contains wells that are being monitored 

Add>> Moves the currently selected well from the Available 
Wells list to the Monitored Wells list 

Add All>> Moves all wells from the Available Wells list to the 
Monitored Wells list 

Remove>> Moves the currently selected well from the 
Monitored Wells list to the Available Wells list 

Remove All>> Moves all wells from the Monitored Wells list to the 
Available Wells list 

NOTE: The Wells tab is only shown when at least one well has been defined in 
the map view 
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Test Well 

Well Name Name of the well being tested 

Initial Displacement The maximum change in water level caused by the 
slug 

Casing Inner Diameter The inner diameter of the pumping well casing. 

Diameter of Drilled Hole The diameter of the pumping well drilled hole. 

Screen Length The length of the pumping well screen. 

Screen Top Depth The depth to top of the pumping well screen relative 
to the top of the aquifer. 

NOTE: This tab is only displayed when a Slug Test document is active. 
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Time The time coordinate of the monitoring well response 

Drawdown The drawdown of the monitoring well response 

NOTE: The Well Data tab appears as shown above when at least one well has 
been defined as monitored in the Wells tab.  If no wells are designated 
as monitored, only the Match Data tab is displayed. 



 

Guide to Using AquiferWin32 Menus and Dialogs  •  247 

 
The Match Data tab, shown above for a simple test, allows the user to alter the 
weighting and/or symbol on each data point.  Increasing the weighting factor 
progressively reduces the influence of a data point when using the Marquardt 
(modified Gauss-Newton) nonlinear least-squares technique.  Weighting is relative 
to the inverse square of the weight value.  A value greater than or equal to 100 
removes the data point from consideration in a linear regression analysis. 

Time The time coordinate of the monitoring well response 

 Drawdown The drawdown of the monitoring well response 

Weight The weight applied to the data point as described 
above 

Symbol Displays the symbol used to display the data point on 
graphs 

The symbol is edited by double clicking the mouse on the spreadsheet cell or setting 
focus on the cell and pressing the Spacebar key.  The Symbol Information property 
sheet shown below is then displayed. 
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Symbol Style 

Color The color of the symbol displayed at each 
time/drawdown data point. 

Thickness The line thickness used to draw the symbol displayed 
at each time/drawdown data point. 

Symbol  The symbol displayed at each time/drawdown data 
point. 

Size The size of the symbol displayed at each 
time/drawdown data point. 

 
The User tab contains customizable parameter boxes which allow the input of a wide 
range of user specified data or text items. Each field initially has a default name 
which can be changed.  Place the cursor over the field name to be changed and right 
click the mouse. On the context menu displayed, select Edit and enter the new name 
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required. Click on OK and the new name will be saved. The required information 
can then be entered into the input section of each box. 

Information entered in these fields can be accessed in footers/headers, figures and 
parameter boxes displayed on graphical output. 

Simulation 
Selecting the Simulation menu displays the Simulation  Information property sheet; 
this property sheet allows you to define monitoring wells for which you want to 
calculate time/drawdown data.  The Simulation Information property sheet is 
described below. 

 
Test Designator: User field that appears in the summary report and can 

be used to annotate a graph or map view. 

Test Information 

Job Number User field that appears in the summary report and can 
be used to annotate a graph or map view. 

Date User field that appears in the summary report and can 
be used to annotate a graph or map view. 

Area Name User field that appears in the summary report and can 
be used to annotate a graph or map view. 

Additional Info User field that appears in the summary report and can 
be used to annotate a graph or map view. 
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Available Wells Contains wells that are not being simulated 

Monitored Wells Contains wells that are being simulated 

Add>> Moves the currently selected well from the Available 
Wells list to the Monitored Wells list 

Add All>> Moves all wells from the Available Wells list to the 
Monitored Wells list 

Remove>> Moves the currently selected well from the 
Monitored Wells list to the Available Wells list 

Remove All>> Moves all wells from the Monitored Wells list to the 
Available Wells list 
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Time The time coordinate at which to calculate well 

responses 

NOTE: The Simulation Times tab is used to define the specific times at which to 
calculate drawdown in all the simulated wells.  Changes to the times 
take effect the next time you calculate the simulation.  
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Time The time coordinate of the simulated well response 

Drawdown The drawdown of the simulated well response 

Analysis 
Selecting the Analysis menu displays the Analysis Information property sheet that 
allows you to document the current analysis and to determine how data from 
monitoring wells is to be analyzed.  The parameters you may modify are described 
below. 

 
Analysis Designator User field that appears in the summary report 

and can be used to annotate a graph or map view. 

Analysis Information 

Job Number User field that appears in the summary report 
and can be used to annotate a graph or map view. 

Date User field that appears in the summary report 
and can be used to annotate a graph or map view. 

Analyst Name User field that appears in the summary report 
and can be used to annotate a graph or map view. 
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Additional Info User field that appears in the summary report 
and can be used to annotate a graph or map view. 

Pumping Information 

Calculate Time Average Pumping Pumping rate used in the analysis is calculated as 
a time average of the pumping schedule. 

Use First Pumping Rate The first pumping rate in the pumping schedule 
is used for the analysis. 

Specify Pumping Rate The pumping rate used in the analysis is 
specified in the adjacent field. 

Variable Pumping Rate The variable pumping rate defined for the 
pumping schedule is used 

 

 
Well Designator: Specifies the monitoring well being edited. 

Match Data Information 

Include Well In Match Data The drawdown data is added to the Match Data 
set 
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Include Well Individually The well is included in the analysis 
independently 

Exclude Well The well is not included in the analysis. 

Adjust Data for Radial Distance The time coordinate is divided by the radial 
distance squared 

Data Clipping 

Min. Time If checked, data points whose transformed time 
value is below the value in the adjacent field are 
excluded from the analysis. 

Max. Time If checked, data points whose transformed time 
value is above the value in the adjacent field are 
excluded from the analysis. 

Min. Drawdown If checked, data points whose transformed 
drawdown value is below the value in the 
adjacent field are excluded from the analysis. 

Max. Drawdown If checked, data points whose transformed 
drawdown value is above the value in the 
adjacent field are excluded from the analysis. 

Data Transformation 

Time Scale/Offset Time values are multiplied by the scale value 
and added to the offset value. 

Drawdown Scale/Offset Drawdown values are multiplied by the scale 
value and added to the offset value. 

Symbol Style 

Color The color of the symbol displayed at each 
time/drawdown data point. 

Thickness The line thickness used to draw the symbol 
displayed at each time/drawdown data point. 

Symbol The symbol displayed at each time/drawdown 
data point. 

Size The size of the symbol displayed at each 
time/drawdown data point. 

NOTE: The Match Data tab appears as shown above when at least one well has 
been defined as monitored in the Wells tab. 
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The User tab contains customizable parameter boxes which allow the input of a wide 
range of user specified data or text items. Each field initially has a default name 
which can be changed.  Place the cursor over the field name to be changed and right 
click the mouse. On the context menu displayed, select Edit and enter the new name 
required. Click on OK and the new name will be saved. The required information 
can then be entered into the input section of each box. 

Information entered in these fields can be accessed in footers/headers, figures and 
parameter boxes displayed on graphical output. 

Units 
Selecting the Units menu displays the Unit Information property sheet with two tabs, 
as shown below.  The first tab is labeled Summary and contains the four basic 
parameters and their respective units.  The values represent either the program 
defaults or the values previously saved as default.  Under normal circumstances, you 
would set the summary units once and save them as your defaults.  If you always use 
the same types of units in your analyses, then you never need to change these again.  
Click the Save As Default check-box to do this and then click OK.  

NOTE: If changes are made to both tabs of this property sheet, the values on 
the Summary tab take priority. 
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Units of Summary Groups 

Time Units Specifies the units to use for time 

Length Units Specifies the units to use for length 

Pumping Rate Units Specifies the units to use for pumping rate 

Transmissivity Units Specifies the units to use for transmissivity 

Save As Defaults The current selections are saved to the system 
registry and are used as the defaults 

Apply Globally The current selections are applied globally 
throughout the current document 

Convert Data The existing data values are converted from the old 
units to the new units 
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Parameters: The parameter for which units are to be changed. 

Units: Units for the selected parameter as they will be 
displayed within the program 

Length Units of length 

Time Units of time 

Volume Units of volume 

Apply Units The current selections are applied to the currently 
selected parameter for the currently selected well 

Apply Globally The current selections are applied to the currently 
selected parameter globally throughout the active 
document 

Convert Data The existing data values are converted from the old 
units to the new units 

Units - Mass 
Selecting the Units menu displays the Unit Information property sheet with two tabs, 
as shown below.  The first tab is labeled Summary and contains the four basic 
parameters and their respective units.  The values represent either the program 
defaults or the values previously saved as default.  Under normal circumstances, you 
would set the summary units once and save them as your defaults.  If you always use 
the same types of units in your analyses, then you never need to change these again.  
Click the Save As Default check-box to do this and then click OK.  
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NOTE: If changes are made to both tabs of this property sheet, the values on 
the Summary tab take priority. 

 
Units of Summary Groups 

Time Units Specifies the units to use for time 

Length Units Specifies the units to use for length 

Pumping Rate Units Specifies the units to use for pumping rate 

Transmissivity Units Specifies the units to use for transmissivity 

Concentration Units Specifies the units to use for concentration 

Save As Defaults The current selections are saved to the system 
registry and are used as the defaults 

Apply Globally The current selections are applied globally 
throughout the current document 

Convert Data The existing data values are converted from the old 
units to the new units 
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Parameters: The parameter for which units are to be changed. 

Units: Units for the selected parameter as they will be 
displayed within the program 

Length Units of length 

Time Units of time 

Volume Units of volume 

Mass Units of mass 

Apply Units The current selections are applied to the currently 
selected parameter for the currently selected well 

Apply Globally The current selections are applied to the currently 
selected parameter globally throughout the active 
document 

Convert Data The existing data values are converted from the old 
units to the new units 

Units - Parameter 
Selecting the Units menu from the edit field context menu displays the Unit 
Information property sheet for the specific parameter.  If the parameter has no mass 
component, the property is as shown below. 
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Units: Units for the selected parameter as they will be 

displayed within the program 

Length Units of length 

Time Units of time 

Volume Units of volume 

Apply Globally The current selections are applied to the currently 
selected parameter globally throughout the active 
document 

Convert Data The existing data values are converted from the old 
units to the new units 

If the parameter has a mass component, the property is as shown below. 
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Units: Units for the selected parameter as they will be 

displayed within the program 

Length Units of length 

Time Units of time 

Volume Units of volume 

Mass Units of mass 

Apply Globally The current selections are applied to the currently 
selected parameter globally throughout the active 
document 

Convert Data The existing data values are converted from the old 
units to the new units 

3D Manipulation 
Selecting the 3D Manipulation menu from the edit field context menu allows the 
manipulation of the 3D view using the mouse and keyboard.  Clicking and/or 
holding the left mouse button in the view causes the display to rotate in the direction 
toward the cursor location.  Holding the Shift button while clicking and/or holding 
the left mouse button causes the display to move in the direction toward the cursor 
location.   

Clicking and/or holding the right mouse button causes the display to zoom in and 
zoom out.  If the cursor is in the upper half of the view, it will zoom out.  If the 
cursor is in the lower half of the view, it will zoom in.  The amount of the zoom is 
controlled by how far the cursor is from the vertical center of the view. 
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Holding the Ctrl button while clicking and/or holding the left mouse button causes 
the display to rotate around its center point.  If the cursor is in the upper half of the 
view, it will rotate counter clockwise.  If the cursor is in the lower half of the view it 
will rotate clockwise.  The amount/speed of the rotation is controlled by how far the 
cursor is from the vertical center of the view. 

Insert 
The Insert menu is only available in the spreadsheet view.  Selecting Insert from the 
Edit menu inserts a new data point before the currently selected row in the 
spreadsheet.  AquiferWin32 automatically assigns the time and drawdown values of 1.0 
so you will need to change these values before continuing with the analysis. 

Append 
The Append menu adds a new row of data to the end of the spreadsheet.  As with 
Insert above, time and drawdown are initially assigned values of 1.0. 

Delete 
The Delete menu deletes the currently highlighted row of the spreadsheet or the 
currently selected block of rows.  For a graph or map view, it deletes all selected 
elements. 

Sort 
The Sort menu sorts the spreadsheet relative to the Time value. 

Column Conversion 
The Column Conversion menu displays the Unit Information property sheet that 
allows you to change the units on any column in the spreadsheet.  Refer to the 
section entitled Units above for more information on this option. 
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Column: The column for which units are to be changed 

Units: Units for the selected parameter as they will be 
displayed within the program 

Length Units of length 

Time Units of time 

Volume Units of volume 

Apply Units The current selections are applied to the currently 
selected parameter for the currently selected well 

Apply Globally The current selections are applied to the currently 
selected parameter globally throughout the current 
document 

Convert Data The existing data values are converted from the old 
units to the new units 

Solution Registration 
The Solution Registration menu is only displayed for Flow Model documents and 
serves to identify each model available to the application.  In the future, some 
models may require registration; if registration is required, the Registration tab will 
be displayed on the Solution Registration Information property sheet.  Although 
WinTran is currently included without separate registration, it serves as an example 
of the screens. 
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Solution Information 

Analysis: Defines the type of analytic solution to use when 
simulating a pump test 

 
Security Code: This is an encrypted code containing information 

about your software license and the configuration of 
the computer used to validate the license 
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Authorization Level: The level of functionality of the application granted 
by the license 

System Code: This is an encrypted code containing information 
about your hardware configuration used to generate a 
unique Security Code 

Options 
The Options menu is only displayed for the spreadsheet view and controls the 
default display characteristics of the spreadsheet and the columns of data contained 
therein.  The specific options are on the Spreadsheet Information property sheet.are 
summarized below. 

 
Spreadsheet Options 

Add initial row to spreadsheet When checked, a default initial data row is added 
to the spreadsheet when a new document is 
created.  This row is initially active to help new 
users enter data for the first time. 

Scroll Timer (milliseconds) Sets the number of milliseconds to wait between 
automatic scrolling events in the spreadsheet 

Grid Color Sets the color to use for the grid of the 
spreadsheet 

Cursor Color Sets the color to use when displaying the cursor 
indicating the currently active line 

Cursor Hatch Sets the hatch pattern to use when displaying the 
cursor indicating the currently active line 
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Selection Options 

Grid Color Sets the grid color to use when a number of data 
lines have been selected 

Background Color Sets the background color to use when a number 
of data lines have been selected 

Text Color Sets the text color to use when a number of data 
lines have been selected 

Text Background Sets the text background color to use when a 
number of data lines have been selected 

Save As Defaults When checked, the values contained in this property 
sheet are stored in the system registry when the 
property sheet is accepted and are used as the defaults 
when an new document is created 

Restore System Defaults When checked, the default system values are restored 
when the property sheet is accepted; this operation 
occurs before the Save As Defaults operation so 
having both checked resets both the document and 
the system registry 

Update Data Columns When checked, the default column characteristics 
defined on the Fonts tab are propagated to the 
existing columns in the spreadsheet 

 
Default Title 

Title Color Sets the color to use when displaying the column 
title  
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Background Color Sets the background color to use when 
displaying the column title 

Font Sets the font to use when displaying the column 
title 

Default Text 

Text Color Sets the color to use when displaying the column 
data values  

Background Color Sets the background color to use when 
displaying the column data values 

Font Sets the font to use when displaying the column 
data values 

Row Numbers 

Number Color Sets the color to use when displaying the 
spreadsheet row number  

Background Color Sets the background color to use when 
displaying the spreadsheet row number 

Font Sets the font to use when displaying the spreadsheet 
row number 

View Menu 

Standard Tools 
Selecting the Standard Tools menu toggles the display of the Standard toolbar.  The 
display position of the toolbar is dependent on where it was previously located. 

  

Match Tools 
Selecting the Match Tools menu toggles the display of the Match toolbar.  The 
display position of the toolbar is dependent on where it was previously located.  

 

Annotation Tools 
Selecting the Annotation Tools menu toggles the display of the Annotation toolbar.  
The display position of the toolbar is dependent on where it was previously located.  
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Analytic Tools 
Selecting the Analytic Tools menu toggles the display of the Analytic toolbar.  The 
display position of the toolbar is dependent on where it was previously located.  

 

Step Tools 
Selecting the Step Tools menu toggles the display of the Step toolbar.  The display 
position of the toolbar is dependent on where it was previously located. 

 

Toolbar Options 
Selecting the Toolbar Options menu activates the Toolbar Options property sheet 
described below. 

 
Display Options 

Standard Tools When checked, the Standard Tools toolbar is 
displayed 

Step Tools When checked, the Step Tools toolbar is displayed 

Annotation Tools When checked, the Annotation Tools toolbar is 
displayed 

Status Bar When checked, the Status Bar is displayed 

Match Tools When checked, the Match Tools toolbar is displayed 

Analytic Tools When checked, the Analytic Tools toolbar is 
displayed 
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Style Options 

Display Parameters 

Rebar Style Specifies Rebar Style toolbars which are aligned 
along the top adjacent to one another and wrap to 
additional lines as the window size changes 

Normal Style Specifies individual, dockable toolbars 

Multi-Dock When checked, multiple toolbars can be combined 
into on floating toolbar frame; Not available for 
Rebar style or with flat buttons 

Flat Buttons Specifies using the new flat looking toolbar buttons 

Tooltips When checked, tooltips are active on toolbar buttons 

Bitmap Menus When checked, the corresponding toolbar button 
bitmaps are displayed adjacent to menu items 

Status Bar 
Selecting the Status Bar menu toggles the display of the status bar. 

 

Optimize 
The Optimize menu is only displayed when the spreadsheet view is active.  This 
menu causes the width of the spreadsheet columns to be optimized for best viewing.  
The width of each column is adjusted to be just wide enough to fully display the title 
and all data values in the column. 

Columns 
The Columns menu is only displayed when the spreadsheet view is active.  This 
selection displays the Spreadsheet Information property sheet where you can 
determine which columns of the spreadsheet are displayed.  Additionally, the 
properties of each column can be modified via the Column Characteristics tab. 
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Available Columns Contains columns that are available to be displayed 

Displayed Contains columns that will be displayed 

Add >> Moves the currently selected column from the 
Available Columns list to the bottom of the Displayed 
list 

Insert >> Moves the currently selected column from the 
Available Columns list to the Displayed list located 
above the selected column in the Displayed list 

<< Remove Moves the currently selected column from the 
Displayed list to the Available Columns list 

 Exchanges the currently selected column in the 
Displayed list with the one above it 

 Exchanges the currently selected column in the 
Displayed list with the one below it 
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Column Select the current column to be edited 

Title 

Column Title Sets the column title to be displayed on the 
spreadsheet 

Title Color Sets the color use when displaying the column title 

Font Defines the font, font style, size, effects and color for 
the  column title 

Data 

Justification Sets justification of the data values within the column 

Column Width Sets the width in pixels of the column 

Optimize Automatically sets the width of the column to be just 
wide enough to display the longest data value and the 
column title 

Data Color Sets the color use when displaying the column data 
values 

Font Defines the font, font style, size, effects and color for 
the data values in the column 

Well Data 
The Well Data menu is only displayed when either the spreadsheet view or the Test 
Simulator view is active.  This menu toggles whether the spreadsheet contains 
separate tabs for data from each of the monitored wells.  In a Simulation document 
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the menu toggles whether separate view tabs are available displaying simulated 
drawdown versus time graphs for all wells simulated. 

When you click on the tab containing the data for a particular well instead of the 
Match Data tab, AquiferWin32 displays drawdown versus time data on the graph 
view.  When the Match Data tab is clicked, however, the graph view changes to 
contain the data plotted over the type curve(s). 

Clip Data 
The Clip Data menu is only displayed when a graph view is active.  This menu 
toggles whether data beyond the edges of the graph are clipped (not displayed).  In 
the Match Data graph view, the data symbols are clipped.  In the predicted graph, 
the observed data points and predicted drawdown versus time curves are clipped. 

Automatic Refresh 
NOTE: This menu is only shown for map views. 

The Automatic Refresh menu selection determines whether AquiferWin32 will 
redraw the window each time a dialog or property sheet is displayed or the window 
is resized, zoomed, or changed in any way.  A checkmark appearing next to Auto 
Refresh means that the display is redrawn after every action that changes the 
display.  Click on this menu to toggle the option on or off (with or without the 
checkmark).  The default condition is Auto Refresh on.  You may want to turn Auto 
Refresh off if you are making a lot of changes and your map is large.  On a fast 
computer (e.g., Pentium), the refresh is fast enough that you probably will not care. 

Refresh 
NOTE: This menu is only shown for map views. 

Selecting Refresh from the View menu causes the map window to be redrawn.  You 
would use this feature if you have turned the Auto Refresh off (see last section) and 
the screen needs to be redrawn after a scroll or other action.  You may also use the 

Standard toolbar  button. 

Scroll and Page 
NOTE: This menu is only shown in map views. 

Selecting Scroll or Page from the View menu displays a third menu with the 
following selections: Left, Right, Up, and Down.  Select which direction the current 
model window will be scrolled.  The only difference between Scroll and Page is the 
distance that is scrolled.  Scroll moves the display a short distance and Page moves 
the display a larger distance. 

Zoom 
NOTE: This menu is only shown in map views. 

The Zoom menu allows you to magnify a point on the current display.  After 
selecting Zoom from the View menu, you must click on a point with the mouse (or 
use the cursor keys followed by the Enter key).  A dialog is displayed where you can 
change the coordinates of the magnification point and the degree of magnification.  
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A zoom value greater than 1 causes the display to be magnified and a value less than 
1 causes more of the map to fit in the current window. 

Window 
NOTE: This menu is only shown in map views. 

Select Window from the View menu to drag a rectangular region of the map that 
will be magnified to fit within the current display.  After selecting Window, click on 
a point and drag a box to cover the area of interest.  Release the mouse button and a 
dialog allows you to edit the coordinates of the corners of the box.  Click OK to 
accept the values and redraw the display. 

Full 
NOTE: This menu is only shown in map views. 

The Full menu contains two submenu choices, labeled Screen and Printer.  Choose 
the Screen menu to display the full map window within the current window on your 
screen.  By default the map window contains your full base map.  Choose the 
Printer menu to make sure that the full map window will fit on a single printed 
page.  This effect can also be achieved using the File->Page Setup menu and 
checking the Size to Page check-box.  You may change the size of the current map 
window by selecting Options->Map->Window.   

Display Bounds 
NOTE: This menu is only shown in map views. 

The Display Bounds menu selection indicates whether the coordinates of the current 
window will be displayed in the corners of the display..  A checkmark appearing on 
the menu next to the selection means that these coordinates will be displayed.  Click 
on the menu selection to toggle the checkmark on and off. 

Reference Head 
NOTE: This menu is only shown in Simulation and Flow Model documents. 

The Reference Head menu indicates whether the arrow for the reference head will 
be displayed.  A checkmark appearing on the menu next to the selection means that 
the reference head will be displayed.  Click on the menu selection to toggle the 
checkmark on and off. 

Recharge Ellipse 
NOTE: This menu is only shown in Flow Model documents. 

The Recharge Ellipse menu indicates whether the recharge ellipse will be displayed.  
A checkmark appearing on the menu next to the selection means that the reference 
head will be displayed.  Click on the menu selection to toggle the checkmark on and 
off. 

Display Map 
NOTE: This menu is only shown in map views. 



 

274  •  Menus and Dialogs Guide to Using AquiferWin32 

The Display Map menu selection indicates whether the base map will be displayed.   
A checkmark appearing on the menu next to the selection means that the map will be 
displayed.  Click on the menu selection to toggle the checkmark on and off. 

Head Contours 
NOTE: This menu is only shown in Flow Model documents. 

The Head Contours menu selection indicates whether the head/drawddown contours 
will be displayed.   A checkmark appearing on the menu next to the selection means 
that the contours will be displayed.  Click on the menu selection to toggle the 
checkmark on and off. 

Display Color Flood 
NOTE: This menu is only shown in map views of Flow Model documents. 

The Display Color Flood menu selection indicates whether a color flood map of 
drawdown or hydraulic head will be displayed.   A checkmark appearing on the 
menu next to the selection means that the map will be displayed.  Click on the menu 
selection to toggle the checkmark on and off. 

Predicted 
The Predicted menu is only displayed in a graph view and is only active in the 
Predicted tab view.  This menu toggles whether the predicted time versus drawdown 
curves are calculated and displayed on the graph.  In cases where it takes a long time 
to calculate the predicted drawdown versus time curves, it is convenient to turn this 
option off while manipulating the graph. 

Default Legend 
The Default Legend menu is used to toggle on/off the display of the default legend 
for the currently selected view/analysis combination.  If no default legend has been 
saved, nothing will be displayed.  Default legends are stored on the computer 
containing the software.  If the document is moved to a different computer different 
default legends will be displayed.  If you want to save the default legend with the 
document on any system, click on the legend to select it, click the Edit->Copy 
menu, click the View->Default Legend menu to turn off the default legend and click 
the Edit->Paste menu and save the document.  Now the legend is part of the 
document. 

Reset 3D 
The Reset 3D menu is used recenter the 3D perspective view.  This is sometimes 
required when changes have been made via the Contour Options property sheet or on 
screen editing. 

Full Screen 
The Full Screen menu is only displayed in a graph view and is only active in the 
match view.  It is used to blow up the match view to use the entire computer screen.  
Everything is removed except a version of the match toolbar that contains a full 
screen button to go back to normal viewing. 
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Add Menu 
The Add menu is for all views except the spreadsheet.  These menus can also be 
selected from the Annotation and Analytic toolbars shown below. 

 

 

Title 

Select the Title menu or choose the  button on the Annotation toolbar to add text 
to the view.  Move the cursor to the point where the text will be inserted and click 
the left mouse button or press the Enter key.  The Title Information property sheet is 
presented prompting for the pertinent display characteristics.  The x-coordinate and 
y-coordinate of the point are also provided in case you would like to override the 
values obtained from setting the location with the mouse or keyboard.  In graph 
views, the coordinates are in inches from the lower left corner of the plot; in map 
views, the coordinates are in map units.  Any number of titles may be added.  Titles 
may also be embedded in Frames and Legends. 
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Title The text to display 

Display Parameters 

Color The color to use when displaying the text 

Angle The angle to rotate the text around the location point  

Alignment The alignment of the label relative to the location 
point 

Font Defines the font, font style and size of the text 

Spatial Parameters 

X: The x-coordinate of the title location in the proper 
units 

Y: The y-coordinate of the title location in the proper 
units 

Parameter 

Select the Parameter menu or choose the  button on the Annotation toolbar to 
add parameter text to the view.  Move the cursor to the point where the text will be 
inserted and click the left mouse button or press the Enter key.  The Parameter 
Information property sheet is presented prompting for the pertinent display 
characteristics.  The x-coordinate and y-coordinate of the point are also provided in 
case you would like to override the values obtained from setting the location with the 
mouse or keyboard.  In graph views, the coordinates are in inches from the lower left 
corner of the plot; in map views, the coordinates are in map units.  Any number of 
parameters may be added.  Parameters may also be embedded in Frames and 
Legends. 
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Parameter: A reference to the parameter to be displayed 

determined by the current selection in the tree control 

Display Parameters 

Color The color to use when displaying the text 

Angle The angle to rotate the text around the location point  

Alignment The alignment of the label relative to the location 
point 

Display Title If checked, the title of the parameter is displayed 

Display Value If checked, the value of the parameter is displayed 

Display Units If checked, the unit string of the parameter is 
displayed 

Font Defines the font, font style and size of the text 

Numeric Parameters 

Format: The format to use when displaying numeric values 

Precision: The number of digits after the decimal point 

Spatial Parameters 

X: The x-coordinate of the parameter location in the 
proper units 

Y: The y-coordinate of the parameter location in the 
proper units 
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Symbol 

Select the Symbol menu or choose the  button on the Annotation toolbar to add 
a symbol to the view.   Move the cursor to the point where the symbol will be 
inserted and click the left mouse button or press the Enter key.  The Symbol 
Information property sheet is presented prompting for the pertinent display 
characteristics.  The x-coordinate and y-coordinate of the point are also provided in 
case you would like to override the values obtained from setting the location with the 
mouse or keyboard. In graph views, the coordinates are in inches from the lower left 
corner of the plot; in map views, the coordinates are in map units.  Any number of 
symbols may be added.  Symbols may also be embedded in Frames, Legends and 
Header/Footer elements. 

 
Symbol Style 

Color The color to use when displaying the symbol 

Thickness The line thickness to use when displaying the symbol 

Symbol The symbol to display 

Size The size of the symbol in points 

Spatial Parameters 

X: The x-coordinate of the symbol location in the proper 
units 

Y: The y-coordinate of the symbol location in the proper 
units 

Line 

Select the Line menu or choose the  button on the Annotation Toolbar to add a 
line to the view.  Move the cursor to the point where the line will start, click and hold 
the left mouse button or press and hold the Shift key and press the Enter key.  Drag 
the mouse or use the arrow keys to move the cursor to the point where the line 
should end and release the left mouse button or the Shift key.  The Line Information 
property sheet is presented prompting for the pertinent display characteristics.  The 
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x-coordinate and y-coordinate of both end points are also provided in case you would 
like to override the values obtained from dragging the line with the mouse or 
keyboard.  In graph views, the coordinates are in inches from the lower left corner of 
the plot; in map views, the coordinates are in map units.  Any number of lines may 
be added.  Lines may also be embedded in Frames, Legends and Header/Footer 
elements. 

 
Line Style 

Color The color used to display the line 

Thickness The thickness in points of the line 

Dash The dash pattern to use for the line 

Length The length in inches of the dash pattern for the line 

Spatial Parameters 

X1: The x-coordinate of the first end point of the line 

Y1: The y-coordinate of the first end point of the line 

X2: The x-coordinate of the second end point of the line 

Y2: The y-coordinate of the second end point of the line 

Frame 

Select the Frame menu or choose the  button on the Annotation Toolbar to add 
a frame to the view.  Move the cursor to the first corner of the frame, click and hold 
the left mouse button or press and hold the Shift key and press the Enter key.  Drag 
the mouse or use the arrow keys to move the cursor to the second corner of the frame 
and release the left mouse button or the Shift key.  The Frame Information property 
sheet is presented prompting for the pertinent display characteristics.  The x-
coordinate and y-coordinate of both corners are also provided in case you would like 
to override the values obtained from dragging the frame with the mouse or keyboard.  
In graph views, the coordinates are in inches from the lower left corner of the plot; in 
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map views, the coordinates are in map units.  Any number of frames may be added.  
Frames may also be embedded in Legends and Header/Footer elements. 

 
Line Style 

Color The color used to display the optional border 

Thickness: The thickness in points of the optional border 

Dash The dash pattern to use for the optional border 

Length The length in inches of the dash pattern for the 
optional border 

Spatial Parameters 

X1: The x-coordinate of the first corner of the frame 

Y1: The y-coordinate of the first corner of the frame 

X2: The x-coordinate of the second corner of the frame 

Y2: The y-coordinate of the second corner of the frame 
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Fill Type 

Type Sets the type of fill to use within the frame 

None The frame is not filled 

Solid The frame is filled with a solid color 

Hatch  The frame is filled with a hatch pattern 

Bitmap The frame is filled with a bitmap 

Metafile The frame is filled with a metafile 

Display Border If checked, a border line is displayed around 
perimeter of the frame 

Background Color Selects the background color with which to fill the 
frame 

Hatch Color/Pattern Selects the hatch color and hatch patter to use to fill 
Hatch type frames 

File Information 

File Name: The name of the file that was loaded for Bitmap and 
Metafile type frames 

NOTE: The contents of the file are loaded and stored within the document so 
the file is no longer required and the name is for historical reference 
only. 

Scale to Rectangle If checked, the bitmap is expanded/compressed to fill 
the frame 

NOTE: This check-box is usually checked, otherwise, the screen display and 
printed output will not be the same. 

Browse Click this button to display a standard File Open 
dialog used to locate the Bitmap or Metafile file 
stored on the computer. 
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Legend 

Select the Legend menu or choose the  button on the Annotation toolbar to add 
a frame to the view.  Move the cursor to the first corner of the frame, click and hold 
the left mouse button or press and hold the Shift key and press the Enter key.  Drag 
the mouse or use the arrow keys to move the cursor to the second corner of the frame 
and release the left mouse button or the Shift key.  The Legend Information property 
sheet is presented prompting for the pertinent display characteristics.  The x-
coordinate and y-coordinate of both corners are also provided in case you would like 
to override the values obtained from dragging the frame with the mouse or keyboard.  
In graph views, the coordinates are in inches from the lower left corner of the plot; in 
map views, the coordinates are in map units.  Any number of legends may be added.  
Legends may also be embedded in Header/Footer elements. 

 
Line Style 

Color The color used to display the optional border 

Thickness The thickness in points of the optional border 

Dash The dash pattern to use for the optional border 

Length The length in inches of the dash pattern for the 
optional border 

Spatial Parameters 

X1: The x-coordinate of the first corner of the legend 

Y1: The y-coordinate of the first corner of the legend 

X2: The x-coordinate of the second corner of the legend 

Y2: The y-coordinate of the second corner of the legend 
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Fill Type 

Type Sets the type of fill to use within the frame 

None The frame is not filled 

Solid The frame is filled with a solid color 

Hatch The frame is filled with a hatch pattern 

Bitmap The frame is filled with a bitmap 

Metafile The frame is filled with a metafile 

Display Border If checked, a border line is displayed around 
perimeter of the frame 

Background Color Selects the background color with which to fill the 
frame 

Hatch Color/Pattern Selects the hatch color and hatch patter to use to fill 
Hatch type frames 

File Information 

File Name: The name of the file that was loaded for Bitmap and 
Metafile type frames 

NOTE: The contents of the file are loaded and stored within the document so 
the file is no longer required and the name is for historical reference 
only. 

Scale to Rectangle If checked, the bitmap is expanded/compressed to fill 
the frame 

NOTE: This check-box is usually checked, otherwise, the screen display and 
printed output will not be the same. 

Browse Click this button to display a standard File Open 
dialog used to locate the Bitmap or Metafile file 
stored on the computer. 



 

284  •  Menus and Dialogs Guide to Using AquiferWin32 

 
Add: Adds an item, of the type selected in Item Type, to the 

legend 

Edit: Presents the property sheet for the item selected in 
the tree control 

Delete: Deletes the selected item currently selected in the tree 
control 

Item Type: Specifies the currently active item to be added when 
the Add button is clicked 

The Automatic Maintenance of Graph Data Sets check-box only appears if the 
parent view of the legend is a graph.  If this check-box is checked, symbols and 
labels for each data set in the graph will be automatically displayed within the 
legend.  If the legend is higher than it is wide, the symbol/label items will be spaced 
evenly vertically and centered horizontally within the legend.  If the legend is wider 
than it is high, the symbol/label items will be spaced evenly horizontally and 
centered vertically within the legend.  Typically, a legend set up using Automatic 
Maintenance of Graph Data Sets does not contain any other elements although it is 
likely embedded in another legend element. 

The Automatic Maintenance of Color Flood Legend check-box only appears if the 
parent view of the legend is a map view of a Flow Model document.  If this check-
box is checked, the legend will contain a color flood legend.  The color flood legend 
will fill the legends frame so if you want to add other text, embed this legend within 
a larger one.  The colors and label characteristics of this color flood legend are 
controlled via the Contour Options property sheet on the Flood Colors and Flood 
Legend tabs. 
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Context Menu: 

The tree control on the Items tab has a context menu that allows you to 
Cut/Copy/Paste items within and across legend objects.  Also, the Save As Default 
menu allows you to save the legend to be used as the default whenever another 
document is created to use this type of analysis.  Refer to the Default Legend section 
for more details. 

Scale Bar 
NOTE: This menu is only shown in map views. 

Select the Scale Bar menu or choose the  button on the Annotation toolbar to 
add a scale bar to the view.   Move the cursor to the point where the scale bar will be 
inserted and click the left mouse button or press the Enter key.  The Scale 
Information property sheet is presented prompting for the pertinent display 
characteristics.  The x-coordinate and y-coordinate of the point are also provided in 
case you would like to override the values obtained from setting the location with the 
mouse or keyboard.  In map views, the coordinates are in map units.  Any number of 
scale bars may be added. 



 

286  •  Menus and Dialogs Guide to Using AquiferWin32 

 
Length: The length of the scale bar in map units 

Width: The width of the scale bar in map units 

Display Parameters 

Color: The color to use when displaying the symbol 

Alignment: The alignment of the scale bar relative to the  
location point 

Font Defines the font, font style, size for the scale bar 

Spatial Parameters 

X: The x-coordinate of the well location in map units 

Y: The y-coordinate of the well location in map units 

Well 
NOTE: This menu is only shown in map views. 

Select the Well menu or choose the  button on the Analytic toolbar to add a well 
to the view.   Move the cursor to the point where the well will be inserted and click 
the left mouse button or press the Enter key.  The Well Information property sheet is 
presented prompting for the pertinent display characteristics.  The x-coordinate and 
y-coordinate of the point are also provided in case you would like to override the 
values obtained from setting the location with the mouse or keyboard.  In map views, 
the coordinates are in map units.  Any number of wells may be added.   

The following property sheet is for wells in other than flow model 
documents. 
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Well Designator: Unique name for the well 

Construction Parameters 

Casing Inner Diameter The inner diameter of the well casing 

Diameter of Drilled Hole The diameter of the drilled hole 

Screen Length The length of the well screen 

Screen Top Depth The depth to top of the well screen relative to the top 
of the aquifer 

Spatial Parameters 

X: The x-coordinate of the well location in map units 

Y: The y-coordinate of the well location in map units 
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Well Parameters 

Color The color to use when displaying the well symbol 

Size The display size in map units of the well symbol 

Label Parameters 

Color The color to use when displaying the well label 

Angle The angle to rotate the text when displaying the well 
label 

Alignment The alignment of the label relative to the label 
location 

Display Label If checked, the well designator is used to label the 
well 

Font Defines the font, font style, size and effects for the 
label  

Label Offsets 

dX: The distance in map units to offset the label in x from 
the x-coordinate of the well location 

dY: The distance in map units to offset the label in y from 
the y-coordinate of the well location 

The following property sheet is for flow model documents. 
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Well Designator: Name for the well 

Hydraulic Parameters 

Constant Pumping Rate If set, this well pumps at a constant rate whose value 
is contained in the adjacent data field 

Transient Pumping Rate If set, this well pumps at a variable rate and the 
pumping schedule is contained on the Transient tab 

Construction Parameters 

Casing Inner Diameter The inner diameter of the well casing 

Diameter of Drilled Hole The diameter of the drilled hole 

Screen Length The length of the well screen 

Screen Top Depth The depth to top of the well screen relative to the top 
of the aquifer 

Spatial Parameters 

X: The x-coordinate of the well location in map units 

Y: The y-coordinate of the well location in map units 
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Well Parameters 

Color The color to use when displaying the well symbol 

Size The display size in map units of the well symbol 

Label Parameters 

Color The color to use when displaying the well label 

Angle The angle to rotate the text when displaying the well 
label 

Alignment The alignment of the label relative to the label 
location 

Display Label If checked, the well designator is used to label the 
well 

Font Defines the font, font style, size and effects for the 
label  

Label Offsets 

dX: The distance in map units to offset the label in x from 
the x-coordinate of the well location 

dY: The distance in map units to offset the label in y from 
the y-coordinate of the well location 
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This spreadsheet defines the pumping schedule used for this well.  This pumping 
schedule is only used if the Transient Pumping Rate radio button has been set on 
the Physical tab and the solution supports variable pumping rates. 
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Transport Parameters 

Concentration: The concentration of injected water 

Constant Concentration Value The concentration value is maintained as 
constant at the injection well 

Monitor Concentration vs. Time Concentration versus time data is calculated for 
the well based on the transport time stepping 
scheme 

Calculated Values 

Total Contaminant Flux: The total contaminant flux rate contributed by 
the well 

The spreadsheet presents the concentration versus time values if the Monitor 
Concentration Vs. Time checkbox has been checked and the model run.. 

Head/Flux Linesink 
NOTE: This menu is only shown in map views of Flow Model documents. 

Select the Head Linesink menu or the  button on the Analytic toolbar to add a 

head linesink to the model.  Select the Flux Linesink menu or choose the  
button on the Analytic toolbar to add a flux linesink to the model.  Move the cursor 
to the point where the linesink will start, click and hold the left mouse button or press 
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and hold the Shift key and press the Enter key.  Drag the mouse or use the arrow 
keys to move the cursor to the point where the linesink should end and release the 
left mouse button or the Shift key.  The Linesink Information property sheet is 
presented prompting for the pertinent display and hydraulic characteristics.  The x-
coordinate and y-coordinate of both end points are also provided in case you would 
like to override the values obtained from dragging the line with the mouse or 
keyboard.  The coordinates are in map units and any number of linesinks may be 
added. 

 
Linesink Designator: Name for the linesink 

Hydraulic Parameters 

Constant Head If set, this linesink is a head linesink whose head 
value is contained in the adjacent data field 

Constant Flux If set, this linesink is a flux linesink whose flux rate 
is contained in the adjacent data field 

Transient Flux If set, this linesink is a flux linesink whose flux rate 
is variable and the rate schedule is contained on the 
Transient tab 

Spatial Parameters 

Start X: The x-coordinate of the starting point of the linesink 

Start Y: The y-coordinate of the starting point of the linesink 

End X: The x-coordinate of the ending point of the linesink 
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End Y: The y-coordinate of the ending point of the linesink 

 
Linesink Parameters 

Color The color used to display the linesink 

Thickness The thickness in map units of the linesink 

Label Parameters 

Color The color to use when displaying the well label 

Angle The angle to rotate the text when displaying the 
linesink label 

Alignment The alignment of the label relative to the label 
location 

Display Label If checked, the linesink designator is used to label the 
linesink 

Font Defines the font, font style, size and effects for the 
label  

Label Offsets 

dX: The distance in map units to offset the label in x from 
the x-coordinate of the center of the linesink 

dY: The distance in map units to offset the label in y from 
the y-coordinate of the center of the linesink 
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Calculated Parameters 

Length of Linesink The total length of the linesink in map units 

Total Constant Flux The total flux rate generated by the linesink 
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This spreadsheet defines the pumping schedule used for this linesink.  This pumping 
schedule is only used if the Transient Flux radio button has been set on the Physical 
tab. 
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Transport Parameters 

Concentration The concentration of water injected by the linesink 

Calculated Values 

Total Contaminant The total contaminant flux rate generated by the 
linesink 

Pond 
NOTE: This menu is only shown in map views of Flow Model documents. 

Select the Pond menu or the  button on the Analytic toolbar to add a pond to the 
model.  Move the cursor to the point at the center of the pond, click and hold the left 
mouse button or press and hold the Shift key and press the Enter key.  Drag the 
mouse or use the arrow keys to move the cursor to the point where the pond should 
end and release the left mouse button or the Shift key.  The Pond Information 
property sheet is presented prompting for the pertinent display and hydraulic 
characteristics.  The x-coordinate and y-coordinate of center and the radius are also 
provided in case you would like to override the values obtained from dragging the 
pond with the mouse or keyboard.  The coordinates are in map units and any number 
of ponds may be added. 
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Pond Designator: Name for the pond 

Hydraulic Parameters 

Constant Infiltration If set, this pond has a constant infiltration rate whose 
value is contained in the adjacent data field 

Transient Infiltration If set, this pond has a variable infiltration rate and the 
infiltration schedule is contained on the Transient tab 

Spatial Parameters 

X: The x-coordinate of the center of the pond in map 
units 

Y: The y-coordinate of the center of the pond in map 
units 

Radius: The radius of the pond in map units 
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Pond Parameters 

Color The color used to display the pond 

Thickness The thickness of the line used to display the 
perimeter of the pond in points 

Label Parameters 

Color The color to use when displaying the pond label 

Angle The angle to rotate the text when displaying the pond 
label 

Alignment The alignment of the label relative to the label 
location 

Display Label If checked, the pond designator is used to label the 
pond 

Font Defines the font, font style, size and effects for the 
label  

Label Offsets 

dX: The distance in map units to offset the label in x from 
the x-coordinate of the center of the pond 

dY: The distance in map units to offset the label in y from 
the y-coordinate of the center of the pond 
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Calculated Parameters 

Area of Pond: The total of the pond in map units 

Total Constant Flux: The total flux rate generated by the pond 
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This spreadsheet defines the infiltration schedule used for this pond.  This infiltration 
schedule is only used if the Transient Infiltration radio button has been set on the 
Physical tab. 



 

302  •  Menus and Dialogs Guide to Using AquiferWin32 

 
Transport Parameters 

Concentration: The concentration of water added to the model by the 
pond. 

Calculated Values 

Total Contaminant Flux: The total contaminant rate generated by the pond 

Particle 
NOTE: This menu is only shown in map views of Flow Model documents. 

Select the Particle->Single menu or choose the  button on the Analytic toolbar 
to add a particle trace to the model.   Move the cursor to the point where the particle 
trace will be inserted and click the left mouse button or press the Enter key.  The 
Particle Trace Information property sheet is presented prompting for the pertinent 
display characteristics.  The x-coordinate and y-coordinate of the point are provided 
in case you would like to override the values obtained from setting the location with 
the mouse or keyboard.  The coordinates are in map units and any number of particle 
traces may be added. 
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Spatial Parameters 

X: The x-coordinate of the start of particle trace in map 
units 

Y: The y-coordinate of the start of particle trace in map 
units 

Streamline 
NOTE: This menu is only shown in map views of Flow Model documents. 

Select the Streamline->Single menu or choose the  button on the Analytic 
toolbar to add a streamline to the model.   Move the cursor to the point where the 
streamline will be inserted and click the left mouse button or press the Enter key.  
The Streamline Information property sheet is presented prompting for the pertinent 
display characteristics.  The x-coordinate and y-coordinate of the point are provided 
in case you would like to override the values obtained from setting the location with 
the mouse or keyboard.  The coordinates are in map units and any number of 
streamlines may be added. 

 
Spatial Parameters 

X: The x-coordinate of the start of streamline in map 
units 

Y: The y-coordinate of the start of streamline in map 
units 

Line Cluster 
NOTE: This menu is only shown in map views of Flow Model documents. 



 

304  •  Menus and Dialogs Guide to Using AquiferWin32 

Select the Streamline->Line or Particle->Line menu to add a line of streamlines or 
particle traces to the model.  Move the cursor to the point where the line cluster will 
start, click and hold the left mouse button or press and hold the Shift key and press 
the Enter key.  Drag the mouse or use the arrow keys to move the cursor to the point 
where the line cluster should end and release the left mouse button or the Shift key.  
The Line Cluster Information property sheet is presented prompting for the pertinent 
display and calculation characteristics.  The x-coordinate and y-coordinate of both 
end points are also provided in case you would like to override the values obtained 
from dragging the line with the mouse or keyboard.  The coordinates are in map 
units and any number of linesinks may be added. 

 

 
Calculation Parameters 

Streamline If set, the line cluster contains streamlines 

Particle Trace If set, the line cluster contains particle traces 

Spatial Parameters 

Start X: The x-coordinate of the starting point of the line 
cluster 

Start Y: The y-coordinate of the starting point of the line 
cluster 

End X: The x-coordinate of the ending point of the line 
cluster 

End Y: The y-coordinate of the ending point of the line 
cluster 

Number: The number of equally spaced streamlines or particle 
traces contained in the line cluster 

Circle Cluster 
NOTE: This menu is only shown in map views of Flow Model documents. 

Select the Streamline->Circle or Particle->Circle menu to add a circle of 
streamlines or particle traces to the model.  Move the cursor to the point at the center 
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of the circle, click and hold the left mouse button or press and hold the Shift key and 
press the Enter key.  Drag the mouse or use the arrow keys to move the cursor to the 
point where the circle should end and release the left mouse button or the Shift key.  
The Circle Cluster Information property sheet is presented prompting for the 
pertinent display and calculation characteristics.  The x-coordinate and y-coordinate 
of center and the radius are also provided in case you would like to override the 
values obtained from dragging the circle with the mouse or keyboard.  The 
coordinates are in map units and any number of circle clusters may be added. 

 
Calculation Parameters 

Streamline If set, the circle cluster contains streamlines 

Particle Trace If set, the circle cluster contains particle traces 

Spatial Parameters 

X: The x-coordinate of the center of the circle cluster in 
map units 

Y: The y-coordinate of the center of the circle cluster in 
map units 

Radius: The radius of the circle cluster in map units 

Number: The number of equally spaced streamlines or particle 
traces contained around the perimeter of the circle 
cluster 

Target 
NOTE: This menu is only shown in map views of Flow Model documents. 

Select the Target menu or choose the  button on the Analytic toolbar to add a 
target to the view.   Move the cursor to the point where the well will be inserted and 
click the left mouse button or press the Enter key.  The Target Information property 
sheet is presented prompting for the pertinent display characteristics.  The x-
coordinate and y-coordinate of the point are also provided in case you would like to 
override the values obtained from setting the location with the mouse or keyboard.  
In map views, the coordinates are in map units.  Any number of targets may be 
added. 
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Target Designator: Name for the target 

Hydraulic Parameters 

Constant Target Head If set, the target head is constant rate with a value 
contained in the adjacent data field 

Transient Target Head If set, this target is variable in time and the values are 
contained on the Transient tab 

Construction Parameters 

Casing Inner Diameter The inner diameter of the target well casing 

Diameter of Drilled Hole The diameter of the drilled hole 

Screen Length The length of the target well screen 

Screen Top Depth The depth to top of the target well screen relative to 
the top of the aquifer 

Spatial Parameters 

X: The x-coordinate of the target location in map units 

Y: The y-coordinate of the target location in map units 
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Target Parameters 

Color The color to use when displaying the target symbol 

Size The display size in map units of the target symbol 

Label Parameters 

Color The color to use when displaying the target label 

Angle The angle to rotate the text when displaying the target 
label 

Alignment The alignment of the label relative to the label 
location 

Display Label If checked, the target designator is used to label the 
target 

Font Defines the font, font style, size and effects for the 
label  

Label Offsets 

dX: The distance in map units to offset the label in x from 
the x-coordinate of the target location 

dY: The distance in map units to offset the label in y from 
the y-coordinate of the target location 
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This spreadsheet defines the head versus time data for this target.  These heads are 
only used if the Transient Target Head radio button has been set on the Physical 
tab. 

Line Calculation 
NOTE: This menu is only shown in map views of Simulation and Flow Model 
documents. 

Select the Line Calculation menu or choose the  button on the Analytic toolbar 
to add a line calculation to the view.   Move the cursor to the point where the line 
will start, click and hold the left mouse button or press and hold the Shift key and 
press the Enter key.  Drag the mouse or use the arrow keys to move the cursor to the 
point where the line should end and release the left mouse button or the Shift key.  
The Line Calculation Information property sheet is presented prompting for the 
pertinent display characteristics.  The x-coordinate and y-coordinate of both end 
points are also provided in case you would like to override the values obtained from 
dragging the line with the mouse or keyboard.  The coordinates are in map units. 
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Line Calculation Designator: Each line calculation must have a unique name so 

that it can be identified on view tabs. 

Spatial Parameters 

Start X: The x-coordinate of the starting point for the line 
calculation in map coordinates.  Distances are 
calculated relative to this point. 

Start Y: The y-coordinate of the starting point for the line 
calculation in map coordinates.  Distances are 
calculated relative to this point. 

End X: The x-coordinate of the ending point for the line 
calculation in map coordinates. 

End Y: The y-coordinate of the ending point for the line 
calculation in map coordinates. 

Data Spacing Parameters 

Equal Divisions Data points will be calculated at equal intervals 
between the start and end points of the line 
calculation. 

Number: The number of equal intervals to calculate between 
the start and end points of the line calculations. 

Linear  Data points will be calculated at specified intervals 
starting at the start point of the line calculation. 

Spacing: The spacing, in map units, between adjacent points in 
the line calculation. 
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Log  Data points will be calculated at logarithmic intervals 
starting at the start point of the line calculation. 

Samples Per Decade: The number of logarithmic intervals between 
adjacent points in the line calculation. 

Custom Distances, in map units, entered into the spreadsheet 
on the Data tab will be used for the calculations. 

 
Line Style 

Color: Sets the color of the line connecting the data points 

Thickness: Sets the thickness in points of the line connecting the 
data points 

Dash: Sets the dash pattern to use for the line connecting 
the data points 

Length: Sets the length in inches of the dash pattern for the 
line connecting the data points 

Label Parameters 

Color The color to use when displaying the line calculation 
label 

Angle The angle to rotate the text when displaying the line 
calculation label 

Alignment The alignment of the label relative to the label 
location 

Display Label If checked, the line calculation designator is used to 
label the well 
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Font Defines the font, font style, size and effects for the 
label  

Label Offsets 

dX: The distance, in map units, to offset the label in x 
from the x-coordinate of the line calculation center 
point. 

dY: The distance, in map units, to offset the label in y 
from the y-coordinate of line calculation center point. 

 
Calculation Time: The time at which to calculate head/drawdown versus 

distance data. 

Spreadsheet The data in the spreadsheet reflect the calculated data 
points.  If Custom has been selected on the Line tab, 
you can edit the number lines and the values of  the 
distances at which to calculate; if Custom was not 
selected, any changes made will be ignored. 

 

Options Menu 
NOTE: The Options menu is only displayed in map views. 

The Options menu contains selections for customizing the AquiferWin32 simulation 
model and associated map.  You may change the appearance of the site map and/or 
contour map using these menus; each of these menus is described below. 



 

312  •  Menus and Dialogs Guide to Using AquiferWin32 

Map 
The Map menu selection contains three submenus, Window, Parameters and 
Locate. The Window option allows you to change the size and location of the map 
window.  The map window by default ranges from 0 to 10000 in both the x and y 
axes.  If a base map is imported, the size of the map window is determined from the 
base map.  The map window is the region that is displayed when you choose View-
>Full->Screen and the area printed.  Selecting Options->Map->Window allows 
you to drag a rectangle on the screen to redefine the new map window.  Doing so 
confirms the boundaries using the Map Window dialog as shown below. 

 
Window Parameters 

Origin X The x-coordinate of the origin of the map in map 
units 

Origin Y The y-coordinate of the origin of the map in map 
units 

Height The height of the map in map units 

Width The width of the map in map units 

The Parameters menu selection displays the Map Options property sheet described 
below. 

The following property sheet is for map views in other than flow 
model documents. 
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Item Sizes 

Well Size The default size for well symbols when they are 
created in map units 

Apply to all wells If checked, the Well Size will be applied to all 
existing well symbols 

Cursor Step The distance, in map units, the cursor is moved in the 
map window when an arrow key is pressed 

Map Text Font 

Font Defines the font, font style and size the text strings 
defined in the optional base map 

 
Item Colors 

Wells: The default color for well symbols when they are 
initially created 

Apply to all wells If checked, the Wells color will be applied to all 
existing well symbols 

Titles: The default color for titles and parameters when they 
are initially created on the map 

Apply to all titles If checked, the Titles color will be applied to all 
existing titles and parameters on the map 

Scale: The default color for scale bars when they are 
initially created on the map 
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Map Window 

Origin X: The x-coordinate of the origin of the map in map 
units 

Origin Y: The y-coordinate of the origin of the map in map 
units 

Height: The height of the map in map units 

Width: The width of the map in map units 

 
File Information 

File Name The name of the base map file  

NOTE: The contents of the file are loaded and stored within the document so 
the file is no longer required and the name is for historical reference 
only. 
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Browse Click this button to display a standard File Open 
dialog used to locate the base map file stored on the 
computer. 

 

Transformation Parameters 

X Offset: The value, in map units, to add to the x-coordinates 
of items in the base map file 

Y Offset: The value, in map units, to add to the y-coordinates 
of items in the base map file 

Angle: The angle, in degrees, to rotate the base map 

The following property sheet is for map views in flow model 
documents. 

 
Item Sizes 

Well Size The default size for well symbols when they are 
created, in map units 

Apply to all If checked, the Well Size will be applied to all 
existing well symbols 

Target Size The default size for target symbols when they are 
created, in map units 
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Apply to all If checked, the Target Size will be applied to all 
existing target symbols 

Linesink Width The default width for linesinks when they are created, 
in map units 

Apply to all If checked, the Linesink Width will be applied to all 
existing linesinks 

Cursor Step The distance, in map units, the cursor is moved in the 
map window when an arrow key is pressed 

Map Text Font 

Font Defines the font, font style and size the text strings 
defined in the optional base map 

 
Item Colors 

Wells:/Linesink (Head);/… The default color for particular item when it is 
initially created 

Apply to all If checked, the corresponding item color will be 
applied to all existing items 
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Map Window 

Origin X: The x-coordinate of the origin of the map in map 
units 

Origin Y: The y-coordinate of the origin of the map in map 
units 

Height: The height of the map in map units 

Width: The width of the map in map units 
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File Information 

File Name The name of the base map file  

NOTE: The contents of the file are loaded and stored within the document so 
the file is no longer required and the name is for historical reference 
only. 

Browse Click this button to display a standard File Open 
dialog used to locate the base map file stored on the 
computer. 

 

Transformation Parameters 

X Offset: The value, in map units, to add to the x-coordinates 
of items in the base map file 

Y Offset: The value, in map units, to add to the y-coordinates 
of items in the base map file 

Angle: The angle, in degrees, to rotate the base map 

 
Use the Locate  menu when you have imported a non-bitmap  map file (.map, .dxf, 
.shp) and you cannot see the map.  An attempt will be made to find the center of the 
map and estimate an appropriate scale.  After the operation is complete, use the 
Options/Map/Window menu to select the part of the map you want to use.   
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Contour 
The Contour menu selection contains two submenus, Window and Parameters. 
The Window option allows you to change the size and location of the contour 
window.  The contour window by default ranges from 0 to 10000 in both the x and y 
axes.  If a base map is imported, the size of the contour window is determined from 
the base map.  Selecting Options->Contour->Window allows you to drag a 
rectangle on the screen to redefine the new contour window.  Doing so confirms the 
boundaries using the Contour  Window dialog as shown below. 

 
Window Parameters 

Origin X The x-coordinate of the origin of the map in map 
units 

Origin Y The y-coordinate of the origin of the map in map 
units 

Height The height of the map in map units 

Width The width of the map in map units 

The Parameters menu selection displays the Contour Options property sheet 
described below.  The contour matrix is made up of a series of equally spaced points 
where head is computed by AquiferWin32.  You may choose the number of points in 
both the X and Y directions.  The upper limit is 180 points in each direction.  
Increasing the number of nodes increases the time required to calculate the 
simulation and to contour the results.  Although the contours will appear smoother 
with a larger contour matrix, there is no difference in the accuracy of the results.  

The following property sheet adapts depending on the document 
type and not all tabs will appear in all circumstances. 
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Contour Resolution 

X Nodes: The number of equal subdivisions along the x-axis of 
the contour window to calculate data values for 
contouring 

Y Nodes: The number of equal subdivisions along the y-axis of 
the contour window to calculate data values for 
contouring 

Display If checked, the contour grid is displayed on the map 
window 

Grid Color: The color to use when displaying the contour grid 

Contour Window 

Origin X The x-coordinate of the origin of the contour window 
in map units 

Origin Y The y-coordinate of the origin of the contour window 
in map units 

Height The height of the contour window in map units 

Width The width of the contour window in map units 
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Contour Information 

Calculated Z Range: Displays the calculated minimum and maximum 
head/drawdown values over the contour window 

Minimum Level: Defines the minimum contour level to display 

Maximum Level: Defines the maximum contour level to display 

Interval: Defines the head/drawdown interval between 
adjacent contour lines 

Contour Line Information 

Color: The color to use when displaying non-labeled contour 
lines 

Thickness: The thickness, in points, of the line used when 
displaying non-labeled contour lines 
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Contour Label Information 

Label Every N: The number of non-labeled contour lines between 
labeled contour lines is one less than this value 

Format: The numeric format to use when displaying the label 
on labeled contour lines 

Precision: The number of digits to the right of the decimal point 
to use when displaying the label on labeled contour 
lines 

Distance between: The linear distance, in map units, between adjacent 
labels on a labeled contour line 

Font Defines the font, font style and size for contour label 

Contour Label Line Information 

Color: The color to use when displaying labeled contour 
lines 

Thickness: The thickness, in points, of the line used when 
displaying labeled contour lines 
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Contour Label Information 

Min Log Cycle: The minimum power of 10 used to when generating 
contours of concentration in a transport model 

Per Cycle: The number of contours displayed within each log 
cycle 

Contour Label Information 

Label Every N: The number of non-labeled contour lines between 
labeled contour lines is one less than this value 

Format: The numeric format to use when displaying the label 
on labeled contour lines 

Precision: The number of digits to the right of the decimal point 
to use when displaying the label on labeled contour 
lines 

Distance between: The linear distance, in map units, between adjacent 
labels on a labeled contour line 

Font Defines the font, font style and size for contour label 

Contour Label Line Information 

Color: The color to use when displaying labeled contour 
lines 

Thickness: The thickness, in points, of the line used when 
displaying labeled contour lines 
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3D Mesh 

Vertical Scale Factor: A multiplier applied to head/drawdown to increase 
the vertical scale relative to the horizontal scale 

Color Bar: Controls the presence and location of the default 
scale bar 

Display X: The x-coordinate of the lower left corner (vertical) or 
upper right corner (horizontal) of the scale bar 

Display Y: The y-coordinate of the lower left corner (vertical) or 
upper right corner (horizontal) of the scale bar 

Contour Plane 

View Contours: When checked, a contour map is displayed in the 3D 
perspective view 

Color: Controls the color of the contours which can be either 
Black or Flood Colors 

Automatic Elevation: Controls the elevation on the vertical axis which 
corresponds to the contour plane; when checked the 
contour map will automatically be relocated as the 
contour data changes 

Specified Elevation: Controls the elevation on the vertical axis which 
corresponds to the contour plane; when checked, the 
value entered in the adjacent edit field will be used to 
locate the contour plane 

Reset 3D View At times, the perspective drawing can leave the field 
of view.  Checking this option will relocate it into 
view 
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Focal Point 

Focal X: The x-coordinate of the focal point used to display 
the 3D perspective drawing 

Focal Y: The y-coordinate of the focal point used to display 
the 3D perspective drawing 

Focal Z: The z-coordinate of the focal point used to display 
the 3D perspective drawing 

Position 

Position X: The x-coordinate of the camera position used to 
display the 3D perspective drawing 

Position Y: The y-coordinate of the camera position used to 
display the 3D perspective drawing 

Position Z: The z-coordinate of the camera position used to 
display the 3D perspective drawing 

View Up 

View X: The x-coordinate defining the view up direction for 
the camera used to display the 3D perspective 
drawing 

View Y: The y-coordinate defining the view up direction for 
the camera used to display the 3D perspective 
drawing 

View Z: The z-coordinate defining the view up direction for 
the camera used to display the 3D perspective 
drawing 
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Automatic When checked, the distribution of colors is 

automatically determined by the application 

Interval: The interval to use when generating flood colors for 
values of head/drawdown to be used when the 
Generate button is clicked. 

Generate When clicked, a new color distribution will be 
generated using the same algorithm as the Automatic 
setting; however, these can be edited by the user 
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Label Information 

First Sets the head/drawdown value for the first labeled 
value in color flood legends 

Number: The number of equally spaced labels to use when 
labeling the color flood legends 

Interval: The interval between adjacent labels; used when the 
Specify Interval option is activated 

Specify Interval When checked, the value for Interval is used when 
labeling color flood legends 

Format: The numeric format to use when displaying the labels 
on color flood legends 

Precision: The number of digits to the right of the decimal point 
to use when displaying the label on color flood 
legends 

Color The color to use when displaying labels on color 
flood legends 

Font Defines the font, font style and size for the label 

Border Line Information 

Color: The color to use when displaying the border around 
the color flood legend 

Thickness: The thickness, in points, of the line used when 
displaying the border around the color flood legend 
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Trace 
The Trace menu displays the Trace Information property sheet which is used to 
define the display and calculation characteristics of streamlines and particle traces 
within the model.  There are two versions of the Trace tab, one for Steady State 
models and one for Transient models. 

 

 
Trace Parameters 

Distance Resolution: The distance resolution determines the accuracy of 
the particle-tracking calculation, which is done 
numerically; a higher number will produce better 
results 

Maximum Time: The time to which particle traces are calculated; 
beyond this time particle traces will be truncated. 

Direction Parameters 

Forward Particles are tracked from the location of the particle 
trace element in a down gradient direction 

Reverse Particles are tracked from the location of the particle 
trace element in an upgradient direction 

Display Options 

Display Arrows When checked, arrows are displayed on streamlines 
according to the parameters on the Streamline tab or 
on particle traces according to the parameters on the 
Particle Trace tab 

Display Time Postings When checked, time postings are displayed on the 
particle traces according to the parameters on the 
Labels tab 
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Trace Parameters 

Distance Resolution: The distance resolution determines the accuracy of 
the particle-tracking calculation, which is done 
numerically; a higher number will produce better 
results 

Start Time: The model time at which particle traces should begin 
to be calculated 

Minimum Time Step: Defines the minimum time period to use between 
adjacent particle movements 

Maximum Time Step: Defines the maximum time period to use between 
adjacent particle movements 

Direction Parameters 

Forward Particles are tracked from the location of the particle 
trace element in a down gradient direction 

Reverse Particles are tracked from the location of the particle 
trace element in an upgradient direction 

Display Options 

Display Arrows When checked, arrows are displayed on streamlines 
according to the parameters on the Streamline tab or 
on particle traces according to the parameters on the 
Particle Trace tab 

Display Time Postings When checked, time postings are displayed on the 
particle traces according to the parameters on the 
Labels tab 
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Arrow Style 

Arrow size: The size of the arrows displayed on streamlines 
defined in map units 

Distance between: The distance between adjacent arrows displayed on 
streamlines defined in map units 

Thickness: The thickness of the line used to draw arrows defined 
in points 

Line Style 

Color: The color used to display the streamline 

Thickness: The thickness in points of the streamline 

Dash: The dash pattern to use for the streamline 

Length: The length in inches of the dash pattern for the 
streamline 
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Arrow Style 

Arrow size: The size of the arrows displayed on particle traces 
defined in map units 

Distance between: The distance between adjacent arrows displayed on 
particle traces defined in map units 

Thickness: The thickness of the line used to draw arrows defined 
in points 

Line Style 

Color: The color used to display the particle trace 

Thickness: The thickness in points of the particle trace 

Dash: The dash pattern to use for the particle trace 

Length: The length in inches of the dash pattern for the 
particle trace 
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Posting Information 

Interval The time interval between the adjacent time labels 

Precision The number of decimal places after the decimal point 
to use when displaying time labels 

Multiplier The multiplier to apply to the time interval between 
adjacent time labels 

Label Style 

Color The color to use when displaying the time label 

Angle The angle to rotate the time label around the location 
point  

Alignment The alignment of the time label relative to the 
location point 

Font Defines the font, font style, size, and effects for the 
time label 

Transient 
The Transient menu displays the Transient Model Information property sheet which 
is used to define the time steps to calculate for a transient model or a transport 
model. 
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Analytic Element Conversions 

Number of well per linesink Specifies the number of equally spaced wells to use 
when representing a flux linesink in a transient model 

Constant Reference Head When checked, the reference head is held constant 
during a transient simulation 

 
Time Step Parameters 
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Number of Time Steps Specifies the number of time steps to calculate; each 
time step is represented by a separate tab in the tab 
view 

Initial Time Value Specifies the first time at which to calculate hydraulic  
head or drawdown 

Initial Time Step Size Specifies the time increment between the Initial Time 
Value and the second time step 

Time Step Multiplier After the first time step, the time step size is 
multiplied by this value to calculate a new time step 
size 

Maximum Time Step Size Specifies the maximum difference in time to use 
between adjacent time steps 

 
Time Step Parameters 

Number of Time Steps Specifies the number of time steps to calculate 

Contour Every Specifies the number of time steps to skip between 
contour maps each of which are represented by a 
separate tab in the tab view 

Initial Time Value Specifies the first time at which to calculate 
concentrations 

Initial Time Step Size Specifies the time increment between the Initial Time 
Value and the second time step 

Time Step Multiplier After the first time step, the time step size is 
multiplied by this value to calculate a new time step 
size 

Maximum Time Step Size Specifies the maximum difference in time to use 
between adjacent time steps 
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Recalculate Traces 
The Recalculate Traces menu controls whether streamlines and particle traces are 
automatically recalculated.  If this menu is checked, newly added or edited 
streamlines and particle traces will be instantly calculated.  When making numerous 
changes to a model, it is sometimes advisable to turn off automatic calculation. 

Constant Reference Head 
The Constant Reference Heads menu controls whether the reference head is held 
constant during a transient simulation.  If this menu is checked and the currently 
active model supports this feature, the reference head will be held constant (as in a 
steady-state model).  If not checked the reference head may change based upon 
drawdown computed at the reference head location.  It is recommended that you do 
NOT keep the reference head constant when you are computing drawdown.  Hold 
the reference head constant if you are comparing the transient model to results of a 
steady-state model. 

Simulation Summary 
The Simulation Summary menu displays a summary of the WinTran model. 

 

Zero Concentrations 
The Zero Concentrations menu resets initial concentration values to 0. 
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Restart 
The Restart menu sets the initial concentration in the WinTran model to be the 
concentrations calculated at the last time step of the current model simulation. 

Snap Wells to Contour Grid 
The Snap Wells to Contour Grid menu controls whether the location of wells is 
automatically adjusted to coincide with the closest contour grid node.  Remember 
that the finite-element mesh used for transport is identical to the contour matrix used to 
contour heads.  If you enter a well at a location other than a node (intersection of 
contour grid lines), the velocities computed by WinTran around the well will not be 
accurate.  The inaccurate velocities may produce undesirable mass balance errors.  It is 
recommended that you use this option to ensure proper mass balance in the transport 
model. 

Calc Menu 

Coarse & Fine 
The Coarse and Fine menus contain the four directions to move the data over the 
type curve (Up, Down, Left, Right).  Coarse is equivalent to pressing the arrows on 

the keyboard or the large arrow buttons on the toolbar .  Fine is 
equivalent to pressing the arrows on the keyboard while holding down the shift key.  

Fine is also equivalent to the small arrow buttons on the toolbar . 

Linear Regression 
NOTE: This menu is only active for step test analysis. 

Two submenus are available on the Linear Regression menu. The first is the Single 

Step menu or the   button on the Step toolbar.  The Single Step menu calculates 
a linear regression line based on the active step.  Since this analysis requires that the 
slope of all regression lines for all steps be equal, the remaining steps are calculated 
by specifying the slope and then finding the intercept of the best-fit line.  The step is 
chosen either by using the toolbar combobox in the Step toolbar, or using the Edit-
>Toggle Step menu. 

The second is the Multiple Steps menu or the  button on the Step toolbar.  The 
Multiple Step menu performs a linear regression on all steps combined to find the 
best slope across all steps and the individual intercepts for each step. 

Optimize 

The Optimize menu or the  button on either the Match toolbar or the Step 
toolbar uses the Marquardt (modified Gauss-Newton) nonlinear least-squares 
technique to find the best statistical match for the data from the active data set.  In a 
multiple well analysis, the active well is optimized. 
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Optimize Group 
Select the Optimize Group menu uses the Marquardt (modified Gauss-Newton) 
nonlinear least-squares technique to find the best statistical match using the data 
from all wells defined in the analysis.  The parameters that are optimized across all 
wells are defined by the Edit->Group Optimize Parameters menu.  If no 
parameters have be defined to optimize across all wells, the Optimize Group menu 
is equivalent to using the Optimize menu for each well individually. 

Reset Data Offset 
The Reset Data Offset menu will set the offset of the match data to 0 which 
synchronizes the origins of the data graph with the type curve graph it is 
superimposed upon.  Occasionally, the field data can get shifted so as not to be 
visible on the graph; this condition can occur when the units of the data are changed 
without converting the data values or if the optimization procedure fails to converge. 

Recalculate Type Curves 
Select the Recalculate Type Curves menu to recalculate all type curves based on 
the prevailing parameters.  At times the type curves become out of sync with the 
current parameters and must be recomputed.  The rightmost field on the status bar 
indicates whether the displayed type curves are valid based on the prevailing 
parameters. 

Match Early Data 
Select the Match Early Data menu to set up the match data graph to display and/or 
adjust the match of early data in an unconfined analysis.  In such an analysis, the 
early match and the late match are separate and changing between Match Early Data 
and Match Late Data may cause the data to shift relative to the type curves. 

Match Late Data 
Select the Match Late Data menu to set up the match data graph to display and/or 
adjust the match results of late data in an unconfined analysis. In such an analysis, 
the early match and the late match are separate and changing between Match Early 
Data and Match Late Data may cause the data to shift relative to the type curves. 

Recalculate 

The Recalculate menu or the  button of the Standard toolbar recalculates the 
predicted drawdown matrix in a Simulation Document.  Whenever you change a 
parameter that invalidates the simulation, the word “Recalculate” appears in the 
status bar indicating that the contour map and/or predicted drawdown versus time 
graphs are not representative of the current simulation parameters. 

Recontour 

The Recontour menu or the  button on the Standard toolbar recontours the 
predicted drawdown matrix in a Simulation Document.  Whenever you change a 
parameter that changes the display characteristics of the contour lines the word 
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“Recalculate” appears in the status bar indicating that the contour map and/or 
predicted drawdown versus time graphs are not representative of the current 
simulation parameters.  The Recontour menu will redisplay the contours without 
recalculating the predicted drawdown matrix. 

Point Calc 
Select the Point Calc menu to quickly compute values of drawdown at particular 
points based on map coordinates.  Choosing this menu displays the Point Calculation 
dialog on the screen.  You have the option to compute drawdown continuously as 
you move the mouse or noncontinuously by entering specific coordinates.  In 
continuous mode, you move the mouse around the map and the drawdown is updated 
in the dialog.  In noncontinuous mode, you enter the specific coordinates in the 
dialog, press the Calculate button, and the new drawdown is computed and 
displayed.  The Point Calculation dialog is modeless and linked to a specific 
simulation document.  As such, it remains visible until you close the document or 
press the Close button. 

 
Spatial Parameters 

X: The x-coordinate of the point to calculate 

Y: The y-coordinate of the point to calculate 

Head/Drawdown 

Head/Drawdown The calculated value of head/drawdown at the point 

Continuous Calculation If checked, the value will be calculated every time 
the mouse cursor moves over the map view 

Close Close the dialog 

Calculate Calculates the value of head/drawdown at the point 
specified in X and Y 

Match Data 
Select the Match Data menu when the spreadsheet view is active to recalculate the 
data points for a multiple well analysis.  This would typically be done after changes 
had been made to the time/drawdown data for individual wells in the spreadsheet 
view.  If the changes are made on a property sheet, the calculation is done 
automatically. 
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Target Statistics 
The Target Statistics menu displays the Target Statistics Information property sheet 
which is used to display the statistical differences between the observed target heads 
or drawdowns and those calculated by the model.  The Summary tab presents the 
statistics across all target values.  The Detail tab each individual target value and the 
corresponding calculated value. 

 

 

Drawdown 
The Drawdown menu toggles between the calculation of hydraulic head and 
drawdown.  If the menu is checked, drawdown is calculated and the reference head is 
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ignored.  If drawdown is being calculated, the target head values are assumed to 
represent drawdown as well. 

Optimize Model 
The Optimize Model menu uses the Marquardt (modified Gauss-Newton) nonlinear 
least-squares technique to find the best statistical match for the target head data 
defined in the model. 

Derivative Analysis 
The Derivative Analysis menu toggles between the manual and automatic curve 
matching of first-order derivatives.  If the menu is checked, derivative type curves 
are calculated and the derivative of the time/drawdown data is displayed.  Likewise, 
the Predicted view tab displays the derivative of the observed time/drawdown data 
and the predicted derivative curve is calculated and displayed.  Refer to the 
Derivative Analysis section of the Concepts Chapter for more details.  

Derivative Optimization 
The Derivative Optimization menu toggles between the optimizing of predicted 
drawdown and the optimizing of the first-order derivative of drawdown.  If the menu 
is checked, the derivative of the time/drawdown data is optimized; otherwise, the 
drawdown itself is optimized.  If the menu is grayed, the selected analysis does not 
support optimization of derivatives.  Refer to the Derivative Analysis section of the 
Concepts Chapter for more details. 

Options 
The Options menu displays the Calculation Options property sheet used to control 
the differentiation method and l-spacing used during a derivative analysis.  It is also 
used to specify the data offsets used in response to coarse and fine manual curve 
match adjustments. 

 
Manual Match Options 
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Coarse Adjustment The distance in inches to move the data relative to the 
type curves when performing a coarse adjustment 

Fine Adjustment The distance in inches to move the data relative to the 
type curves when performing a fine adjustment 

Pressure Derivative Options 

Differentiation Method Specifies the calculation method to use when 
calculating derivatives 

LEAST SQUARES See discussion above 

FIXED ENDPOINT See discussion above 

L-Spacing Specifies the interval over which data and type curve 
derivatives are calculated 

Data Conversion 
Select the Data Conversion menu to display the Data Conversion property sheet for 
converting data from one set of units to another.  This does not effect any parameter 
or calculation in the program but is simply provided for your use in data conversions. 

 
Parameter Select the parameter you are converting values for 

Convert Activate the conversion 

From The value you want to convert in the adjacent units 

To The converted value in the adjacent units 
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To/From Tabs 

Length Units of length corresponding to the active tab 

Time Units of time corresponding to the active tab 

Volume Units of volume corresponding to the active tab 

Model Menu 
The Model menu contains three submenus, Steady-state,  Transient  and 
Transport.  A checkmark appears next to the currently selected menu.  If the menu 
item is grayed, the currently selected model does not support this feature.  You may 
change the current model type by clicking on either Steady-State, Transient or 
Transport.  Only one checkmark can appear on this menu.  For example, if the 
checkmark is next to the Steady-state menu and you click the Transient menu, the 
checkmark next to the Steady-state menu will disappear. 

Steady-state models assume that all analytic elements (e.g. wells, linesinks, and 
ponds) function at the same rate forever.  The resulting water-level contour map 
represents a long-term average condition, called steady-state.  The transient model 
computes water levels over time based on the time steps defined in the Transient 
Model Information property sheet on the Time Steps tab.  The transport model time 
steps are defined on the Transport tab. 

Window Menu 

Cascade 
The Cascade menu arranges windows in an overlapped fashion.  The windows are 
overlapped such that the corners of the windows align diagonally from the upper left 
corner of the frame window. 

Tile Horizontally 
The Tile Horizontally menu arranges windows in non-overlapped tiles of equal size.  
If possible the windows will be arranged horizontally. 

Tile Vertically 
The Tile Vertically menu arranges windows in non-overlapped tiles of equal size.  If 
possible the windows will be arranged vertically. 

Arrange Icons 
The Arrange Icons menu arranges the icons of closed windows along the bottom of 
the frame window. 

Split 
The Split menu activates the separator between the panes of the active document 
window so it can be moved with the keyboard arrow keys. 
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Window 1, 2… 
This menu represents a currently open document window.  The menu will activate 
the window and bring it to the foreground of the frame window. 

 

Help Menu 

Help Topics 
The Help Topics menu displays the online help for AquiferWin32.  The online help 
contains this entire manual with links established between the application and 
pertinent chapters and/or subchapters. 

Solution Help 
The Solution Help menu displays the online help for the selected analytical solution 
or analytical model.  If the menu is grayed, the solution does not have a help file 
associated with it.  Typically the help file associated with particular analytical 
solution will contain details about the solution, its parameters and how to apply 
them. 

What’s This? 
The What’s This? menu allows identification of another menu, toolbar button, etc.  
After selecting this menu, navigate the menus to locate the item you would like help 
on and click on it. 

Tip of the Day 
The Tip of the Day menu displays the Tip of the Day dialog used to display 
suggestions or help about functionality in AquiferWin32. 
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Show Tips on StartUp If checked, this dialog is displayed when the program is 
started 

Next Tip Advances to the next suggestion or help item 

Close Closes the dialog 

About AquiferWin32 
The About AquiferWin32 displays the About AquiferWin32 dialog as below.  This 
dialog presents the program version number, credits and identifies the operating 
system the application is running on. 

  
The Register button, when clicked, is used to register the software by displaying the 
AquiferWin32 Registration dialog as below.  The dialog displays a System Code 
which can be copied to the clipboard (you do this by highlighting the system code 
and pressing Ctrl-C) and pasted into an email to be sent to 
aquifer@groundwatermodels.com or aquifer@esinternational.com.  We will reply 
with a security code that you paste or enter into the Security Code field in the above 
dialog.  Alternatively, you can get a security code by calling either ESI in the United 
States at (610) 670-3400 or ESL in the United Kingdom at +44 1743 248600; 
however, it is strongly recommended that the transaction be done via email since the 
codes are rather long. 
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Security Code: This is an encrypted code containing information 

about your software license and the configuration of 
the computer used to validate the license 

Authorization Level: The level of functionality of the application granted 
by the license 

System Code: This is an encrypted code containing information 
about your hardware configuration used to generate a 
unique Security Code 

About WinFlow 
The About WinFlow displays the About WinFlow dialog as below.  This dialog 
presents the program version number, credits and identifies the operating system the 
application is running on. 
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The Register button, when clicked, is used to register the software by displaying the 
WinFlow Registration dialog as below.  The dialog displays a System Code which 
can be copied to the clipboard (you do this by highlighting the system code and 
pressing Ctrl-C) and pasted into an email to be sent to 
aquifer@groundwatermodels.com or aquifer@esinternational.com.  We will reply 
with a security code that you paste or enter into the Security Code field in the above 
dialog.  Alternatively, you can get a security code by calling either ESI in the United 
States at (610) 670-3400 or ESL in the United Kingdom at +44 1743 248600; 
however, it is strongly recommended that the transaction be done via email since the 
codes are rather long. 

 
Security Code: This is an encrypted code containing information 

about your software license and the configuration of 
the computer used to validate the license 

Authorization Level: The level of functionality of the application granted 
by the license 

System Code: This is an encrypted code containing information 
about your hardware configuration used to generate a 
unique Security Code 

Miscellaneous Dialogs and Property Sheets 

Regression Line Information 
The Regression Line Information property sheet is used to manually set the intercept 
and slope of a linear regression line. 



 

Guide to Using AquiferWin32 Menus and Dialogs  •  347 

 
Line Style 

Color: The color used to display the line 

Thickness: The thickness in points of the line 

Dash: The dash pattern to use for the line 

Length: The length in inches of the dash pattern for the line 

Regression Parameters 

Intercept The y-intercept of the line 

Slope The slope of the line 

Symbol Information 
The Symbol Information property sheet is used to change the style of the symbol 
used to represent a specific data point. 

 
Symbol Style 

Color The color to use when displaying the symbol 

Thickness The line thickness to use when displaying the symbol 
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Symbol The symbol to display 

Size The size of the symbol in points 

Advanced Solution 
This Advanced Solution Information dialog is accessed from the Advanced button 
on the Solution tab of the Solution Information property sheet.  If you have 
convergence problems, this dialog is the first place to go.  Turn off Calculate Initial 
Estimates by clicking on the check-box to remove the check mark.  Now, go back 
and try a manual match making sure to select the type curve you are matching to.  
Also, make sure you have fine-tuned the match after you have selected the curve.  
Merely selecting a type curve does not update the initial guess of the type parameter; 
this is only done when you perform a manual match.   

If optimization fails again, you should increase the value of Lambda by several 
orders of magnitude.  With higher values of Lambda the solution is more likely to 
converge but the precision of convergence is diminished.  If you set Lambda to a 
value of 1 or 10 and you are still can’t achieve convergence, go to the Solution 
Information property sheet and look at the Results tabs.  One or more of the 
parameters are likely diverging and have become invalid.  A likely candidate might 
be the parameter represented by the type curves.  Go to the Exceptions and start 
enforcing minimum and maximum values.  The more you constrain the solution, the 
more likely it will converge. 

 
 

Derivative Fraction Determines the fraction of the current parameter 
value to be add/subtracted when calculating 
derivatives during optimization 

Derivative Type Determines how derivatives are calculated 

Central Parameter Value plus or minus .5*(Derivative Fraction * 
Parameter Value) 

Backward Parameter Value minus (Derivative Fraction * Parameter 
Value) 

Forward Parameter Value plus (Derivative Fraction * Parameter Value) 

Zero Derivative Value Value to assign to (Derivative Fraction * Parameter 
Value) if it calculates to 0 
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Lambda This parameter controls how sensitive the 
optimization solution is.  The default value of .0001 
can be increased by orders of magnitude to help solve 
convergence problems. 

Calculate Initial Estimates If checked, initial estimates for Transmissivity and 
Storage coefficient are calculated using a straight-line 
approximation. 

Header/Footer Name 
The Header/Footer Name dialog is accessed via the New and Rename buttons on 
the Header/Footer tab of the Page Setup Options property sheet. 

 
 

Header/Footer Name Descriptive name given to a header/footer element 

 

Selection Edit Options 
A dynamic Selection Edit Options property sheet is created to allow the currently 
selected data lines to be edited in a block.  Each column visible in the spreadsheet is 
added as a separate tab in the property sheet with a name corresponding to the 
column it represents.  There are two types of columns, numeric and symbol; an 
example of each is described below. 



 

350  •  Menus and Dialogs Guide to Using AquiferWin32 

 
Data Value 

Let Value Unchanged When set, the data value in this column is not 
changed 

Set Value When set, the data value in this column is set to value 
in the adjacent edit field 

Change Value When set, if the data value in this column equals 
value in the adjacent From data field, the data value 
is changed to the value in the To data field 

Arithmetic Steps When set, the data value in this column for the first 
line of the selection is set to the value in the Min. data 
field and subsequent lines are incremented by the 
value in the Incr. data field 

Logarithmic Steps When set, the data value in this column for the first 
line of the selection is set to the value in the First 
data field and subsequent lines are incremented by 
the value calculated from the Per Cycle data field; the 
increment is calculated such that there would be Per 
Cycle evenly spaced log values per log cycle. 

Time Adjustment 

Transformation When checked, the column data are transformed by 
multiplying it by the Scale and adding the Offset 

Scale Specifies the value by which to multiply the column 
value if transformation is active 

Offset Specifies the value to be added to the scaled column 
value if transformation is active 
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Clipping When checked, the column data are clipped based on 
the specified Minimum and Maximum values 

Minimum Specifies the minimum acceptable value for the 
column data; data points with a column value less 
than this value are removed 

Maximum Specifies the maximum acceptable value for the 
column data; data points with a column value greater 
than this value are removed 

 
Data Value 

Let Value Unchanged When set, the symbol in this column is not changed 

Set Value When set, the symbol in this column is set to the 
adjacent symbol styles 

Change Value When set, if the symbol in this column equals the 
adjacent symbol style, the symbol is changed to the 
symbol style defined for the Set Value 

Operate on: 

Color When checked, the symbol definitions above include 
the symbol color 

Thickness When checked, the symbol definitions above include 
the symbol thickness 

Symbol When checked, the symbol definitions above include 
the symbol type 

Size When checked, the symbol definitions above include 
the symbol size 
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WinFlow Units 
The WinFlow Units dialog sheet is used to set the units pertinent to the WinFlow 
Version 1.0 file being opened.  WinFlow Version 1.0 used consistent units which 
were not specified. 

 
Input File Units 

Time Units The time units that apply to the WinFlow file 

Length Units The length units that apply to the WinFlow file 

 

WinTran Units 
The WinTran Units dialog is used to set the units pertinent to the WinTran Version 
1.0 file being opened.  WinTran Version 1.0 used consistent units which were not 
specified. 
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Input File Units 

Time Units The time units that apply to the WinTran file 

Length Units The length units that apply to the WinTran file 

Concentration Units The concentration units that apply to the WinTran 
file 

Legend Wizard 
Lengends generated by the legend wizard are of the style below: 

 
The legend has three sections, the Title sublegend, the Parameter sublegend and the 
Symbol sublegend.  The Title and Symbol sublegends are optional as is the bitmap in 
the Title sublegend. 

To customize the legend created with the wizard, click the Create custom legend 
radio button and the Finish button becomes a Next button to continue the 
customization.  Two other options are available via check boxes.  The Don’t use this 
wizard for future editing option overrides the default behavior that, when you 
double click the legend to edit it, the wizard will not be used.  The Automatically 
Adjust and Locate Legend check box controls whether the system will 
automatically maintain the location of the legend. 
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Create empty legend An empty legend object is created as in previous 

versions so you can manually set it up. 

Use system default legend The system default legend is created for the selected 
analysis. 

Create custom legend The contents of the system default legend are loaded; 
however, subsequent pages of the wizard allow for 
customization of the legend. 

Don’t use this wizard… If this checkbox is checked, future editing of the 
legend will not use this wizard. 

Automatically Adjust… If this checkbox is checked, the contents and location 
of the legend will be automatically maintained. 
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Left tree control The left tree control contains all parameters available 

for the selected analysis that could be added to the 
legend 

Right list control The right tree control contains the parameters that 
will be used to create the legend.  They will appear, 
top to bottom, in the order they appear in this 
list.length 

Append The parameter selected in the left tree control will be 
added as the last item in the right list control 

Insert The parameter selected in the left tree control will be 
added above the item selected in the right list control 

Remove The parameter selected in the right list control will be 
removed from the list 

Up Arrow The parameter selected in the right list will be moved 
up in the list 

Down Arrow The parameter selected in the right list will be moved 
down in the list 

Title The title, to be displayed in the legend, of the item 
selected in the right list is displayed and editable in 
this field 
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Legend Title 

Font Defines the font, font style and size for the legend 
title 

Color Defines the color used for the legend title text 

Legend Title: The title to use when creating the Title sublegend. 

Parameter Titles 

Font Defines the font, font style and size for the parameter 
titles in the main part of the legend 

Color Defines the color used for the parameter titles 

Parameter  Values 

Font Defines the font, font style and size for the parameter 
values in the main part of the legend 

Color Defines the color used for the parameter values 

Format: The numeric format to use when displaying the 
parameter values 

Precision: The number of digits to the right of the decimal point 
to use when displaying the parameter values 
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Main Legend Style 

Border Color: The color to use for the border line around the main 
part of the legend 

Border Thickness: The line thckness of the main legend border in points 

Background Color The color to use for the background of the main part 
of the legend 

Title SubLegend When checked, the title sublegend is displayed in the 
legend 

Symbol SubLegend When checked, the symbol sublegend is displayed in 
the legend 

Title Bitmap When checked, a bitmap is displayed in the left hand 
portion of the title sublegend 

Title SubLegend Style 

Border Color: The color to use for the border line around the title 
sublegend part of the legend 

Border Thickness: The line thckness of the title sublegend border in 
points 

Background Color The color to use for the background of the title 
sublegend 

Title Bitmap 

File Name: The name of the bitmap file that was loaded into the 
title sublegend; the file is stored internally so the file 
need not exist after it has been read 
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Browse Click this button to display a File Open dialog to 
allow for the selection of an appropriate bitmap file 

 
Symbol SubLegend Style 

Border Color: The color to use for the border line around the 
symbol sublegend part of the legend 

Border Thickness: The line thckness of the symbol sublegend border in 
points 

Background Color The color to use for the background of the symbol 
sublegend 

Symbol SubLegend Contents 

The contents of the spreadsheet define the symbol/description combinations that will 
be displayed in the symbol sublegend 

Font Defines the font, font style and size for the symbol 
descriptions in the symbol sublegend 

Color Defines the color used for the descriptions in the 
symbol sublegend 
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WinFlow and WinTran Parameter Tabs 

Parameters 

 
Aquifer Parameters 

Aquifer Top Elevation of the top of the aquifer 

Aquifer Bottom Elevation of the bottom of the aquifer 

Porosity Porosity of the aquifer 

Hydraulic Parameters 

Hydraulic Conductivity Value to use for the hydraulic conductivity of the 
aquifer 

Storage coefficient Value to use for the storage coefficient of the aquifer 

Leakage Factor Value to use for the leakage factor of the aquifer 
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Flow 

 
Aquifer Parameters 

Aquifer Top Elevation of the top of the aquifer 

Aquifer Bottom Elevation of the bottom of the aquifer 

Porosity Porosity of the aquifer 

Hydraulic Parameters 

Hydraulic Conductivity Value to use for the hydraulic conductivity of the 
aquifer 

Storage coefficient Value to use for the storage coefficient of the aquifer 

Leakage Factor Value to use for the leakage factor of the aquifer 
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Transport 

 
Transport Parameters 

Longitudinal Dispersivity Value to use for the longitudinal dispersivity of the 
aquifer 

Transverse Dispersivity Value to use for the transverse dispersivity of the 
aquifer 

Diffusion Coefficient Value to use for the diffusion coefficient of the 
aquifer 

Half life Value to use for the half life of the aquifer 

Retardation Coefficient Value to use for the retardation coefficient of the 
aquifer 
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Solver 

 
Solution Parameters 

Upstream Weighting in X Value to use for the upstream weighting in x  

Upstream Weighting in Y Value to use for the upstream weighting in y within 
the WinTran solver 

Time Stepping Scheme Value to use for the time stepping scheme within the 
WinTran solver 

Flow Model Type Value to use for the flow model type within the 
WinTran solver 
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WinFlow/WinTran Mathematical 
Models 

Steady-state Model 
The equations used in the steady-state portion of WinFlow are derived by Otto D. L. 
Strack’s Groundwater Mechanics (Strack, 1989).  If you intend to use WinFlow 
routinely, you should get a copy of Groundwater Mechanics.  It is well written and 
will give you valuable insight into the underlying assumptions of the analytical 
equations.  You will also be introducted to more advanced techniques not included in 
WinFlow.  The book contains sample FORTRAN source code for the analytical 
functions in WinFlow. 

Dr. Strack is well known for his SLAEM software (Single Layer Analytic Element 
Model), which is much more advanced than WinFlow.  He has also developed a 
three-dimensional version of SLAEM.  If you like analytical modeling with 
WinFlow but need more power and flexibility, you may be interested in SLAEM.  
Dr. Strack can be reached in the Civil and Mineral Engineering Department of the 
University of Minnesota. 

The analytic functions developed by Strack (1989) use the principle of superposition 
to compute the head at a point in the aquifer system.  The total effect resulting from 
several analytic functions, such as a pumping wells, is equal to the sum of the 
individual effect caused by each analytic function acting separately.  For example, if 
you wanted to compute the total drawdown at a point resulting from three pumping 
wells, you would compute the drawdown caused by each well at that point and then 
sum the drawdowns. 

WinFlow allows you to select from a number of analytic functions to simulate two-
dimensional horizontal ground-water flow, including 

Uniform regional flow, 

Wells, 

Recharge (elliptical area), 

Circular recharge areas (Ponds), and 

Line sinks and sources. 
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The head at any point in the system may be computed by summing the effects of any 
number of the above functions.  The equations used to compute the head are 
described below. 

The analytic equations are expressed in terms of discharge potential to keep the 
equations linear for both confined and unconfined flow.  The discharge vector points 
in the direction of ground-water flow and the magnitude of the discharge potential 
equals the volume of water flowing through a cross-section of unit width.  In 
computing head at a point, the discharge potential is computed first and then 
converted to head using the following equations: 

for confined flow: 

φ =
+1

2
K H

KH

2Φ
 

and for unconfined flow: 

 φ = 2
K
Φ

  

 

where: 

 

 Φ = discharge potential (L3/T) 

 K = hydraulic conductivity (L/T) 

 H = aquifer thickness (L) 

 φ = head (L) 

Using these formulae, WinFlow automatically accounts for the transition from 
confined to unconfined flow.  The following equations are used to compute the 
discharge potential at any point (x,y) in the system.  The equations above are then 
used to convert the discharge potential to head. 

 

 Uniform Flow 

 

 Φ(x, y)= -Q (x + y )+ Co u ucos sinα α   

 

  

 Wells 

 

 j=1
n j

j
2

Q
4

[ r (x, y)]+∑
π

ln   

 

 Recharge 
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 Ponds 
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 Linesinks of Known Flux 
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where: 

 x  = x coordinate of calculation point 

 y  = y coordinate of calculation point 

 Qo  = uniform flow [L2/T] 

 αu  = angle between uniform flow and x-axis 

 Qj  = discharge of well j [L3/T] 

 rj  = distance from well j to calculation point [L] 

 N  = recharge rate [L/T] 

 a  = length of a-axis of recharge ellipse [L] 

 b  = length of b-axis of recharge ellipse [L] 

 xr  = x coordinate of center of recharge ellipse [L] 

 yr  = y coordinate of center of recharge ellipse [L] 

 αr  = angle between a-axis and x-axis 
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 xp j  = x coordinate of center of pond j [L] 

 yp j  = y coordinate of center of pond j [L] 

 Rp j = radius of pond j [L] 

 Np j = infiltration rate of pond j 

 σj  = flow per unit length for linesink j [L2/T] 

 Lj  = length of linesink j [L] 

 z1 = starting coordinates of linesink j 

 z2 = ending coordinates of linesink j 

 C  = constant 

 z = x + iy 
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The uniform flow component above does not contain a gradient term explicitly, even 
though you enter the gradient in WinFlow to define uniform regional flow.  The Qo 
term represents the flow per unit width of aquifer and is computed as Qo = KBi, 
where: i = the gradient, K = hydraulic conductivity, and B = saturated thickness.  
WinFlow computes the Qo term at the reference point; therefore, you do not need to 
enter Qo. 

There are two equations for ponds depending upon whether the point (x,y) is located 
inside the pond or outside of the pond.  Thus, either pond equation is used, but not 
both. 

The term that computes the contribution to the discharge potential for line sinks is 
expressed in terms of complex numbers.  The expression ℜ{} signifies that the real 
portion of the complex number computed by the complex expression {} is used in 
the equation. 

The expression for the discharge potential contains one unknown constant C.  The 
constant C is evaluated by requiring that the potential be known at some point (xo,yo) 
in the system.  Once this potential is known, the equation is solved for the constant 
C.  An important ramification of this approach is that the head always equals the 
reference head at the reference point.  This approach is equivalent to setting a 
constant head cell in a numerical model.  It is very important to keep this reference 
head as far as possible from the area of interest. 

WinFlow allows you to specify linesinks of unknown flux by defining a head at the 
center of the linesink.  For n linesinks of specified head, there are n+1 unknowns 
(the flux for each linesink and the constant C).  In this case, the equations are solved 
numerically to compute the constant C and the flux for each linesink of specified 
head. 
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Transient Model 

Basic Models 
The transient model in WinFlow uses the analytical solutions of Theis (1935) and 
Hantush and Jacob (1955) to compute drawdown from a pumping well.  Drawdowns 
from multiple individual wells are then added using the principle of superposition 
(Reilly et al., 1987) to compute the effective drawdown at a point.  Finally, the 
cumulative drawdown is subtracted from a planar potentiometric surface.  The 
surface may be horizontal or inclined at some angle, given by the uniform gradient 
vector. 

The procedure for calculating the head at any point and time (x,y,t) is given below: 

 φ α α(x, y,t)= C - G(x + y )- sj=1
n

jcos sin ∑   
 

 

where: 

 φ = head 

 G = regional gradient [L/L] 

 α = angle between regional gradient and x-axis 

 (x,y) = coordinates of calculation point 

 t = time to compute drawdown 

 sj = drawdown computed for well j 

 C = constant 

 

The constant C is computed using the reference head, as in the steady-state model.  
The main difference between the steady-state model and the transient model is that 
the reference head is maintained at a constant value in the steady-state model.  
However, the reference head is simply a starting point for calculations in the 
transient model.  That is, drawdowns computed at the reference location are 
subtracted from the reference head.  The constant C is evaluated as follows: 

 

 C = + G( x + y )r o oφ α αcos sin   
 

where: 

 φr = reference head 

 xo = x coordinate of reference head 

 yo = y coordinate of reference head 

 

There is an option, however, to keep the reference head at a constant value.  This 
option was added so that the results would be consistent with the steady-state model.  
If you elect to keep the reference head constant in the transient model, drawdown is 
computed at the reference head location and then added to all heads in the contour 
matrix.  The result is that the potentiometric surface is raised by a constant value.  
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Although the absolute values of head will be different between the two approaches, 
the flow directions and travel times (using particle-tracking) will be identical.  The 
reference head should not be held constant if a drawdown model is being calculated 
because there would be zero drawdown at the reference head location. 

The drawdown (sj) is computed from one of two equations.  If the leakage factor (L) 
is zero, the Theis equation is used.  If leakage is nonzero, the Hantush and Jacob 
leaky aquifer solution is computed. 

The Theis (1935) equation for unsteady flow to a well in a confined aquifer makes 
the following simplifying assumptions: 

 

aquifer has infinite areal extent; 

aquifer is homogeneous, isotropic, and of uniform thickness; 

aquifer potentiometric surface is initially horizontal; 

pumping rate is constant; 

well fully penetrates the aquifer; 

horizontal ground-water flow; 

aquifer is confined; 

flow is unsteady; 

water is released instantaneously from storage with decline of hydraulic 
head; 

diameter of pumping well is very small so that storage in the well can be 
neglected; 

 

Drawdown is calculated as described below. 
 

 s =
Q

4 T
w(u)

π
  

 

where: 

 w(u) = Theis well function = u

-ye
y

dy∞∫  

 u = r2 S / (4 T t) 

 r = distance from well to point (x,y) 

 T = aquifer transmissivity [L2/T] 

 S = storage coefficient [dimensionless] 

 t = time 

 Q = pumping rate [L3/T] 

 

The Theis well function, also known as the exponential integral, is computed in 
WinFlow using a numerical approximation given by Abramowitz and Stegun (1965).  
This approach is verified in the next chapter. 
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The Hantush and Jacob (1955) equation for unsteady flow to a well in a semi-
confined aquifer with no storage in aquitards makes the following simplifying 
assumptions: 

 

aquifer has infinite areal extent; 

aquifer is homogeneous, isotropic, and of uniform thickness; 

aquifer potentiometric surface is initially horizontal; 

pumping rate is constant; 

well fully penetrates the aquifer; 

horizontal ground-water flow; 

aquifer is semi-confined; 

flow is unsteady; 

water is released instantaneously from storage with decline of hydraulic 
head; 

diameter of pumping well is very small so that storage in the well can be 
neglected; 

confining bed(s) has infinite areal extent, uniform vertical hydraulic 
conductivity, and uniform thickness; 

confining bed(s) is overlain or underlain by an infinite constant-head plane 
source; and 

flow in the aquitard is vertical. 

 

Drawdown is calculated as described below. 
 

 s =
Q

4 T
w(u,

r
B

)
π

  

 

where: 

 w(u,r/B) = Hantush well function = dyey
1

yB4
ry

u
2

2
][ −−∞

∫  

 u = r2 S / (4 T t) 

 B = 
K
Tb

′

'

 

 b' = thickness of aquitard [L] 

 K' = vertical hydraulic conductivity of aquitard [L/T] 

 T = aquifer transmissivity [L2/T] 

  

The Hantush and Jacob well function is evaluated numerically using a method 
described by Case et al. (1979).  The next chapter verifies that the Hantush and Jacob 
(1955) well function calculations are accurate. 
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Implementing Ponds and Linesinks 
Ponds and linesinks are available for the transient model as well as the steady-state 
model.  The pond element is implemented using the Hantush (1967) analytical 
solution for computing the water-table rise beneath a circular recharging area.  
Linesinks (flux only) are implemented approximately using a series of wells evenly 
spaced along the linesink.  You may determine the number of wells used to 
approximate each linesink.  It will be more accurate as the number of wells 
increases.  Both pond and linesink transient elements are described below. 

Ponds are computed in the transient model using the Hantush (1967) method for 
circular recharge areas.  WinFlow uses the approximate version of the Hantush 
mound equation, given as follows: 

 

for r < R: 

 2 2
i 0

2 -u

0

-uh - h = V
2 K

[W(u )-( r
R

) e + 1
u

(1- e )]0 0

π
 

 
 

and for r > R: 

 2 2
i 0

-uh - h = V
2 K

[W(u)+0.5u e ]
π

 

 

where: 

 

 h = the water-table elevation (above the datum plane) 

 hi = the initial water-table elevation without the pond  

 K = hydraulic conductivity (L/T) of the aquifer 

 W(u) = Theis well function 

 u0 = R2/4vt 

 u = r2/4vt 

 t = time after start of infiltration 

 v = Kb/S 

 V = wπ R2 

 w = constant percolation rate (L/T) 

 S = storativity 
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 b = 0.5[hi + h] 

 R = radius of the pond (L) 

 r = radius of calculation point from center of pond (L) 

 

The Hantush (1967) mound solution was developed with the following simplifying 
assumptions: 

 

the water-table rise is less than 2 percent of the saturated thickness 

t ≥ 0.5 r2/v (u ≤ 0.5) for r < R 

t ≥ 0.5 R2/v for r > R 

otherwise, it uses the same assumptions as the Theis solution. 

Linesinks are simulated in the transient model using an approximate method.  The 
linesink is discretized into n evenly spaced wells with one well located at either end 
of the linesink.  Each well in the interior of the linesink pumps at a rate of Q/(n-1) 
and the wells at the endpoints of the linesink pump at a rate of 0.5 Q/(n-1).  This 
approximation becomes more accurate as the number of wells increases.  You 
control the number of wells used to approximate linesinks in WinFlow. 

Solute Transport Model 

Introduction 
Closed form analytical solutions to the governing equations of ground- water flow 
have wide application in subsurface remediation projects. Complex flow problems 
can be solved using these analytical techniques. The analytic element method 
developed by Strack (1989), as discussed in the previous section, is especially useful 
in modeling complex two- dimensional ground- water flow systerns. The analytic 
elements include wells, line- sinks, and recharge areas, among others, that can be 
used to simulate a variety of subsurface remedial alternatives. While these analytic 
techniques cannot treat the range of complexity provided by numerical techniques, 
the analytical models have advantages over numerical models in ease of use and 
speed of application.   

Analytical solutions to the solute transport equations, on the other hand, are not as 
directly applicable to remediation projects. One of the primary problems with 
transport analytical solutions is the inability to treat changes in the flow field caused 
by wells, drains, and recharge. Transport solutions are normally limited to a uniform 
groundwater flow field. In order to obtain useful solutions to transport problems, 
therefore, the modeler must resort to more powerful numerical techniques, which 
require more time and effort to simulate.   

A hybrid technique has been developed for use in WinTran that combines an 
analytical flow model with a numerical transport model. This technique combines 
the ease of use of an analytical model with the flexibility of a numerical model. The 
flow model utilizes the analytical element techniques of Strack (1989). The transport 
model is based upon the finite- element method using rectangular elements and 
linear basis functions. The two models are both contained within WinTran. 

The hybrid model first solves for the flow field using the analytic element method. 
Boundary conditions for the finite- element model are then automatically taken from 
the analytical flow model. The finite- element mesh is coincident with the head 
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matrix used to contour results obtained from the flow simulation. Thus, you do not 
need to explicitly design a numerical grid or mesh system of nodes. You simply 
specify the location of the mesh and the number of rows and columns in the mesh. 
Because you are somewhat insulated from the mesh design, significant error- 
checking facilities are provided to warn of large mass balance errors and other 
potential problems such as violating specified Peclet and Courant criteria.  

The Hybrid Approach 
The hybrid analytical flow/numerical transport model combines the analytic element 
method developed by Strack (1989) with a finite- element transport technique 
developed by Huyakorn and others (1983). The model is constructed in six stages, 
most of which are transparent to the user. The six stages indude the following:   

(1) The modeler designs the analytical flow model by specifying uniform aquifer 
properties, a regional hydraulic gradient, and analytic elements (e.g. wells, line sinks, 
circular recharge areas, and uniform recharge). The flow model was derived from the 
WinFlow model (ESI, 1995).   

(2) The analytical flow model is infinite in extent; however, the user must specify a 
rectangular region of interest where head is computed and contoured.   

(3) Head is computed at discrete points over the rectangular area of interest and a 
contour map is produced. These points are arranged in a regular mesh of n rows by m 
columns called the contour matrix. The spacings between rows and between columns 
are constant.   

(4) Ground- water velocities are computed analytically at the centroid of each 
rectangular cell in the contour matrix (See the Figure below). These velocities are 
provided directly to the transport model and the contour matrix defines the finite- 
element mesh.  
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(5) Specify initial concentrations over the contour matrix and the nature and extent of 
contaminant sources.   

(6) The finite- element transport model is solved for the specified simulation time(s) 
and results are contoured.   

These six stages require relatively little user- intervention. For example, the finite- 
element mesh data are generated automatically. In addition, ground- water velocities 
are recomputed each time a change is made to the flow model. The element 
velocities are passed automatically to the transport model.   

The Finite Element Transport Model 
The solute transport model solves the partial differential equation describing the 
advection and dispersion of the dissolved species, as shown below:   
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where c is the solute concentration (M/L3); c’ is the solute concentration in the 
injected water (M/L3); Dxx, Dyy, Dxy, and Dyx are the components of the 
hydrodynamic dispersion tensor (L2/T); φ is porosity (dimensionless); R is the 
retardation factor (dimensionless); q is the injection rate per volume of aquifer 
material (L3/T/L3); and λ is the first- order decay coefficient (T- 1). The Darcy 
velocity components are computed by the analytical flow model at the element 
centroids, as described above. 

The dispersion coefficients are computed as described below:   
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where αL is the longitudinal dispersivity, αT is the transverse dispersivity, D* is the 
molecular diffusion coefficient (L2/T), and |V| is the magnitude of the Darcy velocity 
(L/T).  

The retardation factor is computed from the aquifer bulk density (ρs in M/L3) and the 
distribution coefficient (kd in L3/M) as described below:   

 
R = k + 1s dρ

φ  
Boundary conditions for the transport model include prescribed concentration and 
mixed- type boundaries. The latter are used around the edges of the finite- element 
mesh, where solute is removed if flow is exiting the model domain.   

The solute transport equation is solved at each node in the finite element mesh using 
the Galerkin finite element method. A simplification has been adopted for 
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rectangular elements with linear basis functions. The technique is called the 
influence coefficient method and is described by Huyakorn and others (1983). The 
finite element formulation results in a system of linear algebraic equations with an 
asymmetric banded coefficient matrix. The matrix is solved using a direct solver 
based on the LU decomposition of a banded matrix. The finite element equations are 
not presented but can be found in Huyakorn and others (1983) or in Huyakorn and 
Pinder (1983).
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WinFlow/WinTran Verification 

Introduction 
Verification is the process of demonstrating that the computer program performs as 
documented.  In the case of a model, such as WinFlow, verification tests for proper 
implementation of the applicable equations.  These equations are documented in 
Chapter 5 and are tested in this chapter. 

The steady-state and transient models are tested separately, as described below.  In 
each case, the model is first tested using a simple example that can be solved with a 
calculator.  Next, WinFlow computations are compared against either another code 
solving the same problem or against published answers.  The steady-state model is 
further tested by comparing WinFlow results against those of a popular numerical 
model, MODFLOW (McDonald and Harbaugh, 1988). 

Steady-state Model 
 

Three sets of verification problems are presented for the steady-state analytical 
functions used in WinFlow.  In the first problem, a simple uniform flow field with a 
single pumping well is solved using WinFlow and a calculator.  This is one of the 
more common uses for WinFlow and illustrates that the basic code functions are 
programmed accurately.  In the second case, a series of problems are benchmarked 
against the program SLWL (Strack, 1989).  Finally, a simple test case of a single 
well in a uniform unconfined flow field is a benchmark against the numerical model, 
MODFLOW. 

Case 1:  Uniform Flow with a Single Well 
The steady-state analytic function for a single well in a uniform flow field is given 
by Strack (1989) as follows: 

 

 Φ = -Q (x + y )+ Q
4

[ r (x, y)]+ Co
2cos sin lnα α

π
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where 

 Φ = discharge potential [L3/T], 

 Qo = uniform ground-water flow [L2/T], 

 x,y = coordinates of the calculation point, 

 α = angle between uniform flow and x-axis, 

 r(x,y) = distance from the well to the calculation point (x,y), 

 Q = well discharge [L3/T], 

 C  = constant. 

 

In a confined aquifer system, the discharge potential, Φ, is converted to head (φ) by 
the following equation. 

 

 KH

KH2
1 2+

=
Φ

φ  

where 

 φ = head [L], 

 K = hydraulic conductivity [L/T], 

 H = aquifer thickness [L]. 

 

The constant, C, is evaluated by specifying a reference head at a certain location 
within the flow system.  The reference head remains constant during all subsequent 
calculations.  The constant, C, is computed as follows: 

 C = + Q ( x + y )- Q
4

[r ( x , y )]o o o o
2

o oΦ cos sin lnα α
π

 

where 

 Φo = reference discharge potential, 

 (xo,yo) = coordinates of reference head. 

 

In the first verification problem, the aquifer is confined with a uniform regional 
gradient parallel to the x-axis.  The problem assumptions and parameters are listed 
below. 

 K = 100 ft/d 

 H = 100 ft 
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 Gradient (i) = 0.01 ft/ft 

 Qo = KiH = 100 ft2/d 

 reference head, φo = 200 ft at (xo=0,yo=0) 

 Φo = KHφo - ½KH2 = 1500000 ft3/d 

 Q = 100,000 ft3/d at (x=1000,y=1000) 

Using these parameters and equation (3), the constant C equals 1,384,541.  Table 1 
lists the results of hand calculations and WinFlow results (using the Point 
Calculation option) for a series of coordinates.  The two results are identical to five 
significant figures; the calculator results were rounded to five figures.  Thus, 
WinFlow computes the correct answer for this test case. 

 
Table 1  Comparison between WinFlow and calculator results for test case 1. 

X Y Φ φ φ (WinFlow) 
0 1000 1,494,480 199.45 199.448 

250 1000 1,464,902 196.49 196.491 
500 1000 1,433,449 193.34 193.345 
750 1000 1,397,417 189.74 189.742 
1000 1000 1,284,441 178.44 178.444 
1250 1000 1,347,417 184.74 184.742 
1500 1000 1,333,449 183.34 183.345 
1750 1000 1,314,902 181.49 181.491 
2000 1000 1,294,481 179.45 179.448 

Case 2: Benchmark with SLWL 
The SLWL program is provided with the book, Groundwater Mechanics, (Strack, 
1989). SLWL performs the same calculations as WinFlow.  The primary difference 
between the two codes is that SLWL is written in FORTRAN, while WinFlow is 
written in the C programming language. SLWL has additional capabilities to those of 
WinFlow but is not as user-friendly nor does SLWL have good output capabilities. 

A series of twelve test cases are developed to test each of the major components in 
WinFlow, including wells, ponds, linesinks, and recharge.  Each feature added to the 
simulation is designed to produce a significant impact on the flow field, so that 
significant errors would be easily detected.  Both confined and unconfined 
conditions are tested.  These verification data sets are included on the WinFlow disk.  
The data file names are VER1.WFL, VER2.WFL, ....., and VER12.WFL. 

SLWL was modified to export a SURFER contour matrix (grid file) in the same 
manner as WinFlow.  The SURFER grid files were then subtracted from one another 
to create a matrix of differences.  A simple program was created to compute the 
mean and maximum difference.  The results are summarized in Table 2.  The 
features tested in each simulation are summarized in Table 2, along with the mean 
and maximum differences between the two codes.  The specific details of each test 
may be examined by retrieving the verification data files from within WinFlow. 

The maximum difference for each simulation was a uniform value of 0.000198 feet.  
The maximum error was constant, probably due to a consistent difference in the 
computational algorithms used in the C and FORTRAN compilers used for the two 
codes (Microsoft FORTRAN and Microsoft Visual C++).  The mean error for each 
run varied from a low of 0.00000186 (VER6.WFL) to a high of 0.0000139 
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(VER7.WFL).  In all cases, the differences between the two codes are on the order of 
1.0 x 10-6 percent. 

 
Table 2  Mean and maximum differences between WinFlow and SLWL in 12 test cases. 
Data File Uniform Wells Ponds Line-

sinks 
(head) 

Line-
sinks 
(flux) 

Recharg
e 

Aquifer 
Type 
(C/U) 

Max. 
Error 

Mean 
Error 

ver1.wfl 9 9     C 0.000198 0.0000037
ver2.wfl 9 9     U 0.000198 0.0000019
ver3.wfl 9 9 9    C 0.000198 0.0000038
ver4.wfl 9 9 9    U 0.000198 0.0000020
ver5.wfl 9 9  9   C 0.000198 0.0000051
ver6.wfl 9 9  9   U 0.000198 0.0000019
ver7.wfl 9 9   9  C 0.000198 0.0000014
ver8.wfl 9 9   9  U 0.000198 0.0000066
ver9.wfl 9 9 9 9 9  C 0.000198 0.0000048

ver10.wfl 9 9 9 9 9  U 0.000198 0.0000030
ver11.wfl 9 9 9 9 9 9 C 0.000198 0.0000048
ver12.wfl 9 9 9 9 9 9 U 0.000198 0.0000030

Case 3: Benchmark with Numerical Model 
A final test of the steady-state analytic functions in WinFlow is a comparison with a 
numerical model.  The model chosen for comparison is MODFLOW (McDonald and 
Harbaugh, 1988), which is a three-dimensional, finite-difference ground-water flow 
model developed by the United States Geological Survey.  MODFLOW is one of the 
most widely used numerical ground-water flow models. 

A simple problem involving a single pumping well in a uniform flow field is chosen 
as the test case.  The aquifer is unconfined with homogeneous properties.  The model 
parameters are summarized below for the WinFlow data set. 

 

 K = 100 ft/d; 

 Aquifer bottom elevation = 0.0 ft; 

 Gradient (i) = 0.001 ft/ft at an angle of 0o to the x-axis; 

 Qo = KiH = 10 ft2/d; 

 φo = 100 ft at (xo=0, yo=0). 

 

A single well located at coordinates (x=5000, y=5000) pumps 100,000 ft3/d.  The 
WinFlow input data file for this problem is provided on the distribution disk.  The 
file name is "modf1.wfl". 

Additional information is required to simulate the same system with a numerical 
model, such as MODFLOW.  A finite-difference grid was constructed measuring 
10,000 feet in both the x- and y-directions.  There are 125 rows and 125 columns in 
the grid, with a cell spacing of 80 ft.  A constant head of 100 ft was placed along the 
first column and a constant head of 89.532 was placed along the last column.  The 
odd number was used to maintain a constant regional flow of 10 ft3/d/ft across the 
finite-difference grid under nonpumping conditions.  The MODFLOW data set for 
this problem are contained on the WinFlow disk.  Several files are required for input 
to the MODFLOW code.  The files have a common root file name of "wflow" and a 
three-letter extension designating the MODFLOW package name.  The MODFLOW 
files for this problem are as follows: 
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 WFLOW.BAS Basic Package Input 

 WFLOW.BCF Block-Centered-Flow Package Input 

 WFLOW.SIP Strongly Implicit Package Input 

 WFLOW.WEL Well Package Input 

 WFLOW.OC Output Control Input 

 

The WinFlow and MODFLOW calculations were compared by producing a 
SURFER grid file with 50 rows and 50 columns.  The grid corners are located at 
(x=200, y=200) and (x=9800, y=9800).  The two grid files were subtracted from 
each other to obtain a head difference file.  A simple program was written to 
compute the maximum and mean differences.  Contour maps produced for the 
WinFlow and MODFLOW results are also shown in Figure 1. 

In the initial test case, MODFLOW and WinFlow compare favorably, with a 
maximum error of 0.84 feet and a mean error of 0.25 feet.  The change in head 
across the model is 10.468 feet.  Thus, there is a maximum difference of about 8 
percent between the two codes.  The contour maps shown in Figure 1 for the two 
codes are very similar.  The primary difference is the behavior of the contours at the 
upper and lower (north and south) edge of the model.  Contours from the 
MODFLOW run are perpendicular to the boundary, while WinFlow generated 
contours hit the boundary at an angle.  This happens because MODFLOW treats the 
edge of the model as a no-flow or impermeable boundary forcing the contours to hit 
the boundary at right angles.  WinFlow, on the other hand, assumes that the aquifer 
is infinite without any no-flow or impermeable boundaries. 

A second test case was simulated by both WinFlow and MODFLOW in which no-
flow boundaries were simulated with WinFlow.  The northern and southern no-flow 
boundaries were reproduced in WinFlow using image wells.  Two image wells were 
placed at coordinates (x=5000, y=15000) and (x=5000, y=-5000).  Each image well 
pumped 100,000 ft3/d.  Contour maps for the second test case are shown in Figure 2.  
Now the WinFlow contours also strike the boundary at close to right angles.  The 
maximum difference between WinFlow and MODFLOW for the second case is 0.39 
feet, with a mean difference of 0.11 feet.  This represents a significant improvement 
over the first test case.  The maximum difference is 3.7 percent in this case. 

The two test cases presented for the benchmark between WinFlow and MODFLOW 
show that both codes calculate similar head fields for the same problem.  Even 
though the method of solution is different (analytical vs. numerical), each software 
package gives similar results.  These comparisons provide the user with confidence 
that WinFlow is solving the ground-water flow equations properly. 
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MODFLOW 

 
WinFlow 

 
Figure 1.  Comparison between WinFlow and MODFLOW for Test Case 1. 
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MODFLOW 

 
WinFlow with Image Wells 

 
Figure 2.  Comparison between WinFlow and MODFLOW for Test Case 2. 
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Transient Model 
Three sets of verification problems are presented for the transient analytical 
functions used in WinFlow.  In the first problem, drawdown is computed for a single 
well.  In the second case, a uniform regional gradient is added to the problem.  In 
each of the first two test cases, WinFlow calculations are compared to those 
performed with a calculator.  The final test presents tables of the Theis (1935) and 
Hantush and Jacob (1955) well functions for comparison with published tables. 

Case 1: Drawdown from a Single Well 
The drawdown due to a single pumping well may be computed for any point in an 
aquifer using the following equation (Theis 1935): 

 s = Q
4 T

W(u)
π

 

where 

 s = drawdown [L], 

 Q = well pumping rate [L3/T], 

 T = transmissivity [L2/T], 

 u = (r2 S)/(4 T t), 

 r = distance between well and calculation point, 

 S = storage coefficient [dimensionless], 

 t = time after start of pumping [T], 

 W(u) = Theis well function. 

 

In this example problem, we will choose the values of the parameters so that 
calculation is straightforward on a hand calculator and published tables of the Theis 
well function.  The following parameters are used for Case 1: 

 

 T = 2500 ft2/d 

 S = 0.01 

 t = 1.0 d 

 Q = 10,000 ft3/d 

 

WinFlow computed the same values of drawdown (s) as those computed using a 
calculator to four significant figures.  The results of Case 1 are presented in Table 3. 

 
Table 3  Comparison between WinFlow and calculator results for transient case 1. 
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Radius (ft) u W(u) s (ft) s (WinFlow) 
1.0 10-6 13.24 4.214 4.214 

10.0 10-4 8.633 2.748 2.748 
20.0 4 x 10-4 7.247 2.307 2.307 
30.0 9 x 10-4 6.437 2.049 2.049 
40.0 1.6 x 10-3 5.862 1.866 1.866 
50.0 2.5 x 10-3 5.417 1.724 1.724 
60.0 3.6 x 10-3 5.053 1.608 1.608 
70.0 4.9 x 10-3 4.746 1.511 1.511 
80.0 6.4 x 10-3 4.481 1.426 1.426 
90.0 8.1 x 10-3 4.247 1.352 1.352 
100.0 0.01 4.038 1.285 1.285 

Case 2: Drawdown from a Single Well in a Uniform 
Flow Field 
The same parameters used in Case 1 above will be used in Case 2 and a uniform 
regional gradient will be added.  Assume that the gradient is 0.001 ft/ft, with a 
reference head of 100 ft at the well.  Because the transient model does not assume 
that the reference head is constant, the reference head may be specified anywhere 
(even at the well).  We will also assume that the origin of the coordinate system 
(x=0, y=0) is at the well center. 

The equation for a single well in a uniform flow field under transient conditions was 
given in the last chapter as 

 

 φ α α(x, y,t)= C - G(x + y )- scos sin  

where 

 φ = head [L], 

 G = regional gradient [L/L], 

 α = angle between regional gradient and x-axis, 

 (x,y) = coordinates of calculation point, 

 t = time since start of pumping, 

 s = drawdown from well, 

 C = constant. 

 

The constant, C, is equal to the reference head in this case. 

The heads computed by WinFlow and using a hand calculator are presented in Table 
4.  Again, WinFlow results and the calculator results are identical to six significant 
figures. 

 
Table 4  Comparison between WinFlow and hand calculations for transient case 2. 
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X Y φ φ (WinFlow) 
1.0 0.0 95.786 95.786 
10.0 0.0 97.152 97.152 
20.0 0.0 97.493 97.493 
30.0 0.0 97.651 97.651 
40.0 0.0 97.734 97.734 
50.0 0.0 97.776 97.776 
60.0 0.0 97.792 97.792 
70.0 0.0 97.789 97.789 
80.0 0.0 97.774 97.774 
90.0 0.0 97.748 97.748 

100.0 0.0 97.715 97.715 

Case 3: Calculation of Well Function Tables 
The first two transient test cases tested the ability of WinFlow to compute drawdown 
with and without a regional gradient.  These tests illustrated that WinFlow internal 
drawdown calculations are properly implemented.  A further test of the software is 
calculation of well function tables, which tests WinFlow's ability to accurately 
compute drawdown over a wide range of conditions. 

WinFlow uses two transient analytical functions: (1) the Theis (1935) equation for 
confined aquifers, and (2) the Hantush and Jacob (1955) equation for semi-confined 
(or leaky) aquifers.  Values of the Theis well function, W(u), were computed using 
the numerical routines in WinFlow for a wide range of values of u.  These 
calculations are shown in Table 5.  These values can be compared to any published 
values, although the format of the table is identical to that published by Kruseman 
and deRidder (1990) in Annex 3.1, page 294.  Table 5 and Annex 3.1 (Kruseman and 
deRidder 1990) are identical, illustrating that WinFlow can calculate the Theis well 
function accurately over a wide range in u. 

Similarly, the Hantush and Jacob (1955) well function, W(u,r/L), was computed 
using the routines in WinFlow for a range of u and r/L values.  These are shown in 
Tables 6, 7, and 8.  Kruseman and deRidder (1990) have published similar tables in 
Annex 4.2 (pages 298 and 299).  The Kruseman and deRidder (1990) tables and 
Tables 6, 7, and 8 are identical, confirming that WinFlow accurately computes 
values for the Hantush and Jacob leaky well function. 
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Table 5  Theis well function, W(u), computed using routines in WinFlow. 
 
 
u  W(u) W(u 10-1) W(u 10-2) W(u 10-3) W(u 10-4) W(u 10-5) W(u 10-6) W(u 10-7) W(u 10-8) W(u 10-9) W(u 10-10) 
 
 
 
1.0 2.194e- 01 1.823e+00 4.038e+00 6.332e+00 8.633e+00 1.094e+01 1.324e+01 1.554e+01 1.784e+01 2.015e+01 2.245e+01 
1.2 1.584e- 01 1.660e+00 3.858e+00 6.149e+00 8.451e+00 1.075e+01 1.306e+01 1.536e+01 1.766e+01 1.996e+01 2.227e+01 
1.5 1.000e- 01 1.464e+00 3.637e+00 5.927e+00 8.228e+00 1.053e+01 1.283e+01 1.514e+01 1.744e+01 1.974e+01 2.204e+01 
2.0 4.890e- 02 1.223e+00 3.355e+00 5.639e+00 7.940e+00 1.024e+01 1.255e+01 1.485e+01 1.715e+01 1.945e+01 2.176e+01 
2.5 2.491e- 02 1.044e+00 3.137e+00 5.417e+00 7.717e+00 1.002e+01 1.232e+01 1.462e+01 1.693e+01 1.923e+01 2.153e+01 
3.0 1.305e- 02 9.057e- 01 2.959e+00 5.235e+00 7.535e+00 9.837e+00 1.214e+01 1.444e+01 1.674e+01 1.905e+01 2.135e+01 
3.5 6.970e- 03 7.942e- 01 2.810e+00 5.081e+00 7.381e+00 9.683e+00 1.199e+01 1.429e+01 1.659e+01 1.889e+01 2.120e+01 
4.0 3.779e- 03 7.024e- 01 2.681e+00 4.948e+00 7.247e+00 9.549e+00 1.185e+01 1.415e+01 1.646e+01 1.876e+01 2.106e+01 
4.5 2.073e- 03 6.253e- 01 2.568e+00 4.831e+00 7.129e+00 9.432e+00 1.173e+01 1.404e+01 1.634e+01 1.864e+01 2.094e+01 
5.0 1.148e- 03 5.598e- 01 2.468e+00 4.726e+00 7.024e+00 9.326e+00 1.163e+01 1.393e+01 1.623e+01 1.854e+01 2.084e+01 
6.0 3.601e- 04 4.544e- 01 2.295e+00 4.545e+00 6.842e+00 9.144e+00 1.145e+01 1.375e+01 1.605e+01 1.835e+01 2.066e+01 
7.0 1.155e- 04 3.738e- 01 2.151e+00 4.392e+00 6.688e+00 8.990e+00 1.129e+01 1.359e+01 1.590e+01 1.820e+01 2.050e+01 
8.0 3.767e- 05 3.106e- 01 2.027e+00 4.259e+00 6.554e+00 8.856e+00 1.116e+01 1.346e+01 1.576e+01 1.807e+01 2.037e+01 
9.0 1.245e- 05 2.602e- 01 1.919e+00 4.142e+00 6.437e+00 8.739e+00 1.104e+01 1.334e+01 1.565e+01 1.795e+01 2.025e+01 
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Table 6  Hantush well function, W(u,r/L), computed using routines in WinFlow. 
 
 
 
 
u  r/L = 0 0.005 0.01 0.02 0.03 0.04 0.05 0.06 0.07 0.08 0.09 
 
1.0e- 06 1.32e+01 1.08e+01 9.44e+00 8.06e+00 7.25e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
2.0e- 06 1.25e+01 1.08e+01 9.44e+00 8.06e+00 7.25e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
4.0e- 06 1.19e+01 1.07e+01 9.44e+00 8.06e+00 7.25e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
6.0e- 06 1.14e+01 1.06e+01 9.44e+00 8.06e+00 7.25e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
8.0e- 06 1.12e+01 1.05e+01 9.43e+00 8.06e+00 7.25e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
 
1.0e- 05 1.09e+01 1.04e+01 9.42e+00 8.06e+00 7.25e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
2.0e- 05 1.02e+01 9.95e+00 9.30e+00 8.06e+00 7.25e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
4.0e- 05 9.55e+00 9.40e+00 9.01e+00 8.03e+00 7.25e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
6.0e- 05 9.14e+00 9.04e+00 8.77e+00 7.98e+00 7.24e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
8.0e- 05 8.86e+00 8.78e+00 8.57e+00 7.91e+00 7.23e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
 
1.0e- 04 8.63e+00 8.57e+00 8.40e+00 7.84e+00 7.21e+00 6.67e+00 6.23e+00 5.87e+00 5.56e+00 5.29e+00 5.06e+00 
2.0e- 04 7.94e+00 7.91e+00 7.82e+00 7.50e+00 7.07e+00 6.62e+00 6.22e+00 5.86e+00 5.56e+00 5.29e+00 5.06e+00 
4.0e- 04 7.25e+00 7.23e+00 7.19e+00 7.01e+00 6.76e+00 6.45e+00 6.14e+00 5.83e+00 5.55e+00 5.29e+00 5.06e+00 
6.0e- 04 6.84e+00 6.83e+00 6.80e+00 6.68e+00 6.50e+00 6.27e+00 6.02e+00 5.77e+00 5.51e+00 5.27e+00 5.05e+00 
8.0e- 04 6.55e+00 6.55e+00 6.52e+00 6.43e+00 6.29e+00 6.11e+00 5.91e+00 5.69e+00 5.46e+00 5.25e+00 5.04e+00 
 
1.0e- 03 6.33e+00 6.33e+00 6.31e+00 6.23e+00 6.12e+00 5.97e+00 5.80e+00 5.61e+00 5.41e+00 5.21e+00 5.01e+00 
2.0e- 03 5.64e+00 5.64e+00 5.63e+00 5.59e+00 5.53e+00 5.45e+00 5.35e+00 5.24e+00 5.12e+00 4.98e+00 4.85e+00 
4.0e- 03 4.95e+00 4.95e+00 4.94e+00 4.92e+00 4.89e+00 4.85e+00 4.80e+00 4.74e+00 4.67e+00 4.59e+00 4.51e+00 
6.0e- 03 4.54e+00 4.54e+00 4.54e+00 4.53e+00 4.51e+00 4.48e+00 4.45e+00 4.41e+00 4.36e+00 4.30e+00 4.24e+00 
8.0e- 03 4.26e+00 4.26e+00 4.26e+00 4.25e+00 4.23e+00 4.21e+00 4.19e+00 4.15e+00 4.12e+00 4.08e+00 4.03e+00 
 
1.0e- 02 4.04e+00 4.04e+00 4.04e+00 4.03e+00 4.02e+00 4.00e+00 3.98e+00 3.95e+00 3.93e+00 3.89e+00 3.86e+00 
2.0e- 02 3.35e+00 3.35e+00 3.35e+00 3.35e+00 3.34e+00 3.34e+00 3.33e+00 3.31e+00 3.30e+00 3.28e+00 3.26e+00 
4.0e- 02 2.68e+00 2.68e+00 2.68e+00 2.68e+00 2.68e+00 2.67e+00 2.67e+00 2.66e+00 2.66e+00 2.65e+00 2.64e+00 
6.0e- 02 2.30e+00 2.30e+00 2.29e+00 2.29e+00 2.29e+00 2.29e+00 2.29e+00 2.28e+00 2.28e+00 2.27e+00 2.27e+00 
8.0e- 02 2.03e+00 2.03e+00 2.03e+00 2.03e+00 2.02e+00 2.02e+00 2.02e+00 2.02e+00 2.02e+00 2.01e+00 2.01e+00 
 
1.0e- 01 1.82e+00 1.82e+00 1.82e+00 1.82e+00 1.82e+00 1.82e+00 1.82e+00 1.82e+00 1.81e+00 1.81e+00 1.81e+00 
2.0e- 01 1.22e+00 1.22e+00 1.22e+00 1.22e+00 1.22e+00 1.22e+00 1.22e+00 1.22e+00 1.22e+00 1.22e+00 1.22e+00 
4.0e- 01 7.02e- 01 7.02e- 01 7.02e- 01 7.02e- 01 7.02e- 01 7.02e- 01 7.02e- 01 7.02e- 01 7.01e- 01 7.01e- 01 7.00e- 01 
6.0e- 01 4.54e- 01 4.54e- 01 4.54e- 01 4.54e- 01 4.54e- 01 4.54e- 01 4.54e- 01 4.54e- 01 4.54e- 01 4.54e- 01 4.53e- 01 
8.0e- 01 3.11e- 01 3.11e- 01 3.11e- 01 3.11e- 01 3.11e- 01 3.10e- 01 3.10e- 01 3.10e- 01 3.10e- 01 3.10e- 01 3.10e- 01 
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Table 7  Hantush well function, W(u,r/L), computed using routines in WinFlow. 
 
 
 
 
 u r/L = 0 0.1 0.2 0.3 0.4 0.6 0.8 
 
 1.0e- 04 8.63e+00 4.85e+00 3.51e+00 2.74e+00 2.23e+00 1.56e+00 1.13e+00 
 2.0e- 04 7.94e+00 4.85e+00 3.51e+00 2.74e+00 2.23e+00 1.56e+00 1.13e+00 
 4.0e- 04 7.25e+00 4.85e+00 3.51e+00 2.74e+00 2.23e+00 1.56e+00 1.13e+00 
 6.0e- 04 6.84e+00 4.85e+00 3.51e+00 2.74e+00 2.23e+00 1.56e+00 1.13e+00 
 8.0e- 04 6.55e+00 4.84e+00 3.51e+00 2.74e+00 2.23e+00 1.56e+00 1.13e+00 
 
 1.0e- 03 6.33e+00 4.83e+00 3.51e+00 2.74e+00 2.23e+00 1.56e+00 1.13e+00 
 2.0e- 03 5.64e+00 4.71e+00 3.50e+00 2.74e+00 2.23e+00 1.56e+00 1.13e+00 
 4.0e- 03 4.95e+00 4.42e+00 3.48e+00 2.74e+00 2.23e+00 1.56e+00 1.13e+00 
 6.0e- 03 4.54e+00 4.18e+00 3.43e+00 2.74e+00 2.23e+00 1.56e+00 1.13e+00 
 8.0e- 03 4.26e+00 3.98e+00 3.36e+00 2.73e+00 2.23e+00 1.56e+00 1.13e+00 
 
 1.0e- 02 4.04e+00 3.82e+00 3.29e+00 2.71e+00 2.23e+00 1.56e+00 1.13e+00 
 2.0e- 02 3.35e+00 3.24e+00 2.95e+00 2.57e+00 2.18e+00 1.55e+00 1.13e+00 
 4.0e- 02 2.68e+00 2.63e+00 2.48e+00 2.27e+00 2.02e+00 1.52e+00 1.13e+00 
 6.0e- 02 2.30e+00 2.26e+00 2.17e+00 2.02e+00 1.85e+00 1.46e+00 1.11e+00 
 8.0e- 02 2.03e+00 2.00e+00 1.94e+00 1.83e+00 1.69e+00 1.39e+00 1.08e+00 
 
 1.0e- 01 1.82e+00 1.80e+00 1.75e+00 1.67e+00 1.56e+00 1.31e+00 1.05e+00 
 2.0e- 01 1.22e+00 1.22e+00 1.19e+00 1.16e+00 1.11e+00 9.96e- 01 8.58e- 01 
 4.0e- 01 7.02e- 01 7.00e- 01 6.93e- 01 6.81e- 01 6.65e- 01 6.21e- 01 5.65e- 01 
 6.0e- 01 4.54e- 01 4.53e- 01 4.50e- 01 4.44e- 01 4.36e- 01 4.15e- 01 3.87e- 01 
 8.0e- 01 3.11e- 01 3.10e- 01 3.08e- 01 3.05e- 01 3.01e- 01 2.89e- 01 2.73e- 01 
 
 1.0e+00 2.19e- 01 2.19e- 01 2.18e- 01 2.16e- 01 2.14e- 01 2.06e- 01 1.97e- 01 
 2.0e+00 4.89e- 02 4.89e- 02 4.87e- 02 4.85e- 02 4.82e- 02 4.72e- 02 4.60e- 02 
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Table 8  Hantush well function, W(u,r/L), computed using routines in WinFlow. 
 
 
 
 
 u r/L = 0 1.0 2.0 3.0 4.0 5.0 6.0 
 
 1.0e- 02 4.04e+00 8.42e- 01 2.28e- 01 6.95e- 02 2.23e- 02 7.38e- 03 2.49e- 03 
 2.0e- 02 3.35e+00 8.42e- 01 2.28e- 01 6.95e- 02 2.23e- 02 7.38e- 03 2.49e- 03 
 4.0e- 02 2.68e+00 8.42e- 01 2.28e- 01 6.95e- 02 2.23e- 02 7.38e- 03 2.49e- 03 
 6.0e- 02 2.30e+00 8.39e- 01 2.28e- 01 6.95e- 02 2.23e- 02 7.38e- 03 2.49e- 03 
 8.0e- 02 2.03e+00 8.32e- 01 2.28e- 01 6.95e- 02 2.23e- 02 7.38e- 03 2.49e- 03 
 
 1.0e- 01 1.82e+00 8.19e- 01 2.28e- 01 6.95e- 02 2.23e- 02 7.38e- 03 2.49e- 03 
 2.0e- 01 1.22e+00 7.15e- 01 2.27e- 01 6.95e- 02 2.23e- 02 7.38e- 03 2.49e- 03 
 4.0e- 01 7.02e- 01 5.02e- 01 2.10e- 01 6.91e- 02 2.23e- 02 7.38e- 03 2.49e- 03 
 6.0e- 01 4.54e- 01 3.54e- 01 1.77e- 01 6.64e- 02 2.22e- 02 7.38e- 03 2.49e- 03 
 8.0e- 01 3.11e- 01 2.54e- 01 1.44e- 01 6.07e- 02 2.17e- 02 7.36e- 03 2.49e- 03 
 
 1.0e+00 2.19e- 01 1.85e- 01 1.14e- 01 5.34e- 02 2.07e- 02 7.27e- 03 2.49e- 03 
 2.0e+00 4.89e- 02 4.44e- 02 3.34e- 02 2.10e- 02 1.12e- 02 5.13e- 03 2.10e- 03 
 4.0e+00 3.78e- 03 3.58e- 03 3.06e- 03 2.35e- 03 1.63e- 03 1.03e- 03 5.86e- 04 

Transport Model 

Introduction 
The finite-element transport model in WinTran is verified through comparison with 
an analytical solution from Wexler (1992) and with another finite-element transport 
model called SEFTRAN (Huyakorn et al., 1984).  The Wexler analytical solution 
models transport of a dissolved contaminant from a point source in a two-
dimensional uniform flow field.  Six test cases were investigated with SEFTRAN for 
the three different source configurations (injection well, pond, and linesink) in both 
uniform flow and in non-uniform flow fields. 

Comparison to an Analytical Solution 
Wexler (1992) presents a series of analytical solutions to the partial differential 
equations of dissolved contaminant transport in porous media.  WinTran was 
compared to the solution for a continuous point source in an aquifer of infinite extent 
(see page 26 of Wexler, 1992).  The analytical solution was implemented by Wexler 
in a FORTRAN program called POINT2.   

The data for the test problem are presented in Table 1.  Concentration is plotted 
versus time at two locations downgradient of the source for both WinTran and 
SEFTRAN (see Figure 1).  These curves show that WinTran results are virtually 
identical to those of the analytical solution.  Contours for both WinTran results and 
POINT2 results are shown in Figure 2.  Again, these contours are almost identical 
for the two solutions.  The largest difference is at the source, where WinTran slightly 
underpredicts the source concentration.  This is probably caused by dilution of the 
source concentration in the finite-element cell.  The majority of the plume, however, 
matches quite well between WinTran and POINT2. 

Comparison of WinTran to an analytical solution confirms that the basic transport 
model has been coded properly.  The analytical solution, however, assumes that the 
flow field is uniform and the source is a single point and continuous over time.  The 
next section presents a series of tests that illustrate that WinTran performs properly 
for more complex scenarios. 
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Table 1.  Model Parameters for the Analytical Solution Comparison 

 

Parameter    Value 

Hydraulic conductivity   100 ft/d 

Top Elevation    -75 ft 

Bottom Elevation    -100 ft 

Porosity     0.2 

Hydraulic Gradient   0.01 to the East 

Groundwater Velocity   5 ft/d 

Longitudinal Dispersivity   30 ft 

Transverse Dispersivity   3 ft 

Retardation Coefficient   1 

 

X coordinate of source   212.32 ft 

Y coordinate of source   230.87 ft 

Source fluid flow rate   -1 ft3/d 

Source concentration   100 

 

Number of X nodes   70 

Number of Y nodes   70 

Minimum X coordinate   50.0 ft 

Minimum Y coordinate   50.0 ft 

Nodal Spacing in X   8.116 ft 

Nodal Spacing in Y   5.652 ft 

 

Number of time steps   50 

Minimum time step size   0.5 day 

Maximum time step size   10 days 

Time step multiplier   1.1 

Final time value    280.569 days 
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Figure 1.  Time-series comparison between WinTran and an analytical solution at two downgradient nodes 
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Figure 2.  Concentration contours for WinTran and the analytical solution at time=260.569 days. 
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Benchmarking with SEFTRAN 
SEFTRAN (Huyakorn et al., 1984) was chosen for the majority of testing because it 
uses the same finite-element techniques that are employed by WinTran.  SEFTRAN 
also makes a good choice for benchmark testing because it has undergone a 
significant amount of testing at the International Ground Water Modeling Center 
(Huyakorn et al., 1984).   

To facilitate this testing, a special option has been added to the WinTran Export 
menu allowing WinTran to create SEFTRAN data input files.  Three files are 
created, (1) a SEFTRAN flow data set (always called FLOW.IN), (2) a SEFTRAN 
transport data set (you specify the name in the dialog), and (3) a velocity file with 
analytically-computed velocities (always called FLOW.VEL). 

A series of six simulations were performed to test the three different source 
configurations (point source using an injection well, pond infiltration, and linesink 
injection).  Each of the three source terms was tested in both a uniform flow field and 
a non-uniform flow field.  The non-uniform flow field was produced by adding a 
pumping well downgradient from the source.  The results for the six simulations are 
summarized in Table 2 and Table 2b.  Data for the simulations are shown in Table 3. 

The benchmark simulations are evaluated by presenting the following in Table 2: (1) 
maximum source concentration computed by WinTran and SEFTRAN, (2) the mean 
and maximum differences (errors) when SEFTRAN uses WinTran-computed 
velocities, (3) the mean and maximum differences when SEFTRAN uses SEFTRAN-
computed velocities, and (4) mass balance errors for the two models.  The source 
concentrations were scaled to a value of 1.0 in WinTran.  The mass balance errors 
are in percent. 

The mean and maximum differences between the two codes are very low for the case 
when each code uses velocities computed by WinTran.  This tests the WinTran 
transport model because both codes are using the same velocity field.  The tests 
illustrate that the transport model in WinTran is functioning properly for all cases.  
The mass balance error for each code is comparable for all cases and the source 
concentrations are accurate to the fourth decimal place. 

The second set of errors (differences) presented in Table 2 are for SEFTRAN results 
computed using velocities computed by the SEFTRAN flow model.  In the first set 
of differences described in the previous paragraph, the SEFTRAN transport model 
read velocity data computed by WinTran.  The second set of comparisons, therefore, 
are used to evaluate the hybrid modeling approach.  The results show that for 
uniform flow conditions, WinTran and SEFTRAN velocities produce virtually the 
same results.  In a non-uniform flow field, however, the differences are larger.  This 
indicates that the analytically-computed velocities are slightly in error. 

Table 2b presents the differences between SEFTRAN and WinTran when velocities 
in WinTran are computed using finite elements (rather than the analytical model).  In 
this case, the differences are very minor.  Thus, for complex flow fields, you may 
want to consider using the finite-element flow model to compute velocities.  You 
may select this option using the Model->Flow Model Type menu. 

Figures 3 through 8 present concentration contour maps created by WinTran and 
SEFTRAN.  These figures further substantiate that the two models are producing the 
same results. 
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Table 2. Comparison Between WinTran and SEFTRAN for Six Simulations. 

Description Maximum 

Conc. 

Maximum 

Conc. 

 WinTran Velocities 

  

 Seftran Velocities 

  

Mass 

Balance 

Error 

Mass 

Balance 

Error 

  WinTran Seftran Mean 
Error 

Maximum
Error 

Mean 
Error 

Maximum
Error 

WinTran Seftran 

Test 1 
Point Source 

Uniform Flow 

1.0 1.000052 -1.1e-05 7.5e-05 3.8e-05 7.0e-05 0.0129 0.00082 

Test 2 
Pond Source 

Uniform Flow 

1.0 1.00024 -4.2e-05 2.4e-04 4.9e-05 1.99e-04 0.00758 0.0069 

Test 3 
Line Source 

Uniform Flow 

1.0 0.99992 1.66e-05 2.04e-04 1.47e-04 2.4e-03 0.00438 0.018 

Test 4 
Point Source 

Nonuniform 
Flow 

1.0 1.00005 -9.8e-06 7.3e-05 7.5e-06 5.8e-03 0.2057 0.195 

Test 5 
Pond Source 

Nonuniform 
Flow 

1.0 0.99996 7.5e-06 7.23e-05 2.0e-05 0.045 0.147 0.136 

Test 6 
Line Source 

Nonuniform 
Flow 

1.0 0.99991 1.06e-05 1.4e-04 4.2e-05 0.025 0.056 0.046 

 

Table 2b. Comparison Between WinTran (Using the Finite Element Flow Model) 
and SEFTRAN for the Nonuniform Flow Test Cases. 

 

Description Mean 

Error 

Maximum 

Error 

WinTran 

Mass Balance Error 

Test 4 -6.33e-06 6.78e-05 0.145 

Test 5 1.3e-06 1.4e-04 0.161 

Test 6 2.6e-05 2.7e-04 0.20 
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Table 3.  Model Parameters for the SEFTRAN Benckmarking 

 

Parameter    Value 

Hydraulic conductivity   100 ft/d 

Top Elevation    100 ft 

Bottom Elevation    0 ft 

Reference Head    25 ft at (75,65) 

Porosity     0.2 

Hydraulic Gradient   0.01 to the East 

Longitudinal Dispersivity   30 ft 

Transverse Dispersivity   6 ft 

Retardation Coefficient   1 

 

Number of X nodes   35 

Number of Y nodes   35 

Minimum X coordinate   45.03 ft 

Minimum Y coordinate   42.29 ft 

Maximum X coordinate   678.81 ft 

Maximum Y coordinate   413.66 ft 

 

Number of time steps   30 

Minimum time step size   1 day 

Maximum time step size   100 days 

Time step multiplier   1.2 

 

Point Source Information (Simulation 1 and 4) 

Fluid Injection Rate   -1.0 ft3/d 

Concentration in fluid   100 

Coordinates of Well (x,y)   (138.23,227.98) 

 

Pumping Well Information (Simulations 4 through 6) 

Pumping Rate    10,000 ft3/d 

Coordinates of Well (x,y)   (604.25,315.36) 
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Table 3 (continued).  Model Parameters for the SEFTRAN Benckmarking 

 

Linesink Source Information (Simulations 3 and 6) 

Linesink Injection Rate   -1 ft2/d 

Concentration in fluid   100 

Beginning Coordinates of line (x,y)  (145.27,275.11) 

Ending Coordinates of line (x,y)  (143.65,167.59) 

 

Pond Source Information (Simulations 2 and 5) 

Pond Infiltration Rate   0.0015 ft/d 

Concentration in fluid   100 

Pond Radius    24.68 ft 

Coordinates of pond center (x,y)  (137.99,227.41) 
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Figure 3.  Concentration contours for WinTran and SEFTRAN at the final time step for Test Case 1. 
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Figure 4.  Concentration contours for WinTran and SEFTRAN at the final time step for Test Case 2. 
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Figure 5.  Concentration contours for WinTran and SEFTRAN at the final time step for Test Case 3. 



 

Guide to Using AquiferWin32 WinFlow/WinTran Verification  •  405 
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Figure 6.  Concentration contours for WinTran and SEFTRAN at the final time step for Test Case 4. 
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Figure 7.  Concentration contours for WinTran and SEFTRAN at the final time step for Test Case 5. 
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Figure 8.  Concentration contours for WinTran and SEFTRAN at the final time step for Test Case 6. 
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WinFlow Application Guide 

WinFlow Assumptions 
It is important to understand the many simplifying assumptions inherent in an 
analytical model before the model can be applied to a real-world problem.  Chapter 5 
described the equations that are solved in WinFlow.  Chapter 6 verified that these 
equations are properly implemented in the WinFlow software.  This chapter presents 
potential applications of WinFlow to the solution of ground-water problems.  First, 
however, some important assumptions are discussed as they apply to the practical 
application of WinFlow.  For easy identification, the primary assumptions are 
underlined. 

WinFlow is designed to solve two-dimensional ground-water flow problems in a 
horizontal plane.  It is not designed for two-dimensional cross-sections (2D vertical 
plane).  The two primary assumptions are that ground-water flow is horizontal and 
occurs in an infinite aquifer.  WinFlow should not be applied to aquifers exhibiting 
strong vertical gradients unless the scale of the problem is such that horizontal flow 
can still be considered dominant.  WinFlow can be used even in cases where there 
are significant vertical gradients if the horizontal scale of the model is much larger 
than the vertical scale, such as in regional studies. 

Another assumption is that the aquifer hydraulic conductivity is assumed to be 
isotropic and homogeneous.  The base of the aquifer is horizontal and fixed at a 
given elevation.  In the steady-state and transient models, the top of the aquifer is 
also horizontal and fixed at a given elevation.  In the steady-state model, however, 
unconfined conditions are simulated when the hydraulic head is below the top of the 
aquifer.  In the transient model, the aquifer is always confined, even when the head 
falls below the top of the aquifer. 

The reference head in the steady-state model is constant throughout all calculations.  
The reference head is analogous to a constant head boundary condition in a 
numerical model.  It is therefore very important to keep the reference head far from 
the area of interest so that model predictions are not impacted. 

The reference head in the transient model is only used in combination with the 
uniform gradient to compute an initial planar potentiometric surface.  Drawdowns 
computed by either the Theis (1935) or the Hantush and Jacob (1955) methods are 
then subtracted from the planar potentiometric surface to obtain the resulting flow 
field.  Drawdowns are also subtracted from the reference head in the transient model; 
however, there is an option that allows the user to keep the reference head constant 
in the transient model.  This option should only be used when trying to compare the 
transient model to the steady-state model. 
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All pumping rates, linesink fluxes, pond recharge, and elliptical recharge rates are 
constant through time.  In the transient model, all wells start pumping or injecting 
water at time zero. 

All wells are assumed to fully penetrate the aquifer.  Wells are assumed to be 
perfectly efficient and linesinks are in perfect hydraulic communication with the 
aquifer.  Both assumptions are rarely encountered in practice.  There is often head 
loss around the well screen or stream bottom caused by clogging of the pore-space 
by fine-grained material (clay).  There are two important consequences of imperfect 
hydraulic communication. 

 (1) Pumping rates predicted by WinFlow to achieve a desired response 
may not be attainable because more drawdown will be encountered in the 
actual well.  The increased drawdown encountered in the field is caused by 
inefficiency around the well screen.  The same effect will happen using 
linesinks to simulate trenches or drains. 

 (2) The amount of water produced or injected by a linesink to maintain 
a specified head in the linesink will be overestimated if the actual drain has 
less than 100 percent efficiency. 

Particle traces and streamlines are two-dimensional.  In cases where the aquifer 
receives recharge, the capture zone of a pumping well will be large enough to 
capture the amount of recharge equaling the pumping rate of the well (Larson et al., 
1987).  In two-dimensional analyses, such as in WinFlow, the capture zone extends 
upgradient until encountering a ground-water divide or infinity.  This is an important 
consideration in designing a containment system. 

Analysis of Remedial Actions 
WinFlow can provide valuable guidance in designing a ground-water remediation 
system.  The most obvious remedial action that WinFlow can simulate is "pump & 
treat" where the goal is to contain a volume of contaminated aquifer.  WinFlow can 
simulate the effects of both pumping and injection wells.  To illustrate the capture 
zone of a well, use reverse particle-tracking and start the particles in a circle around 
the well. 

WinFlow can simulate trenches and drains using linesinks.  There are two options in 
simulating drains: (1) specify a head to be maintained in the drain and WinFlow will 
compute the discharge rate necessary to achieve the given head; or (2) specify the 
discharge rate and compute the resulting head in the drain.  To illustrate the capture 
zone of the drain, use reverse particle-tracking and start the particles along two lines 
on either side of the linesink. 

WinFlow can simulate a lagoon closure by using ponds.  To do this, set up the initial 
analytical model with ponds that simulate the lagoon.  Adjust the pond recharge rate 
to match field-measured heads.  Finally, remove the pond (or set the pond recharge 
equal to zero) to simulate the effects of closure. 

The effects of capping can be simulated with a combination of elliptical recharge and 
circular ponds.  Set up the initial analytical model using recharge to match field-
measured heads.  A circular cap can then be simulated with a pond that has a 
recharge rate equivalent to the regional recharge rate but opposite in sign (e.g. 
negative). 
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Pumping Test Analysis and Design 
WinFlow's transient model can simulate the effects of a pumping test to facilitate 
interpreting test results or designing a future test.  Pumping test results can be 
interpreted by contouring drawdown at a specified time after the start of the test.  To 
contour drawdown, set the reference head equal to zero and the gradient equal to 
zero.  Make sure that the top of the aquifer is less than zero if the steady-state model 
is used. 

Drawdowns computed by WinFlow can be compared to drawdown contours from the 
pumping test.  Hydraulic conductivity and storage can be adjusted until a reasonable 
match between observed and computed drawdown is achieved.  Image wells can be 
added to the model to simulate boundary effects.  Use calibration targets to provide a 
quantitative match between the results of your aquifer test and the model 
calculations. 

When designing an aquifer test, WinFlow estimates the drawdown likely to occur at 
selected times and at various distances from the pumping well.  Time and drawdown 
estimates can help select appropriate wells to monitor and determine the length of the 
test. 

Regional Modeling 
Strack (1989) advocates the use of "analytic element models" (his term for the 
superposition of analytical functions) in regional flow system modeling.  At a 
regional scale, most aquifers are very thin compared to the distance across the 
aquifer in the horizontal plane.  Thus, the z-axis (vertical dimension) becomes quite 
small and vertical gradients are negligible compared to horizontal gradients.  In this 
case, the problem becomes two-dimensional and can be easily simulated with 
analytical functions. 

The regional model is constructed using linesinks to simulate rivers and streams.  
Recharge from precipitation is applied in a large ellipse covering the area of interest.  
Circular recharge areas (ponds) simulate lakes.  Obviously, wells represent areas of 
ground-water extraction, such as wellfields. 

Strack (1989) has developed many complex analytical functions or analytic elements 
to facilitate regional modeling.  The Single-Layer Analytic Element Model 
(SLAEM) developed by Strack contains these advanced functions not available in 
WinFlow.  SLAEM is available from Dr. Strack. 

Well Head Protection 
Many states are requiring water companies to model the ground-water flow system 
around all public supply wells to determine the "zone of contribution" for each well.  
Small water companies will find it difficult to pay for expensive numerical modeling 
studies.  WinFlow is ideally suited for these small wellfields, because a simple 
regional model can be constructed to comply with wellhead protection regulations at 
little cost.  WinFlow can also be useful for preliminary studies at larger wellfields 
prior to numerical modeling. 

To determine the zone of contribution for a particular time of travel, use reverse 
particle-tracking.  Start the particles in a circle around each well and set the 
maximum travel time to the desired value. 
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WinTran Application Guide 

Introduction 
This chapter presents the major assumptions inherent in WinTran and guidelines for 
the use of the transport model.  These guidelines include estimating memory 
requirements, dealing with model instabilities, and suggestions for simulating 
various transport scenarios. 

WinTran Assumptions 
It is important to understand the many simplifying assumptions inherent in any 
model before the model can be applied to a real-world problem.  This chapter 
presents potential applications of WinTran to the solution of contaminant fate and 
transport problems.  First, however, some important assumptions are discussed as 
they apply to practical application of WinTran.  For easy identification, the primary 
assumptions are underlined. 

WinTran is designed to solve two-dimensional ground-water flow and transport 
problems in a horizontal plane.  It is not designed for two-dimensional cross-sections 
(2D vertical plane).  The two primary assumptions are that ground-water flow is 
horizontal and contaminant concentrations are the same throughout the entire aquifer 
thickness.  WinTran should not be applied to aquifers exhibiting strong vertical 
gradients unless the scale of the problem is such that horizontal flow can still be 
considered dominant.  WinTran can be used even in cases where there are significant 
vertical gradients if the horizontal scale of the model is much larger than the vertical 
scale, such as in regional studies. 

Another assumption is that the aquifer hydraulic conductivity is assumed to be 
isotropic and homogeneous.  The base of the aquifer is horizontal and fixed at a 
given elevation.  The top of the aquifer is also horizontal and fixed at a given 
elevation.  Unconfined conditions are simulated when the hydraulic head is below 
the top of the aquifer.  

The reference head in the flow model is constant throughout all calculations.  The 
reference head is analogous to a constant head boundary condition in a numerical 
model.  It is therefore very important to keep the reference head far from the area of 
interest so that model predictions are not impacted. 

All pumping rates, linesink fluxes, pond recharge, and elliptical recharge rates are 
constant through time.  The transport model simulates transient movement of the 
contaminant in this steady-state velocity field. 



 

Guide to Using AquiferWin32 WinTran Application Guide  •  419 

All wells are assumed to fully penetrate the aquifer.  Wells are assumed to be 
perfectly efficient and linesinks are in perfect hydraulic communication with the 
aquifer.  Both assumptions are rarely encountered in practice.  There is often head 
loss around the well screen or stream bottom caused by clogging of the pore-space 
by fine-grained material (clay).  There are two important consequences of imperfect 
hydraulic communication. 

 (1) Pumping rates predicted by WinTran to achieve a desired response 
may not be attainable because more drawdown will be encountered in the 
actual well.  The increased drawdown encountered in the field is caused by 
inefficiency around the well screen.  The same effect will happen using 
linesinks to simulate trenches or drains. 

 (2) The amount of water produced or injected by a linesink to maintain 
a specified head in the linesink will be overestimated if the actual drain has 
less than 100 percent efficiency. 

Particle traces and streamlines are two-dimensional.  In cases where the aquifer 
receives recharge, the capture zone of a pumping well will be large enough to 
capture the amount of recharge equaling the pumping rate of the well (Larson et al. 
1987).  In two-dimensional analyses, such as in WinTran, the capture zone extends 
upgradient until encountering a ground-water divide or infinity.  This is an important 
consideration in designing a containment system. 

Chemical reactions are reduced to two types, (1) linear, fully-reversible sorption 
using a retardation coefficient, and (2) first-order decay.  WinTran can be used to 
simulate biological decay of organic compounds only if the biological reactions can 
be reduced to a first-order decay reaction.  That is, a contaminant half-life is 
estimated for the compound. 

Memory Requirements 
WinTran uses a substantial amount of computer memory to solve the finite-element 
transport model.  The amount of memory required for each model is determined by 
the size of the contour matrix.  The default size of the contour matrix is 35 x 35 (35 
nodes in both the X- and Y-directions).  In this case, the model requires about 1 
megabyte of memory.  The maximum matrix size allowed in WinTran is 100 x 100, 
requiring about 18 megabytes of memory.  Other matrix sizes and memory 
requirements are shown below: 

Matrix Size    Memory Required 

35 x 35     1 megabyte 

50 x 50     2.6 megabytes 

75 x 75     8 megabytes 

100 x 100    18 megabytes 

Problems with Model Stability 
Numerical transport models require the user to carefully evaluate each simulation for 
potential errors.  WinTran assists you in evaluating model error by displaying the mass 
balance error on the status bar when the transport model is running.  The mass balance 
error is expressed as a percentage and should be less than 10 percent for a valid 
simulation.  Usually, the mass balance error is less than 1 percent. 
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Even if the mass balance error is below 10 percent, there can be oscillations in the 
transport solution.  Oscillations are indicated by negative concentrations computed by 
WinTran.  In extreme cases, alternating nodes will have positive and negative 
concentrations producing diamond-shaped contours.  The following screen shows a 
contour pattern that is typical of numerical oscillations: 

 

Note the diamond shaped contours upgradient of the source.  These contours are 
produced because alternating nodes are positive and negative.  The contouring routine 
draws "bulls-eyes" around these high and low points producing the diamond-shaped 
contours.  This is very typical of oscillating solutions and is probably the most common 
problem you will run into with WinTran.   

The pattern above was produced in the tutorial model by lowering the time-step size to 
0.1 days, using centered-in-time, and reducing the longitudinal dispersivity to 3 ft.  This 
produces a Peclet number of 6.2, which is above the recommended limit of 2.  In the 
screen shown below, the dispersivity value was increased to 30 ft, dropping the Peclet 
number to 0.62.  This was enough to remove the oscillations. 
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When the transport solution oscillates, check the following: 

 (1) The Peclet number is displayed on the status bar as “Pe=“ and is computed 
by dividing the nodal spacing (the distance between nodes in the contour matrix) by the 
longitudinal dispersivity.  The Peclet number should generally be less than 2 for a stable 
solution.  If you are experiencing mass balance problems or oscillations, increase 
dispersivity until the Peclet number is less than 2, as described above. 

 (2) The Courant number is another criterion used to judge the stability of a 
transport simulation.  The Courant number is computed as the velocity times time-step 
size divided by nodal spacing.  This criterion is displayed as “Cr=“ on the status bar and 
should generally be less than 1.  Again, if you are experiencing mass balance or 
oscillation problems, try decreasing the initial and maximum time-step sizes. 

There are also times when the Courant number is too low.  In cases where the Courant 
number is less than 0.1, there can be round-off errors in the matrix solver.  In this case, 
you should increase the initial and maximum time-step sizes until the Courant number is 
close to 1. 

There are two other WinTran options that can aid in model stability.  These include the 
time discretization method (backward and centered in time) and upstream weighting.  
The time discretization methods are selected using the Edit->Time Stepping menu.  
Backward in time is unconditionally stable but is only first-order accurate, while 
centered in time is second-order accurate but may be subject to instability (Javandel et 
al., 1984).  It is usually best to start with backward in time. 

Upstream weighting factors in the X- and Y-directions are edited from the Edit-
>Transport Parameters menu.  Upstream weighting factors of 1.0 indicate full 
upstream weighting, while a weighting factor of 0.0 turns off upstream weighting.  
Upstream weighting adds stability to the solution (helps eliminate oscillations) at the 
expense of added numerical dispersion.  Numerical dispersion is artificial dispersion that 
produces similar results to an increase in the dispersivity coefficient. 
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Analysis of Remedial Actions 

Setting Up the Flow Model 
WinTran can provide valuable guidance in designing a ground-water remediation 
system.  The most obvious remedial action that WinTran can simulate is "pump & 
treat" where the goal is to contain a volume of contaminated aquifer.  WinTran can 
simulate the effects of both pumping and injection wells. 

WinTran can simulate trenches and drains using linesinks.  There are two options in 
simulating drains: (1) specify a head to be maintained in the drain and WinTran will 
compute the discharge rate necessary to achieve the given head; or (2) specify the 
discharge rate and compute the resulting head in the drain.  To illustrate the capture 
zone of the drain, use reverse particle-tracking and start the particles along two lines 
on either side of the linesink. 

WinTran can simulate a lagoon closure by using ponds.  To do this, set up the initial 
analytical model with ponds that simulate the lagoon.  Adjust the pond recharge rate 
to match field-measured heads.  Finally, remove the pond (or set the pond recharge 
equal to zero) to simulate the effects of closure. 

The effects of capping can be simulated with a combination of elliptical recharge and 
circular ponds.  Set up the initial analytical model using recharge to match field-
measured heads.  A circular cap can then be simulated with a pond that has a 
recharge rate equivalent to the regional recharge rate but opposite in sign (e.g. 
negative). 

Setting Up the Transport Model 
Remedial alternatives are usually simulated in several stages, as described below: 

(1) Calibrate the transport model to the observed contaminant plume.  This is 
accomplished by adding source terms to the model (injection wells, infiltrating 
ponds, or injecting linesinks) and adjusting the source concentration until the desired 
plume is simulated.  The length of the simulation should be chosen to approximate 
the length of time that the source of contamination has been effecting the 
groundwater system.   

An alternative approach to calibrating the plume configuration is to import a 
SURFER grid file (e.g. test.grd) containing the contaminant distribution data (use 
File->Import from the main menu).  The contoured concentrations are then used as 
initial conditions for the remedial simulation. 

(2) Save the calibrated concentrations as initial conditions using the Calc->Restart 
option on the main menu.  Skip this step if you have imported a SURFER grid file 
for initial conditions. 

(3) Add the remediation system (pumping wells or linesinks, etc.) and rerun the 
transport model.  To simulate source removal, delete the source terms added in State 
1 above.  This is accomplished by moving the cursor over the source element (well, 

pond, or linesink) until the four-arrow cursor ( ) is displayed.  Click the left 
mouse button to select the element and then press the delete key or select Edit-
>Delete from the main menu.  Now, rerun the transport model to simulate source 
removal. 
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At any time during the simulations, you may save concentrations for later restart 
using the File->Export menu.  Exporting concentration as a restart file (*.rst) will 
allow you to Import these concentrations in later simulations.   

Simulating Biodegradation 
Simulating the biodegradation of organic compounds is a popular modeling scenario, 
especially for dissolved hydrocarbons.  WinTran does not simulate these complex 
degradation processes; however, the decay term in WinTran can be used to 
approximate biodecay.  The biodegradation process is reduced to specifying a half-
life for the compound.  The half-life is the time required to remove half of the 
original mass.  While the half-life is most often used for radioactive elements, such 
as uranium, it can also be used to express the decay of organic compounds through 
biodecay.  The Handbook of Environmental Degradation Rates (Howard et al., 
1991) is a good reference for contaminant half-life data. 

Performing Risk Assessments 
WinTran is not a risk assessment model but can be useful in risk assessments by 
providing concentration data over time at receptor locations.  To obtain the 
concentration over time at these receptor locations, you must add a well at the 
receptor.  Specify the flow rate as zero (0.0) and check the "Observation well" option 
on the well dialog.  These concentration-time data may then be saved to a file for use 
in other programs.  To save these data, select File->Export and choose the file time 
Conc-Time (*.cvt).  The file is a DOS text file delimited by commas.  The first line 
contains the well names and subsequent lines list the time and concentration for each 
well.   
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Digitized Maps 

Digitized Map File Format 
Digitized base maps increase the efficiency of site-specific modeling by placing the 
modeling results in context with the area to be modeled.  As shown in the tutorial, 
WinFlow overlays the base map on head contours and streamlines, making it easier 
to interpret the results. 

WinFlow uses a very simple file format for the digitized base map, as shown in 
Table 9.  The file is made up of two sections.  The first defines a series of line 
segments, while the second set of data defines a series of text strings.  Each line 
segment requires the following data (1) the beginning and ending X and Y 
coordinates, (2) the line style, e.g., dashed or solid, and (3) the line color.  The data 
for each line segment should appear on one line and be separated by at least one 
space between each data item.  Commas may not be used to separate data items. 

The following data items are required for each text item (1) X and Y coordinates of 
the lower left corner of the text, (2) angle of rotation of the text string, (3) height of 
the text, (4) color, and (5) a text string.  The first four data items are entered on one 
line separated by at least one space between each data item.  The text string is 
located on the following line and the height of the text string is in map coordinates 
(not in inches!). 

Line and text colors are defined as integer numbers from 0 through 15.  Each integer 
defines a unique color.  The possible colors are shown in Table 10.  These colors are 
all displayed on VGA color displays. 

The digitized map file is a simple ASCII file that may be created in any text editor.  
You may also find it advantageous to write a simple program to convert files from 
your digitizing software to the WinFlow format.  WinFlow also has the ability to 
convert DXF files directly.  Simply choose File from the main menu and Map from 
the pull-down menu.  Next select DXF from the menu.  Specify the DXF file name 
and a conversion factor, which is explained below.  The DXF file format is a 
relatively standard file format for CAD packages, such as AutoCad. 
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 Table 9  File Format for WinFlow Digitized Maps. 

 

 Line 1 NLS, NTEXT 
 
   NLS = Number of line segments in map 
   NTEXT = Number of Text Strings in map 
 
 Lines 2 to NLS+1 (Enter one line for each line segment) 
   X1, Y1, X2, Y2, NDASH, NCOLOR 
 
   X1, Y1 = Beginning line coordinates 
   X2, Y2 = Ending line coordinates 
   NDASH = Positive integer for solid line, negative 
for dashed 
   NCOLOR = Color index (integer) 
 
 Lines NLS+2 to end (Enter one set per text item) 
   X1, Y1, ANGLE, HEIGHT, NCOLOR 
   TEXT 
 
   X1, Y1 = Coordinates of left side of text string 
   ANGLE = Angle of text string 
   HEIGHT = Height of text string 
   NCOLOR = Color index of text string 
   TEXT = Text string 
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Table 10  Definition of color indices. 

 

 Index   Color 
 
  0   BLACK 
  1   BLUE 
  2   GREEN 
  3   CYAN 
  4   RED 
  5   MAGENTA 
  6   BROWN 
  7   WHITE 
  8   GRAY 
  9   LIGHT BLUE 
  10   LIGHT GREEN 
  11   LIGHT CYAN 
  12   LIGHT RED 
  13   LIGHT MAGENTA 
  14   YELLOW 
  15   BRIGHT WHITE 

 
 

DXF Translator 
The DXF (Drawing Interchange Format) file is a fairly standard format for 
exchanging data between CAD systems.  In particular, the popular AutoCAD 
software uses DXF files extensively.  A translator is provided with WinFlow to 
extract digitized information from DXF files and convert it to the WinFlow digitized 
map format. 

The DXF file contains detailed data describing numerous CAD entities.  An entity is 
a line or symbol placed on the drawing by the CAD system.  The WinFlow DXF 
translator supports the following CAD entities: 

  LINES 

  POLYLINES 

  POINTS 

  ARCS 

  CIRCLES 

  TEXT 
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Certain aspects about these entities are ignored by the translator, such as elevation 
(for 3D CAD software such as AutoCAD Release 10), line style, and line thickness.  
In addition, the curve-fit and spline options applied to POLYLINES are ignored.  
The coordinates and color of the entity are preserved, however. 

Many CAD drawings contain entities called BLOCKS, which are a collection of 
other entities (e.g., lines, circles, text, etc.).  WinFlow will not interpret BLOCKS 
properly, so make sure that these are converted to other entities before creating the 
DXF file in your CAD package.  In AutoCAD terminology, this is called 
“exploding” the blocks. 

The DXF translator is activated from the File menu, as described above. Next, 
specify the DXF file name and a Map file name using standard Windows file dialogs.  
You only have to answer one additional prompt after starting the DXF translator - a 
conversion factor for the translation.  Normally, a conversion factor of 1.0 will work; 
however, sometimes your CAD software will store coordinates in the DXF file in 
units of inches.  If this happens, use a conversion factor of 0.0833333 (1.0/12.0).  
Each coordinate in the DXF file is multiplied by the conversion factor before being 
written to the WinFlow map file.   

After all entities are processed in the DXF file, the digitized map file is created.  A 
message to that effect is displayed at the bottom of the screen.  After the translation 
is finished, the map file is imported into the model and displayed on your screen.
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